Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Bad Status engine status

2 posts in Windows NT Last posting was on 2001-04-18 15:13:35.0Z
Bill Rickerson,Jr Posted on 2001-04-18 10:40:30.0Z
Message-ID: <3ADD6F1D.3682263B@adelphia.net>
Date: Wed, 18 Apr 2001 06:40:30 -0400
From: "Bill Rickerson,Jr" <WRickerson@adelphia.net>
X-Mailer: Mozilla 4.76 [en] (WinNT; U)
X-Accept-Language: en
MIME-Version: 1.0
Subject: Bad Status engine status
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.sqlserver.nt
Lines: 21
NNTP-Posting-Host: ny-kenton2a-498.buf.adelphia.net 24.51.93.242
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:937
Article PK: 1087542

In the Sybase Administrator's guide, it says that you can get the status
of your database engines with this query

select engine, status, affinitied, starttime from sysengines

I receive the following from this query:

engine status affinitied starttime
------ ------------ ----------- -------------------------
0 bad status 3 2001-04-16 20:53:39.483
1 bad status 2 2001-04-16 20:54:16.78
2 bad status 0 2001-04-16 20:54:16.78
3 online 3 2001-04-16 20:54:16.793

This is on a 4 cpu IBM Netfinity 6000 running NT 4.0 sp 6. Does anyone
have any information on this result? Is this something I should be
concerned about and if so, how is it corrected?

Thanks for you consideration
Bill Rickerson
application DBA
M&T Bank


Jim Egan Posted on 2001-04-18 15:13:35.0Z
From: Jim Egan <dbaguru@eganomics.com>
Subject: Re: Bad Status engine status
Date: Wed, 18 Apr 2001 09:13:35 -0600
Message-ID: <MPG.15475d0c8cd54c7798b2a5@forums.sybase.com>
References: <3ADD6F1D.3682263B@adelphia.net>
Reply-To: eganjp@compuserve.com
X-Newsreader: MicroPlanet Gravity v2.50
Newsgroups: sybase.public.sqlserver.nt
Lines: 31
NNTP-Posting-Host: jpe650.sybase.com 157.133.56.43
Path: forums-1-dub!forums-master.sybase.com!forums.sybase.com
Xref: forums-1-dub sybase.public.sqlserver.nt:935
Article PK: 1087541


WRickerson@adelphia.net wrote...
> In the Sybase Administrator's guide, it says that you can get the status
> of your database engines with this query
>
> select engine, status, affinitied, starttime from sysengines
>
> I receive the following from this query:
>
> engine status affinitied starttime
> ------ ------------ ----------- -------------------------
> 0 bad status 3 2001-04-16 20:53:39.483
> 1 bad status 2 2001-04-16 20:54:16.78
> 2 bad status 0 2001-04-16 20:54:16.78
> 3 online 3 2001-04-16 20:54:16.793
>
> This is on a 4 cpu IBM Netfinity 6000 running NT 4.0 sp 6. Does anyone
> have any information on this result? Is this something I should be
> concerned about and if so, how is it corrected?
>

Are you running ASE 12.0? The "bad status" values in sysengines is a known bug - CR
233658. This is only a status value issue and does not mean that the engines are offline.
This is scheduled to be fixed in the 12.0.0.3 release.
--
Jim Egan [TeamSybase]
Senior Consultant
Sybase Professional Services

Get your free subscription to PowerTimes at http://www.powertimes.com