Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Sybase SQL Server 11 on NT 4.0 Server

5 posts in Windows NT Last posting was on 1997-06-18 16:06:59.0Z
John Fotiadis/SYBASE Greece Posted on 1997-06-06 09:23:18.0Z
X-Newsreader: Microsoft Outlook Express 4.71.0544.0
From: "John Fotiadis/SYBASE Greece" <johnf@sybase.com.gr>
Subject: Sybase SQL Server 11 on NT 4.0 Server
Date: Fri, 6 Jun 1997 12:23:18 +0300
Lines: 23
X-MimeOLE: Produced By Microsoft MimeOLE Engine V4.71.0544.0
Message-ID: <3SbC$Klc8GA.201@forums.powersoft.com>
Newsgroups: sybase.public.sqlserver.nt
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.sqlserver.nt:5612
Article PK: 1081689

Does anyone have problems with TCP/IP connections from PB clients to Sybase
SQl Server 11 on WinNT 4.0 Server ?
--

Regards,

John Fotiadis
Senior Systems Engineer
sybasegr@hol.gr, johnf@sybase.com.gr
Phone: + 30 94 464225
----------------------------------------------
Relational Technology S.A.
Sybase Distributor in Greece (CBSS: 32809-1-1)
415 Vouliagmenis Ave.
16346 ATHENS
GREECE

Phone: + 30 1 995 8780
Fax: + 30 1 995 8783
http://www.forthnet.gr/sybasegr
----------------------------------------------


fangj Posted on 1997-06-11 15:44:49.0Z
Message-ID: <339EC7F1.4E6E@midwest.co.cn>
Date: Wed, 11 Jun 1997 23:44:49 +0800
From: fangj@midwest.co.cn
Reply-To: fangj@midwest.co.cn
X-Mailer: Mozilla 3.01Gold (Win95; I)
MIME-Version: 1.0
To: John Fotiadis/SYBASE Greece <johnf@sybase.com.gr>
Subject: Re: Sybase SQL Server 11 on NT 4.0 Server
References: <3SbC$Klc8GA.201@forums.powersoft.com>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.sqlserver.nt
Lines: 18
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.sqlserver.nt:5611
Article PK: 1081688


John Fotiadis/SYBASE Greece wrote:
>
> Does anyone have problems with TCP/IP connections from PB clients to Sybase
> SQl Server 11 on WinNT 4.0 Server ?
> --

It takes about 2 minutes for my PB client on Win95 to connect to the
server
on WinNT 4.0 at the first time. After connection, everything is OK.
I've also tried ping utility comes with Sybase. Same thing happened.
But on Win 3.11, it only takes about 15 sec to do so.

Can anyone tell me what's wrong?

I have got another problem on server. I can't delete any record from a
table.
The server told me that this table is referenced by more than 16 tables.
Can anyone tell me how to increase this number?

Thanks.


fangj Posted on 1997-06-18 16:06:59.0Z
Message-ID: <33A807A3.1B4D@midwest.co.cn>
Date: Thu, 19 Jun 1997 00:06:59 +0800
From: fangj@midwest.co.cn
Reply-To: fangj@midwest.co.cn
X-Mailer: Mozilla 3.01Gold (Win95; I)
MIME-Version: 1.0
Subject: Re: Sybase SQL Server 11 on NT 4.0 Server
References: <3SbC$Klc8GA.201@forums.powersoft.com> <339EC7F1.4E6E@midwest.co.cn>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.sqlserver.nt
Lines: 21
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.sqlserver.nt:5607
Article PK: 1081684

I've found what the problem is.
In sql.ini, I did not use IP addr. to reference the server.
Instead, I used the server name.
After changed to IP addr., it only takes a second to make
the connection, not 2 minutes.

fangj@midwest.co.cn wrote:
>
> It takes about 2 minutes for my PB client on Win95 to connect to the
> server
> on WinNT 4.0 at the first time. After connection, everything is OK.
> I've also tried ping utility comes with Sybase. Same thing happened.
> But on Win 3.11, it only takes about 15 sec to do so.
>
> Can anyone tell me what's wrong?
>
> I have got another problem on server. I can't delete any record from a
> table.
> The server told me that this table is referenced by more than 16 tables.
> Can anyone tell me how to increase this number?
>
> Thanks.


George Patrick Sand Posted on 1997-06-11 16:15:22.0Z
Message-ID: <339ECF1A.721C@mci.com>
Date: Wed, 11 Jun 1997 12:15:22 -0400
From: George Patrick Sand <Pat.Sand@mci.com>
Reply-To: Pat.Sand@mci.com
Organization: MCI FMIS (3392/082)
X-Mailer: Mozilla 3.0Gold (Win95; I)
MIME-Version: 1.0
Subject: Re: Sybase SQL Server 11 on NT 4.0 Server
References: <3SbC$Klc8GA.201@forums.powersoft.com> <339EC7F1.4E6E@midwest.co.cn>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.sqlserver.nt
Lines: 55
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.sqlserver.nt:5610
Article PK: 1081687


fangj@midwest.co.cn wrote:
>
> John Fotiadis/SYBASE Greece wrote:
> >
> > Does anyone have problems with TCP/IP connections from PB clients to Sybase
> > SQl Server 11 on WinNT 4.0 Server ?
> > --
>
> It takes about 2 minutes for my PB client on Win95 to connect to the
> server
> on WinNT 4.0 at the first time. After connection, everything is OK.
> I've also tried ping utility comes with Sybase. Same thing happened.
> But on Win 3.11, it only takes about 15 sec to do so.
>
> Can anyone tell me what's wrong?
>
> I have got another problem on server. I can't delete any record from a
> table.
> The server told me that this table is referenced by more than 16 tables.
> Can anyone tell me how to increase this number?
>
> Thanks.

Regarding the first problem, are you using the native Sybase driver SYt?
or ODBC?
You should use the native driver and the System 10/11 version. I use
mine from Win95 (32-bit) to talk to 11.0.2 Professional on NT 4.0 with
SP 2 and I connect in moments (3-5 seconds). I don't set any DBPARM
values and I have AutoCommit Mode checked. That's it...I'm running 5.0
of PB 32; I haven't applied the 5.0.2 fixes.

Regarding the second problem (more than 16...), you have hit the famous
DRI limit Sybase imposes. You have REFERENCES that total 16 or more and
Sybase won't let you modify the data (Insert, Update, or Delete) under
those conditions. You can either:

1. remove all DRI (Declarative Referential Integrity) stuff for the
table and make your changes, and then reapply the DRI.

2. remove DRI that you don't need. I bet this was error 428; you need
to reduce the number of foreign key references against this table or
that this table makes against others.

In either case, run sp_helpconstraint <tablename> to find out what
constraints are tied to this table. It will also include domains,
defaults, and rules, and table-level constraints. Only the foreign keys
should matter (the ...REFERENCES... part of your schema for that table
and related tables).
--
"Travelin' light but right..."
G. Patrick Sand (Pat.Sand@MCI.COM)
vnet 255-6407
Pager: 1-800-MCI-WORD Pin: 212-2610


fangj Posted on 1997-06-12 15:38:48.0Z
Message-ID: <33A01808.39F0@midwest.co.cn>
Date: Thu, 12 Jun 1997 23:38:48 +0800
From: fangj@midwest.co.cn
Reply-To: fangj@midwest.co.cn
X-Mailer: Mozilla 3.01Gold (Win95; I)
MIME-Version: 1.0
Subject: Re: Sybase SQL Server 11 on NT 4.0 Server
References: <3SbC$Klc8GA.201@forums.powersoft.com> <339EC7F1.4E6E@midwest.co.cn> <339ECF1A.721C@mci.com>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Newsgroups: sybase.public.sqlserver.nt
Lines: 18
Path: forums-1-dub!forums-master.sybase.com!forums.powersoft.com
Xref: forums-1-dub sybase.public.sqlserver.nt:5609
Article PK: 1081686


George Patrick Sand wrote:
>
> Regarding the first problem, are you using the native Sybase driver SYt?
> or ODBC?

I think it's native Sybase driver SYC 32-bit, and the NT 4.0 and Win95
are
all Chinese version. My PB is 5.0.2 32-bit.

> You should use the native driver and the System 10/11 version. I use
> mine from Win95 (32-bit) to talk to 11.0.2 Professional on NT 4.0 with
> SP 2 and I connect in moments (3-5 seconds). I don't set any DBPARM
> values and I have AutoCommit Mode checked. That's it...I'm running 5.0
> of PB 32; I haven't applied the 5.0.2 fixes.

I wonder why Sybase limit the reference number to 16.
Should we not make such a design?