Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Menu bug

5 posts in Pocket PowerBuilder Last posting was on 2003-08-12 06:30:24.0Z
Pocket Powerbuilder Posted on 2003-08-08 12:24:04.0Z
From: "Pocket Powerbuilder" <hov@reknes.no>
Newsgroups: sybase.public.pocketpowerbuilder
Subject: Menu bug
Lines: 19
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
NNTP-Posting-Host: 213.184.214.45
X-Original-NNTP-Posting-Host: 213.184.214.45
Message-ID: <3f339664$1@forums-1-dub>
Date: 8 Aug 2003 05:24:04 -0700
X-Trace: forums-1-dub 1060345444 213.184.214.45 (8 Aug 2003 05:24:04 -0700)
X-Original-Trace: 8 Aug 2003 05:24:04 -0700, 213.184.214.45
X-Authenticated-User: ppb
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:110
Article PK: 266067

Hi

Have just upgrade to PPB 1 build 109 had beta build 106 previous.
After rebuillding and deploying my application to my iPAQ h5450 whit
PocketPC 2002 on it the main menu did vanishing? If i use the iTask program
to swap between programs and reselect me application the main menu suddenly
is there and works fine? Did not have this problem on the beta version, and
i have not changed anything. But popup menus have started to work. :) Have
anyone found a work around for this problem?

Med vennlig hilsen
Reknes AS
:) Håkon Øvrelid
*****************************************
Sentralbord : 70 19 80 80 E-post: hov@reknes.no
Dir. telefon : 70 19 80 87 Hjemmeside: www.reknes.no
Postadresse: Futeveien 50, 6030 LANGEVÅG


Pocket Powerbuilder Posted on 2003-08-11 07:07:41.0Z
From: "Pocket Powerbuilder" <hov@reknes.no>
Newsgroups: sybase.public.pocketpowerbuilder
References: <3f339664$1@forums-1-dub>
Subject: Re: Menu bug
Lines: 58
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
NNTP-Posting-Host: 213.184.214.45
X-Original-NNTP-Posting-Host: 213.184.214.45
Message-ID: <3f3740bd$1@forums-1-dub>
Date: 11 Aug 2003 00:07:41 -0700
X-Trace: forums-1-dub 1060585661 213.184.214.45 (11 Aug 2003 00:07:41 -0700)
X-Original-Trace: 11 Aug 2003 00:07:41 -0700, 213.184.214.45
X-Authenticated-User: ppb
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:118
Article PK: 266074

Found a workaround!
On the application object open event added code to change menu to a dummy
menu and than i just changed it back!

norbit.open()
nvo_norbit_sync i_uosync
String ls_work
integer rc

open(w_logon)
// Establish DB connection
f_conn()

open(w_norbit)

/////////////////////////////
// Menu Bug workaroud
/////////////////////////////
menu m_dummy
w_norbit.changemenu(m_dummy)
w_norbit.changemenu(m_norbit)
/////////////////////////////

// Check whether an employee id exists in the registry
i_uosync = CREATE nvo_norbit_sync
rc = RegistryGet(i_uosync.APP_REGPATH, "MLUserName", RegString!, ls_work)

if rc <> 1 or not IsNumber(ls_work) then
gf_norbit_configure_sync()
end if


"Pocket Powerbuilder" <hov@reknes.no> skrev i melding
news:3f339664$1@forums-1-dub...

> Hi
>
> Have just upgrade to PPB 1 build 109 had beta build 106 previous.
> After rebuillding and deploying my application to my iPAQ h5450 whit
> PocketPC 2002 on it the main menu did vanishing? If i use the iTask
program
> to swap between programs and reselect me application the main menu
suddenly
> is there and works fine? Did not have this problem on the beta version,
and
> i have not changed anything. But popup menus have started to work. :) Have
> anyone found a work around for this problem?
>
> Med vennlig hilsen
> Reknes AS
> :) Håkon Øvrelid
> *****************************************
> Sentralbord : 70 19 80 80 E-post: hov@reknes.no
> Dir. telefon : 70 19 80 87 Hjemmeside: www.reknes.no
> Postadresse: Futeveien 50, 6030 LANGEVÅG
>
>


Berndt Hamboeck Posted on 2003-08-11 09:46:15.0Z
From: "Berndt Hamboeck" <bhamboec@gmx.at>
Newsgroups: sybase.public.pocketpowerbuilder
Organization: Bhitcon[195.233.250.5]
References: <3f339664$1@forums-1-dub> <3f3740bd$1@forums-1-dub>
X-Newsreader: AspNNTP 1.50 (Tri Hoang)
Subject: Re: Menu bug
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: transinc-win02.netoptex.com
X-Original-NNTP-Posting-Host: transinc-win02.netoptex.com
Message-ID: <3f3765e7$1@forums-1-dub>
Date: 11 Aug 2003 02:46:15 -0700
X-Trace: forums-1-dub 1060595175 206.169.167.22 (11 Aug 2003 02:46:15 -0700)
X-Original-Trace: 11 Aug 2003 02:46:15 -0700, transinc-win02.netoptex.com
Lines: 65
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:120
Article PK: 266070

Would you please open a case, so that someone looks at it and fixes it.

On 11 Aug 2003 00:07:41 -0700,
in sybase.public.pocketpowerbuilder

Pocket Powerbuilder <hov@reknes.no> wrote:
>Found a workaround!
>On the application object open event added code to change menu to a dummy
>menu and than i just changed it back!
>
>norbit.open()
>nvo_norbit_sync i_uosync
>String ls_work
>integer rc
>
>open(w_logon)
>// Establish DB connection
>f_conn()
>
>open(w_norbit)
>
>/////////////////////////////
>// Menu Bug workaroud
>/////////////////////////////
>menu m_dummy
>w_norbit.changemenu(m_dummy)
>w_norbit.changemenu(m_norbit)
>/////////////////////////////
>
>// Check whether an employee id exists in the registry
>i_uosync = CREATE nvo_norbit_sync
>rc = RegistryGet(i_uosync.APP_REGPATH, "MLUserName", RegString!, ls_work)
>
>if rc <> 1 or not IsNumber(ls_work) then
> gf_norbit_configure_sync()
>end if
>
>
>"Pocket Powerbuilder" <hov@reknes.no> skrev i melding
>news:3f339664$1@forums-1-dub...
>> Hi
>>
>> Have just upgrade to PPB 1 build 109 had beta build 106 previous.
>> After rebuillding and deploying my application to my iPAQ h5450 whit
>> PocketPC 2002 on it the main menu did vanishing? If i use the iTask
>program
>> to swap between programs and reselect me application the main menu
>suddenly
>> is there and works fine? Did not have this problem on the beta version,
>and
>> i have not changed anything. But popup menus have started to work. :) Have
>> anyone found a work around for this problem?
>>
>> Med vennlig hilsen
>> Reknes AS
>> :) Håkon Øvrelid
>> *****************************************
>> Sentralbord : 70 19 80 80 E-post: hov@reknes.no
>> Dir. telefon : 70 19 80 87 Hjemmeside: www.reknes.no
>> Postadresse: Futeveien 50, 6030 LANGEVÅG
>>
>>
>
>

Berndt


Pocket Powerbuilder Posted on 2003-08-12 06:30:24.0Z
From: "Pocket Powerbuilder" <hov@reknes.no>
Newsgroups: sybase.public.pocketpowerbuilder
References: <3f339664$1@forums-1-dub> <3f3740bd$1@forums-1-dub> <3f3765e7$1@forums-1-dub>
Subject: Re: Menu bug
Lines: 77
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: 213.184.214.45
Message-ID: <3f388996$1@forums-2-dub>
X-Original-Trace: 11 Aug 2003 23:30:46 -0700, 213.184.214.45
NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
Date: 11 Aug 2003 23:30:24 -0700
X-Trace: forums-1-dub 1060669824 10.22.241.42 (11 Aug 2003 23:30:24 -0700)
X-Original-Trace: 11 Aug 2003 23:30:24 -0700, forums-2-dub.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:150
Article PK: 266687

Done!

Case # 20324913 has been created

HÃ¥kon

"Berndt Hamboeck" <bhamboec@gmx.at> skrev i melding
news:3f3765e7$1@forums-1-dub...

> Would you please open a case, so that someone looks at it and fixes it.
>
> On 11 Aug 2003 00:07:41 -0700,
> in sybase.public.pocketpowerbuilder
> Pocket Powerbuilder <hov@reknes.no> wrote:
> >Found a workaround!
> >On the application object open event added code to change menu to a
dummy
> >menu and than i just changed it back!
> >
> >norbit.open()
> >nvo_norbit_sync i_uosync
> >String ls_work
> >integer rc
> >
> >open(w_logon)
> >// Establish DB connection
> >f_conn()
> >
> >open(w_norbit)
> >
> >/////////////////////////////
> >// Menu Bug workaroud
> >/////////////////////////////
> >menu m_dummy
> >w_norbit.changemenu(m_dummy)
> >w_norbit.changemenu(m_norbit)
> >/////////////////////////////
> >
> >// Check whether an employee id exists in the registry
> >i_uosync = CREATE nvo_norbit_sync
> >rc = RegistryGet(i_uosync.APP_REGPATH, "MLUserName", RegString!, ls_work)
> >
> >if rc <> 1 or not IsNumber(ls_work) then
> > gf_norbit_configure_sync()
> >end if
> >
> >
> >"Pocket Powerbuilder" <hov@reknes.no> skrev i melding
> >news:3f339664$1@forums-1-dub...
> >> Hi
> >>
> >> Have just upgrade to PPB 1 build 109 had beta build 106 previous.
> >> After rebuillding and deploying my application to my iPAQ h5450 whit
> >> PocketPC 2002 on it the main menu did vanishing? If i use the iTask
> >program
> >> to swap between programs and reselect me application the main menu
> >suddenly
> >> is there and works fine? Did not have this problem on the beta version,
> >and
> >> i have not changed anything. But popup menus have started to work. :)
Have
> >> anyone found a work around for this problem?
> >>
> >> Med vennlig hilsen
> >> Reknes AS
> >> :) Håkon Øvrelid
> >> *****************************************
> >> Sentralbord : 70 19 80 80 E-post: hov@reknes.no
> >> Dir. telefon : 70 19 80 87 Hjemmeside: www.reknes.no
> >> Postadresse: Futeveien 50, 6030 LANGEVÅG
> >>
> >>
> >
> >
>
> Berndt


Chris Pollach Posted on 2003-08-11 11:05:48.0Z
From: "Chris Pollach" <PollachC@SCC-CSC.gc.ca>
Newsgroups: sybase.public.pocketpowerbuilder
References: <3f339664$1@forums-1-dub> <3f3740bd$1@forums-1-dub>
Subject: Re: Menu bug
Lines: 74
Organization: The Supreme Court of Canada
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
NNTP-Posting-Host: 209.47.227.134
X-Original-NNTP-Posting-Host: 209.47.227.134
Message-ID: <3f37788c$1@forums-1-dub>
Date: 11 Aug 2003 04:05:48 -0700
X-Trace: forums-1-dub 1060599948 209.47.227.134 (11 Aug 2003 04:05:48 -0700)
X-Original-Trace: 11 Aug 2003 04:05:48 -0700, 209.47.227.134
X-Authenticated-User: PPB
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:123
Article PK: 266071

HÃ¥kon;

Yes, I found that problem way back in the later Alpha's. I use the same
approach to clean things up. Have a look at the STD Foundation Libraries on
www.codeXchange.Sybase.com. I also opened up a CaseXpress as well at that
time, but it might be time to open up another as this one seems to have
slipped by.

regards ... Chris
Great White North Technical Evangelist

"Pocket Powerbuilder" <hov@reknes.no> wrote in message
news:3f3740bd$1@forums-1-dub...
> Found a workaround!
> On the application object open event added code to change menu to a dummy
> menu and than i just changed it back!
>
> norbit.open()
> nvo_norbit_sync i_uosync
> String ls_work
> integer rc
>
> open(w_logon)
> // Establish DB connection
> f_conn()
>
> open(w_norbit)
>
> /////////////////////////////
> // Menu Bug workaroud
> /////////////////////////////
> menu m_dummy
> w_norbit.changemenu(m_dummy)
> w_norbit.changemenu(m_norbit)
> /////////////////////////////
>
> // Check whether an employee id exists in the registry
> i_uosync = CREATE nvo_norbit_sync
> rc = RegistryGet(i_uosync.APP_REGPATH, "MLUserName", RegString!, ls_work)
>
> if rc <> 1 or not IsNumber(ls_work) then
> gf_norbit_configure_sync()
> end if
>
>
> "Pocket Powerbuilder" <hov@reknes.no> skrev i melding
> news:3f339664$1@forums-1-dub...
> > Hi
> >
> > Have just upgrade to PPB 1 build 109 had beta build 106 previous.
> > After rebuillding and deploying my application to my iPAQ h5450 whit
> > PocketPC 2002 on it the main menu did vanishing? If i use the iTask
> program
> > to swap between programs and reselect me application the main menu
> suddenly
> > is there and works fine? Did not have this problem on the beta version,
> and
> > i have not changed anything. But popup menus have started to work. :)
Have
> > anyone found a work around for this problem?
> >
> > Med vennlig hilsen
> > Reknes AS
> > :) Håkon Øvrelid
> > *****************************************
> > Sentralbord : 70 19 80 80 E-post: hov@reknes.no
> > Dir. telefon : 70 19 80 87 Hjemmeside: www.reknes.no
> > Postadresse: Futeveien 50, 6030 LANGEVÅG
> >
> >
>
>