Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Today() Function ??

6 posts in Pocket PowerBuilder Last posting was on 2003-08-19 01:08:56.0Z
Mohit Chanana Posted on 2003-08-15 21:51:18.0Z
From: "Mohit Chanana" <NOSPAM_sas@sasintl.com>
Newsgroups: sybase.public.pocketpowerbuilder
Subject: Today() Function ??
Lines: 33
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_000E_01C3634D.663D2260"
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: 209.8.120.210
Message-ID: <3f3d55de$1@forums-2-dub>
X-Original-Trace: 15 Aug 2003 14:51:26 -0700, 209.8.120.210
NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
Date: 15 Aug 2003 14:51:18 -0700
X-Trace: forums-1-dub 1060984278 10.22.241.42 (15 Aug 2003 14:51:18 -0700)
X-Original-Trace: 15 Aug 2003 14:51:18 -0700, forums-2-dub.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:206
Article PK: 266744

Today() Function is not returning the current date on the device; although it works fine on desktop. Any Suggestions ?
 
 


Reed Shilts [Sybase] Posted on 2003-08-18 12:14:49.0Z
From: "Reed Shilts [Sybase]" <reed.dot.shilts.at.sybase.dot.com>
Newsgroups: sybase.public.pocketpowerbuilder
Subject: Re: Today() Function ??
Organization: Sybase
Message-ID: <oig1kvs69gfc9qq0op5sfnnp81am8hma97@4ax.com>
References: <3f3d55de$1@forums-2-dub>
X-Newsreader: Forte Free Agent 1.93/32.576 English (American)
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: rshilts.sybase.com
X-Original-Trace: 18 Aug 2003 05:15:06 -0700, rshilts.sybase.com
Lines: 19
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 18 Aug 2003 05:14:16 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 18 Aug 2003 05:14:49 -0700
X-Trace: forums-1-dub 1061208889 10.22.108.75 (18 Aug 2003 05:14:49 -0700)
X-Original-Trace: 18 Aug 2003 05:14:49 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:208
Article PK: 266746

This has been working fine forever.
Couple things to check:
a) make sure not static initialization
NOT: DATE foo = today()
BUT: DATE foo
foo = today()
b) the emulators have an interesting concept
of time...

Regards,
Reed Shilts
PPB Development Manager
<Standard-Disclaimers-Apply/>

On 15 Aug 2003 14:51:18 -0700, "Mohit Chanana"

<NOSPAM_sas@sasintl.com> wrote:

>Today() Function is not returning the current date on the device; although it works fine on desktop. Any Suggestions ?


Mohit Chanana Posted on 2003-08-18 20:00:38.0Z
From: "Mohit Chanana" <NOSPAM_sas@sasintl.com>
Newsgroups: sybase.public.pocketpowerbuilder
References: <3f3d55de$1@forums-2-dub> <oig1kvs69gfc9qq0op5sfnnp81am8hma97@4ax.com>
Subject: Re: Today() Function ??
Lines: 28
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
NNTP-Posting-Host: 209.8.120.210
X-Original-NNTP-Posting-Host: 209.8.120.210
Message-ID: <3f413066$1@forums-1-dub>
Date: 18 Aug 2003 13:00:38 -0700
X-Trace: forums-1-dub 1061236838 209.8.120.210 (18 Aug 2003 13:00:38 -0700)
X-Original-Trace: 18 Aug 2003 13:00:38 -0700, 209.8.120.210
X-Authenticated-User: ppb
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:217
Article PK: 266754

I have checked them all reed; It works perfectly fine if I execute it on
windows desktop but when I deploy it on the device the Date field comes out
blank. Could it be a device issue ?? I am using HP IPAQ 5555...

"Reed Shilts [Sybase]" <reed.dot.shilts.at.sybase.dot.com> wrote in message
news:oig1kvs69gfc9qq0op5sfnnp81am8hma97@4ax.com...
> This has been working fine forever.
> Couple things to check:
> a) make sure not static initialization
> NOT: DATE foo = today()
> BUT: DATE foo
> foo = today()
> b) the emulators have an interesting concept
> of time...
>
> Regards,
> Reed Shilts
> PPB Development Manager
> <Standard-Disclaimers-Apply/>
>
> On 15 Aug 2003 14:51:18 -0700, "Mohit Chanana"
> <NOSPAM_sas@sasintl.com> wrote:
>
> >Today() Function is not returning the current date on the device;
although it works fine on desktop. Any Suggestions ?
>


Reed Shilts [Sybase] Posted on 2003-08-18 20:36:45.0Z
From: "Reed Shilts [Sybase]" <reed.dot.shilts.at.sybase.dot.com>
Newsgroups: sybase.public.pocketpowerbuilder
Subject: Re: Today() Function ??
Organization: Sybase
Message-ID: <vvd2kvk06cur76fgui1d6l4cb2a4a76a7l@4ax.com>
References: <3f3d55de$1@forums-2-dub> <oig1kvs69gfc9qq0op5sfnnp81am8hma97@4ax.com> <3f413066$1@forums-1-dub>
X-Newsreader: Forte Free Agent 1.93/32.576 English (American)
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: rshilts.sybase.com
X-Original-NNTP-Posting-Host: rshilts.sybase.com
Date: 18 Aug 2003 13:36:45 -0700
X-Trace: forums-1-dub 1061239005 10.18.61.76 (18 Aug 2003 13:36:45 -0700)
X-Original-Trace: 18 Aug 2003 13:36:45 -0700, rshilts.sybase.com
Lines: 44
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:218
Article PK: 266755

I use an IPaq 3955.
hmmmmmm -
Would you post the offending piece of code?
Something is different....

Also - regional settings (mine are sometimes Italian and
sometimes US-English)
Regards,
Reed Shilts
PPB Development Manager
<Standard-Disclaimers-Apply/>


On 18 Aug 2003 13:00:38 -0700, "Mohit Chanana"

<NOSPAM_sas@sasintl.com> wrote:

>I have checked them all reed; It works perfectly fine if I execute it on
>windows desktop but when I deploy it on the device the Date field comes out
>blank. Could it be a device issue ?? I am using HP IPAQ 5555...
>
>"Reed Shilts [Sybase]" <reed.dot.shilts.at.sybase.dot.com> wrote in message
>news:oig1kvs69gfc9qq0op5sfnnp81am8hma97@4ax.com...
>> This has been working fine forever.
>> Couple things to check:
>> a) make sure not static initialization
>> NOT: DATE foo = today()
>> BUT: DATE foo
>> foo = today()
>> b) the emulators have an interesting concept
>> of time...
>>
>> Regards,
>> Reed Shilts
>> PPB Development Manager
>> <Standard-Disclaimers-Apply/>
>>
>> On 15 Aug 2003 14:51:18 -0700, "Mohit Chanana"
>> <NOSPAM_sas@sasintl.com> wrote:
>>
>> >Today() Function is not returning the current date on the device;
>although it works fine on desktop. Any Suggestions ?
>>
>


Mohit Chanana Posted on 2003-08-18 21:02:25.0Z
From: "Mohit Chanana" <NOSPAM_sas@sasintl.com>
Newsgroups: sybase.public.pocketpowerbuilder
References: <3f3d55de$1@forums-2-dub> <oig1kvs69gfc9qq0op5sfnnp81am8hma97@4ax.com> <3f413066$1@forums-1-dub> <vvd2kvk06cur76fgui1d6l4cb2a4a76a7l@4ax.com>
Subject: Re: Today() Function ??
Lines: 60
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: 209.8.120.210
Message-ID: <3f413ef5$1@forums-2-dub>
X-Original-Trace: 18 Aug 2003 14:02:45 -0700, 209.8.120.210
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 18 Aug 2003 14:01:49 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 18 Aug 2003 14:02:25 -0700
X-Trace: forums-1-dub 1061240545 10.22.108.75 (18 Aug 2003 14:02:25 -0700)
X-Original-Trace: 18 Aug 2003 14:02:25 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:219
Article PK: 266758

Aha.. found the Culprit; Its actully a Datawindow Masking issue (The Date
Field on Datawindow was Masked as MM/DD/YYYY) and it was not showing any
result on the device. The moment I switched it back to Edit; it worked just
fine. So its a whole new ball game now.

Regards

-Mohit

"Reed Shilts [Sybase]" <reed.dot.shilts.at.sybase.dot.com> wrote in message
news:vvd2kvk06cur76fgui1d6l4cb2a4a76a7l@4ax.com...
> I use an IPaq 3955.
> hmmmmmm -
> Would you post the offending piece of code?
> Something is different....
>
> Also - regional settings (mine are sometimes Italian and
> sometimes US-English)
> Regards,
> Reed Shilts
> PPB Development Manager
> <Standard-Disclaimers-Apply/>
>
>
> On 18 Aug 2003 13:00:38 -0700, "Mohit Chanana"
> <NOSPAM_sas@sasintl.com> wrote:
>
> >I have checked them all reed; It works perfectly fine if I execute it on
> >windows desktop but when I deploy it on the device the Date field comes
out
> >blank. Could it be a device issue ?? I am using HP IPAQ 5555...
> >
> >"Reed Shilts [Sybase]" <reed.dot.shilts.at.sybase.dot.com> wrote in
message
> >news:oig1kvs69gfc9qq0op5sfnnp81am8hma97@4ax.com...
> >> This has been working fine forever.
> >> Couple things to check:
> >> a) make sure not static initialization
> >> NOT: DATE foo = today()
> >> BUT: DATE foo
> >> foo = today()
> >> b) the emulators have an interesting concept
> >> of time...
> >>
> >> Regards,
> >> Reed Shilts
> >> PPB Development Manager
> >> <Standard-Disclaimers-Apply/>
> >>
> >> On 15 Aug 2003 14:51:18 -0700, "Mohit Chanana"
> >> <NOSPAM_sas@sasintl.com> wrote:
> >>
> >> >Today() Function is not returning the current date on the device;
> >although it works fine on desktop. Any Suggestions ?
> >>
> >
>


Chris Pollach Posted on 2003-08-19 01:08:56.0Z
From: "Chris Pollach" <cpollach@ajja.com>
Newsgroups: sybase.public.pocketpowerbuilder
References: <3f3d55de$1@forums-2-dub> <oig1kvs69gfc9qq0op5sfnnp81am8hma97@4ax.com> <3f413066$1@forums-1-dub> <vvd2kvk06cur76fgui1d6l4cb2a4a76a7l@4ax.com> <3f413ef5$1@forums-2-dub>
Subject: Re: Today() Function ??
Lines: 69
Organization: Software Tool & Die Inc.
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.00.2919.6700
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6700
X-Original-NNTP-Posting-Host: 206.47.171.60
Message-ID: <3f4178bc@forums-2-dub>
X-Original-Trace: 18 Aug 2003 18:09:16 -0700, 206.47.171.60
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 18 Aug 2003 18:08:19 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 18 Aug 2003 18:08:56 -0700
X-Trace: forums-1-dub 1061255336 10.22.108.75 (18 Aug 2003 18:08:56 -0700)
X-Original-Trace: 18 Aug 2003 18:08:56 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:221
Article PK: 266760

Yes, there are a few problems with DW EM's!

"Mohit Chanana" <NOSPAM_sas@sasintl.com> wrote in message
news:3f413ef5$1@forums-2-dub...
> Aha.. found the Culprit; Its actully a Datawindow Masking issue (The Date
> Field on Datawindow was Masked as MM/DD/YYYY) and it was not showing any
> result on the device. The moment I switched it back to Edit; it worked
just
> fine. So its a whole new ball game now.
>
> Regards
>
> -Mohit
>
>
> "Reed Shilts [Sybase]" <reed.dot.shilts.at.sybase.dot.com> wrote in
message
> news:vvd2kvk06cur76fgui1d6l4cb2a4a76a7l@4ax.com...
> > I use an IPaq 3955.
> > hmmmmmm -
> > Would you post the offending piece of code?
> > Something is different....
> >
> > Also - regional settings (mine are sometimes Italian and
> > sometimes US-English)
> > Regards,
> > Reed Shilts
> > PPB Development Manager
> > <Standard-Disclaimers-Apply/>
> >
> >
> > On 18 Aug 2003 13:00:38 -0700, "Mohit Chanana"
> > <NOSPAM_sas@sasintl.com> wrote:
> >
> > >I have checked them all reed; It works perfectly fine if I execute it
on
> > >windows desktop but when I deploy it on the device the Date field comes
> out
> > >blank. Could it be a device issue ?? I am using HP IPAQ 5555...
> > >
> > >"Reed Shilts [Sybase]" <reed.dot.shilts.at.sybase.dot.com> wrote in
> message
> > >news:oig1kvs69gfc9qq0op5sfnnp81am8hma97@4ax.com...
> > >> This has been working fine forever.
> > >> Couple things to check:
> > >> a) make sure not static initialization
> > >> NOT: DATE foo = today()
> > >> BUT: DATE foo
> > >> foo = today()
> > >> b) the emulators have an interesting concept
> > >> of time...
> > >>
> > >> Regards,
> > >> Reed Shilts
> > >> PPB Development Manager
> > >> <Standard-Disclaimers-Apply/>
> > >>
> > >> On 15 Aug 2003 14:51:18 -0700, "Mohit Chanana"
> > >> <NOSPAM_sas@sasintl.com> wrote:
> > >>
> > >> >Today() Function is not returning the current date on the device;
> > >although it works fine on desktop. Any Suggestions ?
> > >>
> > >
> >
>
>