Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

ASA and PowerDesigner

4 posts in General Discussion Last posting was on 2003-08-18 14:42:36.0Z
Anders Peterson Posted on 2003-08-18 12:15:47.0Z
From: Anders Peterson <anders_peterson@optimatika.se>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
Subject: ASA and PowerDesigner
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: h195n2fls35o276.telia.com
Message-ID: <3f40c386$1@forums-2-dub>
X-Original-Trace: 18 Aug 2003 05:16:06 -0700, h195n2fls35o276.telia.com
Lines: 15
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 18 Aug 2003 05:15:14 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 18 Aug 2003 05:15:47 -0700
X-Trace: forums-1-dub 1061208947 10.22.108.75 (18 Aug 2003 05:15:47 -0700)
X-Original-Trace: 18 Aug 2003 05:15:47 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:1620
Article PK: 3846

Hi,.

I'm using SQL Anywhere Studio 7.

I'd like to maintain my database model with PowerDesigner. It works fine
for tables and domains, but not for procedures and triggers.

Interactive SQL cannot run the scripts generated by PowerDesigner. The
problem seems to with '/' and/or ';' characters. I can't figure out how
to configure PowerDesigner to produce correct scripts.

What do I need to do?

/Anders


Paul Horan[TeamSybase] Posted on 2003-08-18 12:39:09.0Z
From: "Paul Horan[TeamSybase]" <paulhATvcisolutionsDOTcom>
Newsgroups: ianywhere.public.general
References: <3f40c386$1@forums-2-dub>
Subject: Re: ASA and PowerDesigner
Lines: 34
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
NNTP-Posting-Host: ny-chicagostreet2c-86.buf.adelphia.net
X-Original-NNTP-Posting-Host: ny-chicagostreet2c-86.buf.adelphia.net
Message-ID: <3f40c8ed$1@forums-1-dub>
Date: 18 Aug 2003 05:39:09 -0700
X-Trace: forums-1-dub 1061210349 68.69.67.86 (18 Aug 2003 05:39:09 -0700)
X-Original-Trace: 18 Aug 2003 05:39:09 -0700, ny-chicagostreet2c-86.buf.adelphia.net
X-Authenticated-User: TeamPS
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:1621
Article PK: 3847


"Anders Peterson" <anders_peterson@optimatika.se> wrote in message news:3f40c386$1@forums-2-dub...
> Hi,.
>
> I'm using SQL Anywhere Studio 7.
>
> I'd like to maintain my database model with PowerDesigner. It works fine
> for tables and domains, but not for procedures and triggers.
>
> Interactive SQL cannot run the scripts generated by PowerDesigner. The
> problem seems to with '/' and/or ';' characters. I can't figure out how
> to configure PowerDesigner to produce correct scripts.
>
> What do I need to do?
>
> /Anders
>

I replace the termination character '/' with the word 'GO', and it works fine.

--
Paul Horan[TeamSybase]

Get the new PB9 books!
http://www.pb9books.com?source=newsgroups

Code samples on Sybase CodeXchange:
http://codexchange.sybase.com

ISUG Enhancement Requests:
http://www.isug.com/cgi-bin/ISUG2/submit_enhancement


Anders Peterson Posted on 2003-08-18 14:42:36.0Z
From: Anders Peterson <anders_peterson@optimatika.se>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
Subject: Re: ASA and PowerDesigner
References: <3f40c386$1@forums-2-dub> <3f40c8ed$1@forums-1-dub>
In-Reply-To: <3f40c8ed$1@forums-1-dub>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: h195n2fls35o276.telia.com
X-Original-NNTP-Posting-Host: h195n2fls35o276.telia.com
Message-ID: <3f40e5dc@forums-1-dub>
Date: 18 Aug 2003 07:42:36 -0700
X-Trace: forums-1-dub 1061217756 81.224.43.195 (18 Aug 2003 07:42:36 -0700)
X-Original-Trace: 18 Aug 2003 07:42:36 -0700, h195n2fls35o276.telia.com
Lines: 35
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:1623
Article PK: 3848

Thanks for helping (so quickly)!

I changed the Database definition:

1) Altered the Block Terminator from '/' to 'go'.
2) I removed the '/' from all trigger templates.

Now eveything works.

/Anders

Paul Horan[TeamSybase] wrote:

> "Anders Peterson" <anders_peterson@optimatika.se> wrote in message news:3f40c386$1@forums-2-dub...
>
>>Hi,.
>>
>>I'm using SQL Anywhere Studio 7.
>>
>>I'd like to maintain my database model with PowerDesigner. It works fine
>>for tables and domains, but not for procedures and triggers.
>>
>>Interactive SQL cannot run the scripts generated by PowerDesigner. The
>>problem seems to with '/' and/or ';' characters. I can't figure out how
>>to configure PowerDesigner to produce correct scripts.
>>
>>What do I need to do?
>>
>>/Anders
>>
>
>
> I replace the termination character '/' with the word 'GO', and it works fine.
>


Anders Peterson Posted on 2003-08-18 14:42:11.0Z
Message-ID: <3F40E5A1.9040605@optimatika.se>
From: Anders Peterson <anders_peterson@optimatika.se>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
To: "Paul Horan[TeamSybase]" <paulhATvcisolutionsDOTcom>
Subject: Re: ASA and PowerDesigner
References: <3f40c386$1@forums-2-dub> <3f40c8ed$1@forums-1-dub>
In-Reply-To: <3f40c8ed$1@forums-1-dub>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: h195n2fls35o276.telia.com
X-Original-NNTP-Posting-Host: h195n2fls35o276.telia.com
Date: 18 Aug 2003 07:42:11 -0700
X-Trace: forums-1-dub 1061217731 81.224.43.195 (18 Aug 2003 07:42:11 -0700)
X-Original-Trace: 18 Aug 2003 07:42:11 -0700, h195n2fls35o276.telia.com
Lines: 35
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:1622
Article PK: 3849

Thanks for helping (so quickly)!

I changed the Database definition:

1) Altered the Block Terminator from '/' to 'go'.
2) I removed the '/' from all trigger templates.

Now eveything works.

/Anders

Paul Horan[TeamSybase] wrote:

> "Anders Peterson" <anders_peterson@optimatika.se> wrote in message news:3f40c386$1@forums-2-dub...
>
>>Hi,.
>>
>>I'm using SQL Anywhere Studio 7.
>>
>>I'd like to maintain my database model with PowerDesigner. It works fine
>>for tables and domains, but not for procedures and triggers.
>>
>>Interactive SQL cannot run the scripts generated by PowerDesigner. The
>>problem seems to with '/' and/or ';' characters. I can't figure out how
>>to configure PowerDesigner to produce correct scripts.
>>
>>What do I need to do?
>>
>>/Anders
>>
>
>
> I replace the termination character '/' with the word 'GO', and it works fine.
>