Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

connection issues

10 posts in Pocket PowerBuilder Last posting was on 2003-08-26 22:08:43.0Z
dw-extreme Posted on 2003-08-25 17:44:28.0Z
Sender: 435c.3f4a4a27.1804289383@sybase.com
From: dw-extreme
Newsgroups: sybase.public.pocketpowerbuilder
Subject: connection issues
X-Mailer: WebNews to Mail Gateway v1.1s
Message-ID: <3f4a4afc.4372.846930886@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 25 Aug 2003 10:44:28 -0700
X-Trace: forums-1-dub 1061833468 10.22.241.41 (25 Aug 2003 10:44:28 -0700)
X-Original-Trace: 25 Aug 2003 10:44:28 -0700, 10.22.241.41
Lines: 11
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:269
Article PK: 266807

I am trying to connect using PPB to am ASA db on a mobile
device. ASA loaded fine and starts up manually. I have the
dsn file in the base directory. The db file is in the same
directory as the dbsrv8 file. All the connect parms point
to the correct locations. But when I try to connect in the
PPB app on the device I get 'DBMS not supported in your
current installation'.

Any ideas?

Thanks


dw-extreme Posted on 2003-08-25 18:40:15.0Z
Sender: 4539.3f4a5769.1804289383@sybase.com
From: dw-extreme
Newsgroups: sybase.public.pocketpowerbuilder
Subject: Re: connection issues
X-Mailer: WebNews to Mail Gateway v1.1s
Message-ID: <3f4a580f.455d.846930886@sybase.com>
References: <3f4a4afc.4372.846930886@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 25 Aug 2003 11:40:15 -0700
X-Trace: forums-1-dub 1061836815 10.22.241.41 (25 Aug 2003 11:40:15 -0700)
X-Original-Trace: 25 Aug 2003 11:40:15 -0700, 10.22.241.41
Lines: 15
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:270
Article PK: 266808

added tge sqlca.dbms='ODBC' and the db now I get the message
SQLSTATE=IM003 Unable to load driver Adaptive Server
Anywhere 8.0.

> I am trying to connect using PPB to am ASA db on a mobile
> device. ASA loaded fine and starts up manually. I have
> the dsn file in the base directory. The db file is in the
> same directory as the dbsrv8 file. All the connect parms
> point to the correct locations. But when I try to connect
> in the PPB app on the device I get 'DBMS not supported in
> your current installation'.
>
> Any ideas?
>
> Thanks


dw-extreme Posted on 2003-08-25 21:07:39.0Z
Sender: 5be8.3f4a7a83.1804289383@sybase.com
From: dw-extreme
Newsgroups: sybase.public.pocketpowerbuilder
Subject: Re: connection issues last question
X-Mailer: WebNews to Mail Gateway v1.1s
Message-ID: <3f4a7ac6.5bf3.846930886@sybase.com>
References: <3f4a4afc.4372.846930886@sybase.com><3f4a580f.455d.846930886@sybase.com>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 25 Aug 2003 14:08:22 -0700, 10.22.241.42
Lines: 2
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 25 Aug 2003 14:06:20 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 25 Aug 2003 14:07:39 -0700
X-Trace: forums-1-dub 1061845659 10.22.108.75 (25 Aug 2003 14:07:39 -0700)
X-Original-Trace: 25 Aug 2003 14:07:39 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:272
Article PK: 266810

Is there anyway to suppress the ASA start dialog when you
connect to a database???


Peg Ostlund Posted on 2003-08-26 12:58:15.0Z
From: "Peg Ostlund" <peggy.ostlund@sybase.com>
Newsgroups: sybase.public.pocketpowerbuilder
References: <3f4a4afc.4372.846930886@sybase.com><3f4a580f.455d.846930886@sybase.com> <3f4a7ac6.5bf3.846930886@sybase.com>
Subject: Re: connection issues last question
Lines: 17
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.50.4920.2300
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4920.2300
NNTP-Posting-Host: postlundw2k.sybase.com
X-Original-NNTP-Posting-Host: postlundw2k.sybase.com
Message-ID: <3f4b5967$1@forums-1-dub>
Date: 26 Aug 2003 05:58:15 -0700
X-Trace: forums-1-dub 1061902695 204.167.46.233 (26 Aug 2003 05:58:15 -0700)
X-Original-Trace: 26 Aug 2003 05:58:15 -0700, postlundw2k.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:275
Article PK: 266813

Yes - use the "-q" switch on the Start line. Example DSN below:

[ODBC]
uid=DBA
pwd=SQL
enginename=Mydb
databasename=Mydb
databasefile=\Program Files\Sybase\ASA\Mydb.db
start=\Program Files\Sybase\ASA\dbsrv8.exe -q

<dw-extreme> wrote in message news:3f4a7ac6.5bf3.846930886@sybase.com...
> Is there anyway to suppress the ASA start dialog when you
> connect to a database???


dw-extreme Posted on 2003-08-26 13:41:46.0Z
Sender: 5217.3f4b6315.1804289383@sybase.com
From: dw-extreme
Newsgroups: sybase.public.pocketpowerbuilder
Subject: Re: connection issues last question
X-Mailer: WebNews to Mail Gateway v1.1s
Message-ID: <3f4b639a.522d.846930886@sybase.com>
References: <3f4a4afc.4372.846930886@sybase.com><3f4a580f.455d.846930886@sybase.com> <3f4a7ac6.5bf3.846930886@sybase.com><3f4b5967$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 26 Aug 2003 06:41:46 -0700
X-Trace: forums-1-dub 1061905306 10.22.241.41 (26 Aug 2003 06:41:46 -0700)
X-Original-Trace: 26 Aug 2003 06:41:46 -0700, 10.22.241.41
Lines: 25
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:276
Article PK: 266814

Thanks! I work better but the Ianywhere screen still asks
me if I want to connect. Are there other switches I need to
add?

Thanks Again

> Yes - use the "-q" switch on the Start line. Example DSN
> below:
>
> [ODBC]
> uid=DBA
> pwd=SQL
> enginename=Mydb
> databasename=Mydb
> databasefile=\Program Files\Sybase\ASA\Mydb.db
> start=\Program Files\Sybase\ASA\dbsrv8.exe -q
>
>
>
> <dw-extreme> wrote in message
> > news:3f4a7ac6.5bf3.846930886@sybase.com... Is there
> > anyway to suppress the ASA start dialog when you connect
> to a database???
>
>


Martyn Mallick Posted on 2003-08-26 18:04:13.0Z
From: "Martyn Mallick" <mmallick.removethis@ianywhere.com>
Newsgroups: sybase.public.pocketpowerbuilder
References: <3f4a4afc.4372.846930886@sybase.com><3f4a580f.455d.846930886@sybase.com> <3f4a7ac6.5bf3.846930886@sybase.com><3f4b5967$1@forums-1-dub> <3f4b639a.522d.846930886@sybase.com>
Subject: Re: connection issues last question
Lines: 34
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.50.4807.1700
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4910.0300
NNTP-Posting-Host: mmallick-pc.sybase.com
X-Original-NNTP-Posting-Host: mmallick-pc.sybase.com
Message-ID: <3f4ba11d$1@forums-1-dub>
Date: 26 Aug 2003 11:04:13 -0700
X-Trace: forums-1-dub 1061921053 172.31.141.129 (26 Aug 2003 11:04:13 -0700)
X-Original-Trace: 26 Aug 2003 11:04:13 -0700, mmallick-pc.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:281
Article PK: 266819

If it is finding the database properly and has the required connection
information, it shouldn't be prompting you at runtime to connect. Are you
getting the ODBC dialog box?

-Marty

<dw-extreme> wrote in message news:3f4b639a.522d.846930886@sybase.com...
> Thanks! I work better but the Ianywhere screen still asks
> me if I want to connect. Are there other switches I need to
> add?
>
> Thanks Again
>
> > Yes - use the "-q" switch on the Start line. Example DSN
> > below:
> >
> > [ODBC]
> > uid=DBA
> > pwd=SQL
> > enginename=Mydb
> > databasename=Mydb
> > databasefile=\Program Files\Sybase\ASA\Mydb.db
> > start=\Program Files\Sybase\ASA\dbsrv8.exe -q
> >
> >
> >
> > <dw-extreme> wrote in message
> > > news:3f4a7ac6.5bf3.846930886@sybase.com... Is there
> > > anyway to suppress the ASA start dialog when you connect
> > to a database???
> >
> >


dw-extreme Posted on 2003-08-26 19:42:30.0Z
Sender: 6d62.3f4bb729.1804289383@sybase.com
From: dw-extreme
Newsgroups: sybase.public.pocketpowerbuilder
Subject: another connection issue
X-Mailer: WebNews to Mail Gateway v1.1s
Message-ID: <3f4bb853.6d72.846930886@sybase.com>
References: <3f4a4afc.4372.846930886@sybase.com><3f4a580f.455d.846930886@sybase.com> <3f4a7ac6.5bf3.846930886@sybase.com><3f4b5967$1@forums-1-dub> <3f4b639a.522d.846930886@sybase.com><3f4ba11d$1@forums-1-dub>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 26 Aug 2003 12:43:15 -0700, 10.22.241.42
Lines: 19
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 26 Aug 2003 12:41:05 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 26 Aug 2003 12:42:30 -0700
X-Trace: forums-1-dub 1061926950 10.22.108.75 (26 Aug 2003 12:42:30 -0700)
X-Original-Trace: 26 Aug 2003 12:42:30 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:286
Article PK: 266823

Ok I am getting close. Here is the situation, I have a
consolidated ASE db called mobile. It is started on the
server, ready to accept requests. I start the sync process
on the cradled device on a db called mobile_client. The
messages appear normal uploading...

Waiting on mobilink to apply upload

Then communication error occured while recieving data from
the mobilink server.

disconnecting

completed.

What would call the communication error? Should I see
messages on the server message window????

Thanks,


David Fishburn Posted on 2003-08-26 22:08:43.0Z
Newsgroups: sybase.public.pocketpowerbuilder
Subject: Re: another connection issue
From: David Fishburn <fishburn_spam_off@ianywhere.com>
References: <3f4bb853.6d72.846930886@sybase.com>
Organization: iAnywhere Solutions
Message-ID: <Xns93E3B85C4B8B3fishburnsybasecom@10.22.241.106>
User-Agent: Xnews/06.02.16
NNTP-Posting-Host: vpn-concord-143.sybase.com
X-Original-NNTP-Posting-Host: vpn-concord-143.sybase.com
Date: 26 Aug 2003 15:08:43 -0700
X-Trace: forums-1-dub 1061935723 158.159.8.143 (26 Aug 2003 15:08:43 -0700)
X-Original-Trace: 26 Aug 2003 15:08:43 -0700, vpn-concord-143.sybase.com
Lines: 42
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:290
Article PK: 266828

dw-extreme wrote in news:3f4bb853.6d72.846930886@sybase.com:

Can you show us the command line you used to start the ML server.
If you did not start it with -vcrs -o file_name, make sure both of those
are there.

> Then communication error occured while recieving data from
> the mobilink server.

This can happen for 2 reasons:
1. The host and port specified in the remote database are wrong (ie ML
is listening on a different IP or port )
2. An error occurred in your synchronization scripts.

By running this, then looking at the file_name from above, we will have
a lot more information.

By the way, there is a MobiLink newsgroup:
sybase.public.sqlanywhere.mobilink

So if you have specific ML issues, it might make more sense to post
there, I do not read this NG as often.

--
David Fishburn
NEW - Certified ASA Developer Version 8
Sybase - iAnywhere Solutions
Professional Services
Please only post to the newsgroup
Please ALWAYS include version and MORE importantly BUILD number with EACH
post (dbeng8 -v).

EBFs and Maintenance Releases
http://downloads.sybase.com/swx/sdmain.stm

Developer Community / Whitepapers
http://www.ianywhere.com/developer

CaseXpress - to report bugs
http://casexpress.sybase.com


dw-extreme Posted on 2003-08-26 19:33:13.0Z
Sender: 6d56.3f4bb5cc.1804289383@sybase.com
From: dw-extreme
Newsgroups: sybase.public.pocketpowerbuilder
Subject: Re: connection issues last question
X-Mailer: WebNews to Mail Gateway v1.1s
Message-ID: <3f4bb626.6d58.846930886@sybase.com>
References: <3f4a4afc.4372.846930886@sybase.com><3f4a580f.455d.846930886@sybase.com> <3f4a7ac6.5bf3.846930886@sybase.com><3f4b5967$1@forums-1-dub> <3f4b639a.522d.846930886@sybase.com><3f4ba11d$1@forums-1-dub>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 26 Aug 2003 12:33:58 -0700, 10.22.241.42
Lines: 37
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 26 Aug 2003 12:31:49 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 26 Aug 2003 12:33:13 -0700
X-Trace: forums-1-dub 1061926393 10.22.108.75 (26 Aug 2003 12:33:13 -0700)
X-Original-Trace: 26 Aug 2003 12:33:13 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:285
Article PK: 266824

No its just the license agreement for the eval copy of ASA.

> If it is finding the database properly and has the
> required connection information, it shouldn't be prompting
> you at runtime to connect. Are you getting the ODBC
> dialog box?
>
> -Marty
>
> <dw-extreme> wrote in message
> > news:3f4b639a.522d.846930886@sybase.com... Thanks! I
> > work better but the Ianywhere screen still asks me if I
> > want to connect. Are there other switches I need to
> add? >
> > Thanks Again
> >
> > > Yes - use the "-q" switch on the Start line. Example
> > > DSN below:
> > >
> > > [ODBC]
> > > uid=DBA
> > > pwd=SQL
> > > enginename=Mydb
> > > databasename=Mydb
> > > databasefile=\Program Files\Sybase\ASA\Mydb.db
> > > start=\Program Files\Sybase\ASA\dbsrv8.exe -q
> > >
> > >
> > >
> > > <dw-extreme> wrote in message
> > > > news:3f4a7ac6.5bf3.846930886@sybase.com... Is there
> > > > anyway to suppress the ASA start dialog when you
> > > connect to a database???
> > >
> > >
>
>


dw-extreme Posted on 2003-08-26 19:43:30.0Z
Sender: 6d79.3f4bb86f.1804289383@sybase.com
From: dw-extreme
Newsgroups: sybase.public.pocketpowerbuilder
Subject: Re: connection issues last question
X-Mailer: WebNews to Mail Gateway v1.1s
Message-ID: <3f4bb890.6d7c.846930886@sybase.com>
References: <3f4a4afc.4372.846930886@sybase.com><3f4a580f.455d.846930886@sybase.com> <3f4a7ac6.5bf3.846930886@sybase.com><3f4b5967$1@forums-1-dub> <3f4b639a.522d.846930886@sybase.com><3f4ba11d$1@forums-1-dub>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 26 Aug 2003 12:44:16 -0700, 10.22.241.42
Lines: 21
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 26 Aug 2003 12:42:06 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 26 Aug 2003 12:43:30 -0700
X-Trace: forums-1-dub 1061927010 10.22.108.75 (26 Aug 2003 12:43:30 -0700)
X-Original-Trace: 26 Aug 2003 12:43:30 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:287
Article PK: 266825

(If this appears twice... sorry)

Ok I am getting close. Here is the situation, I have a
consolidated ASE db called mobile. It is started on the
server, ready to accept requests. I start the sync process
on the cradled device on a db called mobile_client. The
messages appear normal uploading...

Waiting on mobilink to apply upload

Then communication error occured while recieving data from
the mobilink server.

disconnecting

completed.

What would call the communication error? Should I see
messages on the server message window????

Thanks,