Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Aplication Install Problem

10 posts in Pocket PowerBuilder Last posting was on 2003-10-31 12:56:42.0Z
Miguel Carvajal Posted on 2003-08-28 16:33:56.0Z
From: "Miguel Carvajal" <miguelcarvajal555@hotmail.com>
Newsgroups: sybase.public.pocketpowerbuilder
Subject: Aplication Install Problem
Lines: 95
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2600.0000
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000
NNTP-Posting-Host: 200-91-196-198-dial-up.ifx.net.co
X-Original-NNTP-Posting-Host: 200-91-196-198-dial-up.ifx.net.co
Message-ID: <3f4e2ef4@forums-1-dub>
Date: 28 Aug 2003 09:33:56 -0700
X-Trace: forums-1-dub 1062088436 200.91.196.198 (28 Aug 2003 09:33:56 -0700)
X-Original-Trace: 28 Aug 2003 09:33:56 -0700, 200-91-196-198-dial-up.ifx.net.co
X-Authenticated-User: ppb
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:302
Article PK: 266840

Hello

I create an application with PPB 1.0 Build 106. Soon CAB
creates the file (with Cabwiz.exe) to make the installation in my
PocketPC, including my archives and the necessary archives of PPB so
that my application works.

When I execute the file CAB in my PocketPC the installation is made
satisfactorily, but when I execute the installed application, it
appears the following error:

"LoadLibrary failed for VMCE"

That I can do?

Associate the file inf with which I create I file CAB

Thanks

Miguel


Ian Thain Posted on 2003-08-29 11:01:50.0Z
Reply-To: "Ian Thain" <ian.thain@sybase.com>
From: "Ian Thain" <ian.thain@sybase.com>
Newsgroups: sybase.public.pocketpowerbuilder
References: <3f4e2ef4@forums-1-dub>
Subject: Re: Aplication Install Problem
Lines: 33
Organization: Sybase Inc
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
NNTP-Posting-Host: host217-35-101-37.in-addr.btopenworld.com
X-Original-NNTP-Posting-Host: host217-35-101-37.in-addr.btopenworld.com
Message-ID: <3f4f329e$1@forums-1-dub>
Date: 29 Aug 2003 04:01:50 -0700
X-Trace: forums-1-dub 1062154910 217.35.101.37 (29 Aug 2003 04:01:50 -0700)
X-Original-Trace: 29 Aug 2003 04:01:50 -0700, host217-35-101-37.in-addr.btopenworld.com
X-Authenticated-User: ppb
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:304
Article PK: 266842

Miguel

Have you installed the runtime of PPB ?

Ian

"Miguel Carvajal" <miguelcarvajal555@hotmail.com> wrote in message
news:3f4e2ef4@forums-1-dub...
> Hello
>
> I create an application with PPB 1.0 Build 106. Soon CAB
> creates the file (with Cabwiz.exe) to make the installation in my
> PocketPC, including my archives and the necessary archives of PPB so
> that my application works.
>
> When I execute the file CAB in my PocketPC the installation is made
> satisfactorily, but when I execute the installed application, it
> appears the following error:
>
> "LoadLibrary failed for VMCE"
>
> That I can do?
>
> Associate the file inf with which I create I file CAB
>
> Thanks
>
> Miguel
>
>
>


Miguel Carvajal Posted on 2003-08-29 14:06:42.0Z
From: "Miguel Carvajal" <miguelcarvajal555@hotmail.com>
Newsgroups: sybase.public.pocketpowerbuilder
References: <3f4e2ef4@forums-1-dub> <3f4f329e$1@forums-1-dub>
Subject: Re: Aplication Install Problem
Lines: 58
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2600.0000
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000
X-Original-NNTP-Posting-Host: 200-91-196-38-dial-up.ifx.net.co
Message-ID: <3f4f5e2a@forums-2-dub>
X-Original-Trace: 29 Aug 2003 07:07:38 -0700, 200-91-196-38-dial-up.ifx.net.co
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 29 Aug 2003 07:05:00 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 29 Aug 2003 07:06:42 -0700
X-Trace: forums-1-dub 1062166002 10.22.108.75 (29 Aug 2003 07:06:42 -0700)
X-Original-Trace: 29 Aug 2003 07:06:42 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:305
Article PK: 266843

In my PocketPC I have not installed anything. What happens, is that I
included those archives in my CAB of the application not to install
separate SYBASE Pocket Builder, but everything, with my CAB

In CAB of my application, I place the following archives of
PPB, and that when installing my CAB are left in the folder \Windows
of my PocketPC:

"PKODB10U.DLL"
;"pkvm10u.dll"
;"pkodb10u.ini"
;"pkbgr10u.dll"

These are the necessary archives (runtime DLL's) of Pocket Builder so that
an
application works, but the error this appearing.

That I can do?

"Ian Thain" <ian.thain@sybase.com> wrote in message
news:3f4f329e$1@forums-1-dub...
> Miguel
>
> Have you installed the runtime of PPB ?
>
> Ian
>
> "Miguel Carvajal" <miguelcarvajal555@hotmail.com> wrote in message
> news:3f4e2ef4@forums-1-dub...
> > Hello
> >
> > I create an application with PPB 1.0 Build 106. Soon CAB
> > creates the file (with Cabwiz.exe) to make the installation in my
> > PocketPC, including my archives and the necessary archives of PPB so
> > that my application works.
> >
> > When I execute the file CAB in my PocketPC the installation is made
> > satisfactorily, but when I execute the installed application, it
> > appears the following error:
> >
> > "LoadLibrary failed for VMCE"
> >
> > That I can do?
> >
> > Associate the file inf with which I create I file CAB
> >
> > Thanks
> >
> > Miguel
> >
> >
> >
>
>


Reed Shilts [Sybase] Posted on 2003-08-29 14:27:11.0Z
From: "Reed Shilts [Sybase]" <reed.dot.shilts.at.sybase.dot.com>
Newsgroups: sybase.public.pocketpowerbuilder
Subject: Re: Aplication Install Problem
Organization: Sybase
Message-ID: <3vnukvg011b0upntr317bt01sd5ml02uak@4ax.com>
References: <3f4e2ef4@forums-1-dub> <3f4f329e$1@forums-1-dub> <3f4f5e2a@forums-2-dub>
X-Newsreader: Forte Agent 1.93/32.576 English (American)
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: rshilts.sybase.com
X-Original-Trace: 29 Aug 2003 07:28:08 -0700, rshilts.sybase.com
Lines: 96
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 29 Aug 2003 07:25:30 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 29 Aug 2003 07:27:11 -0700
X-Trace: forums-1-dub 1062167231 10.22.108.75 (29 Aug 2003 07:27:11 -0700)
X-Original-Trace: 29 Aug 2003 07:27:11 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:306
Article PK: 266844

Miguel,
The error message is that the PocketBuilder DLLs are not
on the device.
I'm assuming you are seeing this is when you're creating
the final application for your customer.
If this is for development, it's a whole lot easier to just
run "WinCE Setup" from the Pocket PowerBuilder group
in the Start menu....
Or - copy the "Pocket PowerBuilder.ARM.CAB" file to your
PDA and tap it - that installs everything for the PDA.

For customer deployment....
(the subject of a half-written technote for sybase.com)
Basically....

The recommendation for your application distribution is to
do one of two things:
a) explicitely deploy the "Pocket PowerBuilder.ARM.CAB" file.
Easy to do with something like "EZSetup"
b) copy the necessary PKxxx10u.* files into your CAB when
you build your CAB file.
(that is the implication of the commented out lines
in the INF file we create)
Note the semi-colons starting the lines, those are
the comment characters.

For more details, on customer deployment, that technote is
on my "to-do" list.

Hope this helps,
Reed Shilts
Pocket PowerBuilder Development Manager
<Standard-Disclaimers-Apply/>


On 29 Aug 2003 07:06:42 -0700, "Miguel Carvajal"

<miguelcarvajal555@hotmail.com> wrote:

>In my PocketPC I have not installed anything. What happens, is that I
>included those archives in my CAB of the application not to install
>separate SYBASE Pocket Builder, but everything, with my CAB
>
>In CAB of my application, I place the following archives of
>PPB, and that when installing my CAB are left in the folder \Windows
>of my PocketPC:
>
>"PKODB10U.DLL"
>;"pkvm10u.dll"
>;"pkodb10u.ini"
>;"pkbgr10u.dll"
>
>These are the necessary archives (runtime DLL's) of Pocket Builder so that
>an
>application works, but the error this appearing.
>
>That I can do?
>
>
>
>"Ian Thain" <ian.thain@sybase.com> wrote in message
>news:3f4f329e$1@forums-1-dub...
>> Miguel
>>
>> Have you installed the runtime of PPB ?
>>
>> Ian
>>
>> "Miguel Carvajal" <miguelcarvajal555@hotmail.com> wrote in message
>> news:3f4e2ef4@forums-1-dub...
>> > Hello
>> >
>> > I create an application with PPB 1.0 Build 106. Soon CAB
>> > creates the file (with Cabwiz.exe) to make the installation in my
>> > PocketPC, including my archives and the necessary archives of PPB so
>> > that my application works.
>> >
>> > When I execute the file CAB in my PocketPC the installation is made
>> > satisfactorily, but when I execute the installed application, it
>> > appears the following error:
>> >
>> > "LoadLibrary failed for VMCE"
>> >
>> > That I can do?
>> >
>> > Associate the file inf with which I create I file CAB
>> >
>> > Thanks
>> >
>> > Miguel
>> >
>> >
>> >
>>
>>
>


Miguel Carvajal Posted on 2003-08-29 15:09:58.0Z
From: "Miguel Carvajal" <miguelcarvajal555@hotmail.com>
Newsgroups: sybase.public.pocketpowerbuilder
References: <3f4e2ef4@forums-1-dub> <3f4f329e$1@forums-1-dub> <3f4f5e2a@forums-2-dub> <3vnukvg011b0upntr317bt01sd5ml02uak@4ax.com>
Subject: Re: Aplication Install Problem
Lines: 222
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2600.0000
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000
X-Original-NNTP-Posting-Host: 200-91-196-38-dial-up.ifx.net.co
Message-ID: <3f4f6cff@forums-2-dub>
X-Original-Trace: 29 Aug 2003 08:10:55 -0700, 200-91-196-38-dial-up.ifx.net.co
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 29 Aug 2003 08:08:18 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 29 Aug 2003 08:09:58 -0700
X-Trace: forums-1-dub 1062169798 10.22.108.75 (29 Aug 2003 08:09:58 -0700)
X-Original-Trace: 29 Aug 2003 08:09:58 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:307
Article PK: 266846

Reed..... my INF files is:
*********************************************************************
[Version]
Signature = "$Windows NT$"
Provider = "MyG Sistemas"
CESignature = "$Windows CE$"


[CEStrings]
; ***CHANGED HERE***
AppName="oasissfa"
InstallDir=%CE1%\MyGSistemas\OasisSFA

[Strings]
; SA = 2577, ARM = 1824
arm_cpu = 2577
em86_cpu = 568
x86_cpu = 686
reg_path = Software\MyGSistemas\OasisSFA


[CEDevice]
UnsupportedPlatforms = "Jupiter","HPC" ; Does not support pltfrm1
VersionMin = 3.0
VersionMax = 100.0

[CEDevice.ARM]
ProcessorType = %arm_cpu% ; PPC with StrongARM processor

[CEDevice.EM86]
ProcessorType = %em86_cpu% ; Emulator of Pocket PC 2000

[CEDevice.x86]
ProcessorType = %x86_cpu% ; x86 Emulator of Pocket PC 2002


[DefaultInstall]
CopyFiles = Files.Shared, Files.ARM, Files.PPB, Files.DSN, Files.DB
AddReg = RegSettings
CEShortcuts = Shortcuts.All


[SourceDisksNames]
1 = ,"Common files",,.
2 = ,"Application files",,.

[SourceDisksFiles]
; "$CAB_DUP_FILES_COMMON$"=1
"oasissfa.pkd"=1
"PKODB10U.DLL"=1
"pkvm10u.dll"=1
"pkodb10u.ini"=1
"pkbgr10u.dll"=1

"oasissfa_remota.DSN"=1
"oasissfa_remota.db"=1
"oasissfa_remota.log"=1

[SourceDisksFiles.ARM]
"oasissfa.exe.ARM"=2

[DestinationDirs]
DefaultDestDir = 0,%InstallDir%
Files.Shared = 0,%InstallDir%
Files.ARM = 0,%InstallDir%
Files.PPB = 0,"\Windows"
Files.DSN = 0,"\Windows\.."
Files.DB = 0,"\Program Files\Sybase\ASA"
Shortcuts.All = 0,"\Windows\Start Menu"


[Files.Shared]
; "$CAB_DUP_FILES_COMMON$",,,0x80000000 ; mark as shared
"oasissfa.pkd",,,0x80000000 ; mark as shared

[Files.PPB]
"PKODB10U.DLL",,,0x80000000 ; mark as shared
"pkvm10u.dll",,,0x80000000 ; mark as shared
"pkodb10u.ini",,,0x80000000 ; mark as shared
"pkbgr10u.dll",,,0x80000000 ; mark as shared

[Files.ARM]
"oasissfa.exe","oasissfa.exe.ARM",,0x00000001 ; warn if skipped

[Files.DSN]
"oasissfa_remota.DSN",,,0x80000000

[Files.DB]
"oasissfa_remota.db",,,0x80000000
"oasissfa_remota.log",,,0x80000000

[Shortcuts.All]
; nothing...
OasisSFA,0,oasissfa.exe

[RegSettings]
HKLM,Software\PPB,,0,"MyG Sistemas Oasis SFA"

[Strings]
xGenerator = "Sybase Pocket PowerBuilder 1.0"
xCompany = "MyG Sistemas"
xDescription = "Sistema de Información OASIS para Pocket PC"
xCopyright = ""
xProduct = "oasissfa"
xVersion = "1.0.0.1"

; --eof--
*********************************************************************
The file this good? If this good, because when I install CAB and I
execute the application, to me continues appearing the error?

Thanks

Miguel..........

"Reed Shilts [Sybase]" <reed.dot.shilts.at.sybase.dot.com> wrote in message
news:3vnukvg011b0upntr317bt01sd5ml02uak@4ax.com...
> Miguel,
> The error message is that the PocketBuilder DLLs are not
> on the device.
> I'm assuming you are seeing this is when you're creating
> the final application for your customer.
> If this is for development, it's a whole lot easier to just
> run "WinCE Setup" from the Pocket PowerBuilder group
> in the Start menu....
> Or - copy the "Pocket PowerBuilder.ARM.CAB" file to your
> PDA and tap it - that installs everything for the PDA.
>
> For customer deployment....
> (the subject of a half-written technote for sybase.com)
> Basically....
>
> The recommendation for your application distribution is to
> do one of two things:
> a) explicitely deploy the "Pocket PowerBuilder.ARM.CAB" file.
> Easy to do with something like "EZSetup"
> b) copy the necessary PKxxx10u.* files into your CAB when
> you build your CAB file.
> (that is the implication of the commented out lines
> in the INF file we create)
> Note the semi-colons starting the lines, those are
> the comment characters.
>
> For more details, on customer deployment, that technote is
> on my "to-do" list.
>
> Hope this helps,
> Reed Shilts
> Pocket PowerBuilder Development Manager
> <Standard-Disclaimers-Apply/>
>
>
> On 29 Aug 2003 07:06:42 -0700, "Miguel Carvajal"
> <miguelcarvajal555@hotmail.com> wrote:
>
> >In my PocketPC I have not installed anything. What happens, is that I
> >included those archives in my CAB of the application not to install
> >separate SYBASE Pocket Builder, but everything, with my CAB
> >
> >In CAB of my application, I place the following archives of
> >PPB, and that when installing my CAB are left in the folder \Windows
> >of my PocketPC:
> >
> >"PKODB10U.DLL"
> >;"pkvm10u.dll"
> >;"pkodb10u.ini"
> >;"pkbgr10u.dll"
> >
> >These are the necessary archives (runtime DLL's) of Pocket Builder so
that
> >an
> >application works, but the error this appearing.
> >
> >That I can do?
> >
> >
> >
> >"Ian Thain" <ian.thain@sybase.com> wrote in message
> >news:3f4f329e$1@forums-1-dub...
> >> Miguel
> >>
> >> Have you installed the runtime of PPB ?
> >>
> >> Ian
> >>
> >> "Miguel Carvajal" <miguelcarvajal555@hotmail.com> wrote in message
> >> news:3f4e2ef4@forums-1-dub...
> >> > Hello
> >> >
> >> > I create an application with PPB 1.0 Build 106. Soon CAB
> >> > creates the file (with Cabwiz.exe) to make the installation in my
> >> > PocketPC, including my archives and the necessary archives of PPB so
> >> > that my application works.
> >> >
> >> > When I execute the file CAB in my PocketPC the installation is made
> >> > satisfactorily, but when I execute the installed application, it
> >> > appears the following error:
> >> >
> >> > "LoadLibrary failed for VMCE"
> >> >
> >> > That I can do?
> >> >
> >> > Associate the file inf with which I create I file CAB
> >> >
> >> > Thanks
> >> >
> >> > Miguel
> >> >
> >> >
> >> >
> >>
> >>
> >
>


Reed Shilts [Sybase] Posted on 2003-08-29 18:28:06.0Z
From: "Reed Shilts [Sybase]" <reed.dot.shilts.at.sybase.dot.com>
Newsgroups: sybase.public.pocketpowerbuilder
Subject: Re: Aplication Install Problem
Organization: Sybase
Message-ID: <a16vkv4hfvfu97eb2i54o970sqlvhnt6vv@4ax.com>
References: <3f4e2ef4@forums-1-dub> <3f4f329e$1@forums-1-dub> <3f4f5e2a@forums-2-dub> <3vnukvg011b0upntr317bt01sd5ml02uak@4ax.com> <3f4f6cff@forums-2-dub>
X-Newsreader: Forte Agent 1.93/32.576 English (American)
MIME-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 8bit
X-Original-NNTP-Posting-Host: rshilts.sybase.com
X-Original-Trace: 29 Aug 2003 11:29:04 -0700, rshilts.sybase.com
Lines: 258
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 29 Aug 2003 11:26:25 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 29 Aug 2003 11:28:06 -0700
X-Trace: forums-1-dub 1062181686 10.22.108.75 (29 Aug 2003 11:28:06 -0700)
X-Original-Trace: 29 Aug 2003 11:28:06 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:308
Article PK: 266845

I am assuming everything works if you manually deploy
the "Pocket PowerBuilder...CAB" to the target device.

<<is this true?>>

So - the issue is packaging...
From this INF file, I would bet that when the CAB file is
generated it's not finding your PKxxx.DLL files (look in err.log).

Two routes to a solution,

A) add a "file group" which points to the directory containing
the PKxxx.DLL files (for the ARM and x86) - hard to explain further,
but the 'correct' solution.
Refer to msdn.microsoft.com, search for
"CE 3.0" CAB Wizard

This weekend I'll post a "correct" INF file which includes
the PK support files -
An example is always much easier for me...

OR
B) a hack approach, copy the "PKVM10u.dll" and friends from
the "%INSTALL%\wince\arm" directory locally.
THen your current INF file should pick those guys up.
Like I said - a hack which only works for one platform, but
usable as a proof of concept.

Regards,
Reed Shilts
<Standard-Disclaimers-Apply/>


On 29 Aug 2003 08:09:58 -0700, "Miguel Carvajal"

<miguelcarvajal555@hotmail.com> wrote:

>Reed..... my INF files is:
>*********************************************************************
>[Version]
>Signature = "$Windows NT$"
>Provider = "MyG Sistemas"
>CESignature = "$Windows CE$"
>
>
>[CEStrings]
>; ***CHANGED HERE***
>AppName="oasissfa"
>InstallDir=%CE1%\MyGSistemas\OasisSFA
>
>[Strings]
>; SA = 2577, ARM = 1824
>arm_cpu = 2577
>em86_cpu = 568
>x86_cpu = 686
>reg_path = Software\MyGSistemas\OasisSFA
>
>
>[CEDevice]
>UnsupportedPlatforms = "Jupiter","HPC" ; Does not support pltfrm1
>VersionMin = 3.0
>VersionMax = 100.0
>
>[CEDevice.ARM]
>ProcessorType = %arm_cpu% ; PPC with StrongARM processor
>
>[CEDevice.EM86]
>ProcessorType = %em86_cpu% ; Emulator of Pocket PC 2000
>
>[CEDevice.x86]
>ProcessorType = %x86_cpu% ; x86 Emulator of Pocket PC 2002
>
>
>[DefaultInstall]
>CopyFiles = Files.Shared, Files.ARM, Files.PPB, Files.DSN, Files.DB
>AddReg = RegSettings
>CEShortcuts = Shortcuts.All
>
>
>[SourceDisksNames]
>1 = ,"Common files",,.
>2 = ,"Application files",,.
>
>[SourceDisksFiles]
>; "$CAB_DUP_FILES_COMMON$"=1
>"oasissfa.pkd"=1
>"PKODB10U.DLL"=1
>"pkvm10u.dll"=1
>"pkodb10u.ini"=1
>"pkbgr10u.dll"=1
>
>"oasissfa_remota.DSN"=1
>"oasissfa_remota.db"=1
>"oasissfa_remota.log"=1
>
>[SourceDisksFiles.ARM]
>"oasissfa.exe.ARM"=2
>
>[DestinationDirs]
>DefaultDestDir = 0,%InstallDir%
>Files.Shared = 0,%InstallDir%
>Files.ARM = 0,%InstallDir%
>Files.PPB = 0,"\Windows"
>Files.DSN = 0,"\Windows\.."
>Files.DB = 0,"\Program Files\Sybase\ASA"
>Shortcuts.All = 0,"\Windows\Start Menu"
>
>
>[Files.Shared]
>; "$CAB_DUP_FILES_COMMON$",,,0x80000000 ; mark as shared
>"oasissfa.pkd",,,0x80000000 ; mark as shared
>
>[Files.PPB]
>"PKODB10U.DLL",,,0x80000000 ; mark as shared
>"pkvm10u.dll",,,0x80000000 ; mark as shared
>"pkodb10u.ini",,,0x80000000 ; mark as shared
>"pkbgr10u.dll",,,0x80000000 ; mark as shared
>
>[Files.ARM]
>"oasissfa.exe","oasissfa.exe.ARM",,0x00000001 ; warn if skipped
>
>[Files.DSN]
>"oasissfa_remota.DSN",,,0x80000000
>
>[Files.DB]
>"oasissfa_remota.db",,,0x80000000
>"oasissfa_remota.log",,,0x80000000
>
>[Shortcuts.All]
>; nothing...
>OasisSFA,0,oasissfa.exe
>
>[RegSettings]
>HKLM,Software\PPB,,0,"MyG Sistemas Oasis SFA"
>
>[Strings]
>xGenerator = "Sybase Pocket PowerBuilder 1.0"
>xCompany = "MyG Sistemas"
>xDescription = "Sistema de Información OASIS para Pocket PC"
>xCopyright = ""
>xProduct = "oasissfa"
>xVersion = "1.0.0.1"
>
>; --eof--
>*********************************************************************
>The file this good? If this good, because when I install CAB and I
>execute the application, to me continues appearing the error?
>
>Thanks
>
>Miguel..........
>
>
>
>
>
>"Reed Shilts [Sybase]" <reed.dot.shilts.at.sybase.dot.com> wrote in message
>news:3vnukvg011b0upntr317bt01sd5ml02uak@4ax.com...
>> Miguel,
>> The error message is that the PocketBuilder DLLs are not
>> on the device.
>> I'm assuming you are seeing this is when you're creating
>> the final application for your customer.
>> If this is for development, it's a whole lot easier to just
>> run "WinCE Setup" from the Pocket PowerBuilder group
>> in the Start menu....
>> Or - copy the "Pocket PowerBuilder.ARM.CAB" file to your
>> PDA and tap it - that installs everything for the PDA.
>>
>> For customer deployment....
>> (the subject of a half-written technote for sybase.com)
>> Basically....
>>
>> The recommendation for your application distribution is to
>> do one of two things:
>> a) explicitely deploy the "Pocket PowerBuilder.ARM.CAB" file.
>> Easy to do with something like "EZSetup"
>> b) copy the necessary PKxxx10u.* files into your CAB when
>> you build your CAB file.
>> (that is the implication of the commented out lines
>> in the INF file we create)
>> Note the semi-colons starting the lines, those are
>> the comment characters.
>>
>> For more details, on customer deployment, that technote is
>> on my "to-do" list.
>>
>> Hope this helps,
>> Reed Shilts
>> Pocket PowerBuilder Development Manager
>> <Standard-Disclaimers-Apply/>
>>
>>
>> On 29 Aug 2003 07:06:42 -0700, "Miguel Carvajal"
>> <miguelcarvajal555@hotmail.com> wrote:
>>
>> >In my PocketPC I have not installed anything. What happens, is that I
>> >included those archives in my CAB of the application not to install
>> >separate SYBASE Pocket Builder, but everything, with my CAB
>> >
>> >In CAB of my application, I place the following archives of
>> >PPB, and that when installing my CAB are left in the folder \Windows
>> >of my PocketPC:
>> >
>> >"PKODB10U.DLL"
>> >;"pkvm10u.dll"
>> >;"pkodb10u.ini"
>> >;"pkbgr10u.dll"
>> >
>> >These are the necessary archives (runtime DLL's) of Pocket Builder so
>that
>> >an
>> >application works, but the error this appearing.
>> >
>> >That I can do?
>> >
>> >
>> >
>> >"Ian Thain" <ian.thain@sybase.com> wrote in message
>> >news:3f4f329e$1@forums-1-dub...
>> >> Miguel
>> >>
>> >> Have you installed the runtime of PPB ?
>> >>
>> >> Ian
>> >>
>> >> "Miguel Carvajal" <miguelcarvajal555@hotmail.com> wrote in message
>> >> news:3f4e2ef4@forums-1-dub...
>> >> > Hello
>> >> >
>> >> > I create an application with PPB 1.0 Build 106. Soon CAB
>> >> > creates the file (with Cabwiz.exe) to make the installation in my
>> >> > PocketPC, including my archives and the necessary archives of PPB so
>> >> > that my application works.
>> >> >
>> >> > When I execute the file CAB in my PocketPC the installation is made
>> >> > satisfactorily, but when I execute the installed application, it
>> >> > appears the following error:
>> >> >
>> >> > "LoadLibrary failed for VMCE"
>> >> >
>> >> > That I can do?
>> >> >
>> >> > Associate the file inf with which I create I file CAB
>> >> >
>> >> > Thanks
>> >> >
>> >> > Miguel
>> >> >
>> >> >
>> >> >
>> >>
>> >>
>> >
>>
>
>
>


Miguel Carvajal Posted on 2003-09-01 16:01:49.0Z
From: "Miguel Carvajal" <miguelcarvajal555@hotmail.com>
Newsgroups: sybase.public.pocketpowerbuilder
References: <3f4e2ef4@forums-1-dub> <3f4f329e$1@forums-1-dub> <3f4f5e2a@forums-2-dub> <3vnukvg011b0upntr317bt01sd5ml02uak@4ax.com> <3f4f6cff@forums-2-dub> <a16vkv4hfvfu97eb2i54o970sqlvhnt6vv@4ax.com>
Subject: Re: Aplication Install Problem
Lines: 76
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2600.0000
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000
X-Original-NNTP-Posting-Host: 200-91-196-224-dial-up.ifx.net.co
Message-ID: <3f536db3@forums-2-dub>
X-Original-Trace: 1 Sep 2003 09:02:59 -0700, 200-91-196-224-dial-up.ifx.net.co
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 1 Sep 2003 08:59:53 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 1 Sep 2003 09:01:49 -0700
X-Trace: forums-1-dub 1062432109 10.22.108.75 (1 Sep 2003 09:01:49 -0700)
X-Original-Trace: 1 Sep 2003 09:01:49 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:320
Article PK: 266857

Reed...... indeed, when I install CAB of PPB, everything works well,
but with CAB that I am creating it does not work.

You could review my file inf, to see if I am making something bad?

Associate the file inf and also err.log so that you see what when
appears I create CAB

All the referenced archives in the CAB, are in a single folder,
even the PK *. * of PPB.


Reed Shilts [Sybase] Posted on 2003-09-02 13:16:49.0Z
From: "Reed Shilts [Sybase]" <reed.dot.shilts.at.sybase.dot.com>
Newsgroups: sybase.public.pocketpowerbuilder
Subject: Re: Aplication Install Problem
Organization: Sybase
Message-ID: <pe59lv43e9dhvvaa0606ijp12vs2ro9ham@4ax.com>
References: <3f4e2ef4@forums-1-dub> <3f4f329e$1@forums-1-dub> <3f4f5e2a@forums-2-dub> <3vnukvg011b0upntr317bt01sd5ml02uak@4ax.com> <3f4f6cff@forums-2-dub> <a16vkv4hfvfu97eb2i54o970sqlvhnt6vv@4ax.com> <3f536db3@forums-2-dub>
X-Newsreader: Forte Agent 1.93/32.576 English (American)
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: rshilts.sybase.com
X-Original-Trace: 2 Sep 2003 06:18:02 -0700, rshilts.sybase.com
Lines: 38
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 2 Sep 2003 06:14:48 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 2 Sep 2003 06:16:49 -0700
X-Trace: forums-1-dub 1062508609 10.22.108.75 (2 Sep 2003 06:16:49 -0700)
X-Original-Trace: 2 Sep 2003 06:16:49 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:324
Article PK: 266861

Hmmm - the "err.log" has just benign warnings.
The INF file _looks_ kosher (for an ARM only deploy)

Eyeball the generated DAT file and see if all the filenames you
desire appear (it's a binary fiile, but the filenames are there).
Also, is the CAB file about the right size, the sum of all
the files going into it?
During the install process, look around the directories and
see _where_ everything was installed to.

A suggestion, look at other INF files, a couple in the ASA and PPB
directories, along with those from Microsoft and maybe others.
Maybe you'll see something...

I'll be posting my technote and samples on "sybase.com" soon (after
an editor makes it legible to humans), but it looks like you've
already done all the research and this note won't be much help to you.

Regards,
Reed Shilts
PPB Development Manager
<Standard-disclaimers-Apply/>

On 1 Sep 2003 09:01:49 -0700, "Miguel Carvajal"

<miguelcarvajal555@hotmail.com> wrote:

>Reed...... indeed, when I install CAB of PPB, everything works well,
>but with CAB that I am creating it does not work.
>
>You could review my file inf, to see if I am making something bad?
>
>Associate the file inf and also err.log so that you see what when
>appears I create CAB
>
>All the referenced archives in the CAB, are in a single folder,
>even the PK *. * of PPB.
>


Miguel Carvajal Posted on 2003-09-02 14:03:13.0Z
From: "Miguel Carvajal" <miguelcarvajal555@hotmail.com>
Newsgroups: sybase.public.pocketpowerbuilder
References: <3f4e2ef4@forums-1-dub> <3f4f329e$1@forums-1-dub> <3f4f5e2a@forums-2-dub> <3vnukvg011b0upntr317bt01sd5ml02uak@4ax.com> <3f4f6cff@forums-2-dub> <a16vkv4hfvfu97eb2i54o970sqlvhnt6vv@4ax.com> <3f536db3@forums-2-dub> <pe59lv43e9dhvvaa0606ijp12vs2ro9ham@4ax.com>
Subject: Re: Aplication Install Problem
Lines: 15
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2600.0000
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000
NNTP-Posting-Host: 200-91-196-243-dial-up.ifx.net.co
X-Original-NNTP-Posting-Host: 200-91-196-243-dial-up.ifx.net.co
Message-ID: <3f54a321$1@forums-1-dub>
Date: 2 Sep 2003 07:03:13 -0700
X-Trace: forums-1-dub 1062511393 200.91.196.243 (2 Sep 2003 07:03:13 -0700)
X-Original-Trace: 2 Sep 2003 07:03:13 -0700, 200-91-196-243-dial-up.ifx.net.co
X-Authenticated-User: ppb
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:325
Article PK: 266862

Reed:

Indeed, in the file DAT appears all the archives that I want to
install and the sum of the sizes of my archives, agrees with the size
CAB. Also, I review the directories where the archives are due to
install, and all this good; but the error continues appearing.

It would be thankful to you if you manage to find out something but
that it can help me.....

Regards,
Miguel Carvajal


Reed Shilts [Sybase] Posted on 2003-10-31 12:56:42.0Z
From: "Reed Shilts [Sybase]" <reed.dot.shilts.at.sybase.dot.com>
Newsgroups: sybase.public.pocketpowerbuilder
Subject: Re: Aplication Install Problem
Organization: Sybase
Message-ID: <ugm4qvke4pvmvtem2mbebni7f9blhv1dto@4ax.com>
References: <3f4e2ef4@forums-1-dub> <3f4f329e$1@forums-1-dub> <3f4f5e2a@forums-2-dub> <3vnukvg011b0upntr317bt01sd5ml02uak@4ax.com> <3f4f6cff@forums-2-dub> <a16vkv4hfvfu97eb2i54o970sqlvhnt6vv@4ax.com> <3f536db3@forums-2-dub> <pe59lv43e9dhvvaa0606ijp12vs2ro9ham@4ax.com> <3f54a321$1@forums-1-dub> <3fa09201$1@forums-2-dub>
X-Newsreader: Forte Agent 1.93/32.576 English (American)
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: rshilts.sybase.com
X-Original-NNTP-Posting-Host: rshilts.sybase.com
Date: 31 Oct 2003 04:56:42 -0800
X-Trace: forums-1-dub 1067605002 10.18.61.199 (31 Oct 2003 04:56:42 -0800)
X-Original-Trace: 31 Oct 2003 04:56:42 -0800, rshilts.sybase.com
Lines: 31
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:1060
Article PK: 268359

Directory names...

Yours:
[SourceDisksNames.ARM]
3 = ,"PocketBuilder files",,"C:\Program Files\Sybase\Pocket
PowerBuilder 1.0\WinCE"

Should be:
[SourceDisksNames.ARM]
3 = ,"PocketBuilder files",,"C:\Program Files\Sybase\Pocket
PowerBuilder 1.0\WinCE\arm"


HTH,
Reed Shilts
PPB Development Manager
<Standard-Disclaimers-Apply/>

On 29 Oct 2003 20:17:47 -0700, "Stiearc Systems" <pat@gensol.net>

wrote:

>
>Has this problem been resolved as we are having the same problem. That is
>"LoadLibrary failed for VMCE".
>Checked the DLL files and they exist in the windows directory.
>As soon as we deploy "Pocket PowerBuilder.x86.CAB" it all works fine
>Thanks
>
>Attached is the INF file
>