Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Still no luck with lookup fields

2 posts in Delphi Last posting was on 2003-09-02 14:18:10.0Z
Larry Posted on 2003-09-01 14:08:34.0Z
From: "Larry" <quicktill@aol.com>
Newsgroups: Advantage.Delphi
Subject: Still no luck with lookup fields
Date: Mon, 1 Sep 2003 10:08:34 -0400
Lines: 7
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
NNTP-Posting-Host: 172.171.193.69
Message-ID: <3f535344@solutions.advantagedatabase.com>
X-Trace: 1 Sep 2003 08:10:12 -0700, 172.171.193.69
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!172.171.193.69
Xref: solutions.advantagedatabase.com Advantage.Delphi:13827
Article PK: 1107263

If I use a TAdsTable lookup field in a C++Builer DBGrid component, the
LookupResultField does not display the correct data. The correct data is
highlighted when the data is "Pulled down", but is not display upon making
the selection. This does not happen when using Dbase as the database in a
TTable. This same situation occurs when using a DBLookupComboBox. Why?


Jeremy D. Mullin Posted on 2003-09-02 14:18:10.0Z
From: Jeremy D. Mullin <jeremym@extendsys.com>
Newsgroups: Advantage.Delphi
Subject: Re: Still no luck with lookup fields
Date: Tue, 2 Sep 2003 08:18:10 -0600
Message-ID: <MPG.19be548df5d80145989b7e@solutions.advantagedatabase.com>
References: <3f535344@solutions.advantagedatabase.com>
Organization: ESI
X-Newsreader: MicroPlanet Gravity v2.30
NNTP-Posting-Host: 198.60.232.45
X-Trace: 2 Sep 2003 08:16:46 -0700, 198.60.232.45
Lines: 17
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!198.60.232.45
Xref: solutions.advantagedatabase.com Advantage.Delphi:13833
Article PK: 1107268

Hi Larry,

Can you post a small application and data to re-create this problem?

J.D. Mullin
Advantage R&D

In article <3f535344@solutions.advantagedatabase.com>, quicktill@aol.com
says...

> If I use a TAdsTable lookup field in a C++Builer DBGrid component, the
> LookupResultField does not display the correct data. The correct data is
> highlighted when the data is "Pulled down", but is not display upon making
> the selection. This does not happen when using Dbase as the database in a
> TTable. This same situation occurs when using a DBLookupComboBox. Why?
>
>
>