Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Database connection woes

3 posts in Pocket PowerBuilder Last posting was on 2003-09-04 19:50:49.0Z
Roland Smith Posted on 2003-09-02 16:58:32.0Z
From: "Roland Smith" <rsmith@cvps.com>
Newsgroups: sybase.public.pocketpowerbuilder
Subject: Database connection woes
Lines: 31
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
NNTP-Posting-Host: 170.46.129.120
X-Original-NNTP-Posting-Host: 170.46.129.120
Message-ID: <3f54cc38$1@forums-1-dub>
Date: 2 Sep 2003 09:58:32 -0700
X-Trace: forums-1-dub 1062521912 170.46.129.120 (2 Sep 2003 09:58:32 -0700)
X-Original-Trace: 2 Sep 2003 09:58:32 -0700, 170.46.129.120
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:330
Article PK: 266867

I recently got a new PPC 2003 device and I'm having problems getting things
to work that worked fine on the old PPC 2002 device.

Problem 1 - Connecting to desktop database from device:

On my desktop when I start the database "ASA 8.0 Sample" I get these
messages:

Trying to start TCPIP link ...
Unable to start on default port; starting on port 49152 instead
TCPIP link started successfully

I had to add a PORT parm to my .dsn file in order for it to successfully
connect. I am wondering what would cause this. With the old device it
worked fine. I don't know if this message was coming up then or not.

Problem 2 - Connecting to device database from desktop:

I created the shortcut on the device to start the database using the
instructions in doc #1025441. I had to increase the cache size from 600 to
1200 because it was giving out of memory errors. It works but when I run
the shortcut, it always displays the 'Server startup options' window first.
When I click OK it starts and I am able to connect.

Thanks for your wisdom in advance.
Roland
--
Topwiz Software - Home of PBSearch
http://www.topwizprogramming.com/


Martyn Mallick Posted on 2003-09-03 18:27:45.0Z
From: "Martyn Mallick" <mmallick.removethis@ianywhere.com>
Newsgroups: sybase.public.pocketpowerbuilder
References: <3f54cc38$1@forums-1-dub>
Subject: Re: Database connection woes
Lines: 52
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.50.4807.1700
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4910.0300
NNTP-Posting-Host: mmallick-pc.sybase.com
X-Original-NNTP-Posting-Host: mmallick-pc.sybase.com
Message-ID: <3f5632a1$1@forums-1-dub>
Date: 3 Sep 2003 11:27:45 -0700
X-Trace: forums-1-dub 1062613665 172.31.141.129 (3 Sep 2003 11:27:45 -0700)
X-Original-Trace: 3 Sep 2003 11:27:45 -0700, mmallick-pc.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:360
Article PK: 266895

Roland,

1) Can you check to make sure that you are starting an ASA server and not
the personal engine? I believe the DSN for ASA 8.0 Sample starts dbeng8,
and not dbsrv8. For accessing the database from a remote machine, you need
the server to start, the engine only supports connections from the local
machine.

2) Can you post the contents of your shortcut. I can take a look at it and
see if I notice anything.

-Marty

"Roland Smith" <rsmith@cvps.com> wrote in message
news:3f54cc38$1@forums-1-dub...
> I recently got a new PPC 2003 device and I'm having problems getting
things
> to work that worked fine on the old PPC 2002 device.
>
> Problem 1 - Connecting to desktop database from device:
>
> On my desktop when I start the database "ASA 8.0 Sample" I get these
> messages:
>
> Trying to start TCPIP link ...
> Unable to start on default port; starting on port 49152 instead
> TCPIP link started successfully
>
> I had to add a PORT parm to my .dsn file in order for it to successfully
> connect. I am wondering what would cause this. With the old device it
> worked fine. I don't know if this message was coming up then or not.
>
> Problem 2 - Connecting to device database from desktop:
>
> I created the shortcut on the device to start the database using the
> instructions in doc #1025441. I had to increase the cache size from 600
to
> 1200 because it was giving out of memory errors. It works but when I run
> the shortcut, it always displays the 'Server startup options' window
first.
> When I click OK it starts and I am able to connect.
>
> Thanks for your wisdom in advance.
> Roland
> --
> Topwiz Software - Home of PBSearch
> http://www.topwizprogramming.com/
>
>


Alex Reif Posted on 2003-09-04 19:50:49.0Z
From: "Alex Reif" <areif_nospam@sybase.com>
Newsgroups: sybase.public.pocketpowerbuilder
References: <3f54cc38$1@forums-1-dub>
Subject: Re: Database connection woes
Lines: 49
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: areif-xp.sybase.com
Message-ID: <3f5797e9$1@forums-2-dub>
X-Original-Trace: 4 Sep 2003 12:52:09 -0700, areif-xp.sybase.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 4 Sep 2003 12:48:33 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 4 Sep 2003 12:50:49 -0700
X-Trace: forums-1-dub 1062705049 10.22.108.75 (4 Sep 2003 12:50:49 -0700)
X-Original-Trace: 4 Sep 2003 12:50:49 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.pocketpowerbuilder:369
Article PK: 266905

On your desktop, ASA is starting on port 49152 because the default port,
2638, is in use. This will be because of the ActiveSync proxy you added to
allow you to connect to ASA on the device -- every time you put your CE
device in the cradle, ActiveSync will open up port 2638 on your desktop to
listen for incoming requests.

I would either specify a specific port when you start the desktop engine, or
even better change the port number for your ActiveSync proxy and CE engine.

- Alex.

"Roland Smith" <rsmith@cvps.com> wrote in message
news:3f54cc38$1@forums-1-dub...
> I recently got a new PPC 2003 device and I'm having problems getting
things
> to work that worked fine on the old PPC 2002 device.
>
> Problem 1 - Connecting to desktop database from device:
>
> On my desktop when I start the database "ASA 8.0 Sample" I get these
> messages:
>
> Trying to start TCPIP link ...
> Unable to start on default port; starting on port 49152 instead
> TCPIP link started successfully
>
> I had to add a PORT parm to my .dsn file in order for it to successfully
> connect. I am wondering what would cause this. With the old device it
> worked fine. I don't know if this message was coming up then or not.
>
> Problem 2 - Connecting to device database from desktop:
>
> I created the shortcut on the device to start the database using the
> instructions in doc #1025441. I had to increase the cache size from 600
to
> 1200 because it was giving out of memory errors. It works but when I run
> the shortcut, it always displays the 'Server startup options' window
first.
> When I click OK it starts and I am able to connect.
>
> Thanks for your wisdom in advance.
> Roland
> --
> Topwiz Software - Home of PBSearch
> http://www.topwizprogramming.com/
>
>