Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Sudden Performance Problem from 6.11 to 6.2

7 posts in Delphi Last posting was on 2003-09-03 15:47:02.0Z
Glenn Polin Posted on 2003-09-02 21:08:55.0Z
From: "Glenn Polin" <glenn@hudsonsoft.com>
Newsgroups: Advantage.Delphi
Subject: Sudden Performance Problem from 6.11 to 6.2
Date: Tue, 2 Sep 2003 17:08:55 -0400
Lines: 26
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
NNTP-Posting-Host: 151.202.214.37
Message-ID: <3f55073e@solutions.advantagedatabase.com>
X-Trace: 2 Sep 2003 15:10:22 -0700, 151.202.214.37
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!151.202.214.37
Xref: solutions.advantagedatabase.com Advantage.Delphi:13845
Article PK: 1107283

Hi,

We just had a reason to update the TDataset descendant in our Delphi
development system from 6.11 to 6.2. Accordingly, when we cut our new
version of our application, we told the users to update their DLLs as well.

Once they updated, data transfer from the server seems to have slowed down
tremendously, by a factor of 4 to 8 times. So, where the program used to
take 20 seconds to start up, it now takes nearly 90 seconds.

I first thought we had made a mistake in compiling our app. But by running
the older application (compiled with 6.11 TDataset) with the new DLLs (6.2
version), I can see it is somehow the DLLs. Both versions of our
application run much more slowly with the new DLLs. The older version runs
as it used to if it uses the 6.1 DLLs (e.g. 20 seconds for startup), and if
put in a folder with the new DLLs, the same program takes 90 seconds or more
to start.

Help, please! I'm not sure what is going on.

Thanks

Glenn Polin
Hudson Software Corp.


Joachim Duerr (ADS Support) Posted on 2003-09-03 08:50:57.0Z
From: "Joachim Duerr (ADS Support)" <jojo.duerr@gmx.de>
Subject: Re: Sudden Performance Problem from 6.11 to 6.2
Newsgroups: Advantage.Delphi
References: <3f55073e@solutions.advantagedatabase.com>
Organization: Extended Systems GmbH
User-Agent: XanaNews/1.15.6.2
X-Face: ,QMv7[luB)BpWAQ~:"kw6n%0ieY63.:g2K3n~8ky0;||5Xle*Xq+=~<Fy:0CVC2nx@8~vZ
MIME-Version: 1.0
Content-Type: text/plain; charset=iso-8859-1
NNTP-Posting-Host: 195.2.185.25
Message-ID: <3f559d61@solutions.advantagedatabase.com>
Date: 3 Sep 2003 01:50:57 -0700
X-Trace: 3 Sep 2003 01:50:57 -0700, 195.2.185.25
Lines: 20
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!195.2.185.25
Xref: solutions.advantagedatabase.com Advantage.Delphi:13847
Article PK: 1107281


Glenn Polin wrote in <3f55073e@solutions.advantagedatabase.com> :

> I first thought we had made a mistake in compiling our app. But by
> running the older application (compiled with 6.11 TDataset) with the
> new DLLs (6.2 version), I can see it is somehow the DLLs. Both
> versions of our application run much more slowly with the new DLLs.
> The older version runs as it used to if it uses the 6.1 DLLs (e.g. 20
> seconds for startup), and if put in a folder with the new DLLs, the
> same program takes 90 seconds or more to start.

Did you use the latest patches? They have some "speedness fix" built in.
BD0314a
BD0327a

--
Joachim Duerr
Lead ADS Support, Extended Systems GmbH, Germany
advantage[AT]extendsys.de
- posted with Xananews 1.15.6.2 -
!!! ADS 7 Beta now available !!!


Glenn Polin Posted on 2003-09-03 15:09:47.0Z
From: "Glenn Polin" <glenn@hudsonsoft.com>
Newsgroups: Advantage.Delphi
References: <3f55073e@solutions.advantagedatabase.com> <3f559d61@solutions.advantagedatabase.com>
Subject: Re: Sudden Performance Problem from 6.11 to 6.2
Date: Wed, 3 Sep 2003 11:09:47 -0400
Lines: 35
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
NNTP-Posting-Host: 151.202.214.37
Message-ID: <3f5604af@solutions.advantagedatabase.com>
X-Trace: 3 Sep 2003 09:11:43 -0700, 151.202.214.37
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!151.202.214.37
Xref: solutions.advantagedatabase.com Advantage.Delphi:13854
Article PK: 1107291

Yes, the patches solved the problem. Someone please explain why we loaded a
Tdataset recently for 6.2 that needs to be patched. I would never have
assumed that what I downloaded last week is a year old, and needs to be
patched.

Isn't that why we have the Internet? So you can post and I can download the
latest version?

Thanks for the help.

Glenn Polin

"Joachim Duerr (ADS Support)" <jojo.duerr@gmx.de> wrote in message
news:3f559d61@solutions.advantagedatabase.com...
> Glenn Polin wrote in <3f55073e@solutions.advantagedatabase.com> :
>
> > I first thought we had made a mistake in compiling our app. But by
> > running the older application (compiled with 6.11 TDataset) with the
> > new DLLs (6.2 version), I can see it is somehow the DLLs. Both
> > versions of our application run much more slowly with the new DLLs.
> > The older version runs as it used to if it uses the 6.1 DLLs (e.g. 20
> > seconds for startup), and if put in a folder with the new DLLs, the
> > same program takes 90 seconds or more to start.
>
> Did you use the latest patches? They have some "speedness fix" built in.
> BD0314a
> BD0327a
>
> --
> Joachim Duerr
> Lead ADS Support, Extended Systems GmbH, Germany
> advantage[AT]extendsys.de
> - posted with Xananews 1.15.6.2 -
> !!! ADS 7 Beta now available !!!


Ken Brumback Posted on 2003-09-03 15:47:02.0Z
From: "Ken Brumback" <kbrumback_nospam_@arl.i-n-s.com>
Newsgroups: Advantage.Delphi
References: <3f55073e@solutions.advantagedatabase.com> <3f559d61@solutions.advantagedatabase.com> <3f5604af@solutions.advantagedatabase.com>
Subject: Re: Sudden Performance Problem from 6.11 to 6.2
Date: Wed, 3 Sep 2003 11:47:02 -0400
Lines: 53
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
NNTP-Posting-Host: 146.145.6.74
Message-ID: <3f560d7a@solutions.advantagedatabase.com>
X-Trace: 3 Sep 2003 09:49:14 -0700, 146.145.6.74
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!146.145.6.74
Xref: solutions.advantagedatabase.com Advantage.Delphi:13858
Article PK: 1107294

Glenn,

I periodically check the Solutions website for updates. I thought if you
signed up here:

http://www.advantagedatabase.com/ADS/News+-+Events/_Receive+Advantage+Updates.htm

you would get e-mail about updates. I don't remember getting one for the
6.2.011 update. I could be wrong since I get a lot of spam.

Ken

"Glenn Polin" <glenn@hudsonsoft.com> wrote in message
news:3f5604af@solutions.advantagedatabase.com...
> Yes, the patches solved the problem. Someone please explain why we loaded
a
> Tdataset recently for 6.2 that needs to be patched. I would never have
> assumed that what I downloaded last week is a year old, and needs to be
> patched.
>
> Isn't that why we have the Internet? So you can post and I can download
the
> latest version?
>
> Thanks for the help.
>
> Glenn Polin
> "Joachim Duerr (ADS Support)" <jojo.duerr@gmx.de> wrote in message
> news:3f559d61@solutions.advantagedatabase.com...
> > Glenn Polin wrote in <3f55073e@solutions.advantagedatabase.com> :
> >
> > > I first thought we had made a mistake in compiling our app. But by
> > > running the older application (compiled with 6.11 TDataset) with the
> > > new DLLs (6.2 version), I can see it is somehow the DLLs. Both
> > > versions of our application run much more slowly with the new DLLs.
> > > The older version runs as it used to if it uses the 6.1 DLLs (e.g. 20
> > > seconds for startup), and if put in a folder with the new DLLs, the
> > > same program takes 90 seconds or more to start.
> >
> > Did you use the latest patches? They have some "speedness fix" built in.
> > BD0314a
> > BD0327a
> >
> > --
> > Joachim Duerr
> > Lead ADS Support, Extended Systems GmbH, Germany
> > advantage[AT]extendsys.de
> > - posted with Xananews 1.15.6.2 -
> > !!! ADS 7 Beta now available !!!
>
>


Ken Brumback Posted on 2003-09-03 12:17:22.0Z
From: "Ken Brumback" <kbrumback_nospam_@arl.i-n-s.com>
Newsgroups: Advantage.Delphi
References: <3f55073e@solutions.advantagedatabase.com>
Subject: Re: Sudden Performance Problem from 6.11 to 6.2
Date: Wed, 3 Sep 2003 08:17:22 -0400
Lines: 45
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
NNTP-Posting-Host: 146.145.6.74
Message-ID: <3f55dc4f@solutions.advantagedatabase.com>
X-Trace: 3 Sep 2003 06:19:27 -0700, 146.145.6.74
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!146.145.6.74
Xref: solutions.advantagedatabase.com Advantage.Delphi:13849
Article PK: 1107284

Glenn,

If the app is server based, I would verify that the users are running the
app with the new DLLs through the server instead of locally (using ARC). If
I am configuring an app for remote use, I always rename ADSLOC32.DLL to
ADSLOC32.DLX.

Ken Brumback
INS, Inc.

"Glenn Polin" <glenn@hudsonsoft.com> wrote in message
news:3f55073e@solutions.advantagedatabase.com...
> Hi,
>
> We just had a reason to update the TDataset descendant in our Delphi
> development system from 6.11 to 6.2. Accordingly, when we cut our new
> version of our application, we told the users to update their DLLs as
well.
>
> Once they updated, data transfer from the server seems to have slowed down
> tremendously, by a factor of 4 to 8 times. So, where the program used to
> take 20 seconds to start up, it now takes nearly 90 seconds.
>
> I first thought we had made a mistake in compiling our app. But by
running
> the older application (compiled with 6.11 TDataset) with the new DLLs (6.2
> version), I can see it is somehow the DLLs. Both versions of our
> application run much more slowly with the new DLLs. The older version
runs
> as it used to if it uses the 6.1 DLLs (e.g. 20 seconds for startup), and
if
> put in a folder with the new DLLs, the same program takes 90 seconds or
more
> to start.
>
> Help, please! I'm not sure what is going on.
>
> Thanks
>
> Glenn Polin
> Hudson Software Corp.
>
>


Glenn Polin Posted on 2003-09-03 15:13:04.0Z
From: "Glenn Polin" <glenn@hudsonsoft.com>
Newsgroups: Advantage.Delphi
References: <3f55073e@solutions.advantagedatabase.com> <3f55dc4f@solutions.advantagedatabase.com>
Subject: Re: Sudden Performance Problem from 6.11 to 6.2
Date: Wed, 3 Sep 2003 11:13:04 -0400
Lines: 63
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
NNTP-Posting-Host: 151.202.214.37
Message-ID: <3f560574@solutions.advantagedatabase.com>
X-Trace: 3 Sep 2003 09:15:00 -0700, 151.202.214.37
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!151.202.214.37
Xref: solutions.advantagedatabase.com Advantage.Delphi:13855
Article PK: 1107289

Ken,

Thanks for the reply. We are just in the habit of distributing 3 DLLS;
ace32, adsloc32 and axcws32. We stopped local server support a long time
ago. Perhaps we no longer need adsloc32?

The problem was fixed by a patch to the 6.2 DLLs from the web site.

Glenn

"Ken Brumback" <kbrumback_nospam_@arl.i-n-s.com> wrote in message
news:3f55dc4f@solutions.advantagedatabase.com...
> Glenn,
>
> If the app is server based, I would verify that the users are running the
> app with the new DLLs through the server instead of locally (using ARC).
If
> I am configuring an app for remote use, I always rename ADSLOC32.DLL to
> ADSLOC32.DLX.
>
> Ken Brumback
> INS, Inc.
>
> "Glenn Polin" <glenn@hudsonsoft.com> wrote in message
> news:3f55073e@solutions.advantagedatabase.com...
> > Hi,
> >
> > We just had a reason to update the TDataset descendant in our Delphi
> > development system from 6.11 to 6.2. Accordingly, when we cut our new
> > version of our application, we told the users to update their DLLs as
> well.
> >
> > Once they updated, data transfer from the server seems to have slowed
down
> > tremendously, by a factor of 4 to 8 times. So, where the program used
to
> > take 20 seconds to start up, it now takes nearly 90 seconds.
> >
> > I first thought we had made a mistake in compiling our app. But by
> running
> > the older application (compiled with 6.11 TDataset) with the new DLLs
(6.2
> > version), I can see it is somehow the DLLs. Both versions of our
> > application run much more slowly with the new DLLs. The older version
> runs
> > as it used to if it uses the 6.1 DLLs (e.g. 20 seconds for startup), and
> if
> > put in a folder with the new DLLs, the same program takes 90 seconds or
> more
> > to start.
> >
> > Help, please! I'm not sure what is going on.
> >
> > Thanks
> >
> > Glenn Polin
> > Hudson Software Corp.
> >
> >
>
>


Ken Brumback Posted on 2003-09-03 15:38:58.0Z
From: "Ken Brumback" <kbrumback_nospam_@arl.i-n-s.com>
Newsgroups: Advantage.Delphi
References: <3f55073e@solutions.advantagedatabase.com> <3f55dc4f@solutions.advantagedatabase.com> <3f560574@solutions.advantagedatabase.com>
Subject: Re: Sudden Performance Problem from 6.11 to 6.2
Date: Wed, 3 Sep 2003 11:38:58 -0400
Lines: 84
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
NNTP-Posting-Host: 146.145.6.74
Message-ID: <3f560b94@solutions.advantagedatabase.com>
X-Trace: 3 Sep 2003 09:41:08 -0700, 146.145.6.74
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!146.145.6.74
Xref: solutions.advantagedatabase.com Advantage.Delphi:13857
Article PK: 1107293

Glenn,

Glad it works.

It's up to you. I keep the adsloc32.dlx and adslocal.cfx files in case there
is ever a problem with the server (which I do not control) and the users
MUST access the data from the app. This situation happened a few months ago.
The server techs could not load ADS properly (they misread my instructions).
I have them rename and configure the files, change the EXE shortcut setting
to run the app locally. Of course I explain to the users that the
performance will be degraded.

Ken

"Glenn Polin" <glenn@hudsonsoft.com> wrote in message
news:3f560574@solutions.advantagedatabase.com...
> Ken,
>
> Thanks for the reply. We are just in the habit of distributing 3 DLLS;
> ace32, adsloc32 and axcws32. We stopped local server support a long time
> ago. Perhaps we no longer need adsloc32?
>
> The problem was fixed by a patch to the 6.2 DLLs from the web site.
>
> Glenn
>
> "Ken Brumback" <kbrumback_nospam_@arl.i-n-s.com> wrote in message
> news:3f55dc4f@solutions.advantagedatabase.com...
> > Glenn,
> >
> > If the app is server based, I would verify that the users are running
the
> > app with the new DLLs through the server instead of locally (using ARC).
> If
> > I am configuring an app for remote use, I always rename ADSLOC32.DLL to
> > ADSLOC32.DLX.
> >
> > Ken Brumback
> > INS, Inc.
> >
> > "Glenn Polin" <glenn@hudsonsoft.com> wrote in message
> > news:3f55073e@solutions.advantagedatabase.com...
> > > Hi,
> > >
> > > We just had a reason to update the TDataset descendant in our Delphi
> > > development system from 6.11 to 6.2. Accordingly, when we cut our new
> > > version of our application, we told the users to update their DLLs as
> > well.
> > >
> > > Once they updated, data transfer from the server seems to have slowed
> down
> > > tremendously, by a factor of 4 to 8 times. So, where the program used
> to
> > > take 20 seconds to start up, it now takes nearly 90 seconds.
> > >
> > > I first thought we had made a mistake in compiling our app. But by
> > running
> > > the older application (compiled with 6.11 TDataset) with the new DLLs
> (6.2
> > > version), I can see it is somehow the DLLs. Both versions of our
> > > application run much more slowly with the new DLLs. The older version
> > runs
> > > as it used to if it uses the 6.1 DLLs (e.g. 20 seconds for startup),
and
> > if
> > > put in a folder with the new DLLs, the same program takes 90 seconds
or
> > more
> > > to start.
> > >
> > > Help, please! I'm not sure what is going on.
> > >
> > > Thanks
> > >
> > > Glenn Polin
> > > Hudson Software Corp.
> > >
> > >
> >
> >
>
>