Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Page() in dynamically created DW not working correctly

2 posts in Objects Last posting was on 2003-09-12 15:17:30.0Z
Scott Gorke Posted on 2003-09-09 16:50:12.0Z
From: "Scott Gorke" <scott_gorke@picis.com>
Newsgroups: sybase.public.powerbuilder.objects
Subject: Page() in dynamically created DW not working correctly
Lines: 18
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.50.4807.1700
X-MIMEOLE: Produced By Microsoft MimeOLE V5.50.4910.0300
NNTP-Posting-Host: 12.151.152.4
X-Original-NNTP-Posting-Host: 12.151.152.4
Message-ID: <3f5e04c4$1@forums-1-dub>
Date: 9 Sep 2003 09:50:12 -0700
X-Trace: forums-1-dub 1063126212 12.151.152.4 (9 Sep 2003 09:50:12 -0700)
X-Original-Trace: 9 Sep 2003 09:50:12 -0700, 12.151.152.4
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:7584
Article PK: 734867

I have created a PB script that builds a singleton-select DW "on the fly",
based on settings stored in a table. This singleton-select DW also has all
manner of text in its detail band. When I retrieve the DW, the page()
function always returns 1. (EX: if the DW covers 5 pages, all of them report
"Page 1 of 5", where "1" is the result of the page() function.)

Oddly, if I build the same DW in the "standard" way, in the DW painter, the
page() function works just fine.

Do you have any ideas for a workaround or fix? Is this a bug fixed in a
later version of PB? (Currently on PB6.5 build 1082, using Win2000 against
Microsoft SQL2000.)

Thanks in advance,
Scott Gorke
Picis, Inc.


"John Olson [Team Sybase]" <john.olson Posted on 2003-09-12 15:17:30.0Z
From: "John Olson [Team Sybase]" <john.olson@developower_nospam.com>
Newsgroups: sybase.public.powerbuilder.objects
References: <3f5e04c4$1@forums-1-dub>
Subject: Re: Page() in dynamically created DW not working correctly
Lines: 35
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.50.4927.1200
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4927.1200
NNTP-Posting-Host: jerry.scn.spawar.navy.mil
X-Original-NNTP-Posting-Host: jerry.scn.spawar.navy.mil
Message-ID: <3f61e38a$1@forums-1-dub>
Date: 12 Sep 2003 08:17:30 -0700
X-Trace: forums-1-dub 1063379850 192.171.8.15 (12 Sep 2003 08:17:30 -0700)
X-Original-Trace: 12 Sep 2003 08:17:30 -0700, jerry.scn.spawar.navy.mil
X-Authenticated-User: teamPS
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:7588
Article PK: 734869

Scott,

If you haven't already, export the syntax of the generated DW and compare it
to the syntax of the one you built in the DW painter. The differences may
give you a clue as to the problem.

Regards,
John
Team Sybase

"Scott Gorke" <scott_gorke@picis.com> wrote in message
news:3f5e04c4$1@forums-1-dub...
> I have created a PB script that builds a singleton-select DW "on the fly",
> based on settings stored in a table. This singleton-select DW also has all
> manner of text in its detail band. When I retrieve the DW, the page()
> function always returns 1. (EX: if the DW covers 5 pages, all of them
report
> "Page 1 of 5", where "1" is the result of the page() function.)
>
> Oddly, if I build the same DW in the "standard" way, in the DW painter,
the
> page() function works just fine.
>
> Do you have any ideas for a workaround or fix? Is this a bug fixed in a
> later version of PB? (Currently on PB6.5 build 1082, using Win2000 against
> Microsoft SQL2000.)
>
> Thanks in advance,
> Scott Gorke
> Picis, Inc.
>
>