Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

New to 6.2

2 posts in Delphi Last posting was on 2003-09-15 19:25:53.0Z
DA Brookes Posted on 2003-09-11 11:03:25.0Z
From: "DA Brookes" <david.brookes@nospaminterserveprojects.com>
Newsgroups: advantage.delphi
Subject: New to 6.2
Date: Thu, 11 Sep 2003 12:03:25 +0100
Lines: 28
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2600.0000
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000
NNTP-Posting-Host: 62.173.110.62
Message-ID: <3f60564e@solutions.advantagedatabase.com>
X-Trace: 11 Sep 2003 05:02:38 -0700, 62.173.110.62
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!62.173.110.62
Xref: solutions.advantagedatabase.com Advantage.Delphi:13934
Article PK: 1107370

Hi I use D6 Enterprise and have converted my first set of dBASE tables to
ADT.

The following code generates the error "Index not set"

The table has an index "tot_ref" combining two fields "con_no" and "Wc_no"
How do I get past this ?

Regards
Dave

with proj_dir do
begin
IndexName := 'tot_ref';
disablecontrols;
EditRangeStart;;
fieldbyname('group').asstring :=
groups.fieldbyname('group').asstring;
fieldbyname('con_no').asstring := '';
EditRangeend;
fieldbyname('group').asstring :=
groups.fieldbyname('group').asstring;
fieldbyname('con_no').asstring := '%';
applyrange;
enablecontrols;
end;


Jeremy D. Mullin Posted on 2003-09-15 19:25:53.0Z
From: Jeremy D. Mullin <jeremym@extendsys.com>
Newsgroups: advantage.delphi
Subject: Re: New to 6.2
Date: Mon, 15 Sep 2003 13:25:53 -0600
Message-ID: <MPG.19cfc02c59db3eaa989b93@solutions.advantagedatabase.com>
References: <3f60564e@solutions.advantagedatabase.com>
Organization: ESI
X-Newsreader: MicroPlanet Gravity v2.30
NNTP-Posting-Host: 198.60.232.45
X-Trace: 15 Sep 2003 13:23:34 -0700, 198.60.232.45
Lines: 37
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!198.60.232.45
Xref: solutions.advantagedatabase.com Advantage.Delphi:13953
Article PK: 1107389

Shouldn't your index be on 'group' and 'con_no' for the code below to
work?

J.D. Mullin
Advantage R&D

In article <3f60564e@solutions.advantagedatabase.com>,
david.brookes@nospaminterserveprojects.com says...

> Hi I use D6 Enterprise and have converted my first set of dBASE tables to
> ADT.
>
> The following code generates the error "Index not set"
>
> The table has an index "tot_ref" combining two fields "con_no" and "Wc_no"
> How do I get past this ?
>
> Regards
> Dave
>
> with proj_dir do
> begin
> IndexName := 'tot_ref';
> disablecontrols;
> EditRangeStart;;
> fieldbyname('group').asstring :=
> groups.fieldbyname('group').asstring;
> fieldbyname('con_no').asstring := '';
> EditRangeend;
> fieldbyname('group').asstring :=
> groups.fieldbyname('group').asstring;
> fieldbyname('con_no').asstring := '%';
> applyrange;
> enablecontrols;
> end;
>
>
>