Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

ASA 8.01 OEM Authentication Error

10 posts in General Discussion Last posting was on 2003-10-30 20:08:52.0Z
Mike Niemann Posted on 2003-10-27 20:23:44.0Z
From: "Mike Niemann" <mniemann@oowidgets.com>
Newsgroups: ianywhere.public.general
Subject: ASA 8.01 OEM Authentication Error
Lines: 11
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: 167.83.10.24
Message-ID: <3f9d8def@forums-2-dub>
X-Original-Trace: 27 Oct 2003 13:28:15 -0700, 167.83.10.24
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 27 Oct 2003 13:16:17 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 27 Oct 2003 13:23:44 -0700
X-Trace: forums-1-dub 1067289824 10.22.108.75 (27 Oct 2003 13:23:44 -0700)
X-Original-Trace: 27 Oct 2003 13:23:44 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:1925
Article PK: 4162

We are getting an Authentication Error in the middle of a connection... in
other words, we are connecting, setting the Authentication String, and
processing. Sometimes, later we are encountering an Authentication Error as
though the connection had been dropped and re-established. However, in our
code we are not disconnecting and reconnecting.

Has anyone seen this? Any ideas what would cause this?

Regards, Mike Niemann


"Michael Gould" <mgould Posted on 2003-10-27 21:09:46.0Z
From: "Michael Gould" <mgould@*I*h*a*t*e*s**p$a*m*omnicc.com>
Newsgroups: ianywhere.public.general
References: <3f9d8def@forums-2-dub>
Subject: Re: ASA 8.01 OEM Authentication Error
Lines: 31
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
NNTP-Posting-Host: adsl-068-209-131-007.sip.jax.bellsouth.net
X-Original-NNTP-Posting-Host: adsl-068-209-131-007.sip.jax.bellsouth.net
Message-ID: <3f9d97aa$1@forums-1-dub>
Date: 27 Oct 2003 14:09:46 -0700
X-Trace: forums-1-dub 1067292586 68.209.131.7 (27 Oct 2003 14:09:46 -0700)
X-Original-Trace: 27 Oct 2003 14:09:46 -0700, adsl-068-209-131-007.sip.jax.bellsouth.net
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:1926
Article PK: 4165

Mike,

Is is possible that you are exceeding the number of prepare statements which
is causing another connection to be raised? If so, then you would need to
make sure that r you
SET OPTION PUBLIC.MAX_STATEMENT_COUNT=0;

The number defaults to 50 and I believe it can go up to a max of 255
defined. If it's going to be more than that, setting it to 0 turns off this
check.

HTH's

Michael Gould

"Mike Niemann" <mniemann@oowidgets.com> wrote in message
news:3f9d8def@forums-2-dub...
> We are getting an Authentication Error in the middle of a connection... in
> other words, we are connecting, setting the Authentication String, and
> processing. Sometimes, later we are encountering an Authentication Error
as
> though the connection had been dropped and re-established. However, in our
> code we are not disconnecting and reconnecting.
>
> Has anyone seen this? Any ideas what would cause this?
>
> Regards, Mike Niemann
>
>


Mike Niemann Posted on 2003-10-28 16:17:46.0Z
From: "Mike Niemann" <mniemann@oowidgets.com>
Newsgroups: ianywhere.public.general
References: <3f9d8def@forums-2-dub> <3f9d97aa$1@forums-1-dub>
Subject: Re: ASA 8.01 OEM Authentication Error
Lines: 43
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: 167.83.10.24
Message-ID: <3f9ea5cb@forums-2-dub>
X-Original-Trace: 28 Oct 2003 09:22:19 -0700, 167.83.10.24
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 28 Oct 2003 09:10:14 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 28 Oct 2003 09:17:46 -0700
X-Trace: forums-1-dub 1067361466 10.22.108.75 (28 Oct 2003 09:17:46 -0700)
X-Original-Trace: 28 Oct 2003 09:17:46 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:1939
Article PK: 4177

Thanks Michael, we will give it a try.

Regards, Mike Niemann

"Michael Gould" <mgould@*I*h*a*t*e*s**p$a*m*omnicc.com> wrote in message
news:3f9d97aa$1@forums-1-dub...
> Mike,
>
> Is is possible that you are exceeding the number of prepare statements
which
> is causing another connection to be raised? If so, then you would need to
> make sure that r you
> SET OPTION PUBLIC.MAX_STATEMENT_COUNT=0;
>
> The number defaults to 50 and I believe it can go up to a max of 255
> defined. If it's going to be more than that, setting it to 0 turns off
this
> check.
>
> HTH's
>
> Michael Gould
>
> "Mike Niemann" <mniemann@oowidgets.com> wrote in message
> news:3f9d8def@forums-2-dub...
> > We are getting an Authentication Error in the middle of a connection...
in
> > other words, we are connecting, setting the Authentication String, and
> > processing. Sometimes, later we are encountering an Authentication Error
> as
> > though the connection had been dropped and re-established. However, in
our
> > code we are not disconnecting and reconnecting.
> >
> > Has anyone seen this? Any ideas what would cause this?
> >
> > Regards, Mike Niemann
> >
> >
>
>


Mike Niemann Posted on 2003-10-29 18:44:30.0Z
From: "Mike Niemann" <mniemann@oowidgets.com>
Newsgroups: ianywhere.public.general
References: <3f9d8def@forums-2-dub> <3f9d97aa$1@forums-1-dub>
Subject: Re: ASA 8.01 OEM Authentication Error
Lines: 86
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: 167.83.10.24
Message-ID: <3fa019b4$1@forums-2-dub>
X-Original-Trace: 29 Oct 2003 11:49:08 -0700, 167.83.10.24
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 29 Oct 2003 11:36:52 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 29 Oct 2003 11:44:30 -0700
X-Trace: forums-1-dub 1067456670 10.22.108.75 (29 Oct 2003 11:44:30 -0700)
X-Original-Trace: 29 Oct 2003 11:44:30 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:1950
Article PK: 4187

Mike, we tried your suggestion... but no joy. Here is the pseudocode of what
we are doing...

This did not seem to fix the problem. It generates the Authentication
violation failure error about 25% of the time. I ran 2250 insert/update
attempts and received the failure about 600 times.

I have provided a general description of the IAS record insert/update
processing below to help us resolve this issue. We obtain the connection to
the DB one time. At this time the authentification string is executed. The
Set max statements is also executed. The connection is maintained through
the execution of the program.

While (Files Exist)
Open file
Parse records from file
For (1..Number of records in file)
Assign data values from record into data object(s)
Apply business rules (edit some data values)

If (Not connected to DB) // then connect using below statements
//Prepare to Connect then connect using ODBC level
SQLAllocEnv
SQLAllocConnect
SQLConnect
SQLSetConnectOption
Use the SQLExecute command to execute the authentification string
SET TEMPORARY OPTION CONNECTION_AUTHENTICATION=
'Company=Baxter;
Application=RenalSoft;Signature=XX....XXX'
Use the SQLExecute command to execute the string:
SET OPTION PUBLIC.MAX_STATEMENT_COUNT=0;
End IF

// Since we are already connected continue with the bind
Bind 24 data values into ODBC memory locations
Execute stored procedure to do the following:
Use selects to ensure data values are valid
Use selects to ensure patient exists
Modify datetime fields to NULL if appropriate
Execute several small stored procedures to set a few values
Depending on existence of unique data perform either Insert or
Update
Several triggers execute during this process
End 1..Number of records in file
End While

"Michael Gould" <mgould@*I*h*a*t*e*s**p$a*m*omnicc.com> wrote in message
news:3f9d97aa$1@forums-1-dub...
> Mike,
>
> Is is possible that you are exceeding the number of prepare statements
which
> is causing another connection to be raised? If so, then you would need to
> make sure that r you
> SET OPTION PUBLIC.MAX_STATEMENT_COUNT=0;
>
> The number defaults to 50 and I believe it can go up to a max of 255
> defined. If it's going to be more than that, setting it to 0 turns off
this
> check.
>
> HTH's
>
> Michael Gould
>
> "Mike Niemann" <mniemann@oowidgets.com> wrote in message
> news:3f9d8def@forums-2-dub...
> > We are getting an Authentication Error in the middle of a connection...
in
> > other words, we are connecting, setting the Authentication String, and
> > processing. Sometimes, later we are encountering an Authentication Error
> as
> > though the connection had been dropped and re-established. However, in
our
> > code we are not disconnecting and reconnecting.
> >
> > Has anyone seen this? Any ideas what would cause this?
> >
> > Regards, Mike Niemann
> >
> >
>
>


"Michael Gould" <mgould Posted on 2003-10-29 19:00:47.0Z
From: "Michael Gould" <mgould@*I*h*a*t*e*s**p$a*m*omnicc.com>
Newsgroups: ianywhere.public.general
References: <3f9d8def@forums-2-dub> <3f9d97aa$1@forums-1-dub> <3fa019b4$1@forums-2-dub>
Subject: Re: ASA 8.01 OEM Authentication Error
Lines: 104
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
NNTP-Posting-Host: adsl-068-209-131-007.sip.jax.bellsouth.net
X-Original-NNTP-Posting-Host: adsl-068-209-131-007.sip.jax.bellsouth.net
Message-ID: <3fa01c6f$1@forums-1-dub>
Date: 29 Oct 2003 12:00:47 -0700
X-Trace: forums-1-dub 1067457647 68.209.131.7 (29 Oct 2003 12:00:47 -0700)
X-Original-Trace: 29 Oct 2003 12:00:47 -0700, adsl-068-209-131-007.sip.jax.bellsouth.net
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:1952
Article PK: 4189

Mike,

I don't see anything wrong with what your doing. You might want to run with
the ODBC log on or set the database logging on using the -zr switch to see
when or why your losing your authentication.

Michael Gould

"Mike Niemann" <mniemann@oowidgets.com> wrote in message
news:3fa019b4$1@forums-2-dub...
> Mike, we tried your suggestion... but no joy. Here is the pseudocode of
what
> we are doing...
>
> This did not seem to fix the problem. It generates the Authentication
> violation failure error about 25% of the time. I ran 2250 insert/update
> attempts and received the failure about 600 times.
>
> I have provided a general description of the IAS record insert/update
> processing below to help us resolve this issue. We obtain the connection
to
> the DB one time. At this time the authentification string is executed. The
> Set max statements is also executed. The connection is maintained through
> the execution of the program.
>
> While (Files Exist)
> Open file
> Parse records from file
> For (1..Number of records in file)
> Assign data values from record into data object(s)
> Apply business rules (edit some data values)
>
> If (Not connected to DB) // then connect using below statements
> //Prepare to Connect then connect using ODBC level
> SQLAllocEnv
> SQLAllocConnect
> SQLConnect
> SQLSetConnectOption
> Use the SQLExecute command to execute the authentification
string
> SET TEMPORARY OPTION CONNECTION_AUTHENTICATION=
> 'Company=Baxter;
> Application=RenalSoft;Signature=XX....XXX'
> Use the SQLExecute command to execute the string:
> SET OPTION PUBLIC.MAX_STATEMENT_COUNT=0;
> End IF
>
> // Since we are already connected continue with the bind
> Bind 24 data values into ODBC memory locations
> Execute stored procedure to do the following:
> Use selects to ensure data values are valid
> Use selects to ensure patient exists
> Modify datetime fields to NULL if appropriate
> Execute several small stored procedures to set a few values
> Depending on existence of unique data perform either Insert or
> Update
> Several triggers execute during this process
> End 1..Number of records in file
> End While
>
> "Michael Gould" <mgould@*I*h*a*t*e*s**p$a*m*omnicc.com> wrote in message
> news:3f9d97aa$1@forums-1-dub...
> > Mike,
> >
> > Is is possible that you are exceeding the number of prepare statements
> which
> > is causing another connection to be raised? If so, then you would need
to
> > make sure that r you
> > SET OPTION PUBLIC.MAX_STATEMENT_COUNT=0;
> >
> > The number defaults to 50 and I believe it can go up to a max of 255
> > defined. If it's going to be more than that, setting it to 0 turns off
> this
> > check.
> >
> > HTH's
> >
> > Michael Gould
> >
> > "Mike Niemann" <mniemann@oowidgets.com> wrote in message
> > news:3f9d8def@forums-2-dub...
> > > We are getting an Authentication Error in the middle of a
connection...
> in
> > > other words, we are connecting, setting the Authentication String, and
> > > processing. Sometimes, later we are encountering an Authentication
Error
> > as
> > > though the connection had been dropped and re-established. However, in
> our
> > > code we are not disconnecting and reconnecting.
> > >
> > > Has anyone seen this? Any ideas what would cause this?
> > >
> > > Regards, Mike Niemann
> > >
> > >
> >
> >
>
>


Mike Niemann Posted on 2003-10-29 19:26:25.0Z
From: "Mike Niemann" <mniemann@oowidgets.com>
Newsgroups: ianywhere.public.general
References: <3f9d8def@forums-2-dub> <3f9d97aa$1@forums-1-dub> <3fa019b4$1@forums-2-dub> <3fa01c6f$1@forums-1-dub>
Subject: Re: ASA 8.01 OEM Authentication Error
Lines: 120
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: 167.83.10.24
Message-ID: <3fa02387@forums-2-dub>
X-Original-Trace: 29 Oct 2003 12:31:03 -0700, 167.83.10.24
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 29 Oct 2003 12:18:47 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 29 Oct 2003 12:26:25 -0700
X-Trace: forums-1-dub 1067459185 10.22.108.75 (29 Oct 2003 12:26:25 -0700)
X-Original-Trace: 29 Oct 2003 12:26:25 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:1953
Article PK: 4191

Will do Mike.

Thanks for all your help.

Regards, Mike Niemann

"Michael Gould" <mgould@*I*h*a*t*e*s**p$a*m*omnicc.com> wrote in message
news:3fa01c6f$1@forums-1-dub...
> Mike,
>
> I don't see anything wrong with what your doing. You might want to run
with
> the ODBC log on or set the database logging on using the -zr switch to see
> when or why your losing your authentication.
>
> Michael Gould
>
> "Mike Niemann" <mniemann@oowidgets.com> wrote in message
> news:3fa019b4$1@forums-2-dub...
> > Mike, we tried your suggestion... but no joy. Here is the pseudocode of
> what
> > we are doing...
> >
> > This did not seem to fix the problem. It generates the Authentication
> > violation failure error about 25% of the time. I ran 2250 insert/update
> > attempts and received the failure about 600 times.
> >
> > I have provided a general description of the IAS record insert/update
> > processing below to help us resolve this issue. We obtain the connection
> to
> > the DB one time. At this time the authentification string is executed.
The
> > Set max statements is also executed. The connection is maintained
through
> > the execution of the program.
> >
> > While (Files Exist)
> > Open file
> > Parse records from file
> > For (1..Number of records in file)
> > Assign data values from record into data object(s)
> > Apply business rules (edit some data values)
> >
> > If (Not connected to DB) // then connect using below statements
> > //Prepare to Connect then connect using ODBC level
> > SQLAllocEnv
> > SQLAllocConnect
> > SQLConnect
> > SQLSetConnectOption
> > Use the SQLExecute command to execute the authentification
> string
> > SET TEMPORARY OPTION CONNECTION_AUTHENTICATION=
> > 'Company=Baxter;
> > Application=RenalSoft;Signature=XX....XXX'
> > Use the SQLExecute command to execute the string:
> > SET OPTION PUBLIC.MAX_STATEMENT_COUNT=0;
> > End IF
> >
> > // Since we are already connected continue with the bind
> > Bind 24 data values into ODBC memory locations
> > Execute stored procedure to do the following:
> > Use selects to ensure data values are valid
> > Use selects to ensure patient exists
> > Modify datetime fields to NULL if appropriate
> > Execute several small stored procedures to set a few values
> > Depending on existence of unique data perform either Insert or
> > Update
> > Several triggers execute during this process
> > End 1..Number of records in file
> > End While
> >
> > "Michael Gould" <mgould@*I*h*a*t*e*s**p$a*m*omnicc.com> wrote in message
> > news:3f9d97aa$1@forums-1-dub...
> > > Mike,
> > >
> > > Is is possible that you are exceeding the number of prepare statements
> > which
> > > is causing another connection to be raised? If so, then you would
need
> to
> > > make sure that r you
> > > SET OPTION PUBLIC.MAX_STATEMENT_COUNT=0;
> > >
> > > The number defaults to 50 and I believe it can go up to a max of 255
> > > defined. If it's going to be more than that, setting it to 0 turns off
> > this
> > > check.
> > >
> > > HTH's
> > >
> > > Michael Gould
> > >
> > > "Mike Niemann" <mniemann@oowidgets.com> wrote in message
> > > news:3f9d8def@forums-2-dub...
> > > > We are getting an Authentication Error in the middle of a
> connection...
> > in
> > > > other words, we are connecting, setting the Authentication String,
and
> > > > processing. Sometimes, later we are encountering an Authentication
> Error
> > > as
> > > > though the connection had been dropped and re-established. However,
in
> > our
> > > > code we are not disconnecting and reconnecting.
> > > >
> > > > Has anyone seen this? Any ideas what would cause this?
> > > >
> > > > Regards, Mike Niemann
> > > >
> > > >
> > >
> > >
> >
> >
>
>


Mike Niemann Posted on 2003-10-29 20:07:49.0Z
From: "Mike Niemann" <mniemann@oowidgets.com>
Newsgroups: ianywhere.public.general
References: <3f9d8def@forums-2-dub> <3f9d97aa$1@forums-1-dub> <3fa019b4$1@forums-2-dub> <3fa01c6f$1@forums-1-dub>
Subject: Re: ASA 8.01 OEM Authentication Error
Lines: 123
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: 167.83.10.24
Message-ID: <3fa02d3b$1@forums-2-dub>
X-Original-Trace: 29 Oct 2003 13:12:27 -0700, 167.83.10.24
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 29 Oct 2003 13:00:10 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 29 Oct 2003 13:07:49 -0700
X-Trace: forums-1-dub 1067461669 10.22.108.75 (29 Oct 2003 13:07:49 -0700)
X-Original-Trace: 29 Oct 2003 13:07:49 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:1954
Article PK: 4197

Mike,

We used SET TEMPORARY OPTION MAX_STATEMENT_COUNT=0 which seems to have done
the trick. Your original syntax failed with a -3... not sure why [but since
we only wanted this connection "unlimited"... it was no problem]. BTW, we
were/are connecting with dba authority.

Kind Regards, Mike Niemann

"Michael Gould" <mgould@*I*h*a*t*e*s**p$a*m*omnicc.com> wrote in message
news:3fa01c6f$1@forums-1-dub...
> Mike,
>
> I don't see anything wrong with what your doing. You might want to run
with
> the ODBC log on or set the database logging on using the -zr switch to see
> when or why your losing your authentication.
>
> Michael Gould
>
> "Mike Niemann" <mniemann@oowidgets.com> wrote in message
> news:3fa019b4$1@forums-2-dub...
> > Mike, we tried your suggestion... but no joy. Here is the pseudocode of
> what
> > we are doing...
> >
> > This did not seem to fix the problem. It generates the Authentication
> > violation failure error about 25% of the time. I ran 2250 insert/update
> > attempts and received the failure about 600 times.
> >
> > I have provided a general description of the IAS record insert/update
> > processing below to help us resolve this issue. We obtain the connection
> to
> > the DB one time. At this time the authentification string is executed.
The
> > Set max statements is also executed. The connection is maintained
through
> > the execution of the program.
> >
> > While (Files Exist)
> > Open file
> > Parse records from file
> > For (1..Number of records in file)
> > Assign data values from record into data object(s)
> > Apply business rules (edit some data values)
> >
> > If (Not connected to DB) // then connect using below statements
> > //Prepare to Connect then connect using ODBC level
> > SQLAllocEnv
> > SQLAllocConnect
> > SQLConnect
> > SQLSetConnectOption
> > Use the SQLExecute command to execute the authentification
> string
> > SET TEMPORARY OPTION CONNECTION_AUTHENTICATION=
> > 'Company=Baxter;
> > Application=RenalSoft;Signature=XX....XXX'
> > Use the SQLExecute command to execute the string:
> > SET OPTION PUBLIC.MAX_STATEMENT_COUNT=0;
> > End IF
> >
> > // Since we are already connected continue with the bind
> > Bind 24 data values into ODBC memory locations
> > Execute stored procedure to do the following:
> > Use selects to ensure data values are valid
> > Use selects to ensure patient exists
> > Modify datetime fields to NULL if appropriate
> > Execute several small stored procedures to set a few values
> > Depending on existence of unique data perform either Insert or
> > Update
> > Several triggers execute during this process
> > End 1..Number of records in file
> > End While
> >
> > "Michael Gould" <mgould@*I*h*a*t*e*s**p$a*m*omnicc.com> wrote in message
> > news:3f9d97aa$1@forums-1-dub...
> > > Mike,
> > >
> > > Is is possible that you are exceeding the number of prepare statements
> > which
> > > is causing another connection to be raised? If so, then you would
need
> to
> > > make sure that r you
> > > SET OPTION PUBLIC.MAX_STATEMENT_COUNT=0;
> > >
> > > The number defaults to 50 and I believe it can go up to a max of 255
> > > defined. If it's going to be more than that, setting it to 0 turns off
> > this
> > > check.
> > >
> > > HTH's
> > >
> > > Michael Gould
> > >
> > > "Mike Niemann" <mniemann@oowidgets.com> wrote in message
> > > news:3f9d8def@forums-2-dub...
> > > > We are getting an Authentication Error in the middle of a
> connection...
> > in
> > > > other words, we are connecting, setting the Authentication String,
and
> > > > processing. Sometimes, later we are encountering an Authentication
> Error
> > > as
> > > > though the connection had been dropped and re-established. However,
in
> > our
> > > > code we are not disconnecting and reconnecting.
> > > >
> > > > Has anyone seen this? Any ideas what would cause this?
> > > >
> > > > Regards, Mike Niemann
> > > >
> > > >
> > >
> > >
> >
> >
>
>


Mike Niemann Posted on 2003-10-30 13:55:15.0Z
From: "Mike Niemann" <mniemann@oowidgets.com>
Newsgroups: ianywhere.public.general
References: <3f9d8def@forums-2-dub> <3f9d97aa$1@forums-1-dub> <3fa019b4$1@forums-2-dub> <3fa01c6f$1@forums-1-dub>
Subject: Re: ASA 8.01 OEM Authentication Error
Lines: 123
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: 167.83.10.24
Message-ID: <3fa1276b$1@forums-2-dub>
X-Original-Trace: 30 Oct 2003 06:59:55 -0700, 167.83.10.24
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 30 Oct 2003 06:47:32 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 30 Oct 2003 06:55:15 -0700
X-Trace: forums-1-dub 1067525715 10.22.108.75 (30 Oct 2003 06:55:15 -0700)
X-Original-Trace: 30 Oct 2003 06:55:15 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:1965
Article PK: 4202

Michael,

I spoke too soon. As our testing continued, we encountered the same
Authentication Error.

We are totally stumped.

Regards, Mike Niemann

"Michael Gould" <mgould@*I*h*a*t*e*s**p$a*m*omnicc.com> wrote in message
news:3fa01c6f$1@forums-1-dub...
> Mike,
>
> I don't see anything wrong with what your doing. You might want to run
with
> the ODBC log on or set the database logging on using the -zr switch to see
> when or why your losing your authentication.
>
> Michael Gould
>
> "Mike Niemann" <mniemann@oowidgets.com> wrote in message
> news:3fa019b4$1@forums-2-dub...
> > Mike, we tried your suggestion... but no joy. Here is the pseudocode of
> what
> > we are doing...
> >
> > This did not seem to fix the problem. It generates the Authentication
> > violation failure error about 25% of the time. I ran 2250 insert/update
> > attempts and received the failure about 600 times.
> >
> > I have provided a general description of the IAS record insert/update
> > processing below to help us resolve this issue. We obtain the connection
> to
> > the DB one time. At this time the authentification string is executed.
The
> > Set max statements is also executed. The connection is maintained
through
> > the execution of the program.
> >
> > While (Files Exist)
> > Open file
> > Parse records from file
> > For (1..Number of records in file)
> > Assign data values from record into data object(s)
> > Apply business rules (edit some data values)
> >
> > If (Not connected to DB) // then connect using below statements
> > //Prepare to Connect then connect using ODBC level
> > SQLAllocEnv
> > SQLAllocConnect
> > SQLConnect
> > SQLSetConnectOption
> > Use the SQLExecute command to execute the authentification
> string
> > SET TEMPORARY OPTION CONNECTION_AUTHENTICATION=
> > 'Company=Baxter;
> > Application=RenalSoft;Signature=XX....XXX'
> > Use the SQLExecute command to execute the string:
> > SET OPTION PUBLIC.MAX_STATEMENT_COUNT=0;
> > End IF
> >
> > // Since we are already connected continue with the bind
> > Bind 24 data values into ODBC memory locations
> > Execute stored procedure to do the following:
> > Use selects to ensure data values are valid
> > Use selects to ensure patient exists
> > Modify datetime fields to NULL if appropriate
> > Execute several small stored procedures to set a few values
> > Depending on existence of unique data perform either Insert or
> > Update
> > Several triggers execute during this process
> > End 1..Number of records in file
> > End While
> >
> > "Michael Gould" <mgould@*I*h*a*t*e*s**p$a*m*omnicc.com> wrote in message
> > news:3f9d97aa$1@forums-1-dub...
> > > Mike,
> > >
> > > Is is possible that you are exceeding the number of prepare statements
> > which
> > > is causing another connection to be raised? If so, then you would
need
> to
> > > make sure that r you
> > > SET OPTION PUBLIC.MAX_STATEMENT_COUNT=0;
> > >
> > > The number defaults to 50 and I believe it can go up to a max of 255
> > > defined. If it's going to be more than that, setting it to 0 turns off
> > this
> > > check.
> > >
> > > HTH's
> > >
> > > Michael Gould
> > >
> > > "Mike Niemann" <mniemann@oowidgets.com> wrote in message
> > > news:3f9d8def@forums-2-dub...
> > > > We are getting an Authentication Error in the middle of a
> connection...
> > in
> > > > other words, we are connecting, setting the Authentication String,
and
> > > > processing. Sometimes, later we are encountering an Authentication
> Error
> > > as
> > > > though the connection had been dropped and re-established. However,
in
> > our
> > > > code we are not disconnecting and reconnecting.
> > > >
> > > > Has anyone seen this? Any ideas what would cause this?
> > > >
> > > > Regards, Mike Niemann
> > > >
> > > >
> > >
> > >
> >
> >
>
>


"Michael Gould" <mgould Posted on 2003-10-30 20:08:52.0Z
From: "Michael Gould" <mgould@*I*h*a*t*e*s**p$a*m*omnicc.com>
Newsgroups: ianywhere.public.general
References: <3f9d8def@forums-2-dub> <3f9d97aa$1@forums-1-dub> <3fa019b4$1@forums-2-dub> <3fa01c6f$1@forums-1-dub> <3fa1276b$1@forums-2-dub>
Subject: Re: ASA 8.01 OEM Authentication Error
Lines: 143
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
NNTP-Posting-Host: adsl-068-209-131-007.sip.jax.bellsouth.net
X-Original-NNTP-Posting-Host: adsl-068-209-131-007.sip.jax.bellsouth.net
Message-ID: <3fa17de4@forums-1-dub>
Date: 30 Oct 2003 13:08:52 -0700
X-Trace: forums-1-dub 1067548132 68.209.131.7 (30 Oct 2003 13:08:52 -0700)
X-Original-Trace: 30 Oct 2003 13:08:52 -0700, adsl-068-209-131-007.sip.jax.bellsouth.net
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:1973
Article PK: 4212

Mike,

If the database or ODBC log doesn't show any problems, then you probably
need to open a case with Sybase support.

Michael Gould

"Mike Niemann" <mniemann@oowidgets.com> wrote in message
news:3fa1276b$1@forums-2-dub...
> Michael,
>
> I spoke too soon. As our testing continued, we encountered the same
> Authentication Error.
>
> We are totally stumped.
>
> Regards, Mike Niemann
>
> "Michael Gould" <mgould@*I*h*a*t*e*s**p$a*m*omnicc.com> wrote in message
> news:3fa01c6f$1@forums-1-dub...
> > Mike,
> >
> > I don't see anything wrong with what your doing. You might want to run
> with
> > the ODBC log on or set the database logging on using the -zr switch to
see
> > when or why your losing your authentication.
> >
> > Michael Gould
> >
> > "Mike Niemann" <mniemann@oowidgets.com> wrote in message
> > news:3fa019b4$1@forums-2-dub...
> > > Mike, we tried your suggestion... but no joy. Here is the pseudocode
of
> > what
> > > we are doing...
> > >
> > > This did not seem to fix the problem. It generates the Authentication
> > > violation failure error about 25% of the time. I ran 2250
insert/update
> > > attempts and received the failure about 600 times.
> > >
> > > I have provided a general description of the IAS record insert/update
> > > processing below to help us resolve this issue. We obtain the
connection
> > to
> > > the DB one time. At this time the authentification string is executed.
> The
> > > Set max statements is also executed. The connection is maintained
> through
> > > the execution of the program.
> > >
> > > While (Files Exist)
> > > Open file
> > > Parse records from file
> > > For (1..Number of records in file)
> > > Assign data values from record into data object(s)
> > > Apply business rules (edit some data values)
> > >
> > > If (Not connected to DB) // then connect using below
statements
> > > //Prepare to Connect then connect using ODBC level
> > > SQLAllocEnv
> > > SQLAllocConnect
> > > SQLConnect
> > > SQLSetConnectOption
> > > Use the SQLExecute command to execute the authentification
> > string
> > > SET TEMPORARY OPTION CONNECTION_AUTHENTICATION=
> > > 'Company=Baxter;
> > > Application=RenalSoft;Signature=XX....XXX'
> > > Use the SQLExecute command to execute the string:
> > > SET OPTION PUBLIC.MAX_STATEMENT_COUNT=0;
> > > End IF
> > >
> > > // Since we are already connected continue with the bind
> > > Bind 24 data values into ODBC memory locations
> > > Execute stored procedure to do the following:
> > > Use selects to ensure data values are valid
> > > Use selects to ensure patient exists
> > > Modify datetime fields to NULL if appropriate
> > > Execute several small stored procedures to set a few values
> > > Depending on existence of unique data perform either Insert or
> > > Update
> > > Several triggers execute during this process
> > > End 1..Number of records in file
> > > End While
> > >
> > > "Michael Gould" <mgould@*I*h*a*t*e*s**p$a*m*omnicc.com> wrote in
message
> > > news:3f9d97aa$1@forums-1-dub...
> > > > Mike,
> > > >
> > > > Is is possible that you are exceeding the number of prepare
statements
> > > which
> > > > is causing another connection to be raised? If so, then you would
> need
> > to
> > > > make sure that r you
> > > > SET OPTION PUBLIC.MAX_STATEMENT_COUNT=0;
> > > >
> > > > The number defaults to 50 and I believe it can go up to a max of 255
> > > > defined. If it's going to be more than that, setting it to 0 turns
off
> > > this
> > > > check.
> > > >
> > > > HTH's
> > > >
> > > > Michael Gould
> > > >
> > > > "Mike Niemann" <mniemann@oowidgets.com> wrote in message
> > > > news:3f9d8def@forums-2-dub...
> > > > > We are getting an Authentication Error in the middle of a
> > connection...
> > > in
> > > > > other words, we are connecting, setting the Authentication String,
> and
> > > > > processing. Sometimes, later we are encountering an Authentication
> > Error
> > > > as
> > > > > though the connection had been dropped and re-established.
However,
> in
> > > our
> > > > > code we are not disconnecting and reconnecting.
> > > > >
> > > > > Has anyone seen this? Any ideas what would cause this?
> > > > >
> > > > > Regards, Mike Niemann
> > > > >
> > > > >
> > > >
> > > >
> > >
> > >
> >
> >
>
>


Chris Keating (iAnywhere Solutions) Posted on 2003-10-27 21:37:32.0Z
From: "Chris Keating \(iAnywhere Solutions\)" <FightSpam_keating@iAnywhere.com>
Newsgroups: ianywhere.public.general
References: <3f9d8def@forums-2-dub>
Subject: Re: ASA 8.01 OEM Authentication Error
Lines: 21
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: keating-xp.sybase.com
Message-ID: <3f9d9f3a$1@forums-2-dub>
X-Original-Trace: 27 Oct 2003 14:42:02 -0700, keating-xp.sybase.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 27 Oct 2003 14:30:04 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 27 Oct 2003 14:37:32 -0700
X-Trace: forums-1-dub 1067294252 10.22.108.75 (27 Oct 2003 14:37:32 -0700)
X-Original-Trace: 27 Oct 2003 14:37:32 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:1928
Article PK: 4168

A request level log may help to diagnose where this authentication error is
occurring.

/ck

"Mike Niemann" <mniemann@oowidgets.com> wrote in message
news:3f9d8def@forums-2-dub...
> We are getting an Authentication Error in the middle of a connection... in
> other words, we are connecting, setting the Authentication String, and
> processing. Sometimes, later we are encountering an Authentication Error
as
> though the connection had been dropped and re-established. However, in our
> code we are not disconnecting and reconnecting.
>
> Has anyone seen this? Any ideas what would cause this?
>
> Regards, Mike Niemann
>
>