Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Data Store does not work on ce

2 posts in General Discussion Last posting was on 2003-11-05 14:55:02.0Z
Henry Wycislo Posted on 2003-11-04 23:04:38.0Z
Sender: 6d6b.3fa83105.1804289383@sybase.com
From: Henry Wycislo
Newsgroups: ianywhere.public.general
Subject: Data Store does not work on ce
X-Mailer: WebNews to Mail Gateway v1.1s
Message-ID: <3fa831b1.6d72.846930886@sybase.com>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 4 Nov 2003 15:09:37 -0800, 10.22.241.42
Lines: 22
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 4 Nov 2003 14:56:24 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 4 Nov 2003 15:04:38 -0800
X-Trace: forums-1-dub 1067987078 10.22.108.75 (4 Nov 2003 15:04:38 -0800)
X-Original-Trace: 4 Nov 2003 15:04:38 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2019
Article PK: 17355

I created an app that is using a datastore. The datastore
works on the pc but it does not work on the ce. Me thinks me
found a bug.

string str_item
integer n
long ll_rows


datastore ds_exnames
datastore ds_listbox
ds_exnames = create datastore
ds_exnames.dataobject = "dw_exname"

ll_rows = ds_exnames.SetTransObject (SQLCA)

messagebox ("ll_rows",ll_rows)


ll_rows returns a 1 on the pc and a -1 on windows ce. Does
any one have confirmation that datastores work on windows
ce?


Chris Keating (iAnywhere Solutions) Posted on 2003-11-05 14:55:02.0Z
From: "Chris Keating \(iAnywhere Solutions\)" <FightSpam_keating@iAnywhere.com>
Newsgroups: ianywhere.public.general
References: <3fa831b1.6d72.846930886@sybase.com>
Subject: Re: Data Store does not work on ce
Lines: 31
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: keating-xp.sybase.com
Message-ID: <3fa91075$1@forums-2-dub>
X-Original-Trace: 5 Nov 2003 07:00:05 -0800, keating-xp.sybase.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 5 Nov 2003 06:46:44 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 5 Nov 2003 06:55:02 -0800
X-Trace: forums-1-dub 1068044102 10.22.108.75 (5 Nov 2003 06:55:02 -0800)
X-Original-Trace: 5 Nov 2003 06:55:02 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2026
Article PK: 4242

You may want to post this to the Pocket PowerBuilder newsgroup. Are you
include the "dw_exname" in a pb resource file? Remember, dynamically
referenced datawindows need to be referenced in a PBR.

/ck

<Henry Wycislo> wrote in message news:3fa831b1.6d72.846930886@sybase.com...
> I created an app that is using a datastore. The datastore
> works on the pc but it does not work on the ce. Me thinks me
> found a bug.
>
> string str_item
> integer n
> long ll_rows
>
>
> datastore ds_exnames
> datastore ds_listbox
> ds_exnames = create datastore
> ds_exnames.dataobject = "dw_exname"
>
> ll_rows = ds_exnames.SetTransObject (SQLCA)
>
> messagebox ("ll_rows",ll_rows)
>
>
> ll_rows returns a 1 on the pc and a -1 on windows ce. Does
> any one have confirmation that datastores work on windows
> ce?