Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

SQL Anywhere Version 5.0 Database Conversion To iAnywhere 8.0 Issue

2 posts in General Discussion Last posting was on 2003-11-12 20:22:42.0Z
Bob Melcos Posted on 2003-11-12 19:12:49.0Z
Sender: 6a02.3fb28777.1804289383@sybase.com
From: Bob Melcos
Newsgroups: ianywhere.public.general
Subject: SQL Anywhere Version 5.0 Database Conversion To iAnywhere 8.0 Issue
X-Mailer: WebNews to Mail Gateway v1.1s
Message-ID: <3fb28777.6a02.1681692777@sybase.com>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 12 Nov 2003 11:18:15 -0800, 10.22.241.42
Lines: 11
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 12 Nov 2003 11:03:47 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 12 Nov 2003 11:12:49 -0800
X-Trace: forums-1-dub 1068664369 10.22.108.75 (12 Nov 2003 11:12:49 -0800)
X-Original-Trace: 12 Nov 2003 11:12:49 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2059
Article PK: 4276

We currently have a vertical market application that uses
SQLAnywhere 5.0 database at it's backend. The application is
installed as a standalong app or as a client server app
depending on the client needs. We are now upgrading the
database engine to 8.0 and mirgrating the database as well
to 8.0. However, when we install the ASA 8.0 on the client
machine it destroys the 5.0 client libraries and so we are
unable to connect to the old database that needs to be
converted. The database conversion fails. Version 8 client
libraries do not seem to connect to version 5. Does any one
know the fix? Thanks.


Robert Waywell Posted on 2003-11-12 20:22:42.0Z
From: "Robert Waywell" <nospam_rwaywell@ianywhere.com>
Newsgroups: ianywhere.public.general
References: <3fb28777.6a02.1681692777@sybase.com>
Subject: Re: SQL Anywhere Version 5.0 Database Conversion To iAnywhere 8.0 Issue
Lines: 41
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2600.0000
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000
NNTP-Posting-Host: rwaywell-pc.sybase.com
X-Original-NNTP-Posting-Host: rwaywell-pc.sybase.com
Message-ID: <3fb29692$1@forums-1-dub>
Date: 12 Nov 2003 12:22:42 -0800
X-Trace: forums-1-dub 1068668562 172.31.142.236 (12 Nov 2003 12:22:42 -0800)
X-Original-Trace: 12 Nov 2003 12:22:42 -0800, rwaywell-pc.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2061
Article PK: 4277

Make sure you review this section of the docs as a starting point:

What's New in SQL Anywhere Studio

13. Upgrading Version 5 Applications

--
-----------------------------------------------
Robert Waywell
Sybase Adaptive Server Anywhere Developer - Version 8
Sybase Certified Professional

Sybase's iAnywhere Solutions

Please respond ONLY to newsgroup

EBF's and Patches: http://downloads.sybase.com
choose SQL Anywhere Studio >> change 'time frame' to all

To Submit Bug Reports: http://case-express.sybase.com/cx/cx.stm

SQL Anywhere Studio Supported Platforms and Support Status
http://my.sybase.com/detail?id=1002288

Whitepapers, TechDocs, and bug fixes are all available through the iAnywhere
Developer Community at www.ianywhere.com/developer

<Bob Melcos> wrote in message news:3fb28777.6a02.1681692777@sybase.com...
> We currently have a vertical market application that uses
> SQLAnywhere 5.0 database at it's backend. The application is
> installed as a standalong app or as a client server app
> depending on the client needs. We are now upgrading the
> database engine to 8.0 and mirgrating the database as well
> to 8.0. However, when we install the ASA 8.0 on the client
> machine it destroys the 5.0 client libraries and so we are
> unable to connect to the old database that needs to be
> converted. The database conversion fails. Version 8 client
> libraries do not seem to connect to version 5. Does any one
> know the fix? Thanks.