Hello

I have a problem with crashing http.exe service when working with Lotus
Notes adapter.
The system puts a error message to System log (you may see it with NT event
viewer)
/****************** message ******************/
Application popup: http.exe - Application Error : The instruction at
"0x16fe0e18" referenced memory at "0x00000014". The memory could not be
"read".
Click on OK to terminate the program
/****************** message ******************/

But the NT Service "XTND Connect server" is still showing "Running" state,
but does not respond on attepts to connect to it.
So there is no way to restart the service.

When it is working it gives many errors to "Application log" with the follow
messages:
1. <?xml version="1.0" encoding="UTF-16" ?>
<SyncLog Userid="amyran" Version="1.0">
<SessionMode Code="1">Synchronize Data</SessionMode>
<SessionResult Code="4">Session aborted due to errors</SessionResult>
<AdapterCollection Count="2">
<Adapter DisplayName="Lotus Notes" ID="ESI-Notes.2"
Location="http://localhost:5001/cgi-bin/adaptercgi.exe?adapter=NotesAdapter"
Type="server"></Adapter>
<Adapter DisplayName="Palm OS Device" ID="ESI-Palm" Type="client"></Adapter>
</AdapterCollection>
<ErrorCollection Count="1">
<Error AdapterID="ESI-Palm" Code="-9">Invalid response from &apos;Palm OS
Device&apos;</Error>
</ErrorCollection>
</SyncLog>

2. Process Request Failed: Error # -25

3. Adapter's attempt to decrypt the password failed for user (null). The
password may have been encrypted with the wrong key.

We have many users of XCS and the average time between synchronization is
less then two minutes, but sometime (in the morning) it might be less then 1
minute and there are some users (3-4) are synchronizing at the same time.

Is there any workaround?

Thank you in advance,
Dmitry.