Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

odbc-driver asa 9.0

6 posts in General Discussion Last posting was on 2003-12-03 01:04:10.0Z
Wilko Helms Posted on 2003-11-24 22:23:40.0Z
From: "Wilko Helms" <Wilko.Helms@Helms-Partner.de>
Newsgroups: ianywhere.public.general
Subject: odbc-driver asa 9.0
Lines: 14
Organization: Helms & Partner GbmH
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.50.4927.1200
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4927.1200
NNTP-Posting-Host: p508e3586.dip.t-dialin.net
X-Original-NNTP-Posting-Host: p508e3586.dip.t-dialin.net
Message-ID: <3fc284ec@forums-1-dub>
Date: 24 Nov 2003 14:23:40 -0800
X-Trace: forums-1-dub 1069712620 80.142.53.134 (24 Nov 2003 14:23:40 -0800)
X-Original-Trace: 24 Nov 2003 14:23:40 -0800, p508e3586.dip.t-dialin.net
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2126
Article PK: 4342

hello,
I just installed sql anywhere 9.0 built 1235. Trying to define a new
datasource with odbc-driver asa 9.0. But 9.0 doesnt show up. Therre is no
way selecting an 9.0 driver. I can see the example databases using asa 9.0
drivers and configure them, but in new datasource pane only asa 7.0 and asa
8.0 show up.
Registry looks fine as far as I can see, everything concerning asa odbc 9.0
ist installed.

Who can help ?

Thanks, Wilko


wilko Helms Posted on 2003-11-24 22:30:40.0Z
Sender: 42fa.3fc287a3.1804289383@sybase.com
From: wilko Helms
Newsgroups: ianywhere.public.general
Subject: Re: odbc-driver asa 9.0
X-Mailer: WebNews to Mail Gateway v1.1s
Message-ID: <3fc28804.42fe.846930886@sybase.com>
References: <3fc284ec@forums-1-dub>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 24 Nov 2003 14:36:52 -0800, 10.22.241.42
Lines: 17
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 24 Nov 2003 14:20:27 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 24 Nov 2003 14:30:40 -0800
X-Trace: forums-1-dub 1069713040 10.22.108.75 (24 Nov 2003 14:30:40 -0800)
X-Original-Trace: 24 Nov 2003 14:30:40 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2127
Article PK: 4343


> hello,
> I just installed sql anywhere 9.0 built 1235. Trying to
> define a new datasource with odbc-driver asa 9.0. But 9.0
> doesnt show up. Therre is no way selecting an 9.0 driver.
> I can see the example databases using asa 9.0 drivers and
> configure them, but in new datasource pane only asa 7.0
> and asa 8.0 show up.
> Registry looks fine as far as I can see, everything
> concerning asa odbc 9.0 ist installed.
>
> Who can help ?
>
> Thanks, Wilko
>
> Sorry, I forgot : asa 9 runs on win2k professional. I

installed complete studio with all coming odbc-drivers.
Wilko


Chris Keating (iAnywhere Solutions) Posted on 2003-11-25 01:09:29.0Z
From: "Chris Keating \(iAnywhere Solutions\)" <FightSpam_keating@iAnywhere.com>
Newsgroups: ianywhere.public.general
References: <3fc284ec@forums-1-dub>
Subject: Re: odbc-driver asa 9.0
Lines: 56
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
NNTP-Posting-Host: vpn-concord-062.sybase.com
X-Original-NNTP-Posting-Host: vpn-concord-062.sybase.com
Message-ID: <3fc2abc9$1@forums-1-dub>
Date: 24 Nov 2003 17:09:29 -0800
X-Trace: forums-1-dub 1069722569 158.159.8.62 (24 Nov 2003 17:09:29 -0800)
X-Original-Trace: 24 Nov 2003 17:09:29 -0800, vpn-concord-062.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2128
Article PK: 4344

This usually points to a problem with the registry. Can you export the
registry levels HKEY_LOCAL_MACHINE\SOFTWARE\ODBC and
HKEY_CURRENT_USER\SOFTWARE\ODBC (the export is needed since the problem is
not visible in the registry tool). Look for @ symbols in the exported
layers. If they exist, it is a sure sign or problems. It can be cleaned up
but always TAKE A BACKUP of the REGISTRY and the SYSTEM before starting . To
clean up, remove the bad entries or set the rows with @ to represent
accurate setting if known. If you can, post the exported files for review
before proceeding.
--

Chris Keating
Sybase Adaptive Server Anywhere Professional Version 8

****************************************************************************
*
Sign up today for your copy of the SQL Anywhere Studio 9 Developer Edition
and try out the market-leading database for mobile, embedded and small to
medium sized business environments for free!

http://www.ianywhere.com/promos/deved/index.html

****************************************************************************
*

iAnywhere Solutions http://www.iAnywhere.com

** Please only post to the newsgroup

** Whitepapers can be found at http://www.iAnywhere.com/developer
** EBFs can be found at http://downloads.sybase.com/swx/sdmain.stm
** Use CaseXpress to report bugs http://casexpress.sybase.com

****************************************************************************
*

"Wilko Helms" <Wilko.Helms@Helms-Partner.de> wrote in message
news:3fc284ec@forums-1-dub...
> hello,
> I just installed sql anywhere 9.0 built 1235. Trying to define a new
> datasource with odbc-driver asa 9.0. But 9.0 doesnt show up. Therre is no
> way selecting an 9.0 driver. I can see the example databases using asa 9.0
> drivers and configure them, but in new datasource pane only asa 7.0 and
asa
> 8.0 show up.
> Registry looks fine as far as I can see, everything concerning asa odbc
9.0
> ist installed.
>
> Who can help ?
>
> Thanks, Wilko
>
>


wilko Helms Posted on 2003-12-01 22:43:41.0Z
Sender: 3186.3fcbc4c6.1804289383@sybase.com
From: Wilko Helms
Newsgroups: ianywhere.public.general
Subject: Re: odbc-driver asa 9.0
X-Mailer: WebNews to Mail Gateway v1.1s
Message-ID: <3fcbc5a9.3193.846930886@sybase.com>
References: <3fc284ec@forums-1-dub><3fc2abc9$1@forums-1-dub>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 1 Dec 2003 14:50:17 -0800, 10.22.241.42
Lines: 71
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 1 Dec 2003 14:32:46 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 1 Dec 2003 14:43:41 -0800
X-Trace: forums-1-dub 1070318621 10.22.108.75 (1 Dec 2003 14:43:41 -0800)
X-Original-Trace: 1 Dec 2003 14:43:41 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2157
Article PK: 4372

Hello,
thanks for quick response. I tried as you supposed, but
nothing changed. Tried to find sign "@" within reg-entries
but reg had none. SQL Anywhere 8 drivers had keys with type
sz_expand and whole text showed up in hex - i changed them
but still no anywhere 9 driver shows up when adding new odbc
source

thanks in advance
wilko >
This usually points to a problem with the registry. Can

> you export the registry levels
> HKEY_LOCAL_MACHINE\SOFTWARE\ODBC and
> HKEY_CURRENT_USER\SOFTWARE\ODBC (the export is needed
> since the problem is not visible in the registry tool).
> Look for @ symbols in the exported layers. If they exist,
> it is a sure sign or problems. It can be cleaned up but
> always TAKE A BACKUP of the REGISTRY and the SYSTEM before
> starting . To clean up, remove the bad entries or set the
> rows with @ to represent accurate setting if known. If you
> can, post the exported files for review before proceeding.
> --
>
> Chris Keating
> Sybase Adaptive Server Anywhere Professional Version 8
>
> **********************************************************
> ****************** *
> Sign up today for your copy of the SQL Anywhere Studio 9
> Developer Edition and try out the market-leading database
> for mobile, embedded and small to medium sized business
> environments for free!
>
> http://www.ianywhere.com/promos/deved/index.html
>
> **********************************************************
> ****************** *
>
> iAnywhere Solutions http://www.iAnywhere.com
>
> ** Please only post to the newsgroup
>
> ** Whitepapers can be found at
> http://www.iAnywhere.com/developer ** EBFs can be found at
> http://downloads.sybase.com/swx/sdmain.stm ** Use
> CaseXpress to report bugs http://casexpress.sybase.com
>
> **********************************************************
> ****************** *
>
> "Wilko Helms" <Wilko.Helms@Helms-Partner.de> wrote in
> message news:3fc284ec@forums-1-dub...
> > hello,
> > I just installed sql anywhere 9.0 built 1235. Trying to
> > define a new datasource with odbc-driver asa 9.0. But
> > 9.0 doesnt show up. Therre is no way selecting an 9.0
> > driver. I can see the example databases using asa 9.0
> drivers and configure them, but in new datasource pane
> only asa 7.0 and asa
> > 8.0 show up.
> > Registry looks fine as far as I can see, everything
> concerning asa odbc 9.0
> > ist installed.
> >
> > Who can help ?
> >
> > Thanks, Wilko
> >
> >
>
>


Chris Keating (iAnywhere Solutions) Posted on 2003-12-02 14:51:52.0Z
From: "Chris Keating \(iAnywhere Solutions\)" <FightSpam_keating@iAnywhere.com>
Newsgroups: ianywhere.public.general
References: <3fc284ec@forums-1-dub><3fc2abc9$1@forums-1-dub> <3fcbc5a9.3193.846930886@sybase.com>
Subject: Re: odbc-driver asa 9.0
Lines: 111
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: keating-xp.sybase.com
Message-ID: <3fcca893$1@forums-2-dub>
X-Original-Trace: 2 Dec 2003 06:58:27 -0800, keating-xp.sybase.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 2 Dec 2003 06:40:49 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 2 Dec 2003 06:51:52 -0800
X-Trace: forums-1-dub 1070376712 10.22.108.75 (2 Dec 2003 06:51:52 -0800)
X-Original-Trace: 2 Dec 2003 06:51:52 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2161
Article PK: 4368

Just to confirm.... From a text editor, there is no indication of any rogue
'@' symbols? A search of the registry for '@' using regedit is not
meaningful for detecting this problem -- it won't find it.


Can you post your exported HKLM and HKCU \Software\ODBC entries?




--

Chris Keating
Sybase Adaptive Server Anywhere Professional Version 8

****************************************************************************
*
Sign up today for your copy of the SQL Anywhere Studio 9 Developer Edition
and try out the market-leading database for mobile, embedded and small to
medium sized business environments for free!

http://www.ianywhere.com/promos/deved/index.html

****************************************************************************
*

iAnywhere Solutions http://www.iAnywhere.com

** Please only post to the newsgroup

** Whitepapers can be found at http://www.iAnywhere.com/developer
** EBFs can be found at http://downloads.sybase.com/swx/sdmain.stm
** Use CaseXpress to report bugs http://casexpress.sybase.com

****************************************************************************
*

<Wilko Helms> wrote in message news:3fcbc5a9.3193.846930886@sybase.com...
> Hello,
> thanks for quick response. I tried as you supposed, but
> nothing changed. Tried to find sign "@" within reg-entries
> but reg had none. SQL Anywhere 8 drivers had keys with type
> sz_expand and whole text showed up in hex - i changed them
> but still no anywhere 9 driver shows up when adding new odbc
> source
>
> thanks in advance
> wilko >
> This usually points to a problem with the registry. Can
> > you export the registry levels
> > HKEY_LOCAL_MACHINE\SOFTWARE\ODBC and
> > HKEY_CURRENT_USER\SOFTWARE\ODBC (the export is needed
> > since the problem is not visible in the registry tool).
> > Look for @ symbols in the exported layers. If they exist,
> > it is a sure sign or problems. It can be cleaned up but
> > always TAKE A BACKUP of the REGISTRY and the SYSTEM before
> > starting . To clean up, remove the bad entries or set the
> > rows with @ to represent accurate setting if known. If you
> > can, post the exported files for review before proceeding.
> > --
> >
> > Chris Keating
> > Sybase Adaptive Server Anywhere Professional Version 8
> >
> > **********************************************************
> > ****************** *
> > Sign up today for your copy of the SQL Anywhere Studio 9
> > Developer Edition and try out the market-leading database
> > for mobile, embedded and small to medium sized business
> > environments for free!
> >
> > http://www.ianywhere.com/promos/deved/index.html
> >
> > **********************************************************
> > ****************** *
> >
> > iAnywhere Solutions http://www.iAnywhere.com
> >
> > ** Please only post to the newsgroup
> >
> > ** Whitepapers can be found at
> > http://www.iAnywhere.com/developer ** EBFs can be found at
> > http://downloads.sybase.com/swx/sdmain.stm ** Use
> > CaseXpress to report bugs http://casexpress.sybase.com
> >
> > **********************************************************
> > ****************** *
> >
> > "Wilko Helms" <Wilko.Helms@Helms-Partner.de> wrote in
> > message news:3fc284ec@forums-1-dub...
> > > hello,
> > > I just installed sql anywhere 9.0 built 1235. Trying to
> > > define a new datasource with odbc-driver asa 9.0. But
> > > 9.0 doesnt show up. Therre is no way selecting an 9.0
> > > driver. I can see the example databases using asa 9.0
> > drivers and configure them, but in new datasource pane
> > only asa 7.0 and asa
> > > 8.0 show up.
> > > Registry looks fine as far as I can see, everything
> > concerning asa odbc 9.0
> > > ist installed.
> > >
> > > Who can help ?
> > >
> > > Thanks, Wilko
> > >
> > >
> >
> >


wilko Helms Posted on 2003-12-03 01:04:10.0Z
Sender: 4285.3fcd0f8a.1804289383@sybase.com
From: wilko Helms
Newsgroups: ianywhere.public.general
Subject: Re: odbc-driver asa 9.0
X-Mailer: WebNews to Mail Gateway v1.1s
Message-ID: <3fcd381b.43e3.846930886@sybase.com>
References: <3fc284ec@forums-1-dub><3fc2abc9$1@forums-1-dub> <3fcbc5a9.3193.846930886@sybase.com><3fcca893$1@forums-2-dub>
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="-=_forums-2-dub3fcd381b"
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 2 Dec 2003 17:10:51 -0800, 10.22.241.42
Lines: 3524
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 2 Dec 2003 16:53:09 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 2 Dec 2003 17:04:10 -0800
X-Trace: forums-1-dub 1070413450 10.22.108.75 (2 Dec 2003 17:04:10 -0800)
X-Original-Trace: 2 Dec 2003 17:04:10 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2168
Article PK: 4382

hi,

I send you the reg-exports.
thanks in advance
wilko Helms

>
Just to confirm.... From a text editor, there is no
> indication of any rogue '@' symbols? A search of the
> registry for '@' using regedit is not meaningful for
> detecting this problem -- it won't find it.
>
>
> Can you post your exported HKLM and HKCU \Software\ODBC
> entries?
>
>
>
>
> --
>
> Chris Keating
> Sybase Adaptive Server Anywhere Professional Version 8
>
> **********************************************************
> ****************** *
> Sign up today for your copy of the SQL Anywhere Studio 9
> Developer Edition and try out the market-leading database
> for mobile, embedded and small to medium sized business
> environments for free!
>
> http://www.ianywhere.com/promos/deved/index.html
>
> **********************************************************
> ****************** *
>
> iAnywhere Solutions http://www.iAnywhere.com
>
> ** Please only post to the newsgroup
>
> ** Whitepapers can be found at
> http://www.iAnywhere.com/developer ** EBFs can be found at
> http://downloads.sybase.com/swx/sdmain.stm ** Use
> CaseXpress to report bugs http://casexpress.sybase.com
>
> **********************************************************
> ****************** *
>
> <Wilko Helms> wrote in message
> > news:3fcbc5a9.3193.846930886@sybase.com... Hello,
> > thanks for quick response. I tried as you supposed, but
> > nothing changed. Tried to find sign "@" within
> > reg-entries but reg had none. SQL Anywhere 8 drivers had
> > keys with type sz_expand and whole text showed up in hex
> > - i changed them but still no anywhere 9 driver shows up
> > when adding new odbc source
> >
> > thanks in advance
> > wilko >
> > This usually points to a problem with the registry. Can
> > > you export the registry levels
> > > HKEY_LOCAL_MACHINE\SOFTWARE\ODBC and
> > > HKEY_CURRENT_USER\SOFTWARE\ODBC (the export is needed
> > > since the problem is not visible in the registry
> > > tool). Look for @ symbols in the exported layers. If
> > > they exist, it is a sure sign or problems. It can be
> > > cleaned up but always TAKE A BACKUP of the REGISTRY
> > > and the SYSTEM before starting . To clean up, remove
> > > the bad entries or set the rows with @ to represent
> > > accurate setting if known. If you can, post the
> > > exported files for review before proceeding. --
> > >
> > > Chris Keating
> > > Sybase Adaptive Server Anywhere Professional Version 8
> > >
> > >
> > >
> **********************************************************
> > > ****************** * Sign up today for your copy of
> > > the SQL Anywhere Studio 9 Developer Edition and try
> > > out the market-leading database for mobile, embedded
> > > and small to medium sized business environments for
> > free! >
> > > http://www.ianywhere.com/promos/deved/index.html
> > >
> > >
> > >
> **********************************************************
> > ****************** * >
> > > iAnywhere Solutions http://www.iAnywhere.com
> > >
> > > ** Please only post to the newsgroup
> > >
> > > ** Whitepapers can be found at
> > > http://www.iAnywhere.com/developer ** EBFs can be
> > > found at http://downloads.sybase.com/swx/sdmain.stm **
> > > Use CaseXpress to report bugs
> > http://casexpress.sybase.com >
> > >
> > >
> **********************************************************
> > ****************** * >
> > > "Wilko Helms" <Wilko.Helms@Helms-Partner.de> wrote in
> > > message news:3fc284ec@forums-1-dub...
> > > > hello,
> > > > I just installed sql anywhere 9.0 built 1235. Trying
> > > > to define a new datasource with odbc-driver asa 9.0.
> > > > But 9.0 doesnt show up. Therre is no way selecting
> > > > an 9.0 driver. I can see the example databases using
> > > asa 9.0 drivers and configure them, but in new
> > > datasource pane only asa 7.0 and asa
> > > > 8.0 show up.
> > > > Registry looks fine as far as I can see, everything
> > > concerning asa odbc 9.0
> > > > ist installed.
> > > >
> > > > Who can help ?
> > > >
> > > > Thanks, Wilko
> > > >
> > > >
> > >
> > >
>
>