Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Aep runs on the server but not remotely

6 posts in ,  Networking NT Last posting was on 2003-12-02 15:08:57.0Z
Philippos Pitsavas Posted on 2003-11-29 18:31:41.0Z
From: "Philippos Pitsavas" <pitsvas@bluebyte.gr>
Newsgroups: advantage.networking,advantage.nt
Subject: Aep runs on the server but not remotely
Date: Sat, 29 Nov 2003 20:31:41 +0200
Lines: 9
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
NNTP-Posting-Host: 195.66.96.155
Message-ID: <3fc8e708@solutions.advantagedatabase.com>
X-Trace: 29 Nov 2003 11:35:52 -0700, 195.66.96.155
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!195.66.96.155
Xref: solutions.advantagedatabase.com Advantage.Networking:438 Advantage.NT:1298
Article PK: 1130137

When i try to run our Delphi Based application on the server everything
works OK. But when I connect from another pc the AEP that is used by the
program
will not run and so will the program. The network is based on a domain and
the remote pc's use roaming profiles to connect to the server so i assume
that the problem has to do with the Domain's Security which doesn't permit
the AEP to read from the Registry. Can anybody please help?


Wendi Fisher Posted on 2003-12-01 16:59:06.0Z
Date: Mon, 01 Dec 2003 11:59:06 -0500
From: Wendi Fisher <wfisher@adclegal.com>
Reply-To: wfisher@adclegal.com
Organization: ADC Legal Systems
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: advantage.networking,advantage.nt
Subject: Re: Aep runs on the server but not remotely
References: <3fc8e708@solutions.advantagedatabase.com>
In-Reply-To: <3fc8e708@solutions.advantagedatabase.com>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: 63.163.110.38
Message-ID: <3fcb7549@solutions.advantagedatabase.com>
X-Trace: 1 Dec 2003 10:07:21 -0700, 63.163.110.38
Lines: 20
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!63.163.110.38
Xref: solutions.advantagedatabase.com Advantage.Networking:439 Advantage.NT:1299
Article PK: 1130131


Philippos Pitsavas wrote:
> When i try to run our Delphi Based application on the server everything
> works OK. But when I connect from another pc the AEP that is used by the
> program
> will not run and so will the program. The network is based on a domain and
> the remote pc's use roaming profiles to connect to the server so i assume
> that the problem has to do with the Domain's Security which doesn't permit
> the AEP to read from the Registry. Can anybody please help?
>
>

have you tried running the AEP and/or the app from the remote PC using
an admin account that would have complete access? This might help narrow
down the problem.

Wendi Fisher
Data Conversion Programmer
ADC Legal Systems, Inc.
wfisher@adclegal.com
http://www.adclegal.com


Philippos Pitsavas Posted on 2003-12-01 17:22:58.0Z
From: "Philippos Pitsavas" <pitsvas@bluebyte.gr>
Newsgroups: advantage.networking,advantage.nt
References: <3fc8e708@solutions.advantagedatabase.com> <3fcb7549@solutions.advantagedatabase.com>
Subject: Re: Aep runs on the server but not remotely
Date: Mon, 1 Dec 2003 19:22:58 +0200
Lines: 40
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
NNTP-Posting-Host: 212.205.226.98
Message-ID: <3fcb7a00@solutions.advantagedatabase.com>
X-Trace: 1 Dec 2003 10:27:28 -0700, 212.205.226.98
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!212.205.226.98
Xref: solutions.advantagedatabase.com Advantage.Networking:440 Advantage.NT:1300
Article PK: 1130143

? "Wendi Fisher" <wfisher@adclegal.com> ?????? ??? ??????
news:3fcb7549@solutions.advantagedatabase.com...

> Philippos Pitsavas wrote:
> > When i try to run our Delphi Based application on the server
everything
> > works OK. But when I connect from another pc the AEP that is used by the
> > program
> > will not run and so will the program. The network is based on a domain
and
> > the remote pc's use roaming profiles to connect to the server so i
assume
> > that the problem has to do with the Domain's Security which doesn't
permit
> > the AEP to read from the Registry. Can anybody please help?
> >
> >
> have you tried running the AEP and/or the app from the remote PC using
> an admin account that would have complete access? This might help narrow
> down the problem.
>
> Wendi Fisher
> Data Conversion Programmer
> ADC Legal Systems, Inc.
> wfisher@adclegal.com
> http://www.adclegal.com
>

I have tried that but it had no effect. I have also tried logging the
Advantage Service not as a local system Account but as an Administrator.
This din't solve the problem either. The only thing that the AEP is trying
to do, is read a value from the server's registry so I assume that it
doesn't have the right privileges. The real problem is that the server is
using Active Directory and I'm not very familiar with managing security
settings in this case. Thank you in advance.

Philippos Pitsavas
Support Assistant Manager
BlueByte Software


Wendi Fisher Posted on 2003-12-01 19:43:29.0Z
Date: Mon, 01 Dec 2003 14:43:29 -0500
From: Wendi Fisher <wfisher@adclegal.com>
Reply-To: wfisher@adclegal.com
Organization: ADC Legal Systems
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: advantage.networking,advantage.nt
Subject: Re: Aep runs on the server but not remotely
References: <3fc8e708@solutions.advantagedatabase.com> <3fcb7549@solutions.advantagedatabase.com> <3fcb7a00@solutions.advantagedatabase.com>
In-Reply-To: <3fcb7a00@solutions.advantagedatabase.com>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: 63.163.110.38
Message-ID: <3fcb9af1@solutions.advantagedatabase.com>
X-Trace: 1 Dec 2003 12:48:01 -0700, 63.163.110.38
Lines: 76
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!63.163.110.38
Xref: solutions.advantagedatabase.com Advantage.Networking:441 Advantage.NT:1301
Article PK: 1130135


Philippos Pitsavas wrote:
> ? "Wendi Fisher" <wfisher@adclegal.com> ?????? ??? ??????
> news:3fcb7549@solutions.advantagedatabase.com...
>
>>Philippos Pitsavas wrote:
>>
>>>When i try to run our Delphi Based application on the server
>
> everything
>
>>>works OK. But when I connect from another pc the AEP that is used by the
>>>program
>>>will not run and so will the program. The network is based on a domain
>
> and
>
>>>the remote pc's use roaming profiles to connect to the server so i
>
> assume
>
>>>that the problem has to do with the Domain's Security which doesn't
>
> permit
>
>>>the AEP to read from the Registry. Can anybody please help?
>>>
>>>
>>
>>have you tried running the AEP and/or the app from the remote PC using
>>an admin account that would have complete access? This might help narrow
>>down the problem.
>>
>>Wendi Fisher
>>Data Conversion Programmer
>>ADC Legal Systems, Inc.
>>wfisher@adclegal.com
>>http://www.adclegal.com
>>
>
> I have tried that but it had no effect. I have also tried logging the
> Advantage Service not as a local system Account but as an Administrator.
> This din't solve the problem either. The only thing that the AEP is trying
> to do, is read a value from the server's registry so I assume that it
> doesn't have the right privileges. The real problem is that the server is
> using Active Directory and I'm not very familiar with managing security
> settings in this case. Thank you in advance.
>
> Philippos Pitsavas
> Support Assistant Manager
> BlueByte Software
>
>

Ouch... yeah it is going to take some time to figure out. Instead of
trying to run it with a local admin account... try running the app from
the remote pc under a domain admin account. I wasnt aware you were
using AD when I posted before.

Unfortunately I think you are going to have to get into Security
Templates and possibly create a new one applicable to the user account
you want the ADS and the AEP to work under. I found the below article
in the MS Knowledge base about security Templates and step by step
instructions to create one. As you will notice, one of the function
security templates and group policies encompasses is Registry Key Access.

HOW TO: Define Security Templates By Using the Security Templates Snap-In
URL:
http://support.microsoft.com/default.aspx?scid=kb;en-us;816297&Product=winsvr2003

HTH

Wendi Fisher, MCSE
Data Conversion Programmer
ADC Legal Systems, Inc.
wfisher@adclegal.com
http://www.adclegal.com


Joachim Duerr (ADS Support) Posted on 2003-12-02 09:00:56.0Z
From: "Joachim Duerr (ADS Support)" <jojo.duerr@gmx.de>
Subject: Re: Aep runs on the server but not remotely
Newsgroups: advantage.networking,advantage.nt
References: <3fc8e708@solutions.advantagedatabase.com> <3fcb7549@solutions.advantagedatabase.com> <3fcb7a00@solutions.advantagedatabase.com>
Organization: Extended Systems GmbH
User-Agent: XanaNews/1.15.8.2
X-Face: ,QMv7[luB)BpWAQ~:"kw6n%0ieY63.:g2K3n~8ky0;||5Xle*Xq+=~<Fy:0CVC2nx@8~vZ
MIME-Version: 1.0
Content-Type: text/plain; charset=iso-8859-1
NNTP-Posting-Host: 195.2.185.25
Message-ID: <3fcc54c8@solutions.advantagedatabase.com>
Date: 2 Dec 2003 02:00:56 -0700
X-Trace: 2 Dec 2003 02:00:56 -0700, 195.2.185.25
Lines: 15
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!195.2.185.25
Xref: solutions.advantagedatabase.com Advantage.Networking:443 Advantage.NT:1302
Article PK: 1130139


Philippos Pitsavas wrote in <3fcb7a00@solutions.advantagedatabase.com> :

> The only thing that the AEP is trying
> to do, is read a value from the server's registry so I assume that it
> doesn't have the right privileges.

Sorry for the stupid question. But why is the AEP trying to read the
registry? It looks like a design error.

--
Joachim Duerr
EMEA Lead ADS Support, Extended Systems GmbH, Germany
advantage[AT]extendsys.de
- posted with Xananews 1.15.8.2 -
!!! ADS 7 now available !!!


Wendi Fisher Posted on 2003-12-02 15:08:57.0Z
Date: Tue, 02 Dec 2003 10:08:57 -0500
From: Wendi Fisher <wfisher@adclegal.com>
Reply-To: wfisher@adclegal.com
Organization: ADC Legal Systems
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: advantage.networking,advantage.nt
Subject: Re: Aep runs on the server but not remotely
References: <3fc8e708@solutions.advantagedatabase.com> <3fcb7549@solutions.advantagedatabase.com> <3fcb7a00@solutions.advantagedatabase.com> <3fcc54c8@solutions.advantagedatabase.com>
In-Reply-To: <3fcc54c8@solutions.advantagedatabase.com>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: 63.163.110.38
Message-ID: <3fccabfb@solutions.advantagedatabase.com>
X-Trace: 2 Dec 2003 08:12:59 -0700, 63.163.110.38
Lines: 15
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!63.163.110.38
Xref: solutions.advantagedatabase.com Advantage.Networking:444 Advantage.NT:1303
Article PK: 1130145


Joachim Duerr (ADS Support) wrote:

> Philippos Pitsavas wrote in <3fcb7a00@solutions.advantagedatabase.com> :
>
>
>>The only thing that the AEP is trying
>>to do, is read a value from the server's registry so I assume that it
>>doesn't have the right privileges.
>
>
> Sorry for the stupid question. But why is the AEP trying to read the
> registry? It looks like a design error.
>

I wondered about that one too...