Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Synchronizing ASA 6.x (Consolidated) with ASA 9.x (Extract)

8 posts in General Discussion Last posting was on 2004-01-08 16:20:24.0Z
RP Posted on 2004-01-07 16:10:34.0Z
Sender: 4ae0.3ffc2f12.1804289383@sybase.com
From: RP
Newsgroups: ianywhere.public.general
Subject: Synchronizing ASA 6.x (Consolidated) with ASA 9.x (Extract)
X-Mailer: WebNews to Mail Gateway v1.1s
Message-ID: <3ffc2f7a.4ae4.846930886@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 7 Jan 2004 08:10:34 -0800
X-Trace: forums-1-dub 1073491834 10.22.241.41 (7 Jan 2004 08:10:34 -0800)
X-Original-Trace: 7 Jan 2004 08:10:34 -0800, 10.22.241.41
Lines: 2
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2252
Article PK: 4457

Any comments on setting up ASA 9.x to Synchronize with ASA
6.x Consolidated Server?


Greg Fenton Posted on 2004-01-07 16:47:38.0Z
From: Greg Fenton <greg.fenton_NOSPAM_@ianywhere.com>
Organization: iAnywhere Solutions Inc.
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
Subject: Re: Synchronizing ASA 6.x (Consolidated) with ASA 9.x (Extract)
References: <3ffc2f7a.4ae4.846930886@sybase.com>
In-Reply-To: <3ffc2f7a.4ae4.846930886@sybase.com>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: gfenton-xp.sybase.com
Message-ID: <3ffc3a3c$1@forums-2-dub>
X-Original-Trace: 7 Jan 2004 08:56:28 -0800, gfenton-xp.sybase.com
Lines: 56
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 7 Jan 2004 08:33:07 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 7 Jan 2004 08:47:38 -0800
X-Trace: forums-1-dub 1073494058 10.22.108.75 (7 Jan 2004 08:47:38 -0800)
X-Original-Trace: 7 Jan 2004 08:47:38 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2253
Article PK: 4458


RP wrote:
> Any comments on setting up ASA 9.x to Synchronize with ASA
> 6.x Consolidated Server?

Since you are talking about "synchronization", I assume you are using
MobiLink (instead of SQLRemote which is "replication").

A client (dbmlsync) can only synchronize to a server (dbmlsrv) that is
the same version or *newer* than the client itself.

So this means that your ML server needs to be at least as new as your
remote. Now, a 9.0 ML server can (in theory) synchronize using an ASA
6.0 consolidated. I have never heard of anyone trying to do this. My
biggest concern is that you would be running the 9.0 ML server using the
6.0 ODBC drivers to connect to your engine....there are a number of
years that have occured since 6.0 drivers were developed...

If you are going to try it, you will need to upgrade your consolidated's
ML tables by running %ASANY9%\scripts\syncasa.sql against your
consolidated (yes, run the 9.0 syncasa.sql against your 6.0 database).
Both your 6.0 and 9.0 remotes should be able to synchronize now.

In case it is not obvious at this point, you will want to TEST, TEST,
TEST this if you are going to put this into a production environment.
When you go to upgrade the production database, ensure you first have a
valid backup (as is always the case when making modifications to a
production database).

If I were in your shoes, I'd consider upgrading my consolidated to 9.0
as well, just to ensure compatibility with the ML server. The 6.0
remotes will still be able to synchronize to the 9.0 server.

The only thing that *might* stop you from upgrading the consolidated is
if you have applications running against it. It is quite likely that
any apps written to run against a 6.0 consolidated would need at least
some modifications to run properly against a 9.0 database, and it is
possible that some stored procedures and/or triggers in your 6.0
database would need updating as well.

BTW: you might consider posting to the newsgroup dedicated to MobiLink:

sybase.public.sqlanywhere.mobilink

Some in the ML community don't read this newsgroup and it might be
helpful to get others' inputs as well.

Hope this helps,
greg.fenton
--
Greg Fenton
Consultant, Solution Services, iAnywhere Solutions
--------
Visit the iAnywhere Solutions Developer Community
Whitepapers, TechDocs, Downloads
http://www.ianywhere.com/developer/


David Fishburn Posted on 2004-01-07 17:54:55.0Z
Newsgroups: ianywhere.public.general
Subject: Re: Synchronizing ASA 6.x (Consolidated) with ASA 9.x (Extract)
From: David Fishburn <fishburn_spam_off@ianywhere.com>
References: <3ffc2f7a.4ae4.846930886@sybase.com>
Organization: iAnywhere Solutions
Message-ID: <Xns946980EE0C27fishburnsybasecom@10.22.241.106>
User-Agent: Xnews/06.08.25
NNTP-Posting-Host: vpn-concord-080.sybase.com
X-Original-NNTP-Posting-Host: vpn-concord-080.sybase.com
Date: 7 Jan 2004 09:54:55 -0800
X-Trace: forums-1-dub 1073498095 158.159.8.80 (7 Jan 2004 09:54:55 -0800)
X-Original-Trace: 7 Jan 2004 09:54:55 -0800, vpn-concord-080.sybase.com
Lines: 50
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2254
Article PK: 4460

RP wrote in news:3ffc2f7a.4ae4.846930886@sybase.com:

R> Any comments on setting up ASA 9.x to Synchronize with ASA
R> 6.x Consolidated Server?

No, you cannot use a newer MobiLink server against an older ASA
database.

You must upgrade the ASA consolidated database.

Besides improvements in features (ie MobiLink) the database server has
also undergone some serious performance improvements.

The best approach to upgrading is rebuilding your database.
Make a backup of your database first.
Then you can run:
dbunload -c ... -ar

That will replace the existing database with the new one.

or
dbunload -c ... unload_dir
dbinit <insert your options here> dave.db
dbisql -c uid=dba;pwd=sql;dbf=dave.db read reload.sql


What are your reasons for not wanting to take advantage of the new 9.x
database features?

--
David Fishburn
NEW - Certified ASA Developer Version 8
iAnywhere Solutions - Sybase
Professional Services
Please only post to the newsgroup
Please ALWAYS include version and MORE importantly BUILD number with
EACH post (dbeng9 -v).

EBFs and Maintenance Releases
http://downloads.sybase.com/swx/sdmain.stm

Developer Community / Whitepapers
http://www.ianywhere.com/developer

CaseXpress - to report bugs
http://casexpress.sybase.com

CodeXchange - Free samples
http://ianywhere.codexchange.sybase.com/servlets/ProjectDocumentList


Ravindra Passan Posted on 2004-01-07 18:32:44.0Z
From: "Ravindra Passan" <rpassan@hotmail.com>
Newsgroups: ianywhere.public.general
References: <3ffc2f7a.4ae4.846930886@sybase.com> <Xns946980EE0C27fishburnsybasecom@10.22.241.106>
Subject: Re: Synchronizing ASA 6.x (Consolidated) with ASA 9.x (Extract)
Lines: 59
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: 151.121.153.20
Message-ID: <3ffc52de$1@forums-2-dub>
X-Original-Trace: 7 Jan 2004 10:41:34 -0800, 151.121.153.20
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 7 Jan 2004 10:18:12 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 7 Jan 2004 10:32:44 -0800
X-Trace: forums-1-dub 1073500364 10.22.108.75 (7 Jan 2004 10:32:44 -0800)
X-Original-Trace: 7 Jan 2004 10:32:44 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2255
Article PK: 4463

Well, I am using SQL Remote, not the Mobilink. So basically I am
replicating, is it possible to do this?

thanks

"David Fishburn" <fishburn_spam_off@ianywhere.com> wrote in message
news:Xns946980EE0C27fishburnsybasecom@10.22.241.106...
> RP wrote in news:3ffc2f7a.4ae4.846930886@sybase.com:
>
> R> Any comments on setting up ASA 9.x to Synchronize with ASA
> R> 6.x Consolidated Server?
>
> No, you cannot use a newer MobiLink server against an older ASA
> database.
>
> You must upgrade the ASA consolidated database.
>
> Besides improvements in features (ie MobiLink) the database server has
> also undergone some serious performance improvements.
>
> The best approach to upgrading is rebuilding your database.
> Make a backup of your database first.
> Then you can run:
> dbunload -c ... -ar
>
> That will replace the existing database with the new one.
>
> or
> dbunload -c ... unload_dir
> dbinit <insert your options here> dave.db
> dbisql -c uid=dba;pwd=sql;dbf=dave.db read reload.sql
>
>
> What are your reasons for not wanting to take advantage of the new 9.x
> database features?
>
> --
> David Fishburn
> NEW - Certified ASA Developer Version 8
> iAnywhere Solutions - Sybase
> Professional Services
> Please only post to the newsgroup
> Please ALWAYS include version and MORE importantly BUILD number with
> EACH post (dbeng9 -v).
>
> EBFs and Maintenance Releases
> http://downloads.sybase.com/swx/sdmain.stm
>
> Developer Community / Whitepapers
> http://www.ianywhere.com/developer
>
> CaseXpress - to report bugs
> http://casexpress.sybase.com
>
> CodeXchange - Free samples
> http://ianywhere.codexchange.sybase.com/servlets/ProjectDocumentList
>


David Fishburn Posted on 2004-01-07 18:58:12.0Z
Newsgroups: ianywhere.public.general
Subject: Re: Synchronizing ASA 6.x (Consolidated) with ASA 9.x (Extract)
From: David Fishburn <fishburn_spam_off@ianywhere.com>
References: <3ffc2f7a.4ae4.846930886@sybase.com> <Xns946980EE0C27fishburnsybasecom@10.22.241.106> <3ffc52de$1@forums-2-dub>
Organization: iAnywhere Solutions
Message-ID: <Xns94698BA8C652Afishburnsybasecom@10.22.241.106>
User-Agent: Xnews/06.08.25
NNTP-Posting-Host: vpn-concord-080.sybase.com
X-Original-NNTP-Posting-Host: vpn-concord-080.sybase.com
Date: 7 Jan 2004 10:58:12 -0800
X-Trace: forums-1-dub 1073501892 158.159.8.80 (7 Jan 2004 10:58:12 -0800)
X-Original-Trace: 7 Jan 2004 10:58:12 -0800, vpn-concord-080.sybase.com
Lines: 13
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2257
Article PK: 4461

"Ravindra Passan" <rpassan@hotmail.com> wrote in news:3ffc52de$1@forums-2-
dub:

RP> Well, I am using SQL Remote, not the Mobilink. So basically I am
RP> replicating, is it possible to do this?

This may work but it has certainly never been tested, are you sure you
would want to go into production like that? 6.x is very old now.

Why would you not upgrade?

--
David Fishburn


Ravindra Passan Posted on 2004-01-07 19:02:07.0Z
From: "Ravindra Passan" <rpassan@hotmail.com>
Newsgroups: ianywhere.public.general
References: <3ffc2f7a.4ae4.846930886@sybase.com> <Xns946980EE0C27fishburnsybasecom@10.22.241.106> <3ffc52de$1@forums-2-dub> <Xns94698BA8C652Afishburnsybasecom@10.22.241.106>
Subject: Re: Synchronizing ASA 6.x (Consolidated) with ASA 9.x (Extract)
Lines: 26
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
NNTP-Posting-Host: surfec007.sybase.com
X-Original-NNTP-Posting-Host: surfec007.sybase.com
Message-ID: <3ffc57af$1@forums-1-dub>
Date: 7 Jan 2004 11:02:07 -0800
X-Trace: forums-1-dub 1073502127 199.93.176.7 (7 Jan 2004 11:02:07 -0800)
X-Original-Trace: 7 Jan 2004 11:02:07 -0800, surfec007.sybase.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2258
Article PK: 4464

Yes, I know this is outdated and we are in the process of migration. This is
a phased approach where we move some clients to new version and then bunch
by bunch we move others. We have thousands of users that depend on this and
we cannot extract or take a single hit.

Any comments on this are welcomed.

Thanks

"David Fishburn" <fishburn_spam_off@ianywhere.com> wrote in message
news:Xns94698BA8C652Afishburnsybasecom@10.22.241.106...
> "Ravindra Passan" <rpassan@hotmail.com> wrote in news:3ffc52de$1@forums-2-
> dub:
>
> RP> Well, I am using SQL Remote, not the Mobilink. So basically I am
> RP> replicating, is it possible to do this?
>
> This may work but it has certainly never been tested, are you sure you
> would want to go into production like that? 6.x is very old now.
>
> Why would you not upgrade?
>
> --
> David Fishburn


David Fishburn Posted on 2004-01-08 16:20:24.0Z
Newsgroups: ianywhere.public.general
Subject: Re: Synchronizing ASA 6.x (Consolidated) with ASA 9.x (Extract)
From: David Fishburn <fishburn_spam_off@ianywhere.com>
References: <3ffc2f7a.4ae4.846930886@sybase.com> <Xns946980EE0C27fishburnsybasecom@10.22.241.106> <3ffc52de$1@forums-2-dub> <Xns94698BA8C652Afishburnsybasecom@10.22.241.106> <3ffc57af$1@forums-1-dub>
Organization: iAnywhere Solutions
Message-ID: <Xns946A70E2D4512fishburnsybasecom@10.22.241.106>
User-Agent: Xnews/06.08.25
NNTP-Posting-Host: fishburn-t30.sybase.com
X-Original-NNTP-Posting-Host: fishburn-t30.sybase.com
Date: 8 Jan 2004 08:20:24 -0800
X-Trace: forums-1-dub 1073578824 172.31.141.114 (8 Jan 2004 08:20:24 -0800)
X-Original-Trace: 8 Jan 2004 08:20:24 -0800, fishburn-t30.sybase.com
Lines: 50
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2264
Article PK: 4469

"Ravindra Passan" <rpassan@hotmail.com> wrote in
news:3ffc57af$1@forums-1-dub:

RP> Yes, I know this is outdated and we are in the process of migration.
RP> This is a phased approach where we move some clients to new version
RP> and then bunch by bunch we move others. We have thousands of users
RP> that depend on this and we cannot extract or take a single hit.

Well, I always like to look at worst case scenarios.

Lets say you have (over the period of 3 months) just finished upgrading
all 1000 remotes to 9.x.

Now you upgrade the consolidated. The consolidated is "the world" to
the remotes. If something is wrong with the consolidated, then
replication will not happen.

So looking at a "worst" case scenario, if something goes horribly wrong,
this means you would have to re-extract all 1,000 remotes again.

My personal preference is to always start with the consolidated
database. This is true with either SQL Remote or MobiLink.

If you do run into the "worst" case scenario (which should not happen
with appropriate testing and backups), then your time table for
upgrading the remotes has been increased (substantially). But by doing
the server first, you will only re-extract the remotes "once".


--
David Fishburn
NEW - Certified ASA Developer Version 8
iAnywhere Solutions - Sybase
Professional Services
Please only post to the newsgroup
Please ALWAYS include version and MORE importantly BUILD number with
EACH post (dbeng9 -v).

EBFs and Maintenance Releases
http://downloads.sybase.com/swx/sdmain.stm

Developer Community / Whitepapers
http://www.ianywhere.com/developer

CaseXpress - to report bugs
http://casexpress.sybase.com

CodeXchange - Free samples
http://ianywhere.codexchange.sybase.com/servlets/ProjectDocumentList


Breck Carter [TeamSybase] Posted on 2004-01-07 19:22:23.0Z
From: "Breck Carter [TeamSybase]" <NOSPAM__bcarter@risingroad.com>
Newsgroups: ianywhere.public.general
Subject: Re: Synchronizing ASA 6.x (Consolidated) with ASA 9.x (Extract)
Organization: RisingRoad Professional Services
Reply-To: NOSPAM__bcarter@risingroad.com
Message-ID: <j1movvkkejbkqsp95mpntr2rk6c72mdm5a@4ax.com>
References: <3ffc2f7a.4ae4.846930886@sybase.com> <Xns946980EE0C27fishburnsybasecom@10.22.241.106>
X-Newsreader: Forte Agent 1.8/32.548
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: bcarter.sentex.ca
X-Original-NNTP-Posting-Host: bcarter.sentex.ca
Date: 7 Jan 2004 11:22:23 -0800
X-Trace: forums-1-dub 1073503343 64.7.134.118 (7 Jan 2004 11:22:23 -0800)
X-Original-Trace: 7 Jan 2004 11:22:23 -0800, bcarter.sentex.ca
Lines: 14
X-Authenticated-User: TeamPS
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2259
Article PK: 4466

On 7 Jan 2004 09:54:55 -0800, David Fishburn

<fishburn_spam_off@ianywhere.com> wrote:
>No, you cannot use a newer MobiLink server against an older ASA
>database.

Why not, as long as the ml_* tables are upgraded to match? After all,
I an use a newer MobiLink server against an older *Oracle* database.

Breck

--
bcarter@risingroad.com
Mobile and Distributed Enterprise Database Applications
www.risingroad.com