Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Cannot locate or backup database under Novell

5 posts in General Discussion Last posting was on 2004-01-23 15:16:39.0Z
M.P.J. van Drunen Posted on 2004-01-20 15:01:28.0Z
From: "M.P.J. van Drunen" <mvdrunen@bcsbv.nl>
Newsgroups: ianywhere.public.general
Subject: Cannot locate or backup database under Novell
Lines: 33
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: wc-163.r-195-35-162.essentkabel.com
Message-ID: <400d4509$1@forums-2-dub>
X-Original-Trace: 20 Jan 2004 07:11:05 -0800, wc-163.r-195-35-162.essentkabel.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 20 Jan 2004 06:45:41 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 20 Jan 2004 07:01:28 -0800
X-Trace: forums-1-dub 1074610888 10.22.108.75 (20 Jan 2004 07:01:28 -0800)
X-Original-Trace: 20 Jan 2004 07:01:28 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2351
Article PK: 4557

Case
We have our own application running on workstations using the DBSrv8 (Nlm in
this case). When trying to backup we got an error (-697). Due to the file
locking ArcServer 7 also wont backup the files without stopping the
database. After that we tried to do a backup using DBBackup.exe with the
paramaters for life backup. but that also failed (Database not found when
using IP and Host , and Invalid database when using dbf=""). The tools
dblocate and dbping even won't locate our server.

Work situation
Novell 4
Nal / ZenWorks installed (Nal using ASA 7.0.0.4)
ArcServer 7 Netware running
ASA 8.02 started with NLM parameters Host and Port. (load dbsrv8.nlm -gk
all -c 8M -x TCPIP(Host= ; Port= ;) -n prs vol1:... ). Also tried BCast
related parameters.
Own ApplicationrRunning on different Clients (Win98, Win2000) build in
delphi using Native DB components.

Symptoms
Backup using SQL (started from application on workstation does not work) .
Error during backup No Such File or Directory. Error -697
DBLocate cannot locate our server (only the other one, no server name only
IP adress TWICE)
DBPing does not locate server, tryied parameters host,ip , engine name. etc
DBBackup using DBF="". Specified database is invalid.
DBBackup using direct connect (Using IP and Port Number) does not locate
server.

What could i try
mdrunen@bcsbv.nl


Graeme Perrow Posted on 2004-01-20 15:25:40.0Z
From: Graeme Perrow <gperrowNO@SPAMianywhere.com>
Reply-To: gperrowNO@SPAMianywhere.com
Organization: iAnywhere Solutions, Inc.
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031013 Thunderbird/0.3
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
Subject: Re: Cannot locate or backup database under Novell
References: <400d4509$1@forums-2-dub>
In-Reply-To: <400d4509$1@forums-2-dub>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: gperrow-pc.sybase.com
Message-ID: <400d4ab4$1@forums-2-dub>
X-Original-Trace: 20 Jan 2004 07:35:16 -0800, gperrow-pc.sybase.com
Lines: 61
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 20 Jan 2004 07:09:52 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 20 Jan 2004 07:25:40 -0800
X-Trace: forums-1-dub 1074612340 10.22.108.75 (20 Jan 2004 07:25:40 -0800)
X-Original-Trace: 20 Jan 2004 07:25:40 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2352
Article PK: 4560

The host= parameter is not useful on the server - it is a client-side
parameter. What are you trying to set with that parameter?

The problem is that NetWare won't allow two different applications to
listen on the same UDP port. This means that the second server that
starts cannot listen on the default port (2638), so it doesn't receive
broadcast messages from dblocate or any of the other tools. The solution
is to add the port number to the connection string on the clients, i.e.
if the server is using "-x tcpip(port=5000)", then you need to add
"LINKS=tcpip(port=5000)" to the clients' connection strings.

Note that dblocate will still not be able to find the server, but dbping
and dbbackup should.

M.P.J. van Drunen wrote:
> Case
> We have our own application running on workstations using the DBSrv8 (Nlm in
> this case). When trying to backup we got an error (-697). Due to the file
> locking ArcServer 7 also wont backup the files without stopping the
> database. After that we tried to do a backup using DBBackup.exe with the
> paramaters for life backup. but that also failed (Database not found when
> using IP and Host , and Invalid database when using dbf=""). The tools
> dblocate and dbping even won't locate our server.
>
> Work situation
> Novell 4
> Nal / ZenWorks installed (Nal using ASA 7.0.0.4)
> ArcServer 7 Netware running
> ASA 8.02 started with NLM parameters Host and Port. (load dbsrv8.nlm -gk
> all -c 8M -x TCPIP(Host= ; Port= ;) -n prs vol1:... ). Also tried BCast
> related parameters.
> Own ApplicationrRunning on different Clients (Win98, Win2000) build in
> delphi using Native DB components.
>
> Symptoms
> Backup using SQL (started from application on workstation does not work) .
> Error during backup No Such File or Directory. Error -697
> DBLocate cannot locate our server (only the other one, no server name only
> IP adress TWICE)
> DBPing does not locate server, tryied parameters host,ip , engine name. etc
> DBBackup using DBF="". Specified database is invalid.
> DBBackup using direct connect (Using IP and Port Number) does not locate
> server.
>
> What could i try
> mdrunen@bcsbv.nl
>
>

--
Graeme Perrow
Senior Software Developer
gperrow@ianywhere.com
iAnywhere Solutions Inc.
A Sybase company

Whitepapers, TechDocs, bug fixes are all available through the iAnywhere
Developer Community at http://www.ianywhere.com/developer/


M.P.J. van Drunen Posted on 2004-01-20 15:32:07.0Z
From: "M.P.J. van Drunen" <mvdrunen@bcsbv.nl>
Newsgroups: ianywhere.public.general
References: <400d4509$1@forums-2-dub> <400d4ab4$1@forums-2-dub>
Subject: Re: Cannot locate or backup database under Novell
Lines: 79
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: wc-163.r-195-35-162.essentkabel.com
Message-ID: <400d4c36@forums-2-dub>
X-Original-Trace: 20 Jan 2004 07:41:42 -0800, wc-163.r-195-35-162.essentkabel.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 20 Jan 2004 07:16:18 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 20 Jan 2004 07:32:07 -0800
X-Trace: forums-1-dub 1074612727 10.22.108.75 (20 Jan 2004 07:32:07 -0800)
X-Original-Trace: 20 Jan 2004 07:32:07 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2353
Article PK: 4556

Actually that is what i did (added MyIP= instead of Host= serverside). But
still dbbackup and dbping arent able to find the server. Used DBBackup and
DBPing with the specified parameters -x TCPIP(host=x.x.x.x; port=x) as well
as -x TCPIP(Host=x.x.x.x:x) neither option works. Strangely the Delphi
dbNative components are able to find the server , but using the SQL backup
procedures dont work either.


"Graeme Perrow" <gperrowNO@SPAMianywhere.com> schreef in bericht
news:400d4ab4$1@forums-2-dub...

>
> The host= parameter is not useful on the server - it is a client-side
> parameter. What are you trying to set with that parameter?
>
> The problem is that NetWare won't allow two different applications to
> listen on the same UDP port. This means that the second server that
> starts cannot listen on the default port (2638), so it doesn't receive
> broadcast messages from dblocate or any of the other tools. The solution
> is to add the port number to the connection string on the clients, i.e.
> if the server is using "-x tcpip(port=5000)", then you need to add
> "LINKS=tcpip(port=5000)" to the clients' connection strings.
>
> Note that dblocate will still not be able to find the server, but dbping
> and dbbackup should.
>
>
> M.P.J. van Drunen wrote:
> > Case
> > We have our own application running on workstations using the DBSrv8
(Nlm in
> > this case). When trying to backup we got an error (-697). Due to the
file
> > locking ArcServer 7 also wont backup the files without stopping the
> > database. After that we tried to do a backup using DBBackup.exe with the
> > paramaters for life backup. but that also failed (Database not found
when
> > using IP and Host , and Invalid database when using dbf=""). The tools
> > dblocate and dbping even won't locate our server.
> >
> > Work situation
> > Novell 4
> > Nal / ZenWorks installed (Nal using ASA 7.0.0.4)
> > ArcServer 7 Netware running
> > ASA 8.02 started with NLM parameters Host and Port. (load dbsrv8.nlm -gk
> > all -c 8M -x TCPIP(Host= ; Port= ;) -n prs vol1:... ). Also tried BCast
> > related parameters.
> > Own ApplicationrRunning on different Clients (Win98, Win2000) build in
> > delphi using Native DB components.
> >
> > Symptoms
> > Backup using SQL (started from application on workstation does not work)
.
> > Error during backup No Such File or Directory. Error -697
> > DBLocate cannot locate our server (only the other one, no server name
only
> > IP adress TWICE)
> > DBPing does not locate server, tryied parameters host,ip , engine name.
etc
> > DBBackup using DBF="". Specified database is invalid.
> > DBBackup using direct connect (Using IP and Port Number) does not locate
> > server.
> >
> > What could i try
> > mdrunen@bcsbv.nl
> >
> >
>
> --
> Graeme Perrow
> Senior Software Developer
> gperrow@ianywhere.com
> iAnywhere Solutions Inc.
> A Sybase company
>
> Whitepapers, TechDocs, bug fixes are all available through the iAnywhere
> Developer Community at http://www.ianywhere.com/developer/
>


Graeme Perrow Posted on 2004-01-20 17:16:49.0Z
From: Graeme Perrow <gperrowNO@SPAMianywhere.com>
Reply-To: gperrowNO@SPAMianywhere.com
Organization: iAnywhere Solutions, Inc.
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031013 Thunderbird/0.3
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
Subject: Re: Cannot locate or backup database under Novell
References: <400d4509$1@forums-2-dub> <400d4ab4$1@forums-2-dub> <400d4c36@forums-2-dub>
In-Reply-To: <400d4c36@forums-2-dub>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: gperrow-pc.sybase.com
Message-ID: <400d64c0$1@forums-2-dub>
X-Original-Trace: 20 Jan 2004 09:26:24 -0800, gperrow-pc.sybase.com
Lines: 22
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 20 Jan 2004 09:01:00 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 20 Jan 2004 09:16:49 -0800
X-Trace: forums-1-dub 1074619009 10.22.108.75 (20 Jan 2004 09:16:49 -0800)
X-Original-Trace: 20 Jan 2004 09:16:49 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2356
Article PK: 4559

Can you add "-z -o sys:asa.out" to your server start line and then post
the contents of asa.out?

M.P.J. van Drunen wrote:
> Actually that is what i did (added MyIP= instead of Host= serverside). But
> still dbbackup and dbping arent able to find the server. Used DBBackup and
> DBPing with the specified parameters -x TCPIP(host=x.x.x.x; port=x) as well
> as -x TCPIP(Host=x.x.x.x:x) neither option works. Strangely the Delphi
> dbNative components are able to find the server , but using the SQL backup
> procedures dont work either.

--
Graeme Perrow
Senior Software Developer
gperrow@ianywhere.com
iAnywhere Solutions Inc.
A Sybase company

Whitepapers, TechDocs, bug fixes are all available through the iAnywhere
Developer Community at http://www.ianywhere.com/developer/


M.P.J. van Drunen Posted on 2004-01-23 15:16:39.0Z
From: "M.P.J. van Drunen" <mvdrunen@bcsbv.nl>
Newsgroups: ianywhere.public.general
References: <400d4509$1@forums-2-dub> <400d4ab4$1@forums-2-dub> <400d4c36@forums-2-dub> <400d64c0$1@forums-2-dub>
Subject: Re: Cannot locate or backup database under Novell
Lines: 34
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
NNTP-Posting-Host: wc-163.r-195-35-162.essentkabel.com
X-Original-NNTP-Posting-Host: wc-163.r-195-35-162.essentkabel.com
Message-ID: <40113ad7@forums-1-dub>
Date: 23 Jan 2004 07:16:39 -0800
X-Trace: forums-1-dub 1074870999 195.35.162.163 (23 Jan 2004 07:16:39 -0800)
X-Original-Trace: 23 Jan 2004 07:16:39 -0800, wc-163.r-195-35-162.essentkabel.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2377
Article PK: 4582

Found the problem, could find the database using both Eng= and the host and
port.


"Graeme Perrow" <gperrowNO@SPAMianywhere.com> schreef in bericht
news:400d64c0$1@forums-2-dub...

>
> Can you add "-z -o sys:asa.out" to your server start line and then post
> the contents of asa.out?
>
> M.P.J. van Drunen wrote:
> > Actually that is what i did (added MyIP= instead of Host= serverside).
But
> > still dbbackup and dbping arent able to find the server. Used DBBackup
and
> > DBPing with the specified parameters -x TCPIP(host=x.x.x.x; port=x) as
well
> > as -x TCPIP(Host=x.x.x.x:x) neither option works. Strangely the Delphi
> > dbNative components are able to find the server , but using the SQL
backup
> > procedures dont work either.
>
> --
> Graeme Perrow
> Senior Software Developer
> gperrow@ianywhere.com
> iAnywhere Solutions Inc.
> A Sybase company
>
> Whitepapers, TechDocs, bug fixes are all available through the iAnywhere
> Developer Community at http://www.ianywhere.com/developer/
>