Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Create grouped table in PB query doesn't working like in other SQL Viewers

2 posts in Appeon (partner product) Last posting was on 2004-02-04 04:52:39.0Z
OferM Posted on 2004-01-22 08:33:07.0Z
Sender: 5d8f.400f847b.1804289383@sybase.com
From: OferM
Newsgroups: sybase.public.appeon
Subject: Create grouped table in PB query doesn't working like in other SQL Viewers
X-Mailer: WebNews to Mail Gateway v1.1s
Message-ID: <400f8d0a.5e5a.846930886@sybase.com>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 22 Jan 2004 00:42:50 -0800, 10.22.241.42
Lines: 27
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 22 Jan 2004 00:17:10 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 22 Jan 2004 00:33:07 -0800
X-Trace: forums-1-dub 1074760387 10.22.108.75 (22 Jan 2004 00:33:07 -0800)
X-Original-Trace: 22 Jan 2004 00:33:07 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:46
Article PK: 12354

I am trying to create temp table in DB Administration in
Powerbuilder 6.5 as follow:

// drop old temp table
drop table #desk_tmp;
// create new temp table with data from "entries" table
select Entries.client_id,
orders = count(1)
into #desk_tmp
from Entries
group by Entries.client_id ;
// then run
select client_id, orders FROM #desk_tmp ;
// the resultes:
It returns the temp table created but:
1. Gives error message "no CS_Command pointer passed to
function: DESCRIBE"
2. The client id field is filled but the orders field is all
set to 0
3. It doesn't create the entries grouped.

The query is fine because when I run it in SQL ADVENTAGE
viewer I receive the correct resultes: all rows are grouped
the oreders field is correct and no error message.
(This also happens if the table is not temp...)
What does PB needs to get in order to create the table
properly?


Armeen Mazda Posted on 2004-02-04 04:52:39.0Z
From: "Armeen Mazda" <armeen.mazda@appeon.net>
Newsgroups: sybase.public.appeon
References: <400f8d0a.5e5a.846930886@sybase.com>
Subject: Re: Create grouped table in PB query doesn't working like in other SQL Viewers
Lines: 41
Organization: Appeon Corporation
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
NNTP-Posting-Host: 61.144.207.53
X-Original-NNTP-Posting-Host: 61.144.207.53
Message-ID: <40207a97@forums-1-dub>
Date: 3 Feb 2004 20:52:39 -0800
X-Trace: forums-1-dub 1075870359 61.144.207.53 (3 Feb 2004 20:52:39 -0800)
X-Original-Trace: 3 Feb 2004 20:52:39 -0800, 61.144.207.53
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:67
Article PK: 12365

The Appeon newsgroup is monitored by Sybase and Appeon engineering staff who
are very knowledgeable about Appeon issues. However, your question is
purely PowerBuilder-related and is therefore best answered by the staff and
users of the PowerBuilder newsgroup: sybase.public.powerbuilder.general. I
am sure if you re-post your question to that newsgroup you will receive the
help you need.

Regards,
Armeen Mazda
Appeon Corporation

<OferM> wrote in message news:400f8d0a.5e5a.846930886@sybase.com...
> I am trying to create temp table in DB Administration in
> Powerbuilder 6.5 as follow:
>
> // drop old temp table
> drop table #desk_tmp;
> // create new temp table with data from "entries" table
> select Entries.client_id,
> orders = count(1)
> into #desk_tmp
> from Entries
> group by Entries.client_id ;
> // then run
> select client_id, orders FROM #desk_tmp ;
> // the resultes:
> It returns the temp table created but:
> 1. Gives error message "no CS_Command pointer passed to
> function: DESCRIBE"
> 2. The client id field is filled but the orders field is all
> set to 0
> 3. It doesn't create the entries grouped.
>
> The query is fine because when I run it in SQL ADVENTAGE
> viewer I receive the correct resultes: all rows are grouped
> the oreders field is correct and no error message.
> (This also happens if the table is not temp...)
> What does PB needs to get in order to create the table
> properly?