Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

repagent.cfg not found problem

2 posts in Replication Agent Last posting was on 2004-02-02 18:08:06.0Z
chiur Posted on 2004-02-02 10:32:14.0Z
From: "chiur" <chiur@sybase.com>
Newsgroups: sybase.public.rep-agent
Subject: repagent.cfg not found problem
Lines: 97
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 5.50.4922.1500
X-MimeOLE: Produced By Microsoft MimeOLE V5.50.4925.2800
X-Original-NNTP-Posting-Host: chiur-pc.sybase.com
Message-ID: <401e299c@forums-2-dub>
X-Original-Trace: 2 Feb 2004 02:42:36 -0800, chiur-pc.sybase.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 2 Feb 2004 02:15:11 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 2 Feb 2004 02:32:14 -0800
X-Trace: forums-1-dub 1075717934 10.22.108.75 (2 Feb 2004 02:32:14 -0800)
X-Original-Trace: 2 Feb 2004 02:32:14 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.rep-agent:646
Article PK: 862297

Hi All,

I have an urgent issue for RepAgent for MS-SQL. The following information
will include platform and the detail steps to reproduce?this problem.
Any advice will be very thankful !!

Regards,
Robert Chu
Sybase Taiwan CS&S

****************************************************************************
*****************************************
Customer : Chunghwa Teleco International Branch.
Product : RepAgent for MS-SQL 12.5 with ebf 10597
SYBASE_JRE=c:\sybase\shared-1_0\jre1.2.2
JAVA_HOME=C:\j2sdk1.4.1_03

The following error message is from customer replication agent.
E. 2003/10/08 10:14:09.57. com.sybase.ra.beanmgr.PropertyBroker?Parameter
file <C:\sybase\rax-12_5\repagent\repagent.cfg> not found
F. 2003/10/08 10:14:09.57. com.sybase.ra.RepAgent?Error while trying to
register RepAgent with the bean manager.
I. 2003/10/08 10:14:09.57. com.sybase.ra.RepAgent?RepAgent requesting Java
Virtual Machine exit with message: Error while trying to register RepAgent
with the bean manager.

Here is what I do on the customer site.

Step 1. I use the repagent administrator.bat to create the MS-SQL repagent.

Step 2. I use the following command to startup repagent.

??????ra -i repagent

??????The agent could be started without any error.

Step 3. I use isql to logon "repagent" and execute "shutdown" to stop
"repagent" process. The agent could be stopped without any error

Here is the problem. When I repeat the "Step 3" to restart my "repagent". I
will get the error message on the "DOS Console".

RepAgent requesting Java Virtual Machine exit with message: Error while
trying to register RepAgent with the bean manager.

I use the same file to test it on my machine without any error. My
environment variable is the same as customer's environment. I use the same
version's Java SDK on my machine.

hitleft.gif
hitright.gif

Wanda Beck Posted on 2004-02-02 18:08:06.0Z
From: "Wanda Beck" <wbeck@sybase.com>
Newsgroups: sybase.public.rep-agent
References: <401e299c@forums-2-dub>
Subject: Re: repagent.cfg not found problem
Lines: 92
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: wbeckw2k.sybase.com
Message-ID: <401e9476$1@forums-2-dub>
X-Original-Trace: 2 Feb 2004 10:18:30 -0800, wbeckw2k.sybase.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 2 Feb 2004 09:51:02 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 2 Feb 2004 10:08:06 -0800
X-Trace: forums-1-dub 1075745286 10.22.108.75 (2 Feb 2004 10:08:06 -0800)
X-Original-Trace: 2 Feb 2004 10:08:06 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.rep-agent:647
Article PK: 862300

Hi, Robert,

Sounds like the 'repagent' instance config file disappeared. Is this a
brand new instance or has it been around for a while and suddenly the
customer has this problem?

Before the customer does anything, s/he should look in the
%SYBASE%\rax-12_5\repagent directory. Is there a repagent.old in there? If
so, s/he should do the following:

cp %SYBASE%\rax-12_5\repagent\repagent.old
%SYBASE%\rax-12_5\repagent\repagent.cfg

Then, s/he can start the RepAgent again ( ra -i repagent ), and whatever
configuration the customer had should still be there.

If not, the easiest way to get back to working is to do the following:

1. Copy the base mssql config file to the instance directory:

cp %SYBASE%\rax-12_5\config\ram.cfg
%SYBASE%\rax-12_5\repagent\repagent.cfg

2. Start the RepAgent again, then login to the RepAgent and
re-configure all the parameters. If the customer had
previously already created an XLog at the primary database, then s/he
must be sure to keep the pdb_xlog_prefix
and the pds_username the same as they were before.

If the customer continues to have problems, please let me know.

Thanks,
Wanda Beck

"chiur" <chiur@sybase.com> wrote in message news:401e299c@forums-2-dub...
> Hi All,
>
> I have an urgent issue for RepAgent for MS-SQL. The following information
> will include platform and the detail steps to reproduce?this problem.
> Any advice will be very thankful !!
>
> Regards,
> Robert Chu
> Sybase Taiwan CS&S
>
>
****************************************************************************
> *****************************************
> Customer : Chunghwa Teleco International Branch.
> Product : RepAgent for MS-SQL 12.5 with ebf 10597
> SYBASE_JRE=c:\sybase\shared-1_0\jre1.2.2
> JAVA_HOME=C:\j2sdk1.4.1_03
>
> The following error message is from customer replication agent.
> E. 2003/10/08 10:14:09.57. com.sybase.ra.beanmgr.PropertyBroker?Parameter
> file <C:\sybase\rax-12_5\repagent\repagent.cfg> not found
> F. 2003/10/08 10:14:09.57. com.sybase.ra.RepAgent?Error while trying to
> register RepAgent with the bean manager.
> I. 2003/10/08 10:14:09.57. com.sybase.ra.RepAgent?RepAgent requesting Java
> Virtual Machine exit with message: Error while trying to register RepAgent
> with the bean manager.
>
> Here is what I do on the customer site.
>
> Step 1. I use the repagent administrator.bat to create the MS-SQL
repagent.
>
> Step 2. I use the following command to startup repagent.
>
> ??????ra -i repagent
>
> ??????The agent could be started without any error.
>
> Step 3. I use isql to logon "repagent" and execute "shutdown" to stop
> "repagent" process. The agent could be stopped without any error
>
> Here is the problem. When I repeat the "Step 3" to restart my "repagent".
I
> will get the error message on the "DOS Console".
>
> RepAgent requesting Java Virtual Machine exit with message: Error while
> trying to register RepAgent with the bean manager.
>
> I use the same file to test it on my machine without any error. My
> environment variable is the same as customer's environment. I use the same
> version's Java SDK on my machine.
>
>
>
>