Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

OLE Run Time error

2 posts in ,  Objects General Discussion Last posting was on 2004-02-25 15:14:57.0Z
Jordan Polson Posted on 2004-02-16 17:58:59.0Z
From: "Jordan Polson" <jordan.polson@datarich.net>
Newsgroups: sybase.public.powerbuilder.general,sybase.public.powerbuilder.objects
Subject: OLE Run Time error
Lines: 33
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: h68-150-221-47.ed.shawcable.net
Message-ID: <40310785@forums-2-dub>
X-Original-Trace: 16 Feb 2004 10:10:13 -0800, h68-150-221-47.ed.shawcable.net
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 16 Feb 2004 09:40:32 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 16 Feb 2004 09:58:59 -0800
X-Trace: forums-1-dub 1076954339 10.22.108.75 (16 Feb 2004 09:58:59 -0800)
X-Original-Trace: 16 Feb 2004 09:58:59 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.general:159707 sybase.public.powerbuilder.objects:7797
Article PK: 611525

Hi all,

Using PB9.0.1, Build 7096, PFC, ASA9

I've got a ole object on my window and I'm loading it with a jpeg image from
a long binary column in ASA9.

However, when I run the application I get a "Bad Runtime Function Reference"
on the assignment of the blob (ole_image.objectdata = ole_blob)

Any ideas? Is this perhaps a bug with 9.0.1?

code:
blob ole_blob

selectblob AircraftImage into :ole_blob
from AircraftModels
where AircraftModelId = :al_AircraftModelId;

if SQLCA.SQLCode <> 0 then
MessageBox("Retrieve Image Blob",SQLCA.SQLErrText,Information!)
return
end if

//assign the blob data to the actual data control
If SQLCA.SQLNrows = 1 Then
ole_image.objectdata = ole_blob // run time error on this line
End If

Thanks for any ideas,
Jordan


Terry Voth Posted on 2004-02-25 15:14:57.0Z
From: Terry Voth <sequel@techno-kitten.com>
Newsgroups: sybase.public.powerbuilder.general
Subject: Re: OLE Run Time error
Message-ID: <lsep30l3uh1vi8k1mmujefdstlajo48hoq@4ax.com>
References: <40310785@forums-2-dub>
X-Newsreader: Forte Agent 2.0/32.640
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: xtreme-16-103.dyn.aci.on.ca
X-Original-Trace: 25 Feb 2004 07:15:12 -0800, xtreme-16-103.dyn.aci.on.ca
Lines: 44
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 25 Feb 2004 07:14:19 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 25 Feb 2004 07:14:57 -0800
X-Trace: forums-1-dub 1077722097 10.22.108.75 (25 Feb 2004 07:14:57 -0800)
X-Original-Trace: 25 Feb 2004 07:14:57 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.general:160252
Article PK: 612044

I don't use OLE controls as much as OLE objects, but I'd try
ole_image.object.objectdata = ole_blob.

Good luck,

Terry [TeamSybase] and Sequel the techno-kitten

On 16 Feb 2004 09:58:59 -0800, "Jordan Polson"

<jordan.polson@datarich.net> wrote:

>Using PB9.0.1, Build 7096, PFC, ASA9
>
>I've got a ole object on my window and I'm loading it with a jpeg image from
>a long binary column in ASA9.
>
>However, when I run the application I get a "Bad Runtime Function Reference"
>on the assignment of the blob (ole_image.objectdata = ole_blob)
>
>Any ideas? Is this perhaps a bug with 9.0.1?
>
>code:
>blob ole_blob
>
>selectblob AircraftImage into :ole_blob
> from AircraftModels
> where AircraftModelId = :al_AircraftModelId;
>
>if SQLCA.SQLCode <> 0 then
> MessageBox("Retrieve Image Blob",SQLCA.SQLErrText,Information!)
> return
>end if
>
>//assign the blob data to the actual data control
>If SQLCA.SQLNrows = 1 Then
> ole_image.objectdata = ole_blob // run time error on this line
>End If

Sequel's Sandbox: http://www.techno-kitten.com
Home of PBL Peeper, a free PowerBuilder Developer's Toolkit.
Version 2.2.06 now available at the Sandbox
See the PB Troubleshooting Guide at the Sandbox
^ ^
o o
=*=