Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

.NET DataProvider causing machine to hang

8 posts in General Discussion Last posting was on 2004-03-24 17:16:57.0Z
Jim Rand Posted on 2004-02-19 16:20:12.0Z
Reply-To: "Jim Rand" <jimrand@ix.netcom.com>
From: "Jim Rand" <jimrand@ix.netcom.com>
Newsgroups: ianywhere.public.general
Subject: .NET DataProvider causing machine to hang
Lines: 55
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
NNTP-Posting-Host: user-uinj01t.dialup.mindspring.com
X-Original-NNTP-Posting-Host: user-uinj01t.dialup.mindspring.com
Message-ID: <4034e23c@forums-1-dub>
Date: 19 Feb 2004 08:20:12 -0800
X-Trace: forums-1-dub 1077207612 165.121.128.61 (19 Feb 2004 08:20:12 -0800)
X-Original-Trace: 19 Feb 2004 08:20:12 -0800, user-uinj01t.dialup.mindspring.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2549
Article PK: 5687

I am attempting to use the .NET data provider in a Visual Studio (2003) web
application.
When a mistake is made, the machine just hangs. All applications approach
response speed of diesel fuel at -40 degrees. You have to shut the power off
to the machine to get control back.

Is it better just to use the OLEDBProvider and pass on the the Sybase native
provider?

Here is code which probably has a mistake in it:

private void Page_Load(object sender, System.EventArgs e)
{
if (!IsPostBack)
{
AsaConnection conn = new AsaConnection();
try
{
string connect = "Data Source=WMAdmin;UID=myid;PWD=password";
conn.ConnectionString = connect;
AsaCommand cmd = new AsaCommand();
cmd.CommandText = @"SELECT S.WebSessionID, S.SessionStart,
S.SessionExpire,
CAST(S.TS AS CHAR) AS ExactTS, S.SessionKey,
S.IPAddress, S.WebUserID
FROM WebSession AS S
WHERE S.WebSessionID = @WebSessionID";
AsaParameter param = new
AsaParameter("@WebSessionID",AsaDbType.Integer);
param.Value = 50001;
cmd.Parameters.Add(param);
cmd.Connection = conn;
conn.Open();
AsaDataReader reader = cmd.ExecuteReader();
if(reader.Read())
{
Response.Write(reader["SessionKey"]);
}
}
catch (Exception ex)
{
Response.Write(ex.Message);
}
finally
{
if ((conn != null) && (conn.State == ConnectionState.Open))
{
conn.Close();
}
}

}
}


Jason Hinsperger Posted on 2004-02-19 16:54:06.0Z
From: "Jason Hinsperger" <NOJason_HinspergerSPAM@hotmail.com>
Newsgroups: ianywhere.public.general
References: <4034e23c@forums-1-dub>
Subject: Re: .NET DataProvider causing machine to hang
Lines: 83
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
NNTP-Posting-Host: hinsperg-pc1.sybase.com
X-Original-NNTP-Posting-Host: hinsperg-pc1.sybase.com
Message-ID: <4034ea2e$1@forums-1-dub>
Date: 19 Feb 2004 08:54:06 -0800
X-Trace: forums-1-dub 1077209646 172.31.143.226 (19 Feb 2004 08:54:06 -0800)
X-Original-Trace: 19 Feb 2004 08:54:06 -0800, hinsperg-pc1.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2551
Article PK: 5688

I would highly recommend choosing the ADO.Net provider over the OLEDB
provider for .Net.

We have noticed similar behaviour here (though somewhat sporadic), and are
trying to determine the cause.
FYI, the source of the slowdown is aspnet_wp.exe. If you kill that process
before running your app. each time you rebuild it, that seems to avoid the
slowdown (it is restarted automatically, I think by IIS).

We will post back here when we get a clear picture of what the problem is.

--
Jason Hinsperger
International and Sustaining Engineering
iAnywhere Solutions

Whitepapers, TechDocs, and bug fixes are all available through the iAnywhere
Developer Community at www.ianywhere.com/developer
--

"Jim Rand" <jimrand@ix.netcom.com> wrote in message
news:4034e23c@forums-1-dub...
> I am attempting to use the .NET data provider in a Visual Studio (2003)
web
> application.
> When a mistake is made, the machine just hangs. All applications approach
> response speed of diesel fuel at -40 degrees. You have to shut the power
off
> to the machine to get control back.
>
> Is it better just to use the OLEDBProvider and pass on the the Sybase
native
> provider?
>
> Here is code which probably has a mistake in it:
>
> private void Page_Load(object sender, System.EventArgs e)
> {
> if (!IsPostBack)
> {
> AsaConnection conn = new AsaConnection();
> try
> {
> string connect = "Data Source=WMAdmin;UID=myid;PWD=password";
> conn.ConnectionString = connect;
> AsaCommand cmd = new AsaCommand();
> cmd.CommandText = @"SELECT S.WebSessionID, S.SessionStart,
> S.SessionExpire,
> CAST(S.TS AS CHAR) AS ExactTS, S.SessionKey,
> S.IPAddress, S.WebUserID
> FROM WebSession AS S
> WHERE S.WebSessionID = @WebSessionID";
> AsaParameter param = new
> AsaParameter("@WebSessionID",AsaDbType.Integer);
> param.Value = 50001;
> cmd.Parameters.Add(param);
> cmd.Connection = conn;
> conn.Open();
> AsaDataReader reader = cmd.ExecuteReader();
> if(reader.Read())
> {
> Response.Write(reader["SessionKey"]);
> }
> }
> catch (Exception ex)
> {
> Response.Write(ex.Message);
> }
> finally
> {
> if ((conn != null) && (conn.State == ConnectionState.Open))
> {
> conn.Close();
> }
> }
>
> }
> }
>
>


Jim Rand Posted on 2004-02-19 17:19:54.0Z
Reply-To: "Jim Rand" <jimrand@ix.netcom.com>
From: "Jim Rand" <jimrand@ix.netcom.com>
Newsgroups: ianywhere.public.general
References: <4034e23c@forums-1-dub> <4034ea2e$1@forums-1-dub>
Subject: Re: .NET DataProvider causing machine to hang
Lines: 44
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: user-uinj2ph.dialup.mindspring.com
Message-ID: <4034f2e9@forums-2-dub>
X-Original-Trace: 19 Feb 2004 09:31:21 -0800, user-uinj2ph.dialup.mindspring.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 19 Feb 2004 09:01:11 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 19 Feb 2004 09:19:54 -0800
X-Trace: forums-1-dub 1077211194 10.22.108.75 (19 Feb 2004 09:19:54 -0800)
X-Original-Trace: 19 Feb 2004 09:19:54 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2552
Article PK: 5689

Hi Jason,

Thank you for getting back to me on this so quickly.

For phase 1 of the project, I'm going to use OLEDB with the
provider=ASAProv.80.

For phase 2, I'd like to use Sybase .NET provider.

Please let me know when you have a fix.

Thanks,

Jim Rand
jimrand@ix.netcom.com

"Jason Hinsperger" <NOJason_HinspergerSPAM@hotmail.com> wrote in message
news:4034ea2e$1@forums-1-dub...
> I would highly recommend choosing the ADO.Net provider over the OLEDB
> provider for .Net.
>
> We have noticed similar behaviour here (though somewhat sporadic), and are
> trying to determine the cause.
> FYI, the source of the slowdown is aspnet_wp.exe. If you kill that
process
> before running your app. each time you rebuild it, that seems to avoid the
> slowdown (it is restarted automatically, I think by IIS).
>
> We will post back here when we get a clear picture of what the problem is.
>
> --
> Jason Hinsperger
> International and Sustaining Engineering
> iAnywhere Solutions
>
> Whitepapers, TechDocs, and bug fixes are all available through the
iAnywhere
> Developer Community at www.ianywhere.com/developer
> --
>


Jason Hinsperger Posted on 2004-02-24 13:18:29.0Z
From: "Jason Hinsperger" <NOJason_HinspergerSPAM@hotmail.com>
Newsgroups: ianywhere.public.general
References: <4034e23c@forums-1-dub> <4034ea2e$1@forums-1-dub> <4034f2e9@forums-2-dub>
Subject: Re: .NET DataProvider causing machine to hang
Lines: 83
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: hinsperg-pc1.sybase.com
Message-ID: <403b4f31$1@forums-2-dub>
X-Original-Trace: 24 Feb 2004 05:18:41 -0800, hinsperg-pc1.sybase.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 24 Feb 2004 05:17:58 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 24 Feb 2004 05:18:29 -0800
X-Trace: forums-1-dub 1077628709 10.22.108.75 (24 Feb 2004 05:18:29 -0800)
X-Original-Trace: 24 Feb 2004 05:18:29 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2607
Article PK: 5745

It seems there is a bug in VS.NET related to ASP.NET dynamic update. VS.NET
hangs when deploying the new version of a web app. VS.NET fails to copy the
AsaClient.dll because it's locked.

As a work around, you can change the "idleTimeout" option in the
machine.config file. For example:

<system.web>

<processModel>

idleTimeout="0:00:01"

</processModel>

</system.web>

The idleTimeout is changed to 1 second. The aspnet_wp.exe will automatically
ends the ASP.NET app 1 second after the user closes the browser.


--
Jason Hinsperger
International and Sustaining Engineering
iAnywhere Solutions

Whitepapers, TechDocs, and bug fixes are all available through the iAnywhere
Developer Community at www.ianywhere.com/developer
--

"Jim Rand" <jimrand@ix.netcom.com> wrote in message
news:4034f2e9@forums-2-dub...
> Hi Jason,
>
> Thank you for getting back to me on this so quickly.
>
> For phase 1 of the project, I'm going to use OLEDB with the
> provider=ASAProv.80.
>
> For phase 2, I'd like to use Sybase .NET provider.
>
> Please let me know when you have a fix.
>
> Thanks,
>
> Jim Rand
> jimrand@ix.netcom.com
>
>
>
> "Jason Hinsperger" <NOJason_HinspergerSPAM@hotmail.com> wrote in message
> news:4034ea2e$1@forums-1-dub...
> > I would highly recommend choosing the ADO.Net provider over the OLEDB
> > provider for .Net.
> >
> > We have noticed similar behaviour here (though somewhat sporadic), and
are
> > trying to determine the cause.
> > FYI, the source of the slowdown is aspnet_wp.exe. If you kill that
> process
> > before running your app. each time you rebuild it, that seems to avoid
the
> > slowdown (it is restarted automatically, I think by IIS).
> >
> > We will post back here when we get a clear picture of what the problem
is.
> >
> > --
> > Jason Hinsperger
> > International and Sustaining Engineering
> > iAnywhere Solutions
> >
> > Whitepapers, TechDocs, and bug fixes are all available through the
> iAnywhere
> > Developer Community at www.ianywhere.com/developer
> > --
> >
>
>


Jim Rand Posted on 2004-02-24 15:51:28.0Z
Reply-To: "Jim Rand" <jimrand@ix.netcom.com>
From: "Jim Rand" <jimrand@ix.netcom.com>
Newsgroups: ianywhere.public.general
References: <4034e23c@forums-1-dub> <4034ea2e$1@forums-1-dub> <4034f2e9@forums-2-dub> <403b4f31$1@forums-2-dub>
Subject: Re: .NET DataProvider causing machine to hang
Lines: 44
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: user-uinj0a6.dialup.mindspring.com
Message-ID: <403b730b@forums-2-dub>
X-Original-Trace: 24 Feb 2004 07:51:39 -0800, user-uinj0a6.dialup.mindspring.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 24 Feb 2004 07:50:56 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 24 Feb 2004 07:51:28 -0800
X-Trace: forums-1-dub 1077637888 10.22.108.75 (24 Feb 2004 07:51:28 -0800)
X-Original-Trace: 24 Feb 2004 07:51:28 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2615
Article PK: 6089

Hi Jason,

Thank you. I'll try it.

Jim

"Jason Hinsperger" <NOJason_HinspergerSPAM@hotmail.com> wrote in message
news:403b4f31$1@forums-2-dub...
> It seems there is a bug in VS.NET related to ASP.NET dynamic update.
VS.NET
> hangs when deploying the new version of a web app. VS.NET fails to copy
the
> AsaClient.dll because it's locked.
>
> As a work around, you can change the "idleTimeout" option in the
> machine.config file. For example:
>
> <system.web>
>
> <processModel>
>
> idleTimeout="0:00:01"
>
> </processModel>
>
> </system.web>
>
> The idleTimeout is changed to 1 second. The aspnet_wp.exe will
automatically
> ends the ASP.NET app 1 second after the user closes the browser.
>
>
> --
> Jason Hinsperger
> International and Sustaining Engineering
> iAnywhere Solutions
>
> Whitepapers, TechDocs, and bug fixes are all available through the
iAnywhere
> Developer Community at www.ianywhere.com/developer
> --
>


Jim Rand Posted on 2004-02-29 19:18:55.0Z
Reply-To: "Jim Rand" <jimrand@ix.netcom.com>
From: "Jim Rand" <jimrand@ix.netcom.com>
Newsgroups: ianywhere.public.general
References: <4034e23c@forums-1-dub> <4034ea2e$1@forums-1-dub> <4034f2e9@forums-2-dub> <403b4f31$1@forums-2-dub> <403b730b@forums-2-dub>
Subject: Re: .NET DataProvider causing machine to hang
Lines: 84
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
NNTP-Posting-Host: user-uinj21d.dialup.mindspring.com
X-Original-NNTP-Posting-Host: user-uinj21d.dialup.mindspring.com
Message-ID: <40423b1f@forums-1-dub>
Date: 29 Feb 2004 11:18:55 -0800
X-Trace: forums-1-dub 1078082335 165.121.136.45 (29 Feb 2004 11:18:55 -0800)
X-Original-Trace: 29 Feb 2004 11:18:55 -0800, user-uinj21d.dialup.mindspring.com
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2676
Article PK: 6148

Hi Jason,

Changing the "idle Timeout" is NOT a good choice. Yes, VS.NET doesn't hang.
However,

1) you lose application state.
2) the interactive debugger fails
3) caching configuration information in a Singleton no longer works:
internal sealed class WMUtility{

private WMUtility(){
}

private static string connString = null;

public static string ConnectionString{
get{
if (connString == null){
/* If the idle timeout is set to "0:00:01", this fires
each time a connection string is requested.
If the idle timeout is left at the default of
"Infinite", this occurs only once */
connString =
WMUtility.Decrypt(System.Configuration.ConfigurationSettings.AppSettings["Sy
baseConnect"]);
}
return connString;
}
}
}

Have you got another alternative?

Thanks
==================================

"Jim Rand" <jimrand@ix.netcom.com> wrote in message
news:403b730b@forums-2-dub...
> Hi Jason,
>
> Thank you. I'll try it.
>
> Jim
>
> "Jason Hinsperger" <NOJason_HinspergerSPAM@hotmail.com> wrote in message
> news:403b4f31$1@forums-2-dub...
> > It seems there is a bug in VS.NET related to ASP.NET dynamic update.
> VS.NET
> > hangs when deploying the new version of a web app. VS.NET fails to copy
> the
> > AsaClient.dll because it's locked.
> >
> > As a work around, you can change the "idleTimeout" option in the
> > machine.config file. For example:
> >
> > <system.web>
> >
> > <processModel>
> >
> > idleTimeout="0:00:01"
> >
> > </processModel>
> >
> > </system.web>
> >
> > The idleTimeout is changed to 1 second. The aspnet_wp.exe will
> automatically
> > ends the ASP.NET app 1 second after the user closes the browser.
> >
> >
> > --
> > Jason Hinsperger
> > International and Sustaining Engineering
> > iAnywhere Solutions
> >
> > Whitepapers, TechDocs, and bug fixes are all available through the
> iAnywhere
> > Developer Community at www.ianywhere.com/developer
> > --
> >
>
>


Jason Hinsperger Posted on 2004-03-01 13:58:54.0Z
From: "Jason Hinsperger" <NOJason_HinspergerSPAM@hotmail.com>
Newsgroups: ianywhere.public.general
References: <4034e23c@forums-1-dub> <4034ea2e$1@forums-1-dub> <4034f2e9@forums-2-dub> <403b4f31$1@forums-2-dub> <403b730b@forums-2-dub> <40423b1f@forums-1-dub>
Subject: Re: .NET DataProvider causing machine to hang
Lines: 106
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
NNTP-Posting-Host: hinsperg-pc1.sybase.com
X-Original-NNTP-Posting-Host: hinsperg-pc1.sybase.com
Message-ID: <4043419e$1@forums-1-dub>
Date: 1 Mar 2004 05:58:54 -0800
X-Trace: forums-1-dub 1078149534 172.31.143.226 (1 Mar 2004 05:58:54 -0800)
X-Original-Trace: 1 Mar 2004 05:58:54 -0800, hinsperg-pc1.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2677
Article PK: 6151

If you kill aspnet_wp.exe after exiting the application, the problem should
go away. The process will automatically be restarted.
We are trying to get the issue resolved at Microsoft.

--
Jason Hinsperger
International and Sustaining Engineering
iAnywhere Solutions

Whitepapers, TechDocs, and bug fixes are all available through the iAnywhere
Developer Community at www.ianywhere.com/developer
--

"Jim Rand" <jimrand@ix.netcom.com> wrote in message
news:40423b1f@forums-1-dub...
> Hi Jason,
>
> Changing the "idle Timeout" is NOT a good choice. Yes, VS.NET doesn't
hang.
> However,
>
> 1) you lose application state.
> 2) the interactive debugger fails
> 3) caching configuration information in a Singleton no longer works:
> internal sealed class WMUtility{
>
> private WMUtility(){
> }
>
> private static string connString = null;
>
> public static string ConnectionString{
> get{
> if (connString == null){
> /* If the idle timeout is set to "0:00:01", this fires
> each time a connection string is requested.
> If the idle timeout is left at the default of
> "Infinite", this occurs only once */
> connString =
>
WMUtility.Decrypt(System.Configuration.ConfigurationSettings.AppSettings["Sy
> baseConnect"]);
> }
> return connString;
> }
> }
> }
>
> Have you got another alternative?
>
> Thanks
> ==================================
>
> "Jim Rand" <jimrand@ix.netcom.com> wrote in message
> news:403b730b@forums-2-dub...
> > Hi Jason,
> >
> > Thank you. I'll try it.
> >
> > Jim
> >
> > "Jason Hinsperger" <NOJason_HinspergerSPAM@hotmail.com> wrote in message
> > news:403b4f31$1@forums-2-dub...
> > > It seems there is a bug in VS.NET related to ASP.NET dynamic update.
> > VS.NET
> > > hangs when deploying the new version of a web app. VS.NET fails to
copy
> > the
> > > AsaClient.dll because it's locked.
> > >
> > > As a work around, you can change the "idleTimeout" option in the
> > > machine.config file. For example:
> > >
> > > <system.web>
> > >
> > > <processModel>
> > >
> > > idleTimeout="0:00:01"
> > >
> > > </processModel>
> > >
> > > </system.web>
> > >
> > > The idleTimeout is changed to 1 second. The aspnet_wp.exe will
> > automatically
> > > ends the ASP.NET app 1 second after the user closes the browser.
> > >
> > >
> > > --
> > > Jason Hinsperger
> > > International and Sustaining Engineering
> > > iAnywhere Solutions
> > >
> > > Whitepapers, TechDocs, and bug fixes are all available through the
> > iAnywhere
> > > Developer Community at www.ianywhere.com/developer
> > > --
> > >
> >
> >
>
>


Jason Hinsperger Posted on 2004-03-24 17:16:57.0Z
From: "Jason Hinsperger" <NOJason_HinspergerSPAM@hotmail.com>
Newsgroups: ianywhere.public.general
References: <4034e23c@forums-1-dub> <4034ea2e$1@forums-1-dub> <4034f2e9@forums-2-dub> <403b4f31$1@forums-2-dub> <403b730b@forums-2-dub> <40423b1f@forums-1-dub> <4043419e$1@forums-1-dub>
Subject: Re: .NET DataProvider causing machine to hang
Lines: 133
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: hinsperg-pc1.sybase.com
Message-ID: <4061c285$1@forums-2-dub>
X-Original-Trace: 24 Mar 2004 09:16:53 -0800, hinsperg-pc1.sybase.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 24 Mar 2004 09:16:54 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 24 Mar 2004 09:16:57 -0800
X-Trace: forums-1-dub 1080148617 10.22.108.75 (24 Mar 2004 09:16:57 -0800)
X-Original-Trace: 24 Mar 2004 09:16:57 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:2840
Article PK: 6310

We have tracked down and resolved this problem. The aspnet_wp.exe should no
longer hang when you rebuild asp.net applications which use the ADO.NET
provider as of the following ebfs.
8.0.2 ebf 4397

9.0.0 ebf 1292

9.0.1 ebf 1839

--
Jason Hinsperger
International and Sustaining Engineering
iAnywhere Solutions


Whitepapers, TechDocs, and bug fixes are all available through the iAnywhere
Developer Community at www.ianywhere.com/developer
--

"Jason Hinsperger" <NOJason_HinspergerSPAM@hotmail.com> wrote in message
news:4043419e$1@forums-1-dub...
> If you kill aspnet_wp.exe after exiting the application, the problem
should
> go away. The process will automatically be restarted.
> We are trying to get the issue resolved at Microsoft.
>
> --
> Jason Hinsperger
> International and Sustaining Engineering
> iAnywhere Solutions
>
> Whitepapers, TechDocs, and bug fixes are all available through the
iAnywhere
> Developer Community at www.ianywhere.com/developer
> --
>
>
>
> "Jim Rand" <jimrand@ix.netcom.com> wrote in message
> news:40423b1f@forums-1-dub...
> > Hi Jason,
> >
> > Changing the "idle Timeout" is NOT a good choice. Yes, VS.NET doesn't
> hang.
> > However,
> >
> > 1) you lose application state.
> > 2) the interactive debugger fails
> > 3) caching configuration information in a Singleton no longer works:
> > internal sealed class WMUtility{
> >
> > private WMUtility(){
> > }
> >
> > private static string connString = null;
> >
> > public static string ConnectionString{
> > get{
> > if (connString == null){
> > /* If the idle timeout is set to "0:00:01", this fires
> > each time a connection string is requested.
> > If the idle timeout is left at the default of
> > "Infinite", this occurs only once */
> > connString =
> >
>
WMUtility.Decrypt(System.Configuration.ConfigurationSettings.AppSettings["Sy
> > baseConnect"]);
> > }
> > return connString;
> > }
> > }
> > }
> >
> > Have you got another alternative?
> >
> > Thanks
> > ==================================
> >
> > "Jim Rand" <jimrand@ix.netcom.com> wrote in message
> > news:403b730b@forums-2-dub...
> > > Hi Jason,
> > >
> > > Thank you. I'll try it.
> > >
> > > Jim
> > >
> > > "Jason Hinsperger" <NOJason_HinspergerSPAM@hotmail.com> wrote in
message
> > > news:403b4f31$1@forums-2-dub...
> > > > It seems there is a bug in VS.NET related to ASP.NET dynamic update.
> > > VS.NET
> > > > hangs when deploying the new version of a web app. VS.NET fails to
> copy
> > > the
> > > > AsaClient.dll because it's locked.
> > > >
> > > > As a work around, you can change the "idleTimeout" option in the
> > > > machine.config file. For example:
> > > >
> > > > <system.web>
> > > >
> > > > <processModel>
> > > >
> > > > idleTimeout="0:00:01"
> > > >
> > > > </processModel>
> > > >
> > > > </system.web>
> > > >
> > > > The idleTimeout is changed to 1 second. The aspnet_wp.exe will
> > > automatically
> > > > ends the ASP.NET app 1 second after the user closes the browser.
> > > >
> > > >
> > > > --
> > > > Jason Hinsperger
> > > > International and Sustaining Engineering
> > > > iAnywhere Solutions
> > > >
> > > > Whitepapers, TechDocs, and bug fixes are all available through the
> > > iAnywhere
> > > > Developer Community at www.ianywhere.com/developer
> > > > --
> > > >
> > >
> > >
> >
> >
>
>