Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

InsertDocument for RTE Control

2 posts in Objects Last posting was on 2004-03-16 17:42:24.0Z
Tom Rolseth Posted on 2004-03-09 16:51:22.0Z
From: "Tom Rolseth" <tpr@npomn.com>
Newsgroups: sybase.public.powerbuilder.objects
Subject: InsertDocument for RTE Control
Lines: 11
Organization: NPO Solutions
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: 65.214.76.97
Message-ID: <404df64b@forums-2-dub>
X-Original-Trace: 9 Mar 2004 08:52:27 -0800, 65.214.76.97
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 9 Mar 2004 08:49:29 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 9 Mar 2004 08:51:22 -0800
X-Trace: forums-1-dub 1078851082 10.22.108.75 (9 Mar 2004 08:51:22 -0800)
X-Original-Trace: 9 Mar 2004 08:51:22 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:7823
Article PK: 735095

I am using the script below to insert a rich text file. However, the return
code is always -1. I know the file is valid (the FileExists check is true).
Any ideas as to what I am doing wrong? Thanks, Tom

bExists = FileExists("c:\fpower\fund_memo.rtf")
IF bExists THEN
lReturn = rte_1.InsertDocument("c:\fpower\fund_memo.rtf", TRUE,
FileTypeRichText!)
END IF


Andy Turiansky [TeamSybase] Posted on 2004-03-16 17:42:24.0Z
From: "Andy Turiansky [TeamSybase]" <aturiansky@comcast.net>
Newsgroups: sybase.public.powerbuilder.objects
Organization: 192.195.217.10
References: <404df64b@forums-2-dub>
X-Newsreader: AspNNTP 1.50 (Takeshi Eto)
Subject: Re: InsertDocument for RTE Control
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: 64.79.161.46
X-Original-NNTP-Posting-Host: 64.79.161.46
Message-ID: <40573c80$1@forums-1-dub>
Date: 16 Mar 2004 09:42:24 -0800
X-Trace: forums-1-dub 1079458944 64.79.161.46 (16 Mar 2004 09:42:24 -0800)
X-Original-Trace: 16 Mar 2004 09:42:24 -0800, 64.79.161.46
Lines: 30
X-Authenticated-User: teamps
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:7824
Article PK: 735096

Try opening the file in MS Word to confirm it is a valid RTF file.... maybe the
file is corrupted or not really an RTF file.

On 9 Mar 2004 08:51:22 -0800,
in sybase.public.powerbuilder.objects

Tom Rolseth <tpr@npomn.com> wrote:
>I am using the script below to insert a rich text file. However, the return
>code is always -1. I know the file is valid (the FileExists check is true).
>Any ideas as to what I am doing wrong? Thanks, Tom
>
>bExists = FileExists("c:\fpower\fund_memo.rtf")
>IF bExists THEN
> lReturn = rte_1.InsertDocument("c:\fpower\fund_memo.rtf", TRUE,
>FileTypeRichText!)
>END IF
>
>

- - -
Andy [TeamSybase]

Submit Sybase product enhancement requests via:
http://www.isug.com/cgi-bin/ISUG2/submit_enhancement


Techwave 2003 - http://www.sybase.com/techwave2003
International Sybase User Group (ISUG) - http://www.isug.com
CodeXchange - http://powerbuilder.codeXchange.sybase.com/