Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Events Events Events

3 posts in General Discussion Last posting was on 2004-04-28 22:26:06.0Z
Billy Willoughby Posted on 2004-04-23 16:49:37.0Z
From: "Billy Willoughby" <Billy@FultonPaper.com>
Newsgroups: ianywhere.public.general
Subject: Events Events Events
Lines: 16
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
NNTP-Posting-Host: 64.240.244.75
X-Original-NNTP-Posting-Host: 64.240.244.75
Message-ID: <40894921@forums-1-dub>
Date: 23 Apr 2004 09:49:37 -0700
X-Trace: forums-1-dub 1082738977 64.240.244.75 (23 Apr 2004 09:49:37 -0700)
X-Original-Trace: 23 Apr 2004 09:49:37 -0700, 64.240.244.75
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:3002
Article PK: 6468

Good Morning Everyone;

I posted a couple of weeks ago about my events not firing, and was
advised to update to 8.0.2.4372 to resolve the problem. While this fixed
the events that were not firing correctly, I now have a new issue. It seems
that on some events, it's now firing them at times that are not on the
schedule. Example: I have an event set to fire every Saturday Morning. It
didn't run on Saturday this week, it ran on Monday. I can find no reason
why the event would run on the wrong day (Yes the time and date are
correct). Any ideas relating to this problem?

Thanks,

Billy Willoughby


Greg Fenton Posted on 2004-04-23 17:17:20.0Z
From: Greg Fenton <greg.fenton_NOSPAM_@ianywhere.com>
Organization: iAnywhere Solutions Inc.
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113 MultiZilla/1.6.2.0c
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
Subject: Re: Events Events Events
References: <40894921@forums-1-dub>
In-Reply-To: <40894921@forums-1-dub>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: gfenton-xp.sybase.com
Message-ID: <40894f9b$1@forums-2-dub>
X-Original-Trace: 23 Apr 2004 10:17:15 -0700, gfenton-xp.sybase.com
Lines: 16
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 23 Apr 2004 10:17:17 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 23 Apr 2004 10:17:20 -0700
X-Trace: forums-1-dub 1082740640 10.22.108.75 (23 Apr 2004 10:17:20 -0700)
X-Original-Trace: 23 Apr 2004 10:17:20 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:3003
Article PK: 6470


Billy Willoughby wrote:
> I can find no reason
> why the event would run on the wrong day (Yes the time and date are
> correct). Any ideas relating to this problem?
>

Can you post the SCHEDULE clause for your event?

greg.fenton
--
Greg Fenton
Consultant, Solution Services, iAnywhere Solutions
--------
Visit the iAnywhere Solutions Developer Community
Whitepapers, TechDocs, Downloads
http://www.ianywhere.com/developer/


Billy Willoughby Posted on 2004-04-28 22:26:06.0Z
From: "Billy Willoughby" <Billy@FultonPaper.com>
Newsgroups: ianywhere.public.general
References: <40894921@forums-1-dub> <40894f9b$1@forums-2-dub>
Subject: Re: Events Events Events
Lines: 46
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
X-Original-NNTP-Posting-Host: 64.240.244.75
Message-ID: <40902f7a$1@forums-2-dub>
X-Original-Trace: 28 Apr 2004 15:26:02 -0700, 64.240.244.75
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 28 Apr 2004 15:26:05 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 28 Apr 2004 15:26:06 -0700
X-Trace: forums-1-dub 1083191166 10.22.108.75 (28 Apr 2004 15:26:06 -0700)
X-Original-Trace: 28 Apr 2004 15:26:06 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:3015
Article PK: 6481

I hope this is the information your looking for. Interestingly enough, it
ran at 3 am on Monday. (First Log Entry is 4/26/04 03:04:55)

Thanks,

Billy

CREATE EVENT "TuneUp" ENABLE AT ALL
HANDLER
begin
call dbtune()
end
go
COMMENT TO PRESERVE FORMAT ON EVENT "TuneUp" IS
{BEGIN
call dbtune;
END
}
go
ALTER EVENT "TuneUp"
ADD SCHEDULE "TuneUp_1"
START TIME '06:00:00' ON ('Saturday') START DATE '2004/03/30'
go

"Greg Fenton" <greg.fenton_NOSPAM_@ianywhere.com> wrote in message
news:40894f9b$1@forums-2-dub...
> Billy Willoughby wrote:
> > I can find no reason
> > why the event would run on the wrong day (Yes the time and date are
> > correct). Any ideas relating to this problem?
> >
>
> Can you post the SCHEDULE clause for your event?
>
> greg.fenton
> --
> Greg Fenton
> Consultant, Solution Services, iAnywhere Solutions
> --------
> Visit the iAnywhere Solutions Developer Community
> Whitepapers, TechDocs, Downloads
> http://www.ianywhere.com/developer/