Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Packet owner not logged in

2 posts in ,  Networking PHP Last posting was on 2004-05-24 21:18:18.0Z
Tom Brown Posted on 2004-05-21 13:38:33.0Z
Date: Fri, 21 May 2004 07:38:33 -0600
From: Tom Brown <tbrown@westernwats.com>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: Advantage.Networking,Advantage.PHP
Subject: Packet owner not logged in
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: 216.20.254.254
Message-ID: <40ae082a@solutions.advantagedatabase.com>
X-Trace: 21 May 2004 07:46:18 -0700, 216.20.254.254
Lines: 34
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!216.20.254.254
Xref: solutions.advantagedatabase.com Advantage.Networking:460 Advantage.PHP:329
Article PK: 1131885

Hello,

We have been having some strange advantage errors lately. We connect to
ADS through PHP (apache's mod_php), Delphi and Java (at the same time).
Each application connects to more than one server at once (serverA and
serverB).

These are the problems we are experiencing:

1) Many "10054" errors in the ADS error log.
2) "7041" errors in the ADS error log on the wrong server.
3) "7041" errors returned to the client when the file exists (somehow
the query is sent to the wrong server; See problem 2). This only happens
from PHP.
4) Drastic DB slowdown. The worker threads on the server are pegged, but
there is very little CPU usage.
5) Extremely high counts of "Packet owner not connected" in the ADS
management interface (communication statistics).

The "Packet owner not connected" count doesn't seem to be related to the
load we put on the server. It seems to increment even when we're hardly
doing anything on the server. What does this mean?

The other problems all seem to happen at once, and we're not sure if the
problem has to do with our Apache/PHP installation or if it's something
odd with our network. We are NOT using the newest version of PHP_ADS
because we have to connect to an older 6.x server as well as 7.x servers.

What suggestions do you have that we can use to further isolate the problem?

Tom Brown
Developer
Western Wats


Lance Schmidt Posted on 2004-05-24 21:18:18.0Z
From: "Lance Schmidt" <LanceSc@ExtendSys.com>
Newsgroups: Advantage.Networking,Advantage.PHP
References: <40ae082a@solutions.advantagedatabase.com>
Subject: Re: Packet owner not logged in
Date: Mon, 24 May 2004 15:18:18 -0600
Lines: 52
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1409
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1409
NNTP-Posting-Host: 198.102.102.147
Message-ID: <40b26846@solutions.advantagedatabase.com>
X-Trace: 24 May 2004 15:25:26 -0700, 198.102.102.147
Path: solutions.advantagedatabase.com!solutions.advantagedatabase.com!198.102.102.147
Xref: solutions.advantagedatabase.com Advantage.Networking:462 Advantage.PHP:331
Article PK: 1131888

Hi Tom,

I suggest you contact support with this problem. This problem sounds like
it is going to be difficult enough to work out without a day delay between
our posts on this new group.

Best Regards,

Lance Schmidt
Advantage R&D
LanceSc@ExtendSys.com

"Tom Brown" <tbrown@westernwats.com> wrote in message
news:40ae082a@solutions.advantagedatabase.com...
> Hello,
>
> We have been having some strange advantage errors lately. We connect to
> ADS through PHP (apache's mod_php), Delphi and Java (at the same time).
> Each application connects to more than one server at once (serverA and
> serverB).
>
> These are the problems we are experiencing:
>
> 1) Many "10054" errors in the ADS error log.
> 2) "7041" errors in the ADS error log on the wrong server.
> 3) "7041" errors returned to the client when the file exists (somehow
> the query is sent to the wrong server; See problem 2). This only happens
> from PHP.
> 4) Drastic DB slowdown. The worker threads on the server are pegged, but
> there is very little CPU usage.
> 5) Extremely high counts of "Packet owner not connected" in the ADS
> management interface (communication statistics).
>
> The "Packet owner not connected" count doesn't seem to be related to the
> load we put on the server. It seems to increment even when we're hardly
> doing anything on the server. What does this mean?
>
> The other problems all seem to happen at once, and we're not sure if the
> problem has to do with our Apache/PHP installation or if it's something
> odd with our network. We are NOT using the newest version of PHP_ADS
> because we have to connect to an older 6.x server as well as 7.x servers.
>
> What suggestions do you have that we can use to further isolate the
problem?
>
> Tom Brown
> Developer
> Western Wats
>