Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

EJB Lookup Fails

3 posts in EJB Client Last posting was on 2004-08-26 11:51:59.0Z
Mike Posted on 2004-08-05 10:21:00.0Z
Sender: 4a14.4111fb46.1804289383@sybase.com
From: Mike
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: EJB Lookup Fails
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <41120a0c.4b3a.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 5 Aug 2004 03:21:00 -0700
X-Trace: forums-1-dub 1091701260 10.22.241.41 (5 Aug 2004 03:21:00 -0700)
X-Original-Trace: 5 Aug 2004 03:21:00 -0700, 10.22.241.41
Lines: 20
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:328
Article PK: 424504

Hi,

My EJB session bean has been deployed to EAServer 5.0 Build
50054 and I've generated the proxies with PB 9.0.1 Build
7204. Connecting to EAServer appears to work, the return
code is 0, however when I try to do the myConnection.Lookup
to create the home interface, it fails.

The error code is 50 and the error text is "Distributed
Service Error: E13 Could not create object of class
"MyTestPackage/MyTestEJB". (7E6)

I've cut and paste the two last arguments for the Lookup
function directly from the EJB properties in EAServer
Manager.

Does anyone have any thoughts on the cause of the problem.

Thanks,
Mike


Ben (bede) Posted on 2004-08-05 10:31:47.0Z
From: Ben (bede) <bedeNOSP@Msofico.be>
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: Re: EJB Lookup Fails
Message-ID: <MPG.1b7c298e91b323f1989682@forums.sybase.com>
References: <41120a0c.4b3a.1681692777@sybase.com>
Organization: Sofico
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-15"
Content-Transfer-Encoding: 7bit
User-Agent: MicroPlanet-Gravity/2.70.2067
NNTP-Posting-Host: uu194-7-38-226.unknown.uunet.be
X-Original-NNTP-Posting-Host: uu194-7-38-226.unknown.uunet.be
Date: 5 Aug 2004 03:31:47 -0700
X-Trace: forums-1-dub 1091701907 194.7.38.226 (5 Aug 2004 03:31:47 -0700)
X-Original-Trace: 5 Aug 2004 03:31:47 -0700, uu194-7-38-226.unknown.uunet.be
Lines: 27
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:329
Article PK: 424505

Have you double-checked your classpath?
Are you using the same java runtime version?

Ben

In article <41120a0c.4b3a.1681692777@sybase.com>, Mike says...

> Hi,
>
> My EJB session bean has been deployed to EAServer 5.0 Build
> 50054 and I've generated the proxies with PB 9.0.1 Build
> 7204. Connecting to EAServer appears to work, the return
> code is 0, however when I try to do the myConnection.Lookup
> to create the home interface, it fails.
>
> The error code is 50 and the error text is "Distributed
> Service Error: E13 Could not create object of class
> "MyTestPackage/MyTestEJB". (7E6)
>
> I've cut and paste the two last arguments for the Lookup
> function directly from the EJB properties in EAServer
> Manager.
>
> Does anyone have any thoughts on the cause of the problem.
>
> Thanks,
> Mike
>


Andy Turiansky [TeamSybase] Posted on 2004-08-26 11:51:59.0Z
From: "Andy Turiansky [TeamSybase]" <aturiansky@comcast.net>
Newsgroups: sybase.public.powerbuilder.ejbclient
Organization: 192.189.32.10
References: <41120a0c.4b3a.1681692777@sybase.com>
X-Newsreader: AspNNTP 1.50 (Takeshi Eto)
Subject: Re: EJB Lookup Fails
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: web110.discountasp.net
Message-ID: <412dd052$1@forums-2-dub>
X-Original-Trace: 26 Aug 2004 04:58:10 -0700, web110.discountasp.net
Lines: 27
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 26 Aug 2004 04:41:50 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 26 Aug 2004 04:51:59 -0700
X-Trace: forums-1-dub 1093521119 10.22.108.75 (26 Aug 2004 04:51:59 -0700)
X-Original-Trace: 26 Aug 2004 04:51:59 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:342
Article PK: 424518

I had an issue with the Lookup also, and I found that the JNDI_NAME I set in my
client did not match to that of what was on the server. Once I sync'd these up,
the lookup was successful

On 5 Aug 2004 03:21:00 -0700,
in sybase.public.powerbuilder.ejbclient

<Mike> wrote:
>Hi,
>
>My EJB session bean has been deployed to EAServer 5.0 Build
>50054 and I've generated the proxies with PB 9.0.1 Build
>7204. Connecting to EAServer appears to work, the return
>code is 0, however when I try to do the myConnection.Lookup
>to create the home interface, it fails.
>
>The error code is 50 and the error text is "Distributed
>Service Error: E13 Could not create object of class
>"MyTestPackage/MyTestEJB". (7E6)
>
>I've cut and paste the two last arguments for the Lookup
>function directly from the EJB properties in EAServer
>Manager.
>
>Does anyone have any thoughts on the cause of the problem.
>
>Thanks,
>Mike