Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

ADO.NET connection to SQL Server

4 posts in DataWindow .NET Last posting was on 2004-08-10 21:29:20.0Z
Alex McC Posted on 2004-08-10 19:55:55.0Z
Sender: 310b.41192609.1804289383@sybase.com
From: Alex McC
Newsgroups: sybase.public.datawindow.net
Subject: ADO.NET connection to SQL Server
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4119284b.315f.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 10 Aug 2004 12:55:55 -0700
X-Trace: forums-1-dub 1092167755 10.22.241.41 (10 Aug 2004 12:55:55 -0700)
X-Original-Trace: 10 Aug 2004 12:55:55 -0700, 10.22.241.41
Lines: 13
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.datawindow.net:73
Article PK: 124510

Hi

Just installed eval version and cannot connect to SQL Server
(get Invalid authorization specification)

I'm connecting via trusted connection to local db (Northwind
database). Noticed a help comment that I should include
Database=Northwind in extended properties. I connected okay
to the sample Adaptive demo.

Appreciate any advice

Alex


Jim O'Neil [Sybase] Posted on 2004-08-10 20:55:25.0Z
From: "Jim O'Neil [Sybase]" <joneil_at_sybase_dot_com>
Newsgroups: sybase.public.datawindow.net
Subject: Re: ADO.NET connection to SQL Server
Message-ID: <ekcih0lvvju936tc9ijnqre9hmlumeemtt@4ax.com>
References: <4119284b.315f.1681692777@sybase.com>
X-Newsreader: Forte Agent 2.0/32.652
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: joneilw2k.sybase.com
X-Original-NNTP-Posting-Host: joneilw2k.sybase.com
Date: 10 Aug 2004 13:55:25 -0700
X-Trace: forums-1-dub 1092171325 10.18.63.187 (10 Aug 2004 13:55:25 -0700)
X-Original-Trace: 10 Aug 2004 13:55:25 -0700, joneilw2k.sybase.com
Lines: 26
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.datawindow.net:74
Article PK: 124511

I think this may be a bug. I'm not able to do it either. Note that
when you select the Trusted Connection checkbox, that the syntax view
on the preview tab doesn't change. Nor does it change if you
explicitly put "Trusted Connection=yes" in the Extended string.

Assuming that what we see on the Preview tab is accurate, try setting
your Data Source string to the real name of the datasource followed by
;Trusted Connection=yes (with no closing ;). That should get the
Preview tab correct, but I still can't guarantee that it will work.

On 10 Aug 2004 12:55:55 -0700, Alex McC wrote:

>Hi
>
>Just installed eval version and cannot connect to SQL Server
>(get Invalid authorization specification)
>
>I'm connecting via trusted connection to local db (Northwind
>database). Noticed a help comment that I should include
>Database=Northwind in extended properties. I connected okay
>to the sample Adaptive demo.
>
>Appreciate any advice
>
>Alex


Jim O'Neil [Sybase] Posted on 2004-08-10 21:04:05.0Z
From: "Jim O'Neil [Sybase]" <joneil_at_sybase_dot_com>
Newsgroups: sybase.public.datawindow.net
Subject: Re: ADO.NET connection to SQL Server
Message-ID: <pddih0lt4ppo4oflbl6fns14grrthls0fs@4ax.com>
References: <4119284b.315f.1681692777@sybase.com> <ekcih0lvvju936tc9ijnqre9hmlumeemtt@4ax.com>
X-Newsreader: Forte Agent 2.0/32.652
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: joneilw2k.sybase.com
X-Original-NNTP-Posting-Host: joneilw2k.sybase.com
Date: 10 Aug 2004 14:04:05 -0700
X-Trace: forums-1-dub 1092171845 10.18.63.187 (10 Aug 2004 14:04:05 -0700)
X-Original-Trace: 10 Aug 2004 14:04:05 -0700, joneilw2k.sybase.com
Lines: 38
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.datawindow.net:75
Article PK: 124509

I should have added that you can still continue your evaluation by
using the OLE-DB interface within DW Designer. I suspect you'll be
able to connect fine in an application with the ADO.NET driver, since
you provide the explicit code for the connection (versus having
DataWindow Designer create the string from the data you entered in the
profile). So, you could design your datawindows using the OLE-DB
connection to SQL Server and run your application (with the
datawindows unchanged) using the ADO.NET connection.

On 10 Aug 2004 13:55:25 -0700, "Jim O'Neil [Sybase]"

<joneil_at_sybase_dot_com> wrote:

>I think this may be a bug. I'm not able to do it either. Note that
>when you select the Trusted Connection checkbox, that the syntax view
>on the preview tab doesn't change. Nor does it change if you
>explicitly put "Trusted Connection=yes" in the Extended string.
>
>Assuming that what we see on the Preview tab is accurate, try setting
>your Data Source string to the real name of the datasource followed by
>;Trusted Connection=yes (with no closing ;). That should get the
>Preview tab correct, but I still can't guarantee that it will work.
>
>On 10 Aug 2004 12:55:55 -0700, Alex McC wrote:
>
>>Hi
>>
>>Just installed eval version and cannot connect to SQL Server
>>(get Invalid authorization specification)
>>
>>I'm connecting via trusted connection to local db (Northwind
>>database). Noticed a help comment that I should include
>>Database=Northwind in extended properties. I connected okay
>>to the sample Adaptive demo.
>>
>>Appreciate any advice
>>
>>Alex


Alex McC Posted on 2004-08-10 21:29:20.0Z
Sender: 15fd.41193f2c.1804289383@sybase.com
From: Alex McC
Newsgroups: sybase.public.datawindow.net
Subject: Re: ADO.NET connection to SQL Server
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <41193f68.1604.1681692777@sybase.com>
References: <ekcih0lvvju936tc9ijnqre9hmlumeemtt@4ax.com>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 10 Aug 2004 14:34:32 -0700, 10.22.241.42
Lines: 34
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 10 Aug 2004 14:20:41 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 10 Aug 2004 14:29:20 -0700
X-Trace: forums-1-dub 1092173360 10.22.108.75 (10 Aug 2004 14:29:20 -0700)
X-Original-Trace: 10 Aug 2004 14:29:20 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.datawindow.net:77
Article PK: 124513

Thanks, works by adding ;Integrated Security=SSPI to the
database name

Alex

> I think this may be a bug. I'm not able to do it either.
> Note that when you select the Trusted Connection checkbox,
> that the syntax view on the preview tab doesn't change.
> Nor does it change if you explicitly put "Trusted
> Connection=yes" in the Extended string.
>
> Assuming that what we see on the Preview tab is accurate,
> try setting your Data Source string to the real name of
> the datasource followed by ;Trusted Connection=yes (with
> no closing ;). That should get the Preview tab correct,
> but I still can't guarantee that it will work.
>
> On 10 Aug 2004 12:55:55 -0700, Alex McC wrote:
>
> >Hi
> >
> >Just installed eval version and cannot connect to SQL
> Server >(get Invalid authorization specification)
> >
> >I'm connecting via trusted connection to local db
> (Northwind >database). Noticed a help comment that I
> should include >Database=Northwind in extended properties.
> I connected okay >to the sample Adaptive demo.
> >
> >Appreciate any advice
> >
> >Alex
>