Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

How do I get a composite datawindow to scroll properly in pb9?

3 posts in DataWindow .NET Last posting was on 2004-09-08 03:00:56.0Z
robyn.jamison Posted on 2004-09-07 18:09:59.0Z
Sender: 683e.413df922.1804289383@sybase.com
From: robyn.jamison@bankofamerica.com
Newsgroups: sybase.public.datawindow.net
Subject: How do I get a composite datawindow to scroll properly in pb9?
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <413dfb13.6871.1681692777@sybase.com>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 7 Sep 2004 11:16:51 -0700, 10.22.241.42
Lines: 7
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 7 Sep 2004 10:58:37 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 7 Sep 2004 11:09:59 -0700
X-Trace: forums-1-dub 1094580599 10.22.108.75 (7 Sep 2004 11:09:59 -0700)
X-Original-Trace: 7 Sep 2004 11:09:59 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.datawindow.net:314
Article PK: 124747

We have a composite datawindow where the nested dataobjects
and print specifications are set at run time. Once the user
prints the report, the report scrolls properly. Until then,
the first page is fine, but the second page is half blank,
the third shows even less data and so on until about the
fifth page through the end which display as totally blank
pages.


Jim O'Neil [Sybase] Posted on 2004-09-08 02:55:22.0Z
From: "Jim O'Neil [Sybase]" <joneil_at_sybase_dot_com>
Newsgroups: sybase.public.datawindow.net
Subject: Re: How do I get a composite datawindow to scroll properly in pb9?
Message-ID: <dcssj05kbhr9e7suojocj1dqhcfglkdksg@4ax.com>
References: <413dfb13.6871.1681692777@sybase.com>
X-Newsreader: Forte Agent 2.0/32.652
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: vpn-concord-058.sybase.com
X-Original-NNTP-Posting-Host: vpn-concord-058.sybase.com
Date: 7 Sep 2004 19:55:22 -0700
X-Trace: forums-1-dub 1094612122 158.159.8.58 (7 Sep 2004 19:55:22 -0700)
X-Original-Trace: 7 Sep 2004 19:55:22 -0700, vpn-concord-058.sybase.com
Lines: 19
X-Authenticated-User: teamsybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.datawindow.net:319
Article PK: 124749

Given that you are massaging nested datawindows and print
specifications dynamically, this is probably going to require a call
to suppot to work through.

Is it safe to assume that if you set up a 'static' datawindow that is
identical to what would eventually be constructed dynamically, that
everything is working fine? chances are this behavior isn't confined
to DW.NET and would be something present in PowerBuilder as well.

On 7 Sep 2004 11:09:59 -0700, robyn.jamison@bankofamerica.com wrote:

>We have a composite datawindow where the nested dataobjects
>and print specifications are set at run time. Once the user
>prints the report, the report scrolls properly. Until then,
>the first page is fine, but the second page is half blank,
>the third shows even less data and so on until about the
>fifth page through the end which display as totally blank
>pages.


dfish Posted on 2004-09-08 03:00:56.0Z
From: dfish@_no_spam_sybase.com (Dave Fish [Team Sybase])
Newsgroups: sybase.public.datawindow.net
Subject: Re: How do I get a composite datawindow to scroll properly in pb9?
Organization: Sybase Professional Services
Reply-To: nospam_dfish@sybase.com_nospam
Message-ID: <413e7304.42440636@forums.sybase.com>
References: <413dfb13.6871.1681692777@sybase.com>
X-Newsreader: Forte Free Agent 1.21/32.243
X-Original-NNTP-Posting-Host: vpn-dub-063.sybase.com
X-Original-Trace: 7 Sep 2004 20:07:50 -0700, vpn-dub-063.sybase.com
Lines: 23
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 7 Sep 2004 19:49:32 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 7 Sep 2004 20:00:56 -0700
X-Trace: forums-1-dub 1094612456 10.22.108.75 (7 Sep 2004 20:00:56 -0700)
X-Original-Trace: 7 Sep 2004 20:00:56 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.datawindow.net:320
Article PK: 124750

Please post this question in the PowerBuilder.DataWindow newsgroup.
This newsgroup is for DataWindow .NET questions and issues.

Regards,
Dave Fish
Sybase

TeamSybase blogs: http://www.teamsybase.net/blogs


DataWindow.NET code examples available on CodeXchange:
http://datawindownet.codexchange.sybase.com

On 7 Sep 2004 11:09:59 -0700, robyn.jamison@bankofamerica.com wrote:

>We have a composite datawindow where the nested dataobjects
>and print specifications are set at run time. Once the user
>prints the report, the report scrolls properly. Until then,
>the first page is fine, but the second page is half blank,
>the third shows even less data and so on until about the
>fifth page through the end which display as totally blank
>pages.