Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

ASA 7 -> ASA 9

2 posts in General Discussion Last posting was on 2004-10-19 21:09:58.0Z
Andreas Hjortsberg Posted on 2004-10-18 13:33:02.0Z
From: Andreas Hjortsberg <andreas.hjortsberg@x-change.se>
Reply-To: andreas.hjortsberg@x-change.se
User-Agent: Mozilla Thunderbird 0.6 (Windows/20040502)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
Subject: ASA 7 -> ASA 9
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: 212.75.74.201
X-Original-NNTP-Posting-Host: 212.75.74.201
Message-ID: <4173c60e@forums-1-dub>
Date: 18 Oct 2004 06:33:02 -0700
X-Trace: forums-1-dub 1098106382 212.75.74.201 (18 Oct 2004 06:33:02 -0700)
X-Original-Trace: 18 Oct 2004 06:33:02 -0700, 212.75.74.201
Lines: 14
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:3746
Article PK: 7645

Hello!

I have unload an ASA 7 and reloaded it in to a ASA 9 and that seems to
be in order.
If I run one of my querys in iSQL I get the expected results, but then I
run my application which use jdbc:sybase:Tds and driver
com.sybase.jdbc2.jdbc.SybDriver the query can take about a couple of
minutes to run in ASA 9 (and seconds in ASA 7). I only have this problem
whit one query and basicly it's a join over an view and a table. I
haven't updated the driver/adaptor so which driver should I use.

Regards

/Andreas


Glenn Paulley Posted on 2004-10-19 21:09:58.0Z
Newsgroups: ianywhere.public.general
Subject: Re: ASA 7 -> ASA 9
From: Glenn Paulley <paulley@ianywhere.com>
References: <4173c60e@forums-1-dub>
Organization: iAnywhere Solutions
Message-ID: <Xns9587AE9F92945paulleyianywherecom@10.22.241.106>
User-Agent: Xnews/5.04.25
NNTP-Posting-Host: paulley-t41.sybase.com
X-Original-NNTP-Posting-Host: paulley-t41.sybase.com
Date: 19 Oct 2004 14:09:58 -0700
X-Trace: forums-1-dub 1098220198 10.25.99.149 (19 Oct 2004 14:09:58 -0700)
X-Original-Trace: 19 Oct 2004 14:09:58 -0700, paulley-t41.sybase.com
Lines: 40
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:3763
Article PK: 7666

Andreas Hjortsberg <andreas.hjortsberg@x-change.se> wrote in
news:4173c60e@forums-1-dub:

> Hello!
>
> I have unload an ASA 7 and reloaded it in to a ASA 9 and that seems to
> be in order.
> If I run one of my querys in iSQL I get the expected results, but then
I
> run my application which use jdbc:sybase:Tds and driver
> com.sybase.jdbc2.jdbc.SybDriver the query can take about a couple of
> minutes to run in ASA 9 (and seconds in ASA 7). I only have this
problem
> whit one query and basicly it's a join over an view and a table. I
> haven't updated the driver/adaptor so which driver should I use.
>
> Regards
>
> /Andreas
>

What is the graphical plan for the query when you connect over TDS?

Are you running the query as the same user (ie with the same connection
options)?

Can you please post the query and the view definition?

--
Glenn Paulley
Research and Development Manager, Query Processing
iAnywhere Solutions Engineering

EBF's and Patches: http://downloads.sybase.com
choose SQL Anywhere Studio >> change 'time frame' to all

To Submit Bug Reports: http://casexpress.sybase.com/cx/cx.stm

SQL Anywhere Studio Supported Platforms and Support Status
http://my.sybase.com/detail?id=1002288