Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

printer error and saveas error!

12 posts in Appeon (partner product) Last posting was on 2004-12-06 09:47:54.0Z
Robert Baluyot Posted on 2004-11-15 04:08:19.0Z
Sender: 769b.419828ef.1804289383@sybase.com
From: robert baluyot
Newsgroups: sybase.public.appeon
Subject: printer error and saveas error!
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <41982bb3.76c4.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 14 Nov 2004 20:08:19 -0800
X-Trace: forums-1-dub 1100491699 10.22.241.41 (14 Nov 2004 20:08:19 -0800)
X-Original-Trace: 14 Nov 2004 20:08:19 -0800, 10.22.241.41
Lines: 21
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:558
Article PK: 20800

hi,

I installed appeon on w2k sp4 and it works fine when i
preview you demo apps for sales. so for the apps works fine
but some datawindow on reports dont show. even i click the
print button apps will send printer error -1.

This also occur on save as button. with error message saveas
error -1:.

no message on log found to be a problem.

pdfwriter already setup on server and developer. and set it
as the default printer.

please help.


TIA

Robert


Julie Jiang Posted on 2004-11-15 08:24:12.0Z
From: "Julie Jiang" <julie.jiang@appeon.net>
Newsgroups: sybase.public.appeon
References: <41982bb3.76c4.1681692777@sybase.com>
Subject: Re: printer error and saveas error!
Lines: 42
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
NNTP-Posting-Host: 210.21.221.184
X-Original-NNTP-Posting-Host: 210.21.221.184
Message-ID: <419867ac@forums-1-dub>
Date: 15 Nov 2004 00:24:12 -0800
X-Trace: forums-1-dub 1100507052 210.21.221.184 (15 Nov 2004 00:24:12 -0800)
X-Original-Trace: 15 Nov 2004 00:24:12 -0800, 210.21.221.184
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:559
Article PK: 20798

Hi Robert,

If you run Appeon applications, make sure EAServer is started from Windows
Start menu, not started as a service or in debug mode. EAServer, if started
as a service, does not support PDF printing well.

If you already start EAServer from Windows start menu but still have the
error, please send the error screenshot to me. Besides, which Appeon
version you are using? Looks like you are using Appeon 2.7 because you
installed PDFWriter. If you use Appeon 2.8, Appeon 2.8 PDF does not work
with PDFWriter, but works with PDFPrinter that is included in the Appeon
installation package (you can find the installation link in the installation
main UI), so please switch to PDFPrinter.

Regards,
Julie

<robert baluyot> wrote in message
news:41982bb3.76c4.1681692777@sybase.com...
> hi,
>
> I installed appeon on w2k sp4 and it works fine when i
> preview you demo apps for sales. so for the apps works fine
> but some datawindow on reports dont show. even i click the
> print button apps will send printer error -1.
>
> This also occur on save as button. with error message saveas
> error -1:.
>
> no message on log found to be a problem.
>
> pdfwriter already setup on server and developer. and set it
> as the default printer.
>
> please help.
>
>
> TIA
>
> Robert


Rex Geissler Posted on 2004-11-15 19:01:41.0Z
From: "Rex Geissler" <Rex.Geissler@sybase.com>
Newsgroups: sybase.public.appeon
References: <41982bb3.76c4.1681692777@sybase.com> <419867ac@forums-1-dub>
Subject: Re: printer error and saveas error!
Lines: 60
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
NNTP-Posting-Host: rgeissle-w2k.sybase.com
X-Original-NNTP-Posting-Host: rgeissle-w2k.sybase.com
Message-ID: <4198fd15$1@forums-1-dub>
Date: 15 Nov 2004 11:01:41 -0800
X-Trace: forums-1-dub 1100545301 10.20.20.145 (15 Nov 2004 11:01:41 -0800)
X-Original-Trace: 15 Nov 2004 11:01:41 -0800, rgeissle-w2k.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:561
Article PK: 20801

Hi Robert,

Appeon also supports starting EAServer as a service from a third-party
service product such as Service + from http://www.activeplus.com, which
Sybase uses on the VMWare servers for our TrySybase applications at
http://www.trysybase.com. You can see a description of how to set Appeon up
as a service in the Appeon 2.6 Troubleshooting Guide (not 2.8) around
http://sybooks.sybase.com/onlinebooks/group-apn/apng0280e.

Regards, Rex

"Julie Jiang" <julie.jiang@appeon.net> wrote in message
news:419867ac@forums-1-dub...
> Hi Robert,
>
> If you run Appeon applications, make sure EAServer is started from Windows
> Start menu, not started as a service or in debug mode. EAServer, if
started
> as a service, does not support PDF printing well.
>
> If you already start EAServer from Windows start menu but still have the
> error, please send the error screenshot to me. Besides, which Appeon
> version you are using? Looks like you are using Appeon 2.7 because you
> installed PDFWriter. If you use Appeon 2.8, Appeon 2.8 PDF does not work
> with PDFWriter, but works with PDFPrinter that is included in the Appeon
> installation package (you can find the installation link in the
installation
> main UI), so please switch to PDFPrinter.
>
> Regards,
> Julie
>
> <robert baluyot> wrote in message
> news:41982bb3.76c4.1681692777@sybase.com...
> > hi,
> >
> > I installed appeon on w2k sp4 and it works fine when i
> > preview you demo apps for sales. so for the apps works fine
> > but some datawindow on reports dont show. even i click the
> > print button apps will send printer error -1.
> >
> > This also occur on save as button. with error message saveas
> > error -1:.
> >
> > no message on log found to be a problem.
> >
> > pdfwriter already setup on server and developer. and set it
> > as the default printer.
> >
> > please help.
> >
> >
> > TIA
> >
> > Robert
>
>


Robert Baluyot Posted on 2004-12-02 05:37:53.0Z
From: "robert baluyot" <bobot@astech.net.ph>
Newsgroups: sybase.public.appeon
Organization: 203.87.138.235
References: <419867ac@forums-1-dub> <41a1600d.1682.1681692777@sybase.com> <41a30afe@forums-1-dub> <41ac4741$1@forums-2-dub> <41ad2925$1@forums-1-dub>
X-Newsreader: AspNNTP 1.50 (Takeshi Eto)
Subject: Re: printer error and saveas error!
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: web110.discountasp.net
X-Original-NNTP-Posting-Host: web110.discountasp.net
Message-ID: <41aeaa31$3@forums-1-dub>
Date: 1 Dec 2004 21:37:53 -0800
X-Trace: forums-1-dub 1101965873 64.79.161.40 (1 Dec 2004 21:37:53 -0800)
X-Original-Trace: 1 Dec 2004 21:37:53 -0800, web110.discountasp.net
Lines: 110
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:605
Article PK: 20823

We are already running on PB 9 #7171. but dont know about pbvm. how do i check
it.

On 30 Nov 2004 18:15:01 -0800,
in sybase.public.appeon

Julie Jiang <julie.jiang@appeon.net> wrote:
>Hi Robert,
>
>Please upgrade your PowerBuilder and PBVM to the required versions.
>
>Appeon installation CD contains the installer for the required PowerBuilder
>and PBVM patches. For example, Appeon 2.8 Advanced Edition installation CD
>contains the installer for PowerBuilder #7171 and PBVM #7171.
>
>If you do not have Appeon installation CD, please get the required
>PowerBuilder and PBVM patches from http://downloads.sybase.com/.
>
>Regards,
>Julie
>
>"Robert Baluyot" <bobot@astech.net.ph> wrote in message
>news:41ac4741$1@forums-2-dub...
>> We are using PBVM comes from the installer (PBVM 9). With regards to
>> Powerbuilder, its PB9 with no patch.
>>
>> Thanks
>>
>> On 23 Nov 2004 02:03:42 -0800,
>> in sybase.public.appeon
>> Julie Jiang <julie.jiang@appeon.net> wrote:
>> >Hi Robert,
>> >
>> >Please provide the following information to me:
>> >
>> >1) Version of PowerBuilder used (PowerBuilder 8.0.4 10656 or PowerBuilder
>> >9.0.1 7171 is required)
>> >2) Version of PBVM used (PBVM 8.0.4 10656 or PBVM 9.0.1 7171 is required)
>> >3) Error screenshot
>> >4) Set the AEM | Server Properties | Web | Log Mode to debug, reproduce
>the
>> >problem, and the jaguar.log in %JAGUAR%\bin and logs in
>> >%JAGUAR%\bin\appeonlog.
>> >
>> >Regards,
>> >Julie
>> >
>> ><Robert E. Baluyot> wrote in message
>> >news:41a1600d.1682.1681692777@sybase.com...
>> >> After several re-installation from my Windows 2000 Advance
>> >> Server SP4. Still no luck running datawindow graphs and
>> >> reports. I still encounter no result for graph and reports
>> >> but with other free-form and tabular datawindows its working
>> >> great.
>> >>
>> >>
>> >> Please help.
>> >>
>> >>
>> >> TIA
>> >>
>> >>
>> >> > Hi Robert,
>> >> >
>> >> > If you run Appeon applications, make sure EAServer is
>> >> > started from Windows Start menu, not started as a service
>> >> > or in debug mode. EAServer, if started as a service, does
>> >> > not support PDF printing well.
>> >> >
>> >> > If you already start EAServer from Windows start menu but
>> >> > still have the error, please send the error screenshot to
>> >> > me. Besides, which Appeon version you are using? Looks
>> >> > like you are using Appeon 2.7 because you installed
>> >> > PDFWriter. If you use Appeon 2.8, Appeon 2.8 PDF does not
>> >> > work with PDFWriter, but works with PDFPrinter that is
>> >> > included in the Appeon installation package (you can find
>> >> > the installation link in the installation main UI), so
>> >> > please switch to PDFPrinter.
>> >> >
>> >> > Regards,
>> >> > Julie
>> >> >
>> >> > <robert baluyot> wrote in message
>> >> > news:41982bb3.76c4.1681692777@sybase.com...
>> >> > > hi,
>> >> > >
>> >> > > I installed appeon on w2k sp4 and it works fine when i
>> >> > > preview you demo apps for sales. so for the apps works
>> >> > > fine but some datawindow on reports dont show. even i
>> >> > > click the print button apps will send printer error -1.
>> >> > >
>> >> > > This also occur on save as button. with error message
>> >> > > saveas error -1:.
>> >> > >
>> >> > > no message on log found to be a problem.
>> >> > >
>> >> > > pdfwriter already setup on server and developer. and set
>> >> > > it as the default printer.
>> >> > >
>> >> > > please help.
>> >> > >
>> >> > >
>> >> > > TIA
>> >> > >
>> >> > > Robert
>> >> >
>> >> >
>> >
>> >
>
>


Julie Jiang Posted on 2004-12-03 01:17:37.0Z
From: "Julie Jiang" <julie.jiang@appeon.net>
Newsgroups: sybase.public.appeon
References: <419867ac@forums-1-dub> <41a1600d.1682.1681692777@sybase.com> <41a30afe@forums-1-dub> <41ac4741$1@forums-2-dub> <41ad2925$1@forums-1-dub> <41aeaa31$3@forums-1-dub>
Subject: Re: printer error and saveas error!
Lines: 141
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
NNTP-Posting-Host: 210.21.221.187
X-Original-NNTP-Posting-Host: 210.21.221.187
Message-ID: <41afbeb1@forums-1-dub>
Date: 2 Dec 2004 17:17:37 -0800
X-Trace: forums-1-dub 1102036657 210.21.221.187 (2 Dec 2004 17:17:37 -0800)
X-Original-Trace: 2 Dec 2004 17:17:37 -0800, 210.21.221.187
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:610
Article PK: 20825

Hi Robert,

Two major steps for you to get the PBVM version:
1) Get the location of the PBVM that is used by Appeon Server (this location
is specified during Appeon Server installation):
open the registry editor of the Appeon Server machine -->
go to the registry key -->
in the HKEY_LOCAL_MACHINE | SOFTWARE | Appeon | AS, you can get the data of
the PBVMVersion, which is the location.

2) Check the version of the PBVM:
go to the location found in step 1 -->
open the properties of pbvm90.dll -->
in the Version tab, you can find the complete version of the PBVM.

If the PBVM version is not 9.0 #7171, please install PBVM 9.0 #7171 to the
location found in step 1.

Regards,
Julie

"robert baluyot" <bobot@astech.net.ph> wrote in message
news:41aeaa31$3@forums-1-dub...
> We are already running on PB 9 #7171. but dont know about pbvm. how do i
check
> it.
>
> On 30 Nov 2004 18:15:01 -0800,
> in sybase.public.appeon
> Julie Jiang <julie.jiang@appeon.net> wrote:
> >Hi Robert,
> >
> >Please upgrade your PowerBuilder and PBVM to the required versions.
> >
> >Appeon installation CD contains the installer for the required
PowerBuilder
> >and PBVM patches. For example, Appeon 2.8 Advanced Edition installation
CD
> >contains the installer for PowerBuilder #7171 and PBVM #7171.
> >
> >If you do not have Appeon installation CD, please get the required
> >PowerBuilder and PBVM patches from http://downloads.sybase.com/.
> >
> >Regards,
> >Julie
> >
> >"Robert Baluyot" <bobot@astech.net.ph> wrote in message
> >news:41ac4741$1@forums-2-dub...
> >> We are using PBVM comes from the installer (PBVM 9). With regards to
> >> Powerbuilder, its PB9 with no patch.
> >>
> >> Thanks
> >>
> >> On 23 Nov 2004 02:03:42 -0800,
> >> in sybase.public.appeon
> >> Julie Jiang <julie.jiang@appeon.net> wrote:
> >> >Hi Robert,
> >> >
> >> >Please provide the following information to me:
> >> >
> >> >1) Version of PowerBuilder used (PowerBuilder 8.0.4 10656 or
PowerBuilder
> >> >9.0.1 7171 is required)
> >> >2) Version of PBVM used (PBVM 8.0.4 10656 or PBVM 9.0.1 7171 is
required)
> >> >3) Error screenshot
> >> >4) Set the AEM | Server Properties | Web | Log Mode to debug,
reproduce
> >the
> >> >problem, and the jaguar.log in %JAGUAR%\bin and logs in
> >> >%JAGUAR%\bin\appeonlog.
> >> >
> >> >Regards,
> >> >Julie
> >> >
> >> ><Robert E. Baluyot> wrote in message
> >> >news:41a1600d.1682.1681692777@sybase.com...
> >> >> After several re-installation from my Windows 2000 Advance
> >> >> Server SP4. Still no luck running datawindow graphs and
> >> >> reports. I still encounter no result for graph and reports
> >> >> but with other free-form and tabular datawindows its working
> >> >> great.
> >> >>
> >> >>
> >> >> Please help.
> >> >>
> >> >>
> >> >> TIA
> >> >>
> >> >>
> >> >> > Hi Robert,
> >> >> >
> >> >> > If you run Appeon applications, make sure EAServer is
> >> >> > started from Windows Start menu, not started as a service
> >> >> > or in debug mode. EAServer, if started as a service, does
> >> >> > not support PDF printing well.
> >> >> >
> >> >> > If you already start EAServer from Windows start menu but
> >> >> > still have the error, please send the error screenshot to
> >> >> > me. Besides, which Appeon version you are using? Looks
> >> >> > like you are using Appeon 2.7 because you installed
> >> >> > PDFWriter. If you use Appeon 2.8, Appeon 2.8 PDF does not
> >> >> > work with PDFWriter, but works with PDFPrinter that is
> >> >> > included in the Appeon installation package (you can find
> >> >> > the installation link in the installation main UI), so
> >> >> > please switch to PDFPrinter.
> >> >> >
> >> >> > Regards,
> >> >> > Julie
> >> >> >
> >> >> > <robert baluyot> wrote in message
> >> >> > news:41982bb3.76c4.1681692777@sybase.com...
> >> >> > > hi,
> >> >> > >
> >> >> > > I installed appeon on w2k sp4 and it works fine when i
> >> >> > > preview you demo apps for sales. so for the apps works
> >> >> > > fine but some datawindow on reports dont show. even i
> >> >> > > click the print button apps will send printer error -1.
> >> >> > >
> >> >> > > This also occur on save as button. with error message
> >> >> > > saveas error -1:.
> >> >> > >
> >> >> > > no message on log found to be a problem.
> >> >> > >
> >> >> > > pdfwriter already setup on server and developer. and set
> >> >> > > it as the default printer.
> >> >> > >
> >> >> > > please help.
> >> >> > >
> >> >> > >
> >> >> > > TIA
> >> >> > >
> >> >> > > Robert
> >> >> >
> >> >> >
> >> >
> >> >
> >
> >