Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

EJB Proxy Generation error

4 posts in EJB Client Last posting was on 2004-11-22 13:10:35.0Z
Bala Narasimhan Posted on 2004-11-19 00:08:36.0Z
From: "Bala Narasimhan" <bala.narasimhan@energy.sungard.com>
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: EJB Proxy Generation error
Lines: 19
Organization: Sungard Energy Systems
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
X-Original-NNTP-Posting-Host: 198.63.161.84
Message-ID: <419d3980$1@forums-2-dub>
X-Original-Trace: 18 Nov 2004 16:08:32 -0800, 198.63.161.84
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 18 Nov 2004 16:08:33 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 18 Nov 2004 16:08:36 -0800
X-Trace: forums-1-dub 1100822916 10.22.108.75 (18 Nov 2004 16:08:36 -0800)
X-Original-Trace: 18 Nov 2004 16:08:36 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:388
Article PK: 424563

PB 10 - Build 4510
I get the following errors when trying to generate proxies for an EJB...
Generation Errors: No binary file 'RemoteApplicationModule'
Deployment Errors: No files returned for package/component:
'com.company.prod.bc4j.com.dmn.common.ejb.beanmanaged.RemoteCompaniesModule'
. Error Code: Unknown. Proxy was not created.

I did have the jar file that contains the 'RemoteApplicationModule' into the
classpath using the Tools -> System Options -> Java tab.

is there any thing else i should be doing?

Thanks


Bede <bede_n Posted on 2004-11-19 10:10:26.0Z
From: Bede <bede_n@osp_am_sofico.be>
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: Re: EJB Proxy Generation error
Message-ID: <MPG.1c07e51c98ed7f0b989680@forums.sybase.com>
References: <419d3980$1@forums-2-dub>
Organization: Sofico
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-15"
Content-Transfer-Encoding: 7bit
User-Agent: MicroPlanet-Gravity/2.70.2067
NNTP-Posting-Host: uu194-7-38-226.unknown.uunet.be
X-Original-NNTP-Posting-Host: uu194-7-38-226.unknown.uunet.be
Date: 19 Nov 2004 02:10:26 -0800
X-Trace: forums-1-dub 1100859026 194.7.38.226 (19 Nov 2004 02:10:26 -0800)
X-Original-Trace: 19 Nov 2004 02:10:26 -0800, uu194-7-38-226.unknown.uunet.be
Lines: 33
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:389
Article PK: 424565

Hi, i'm not on PB10 yet but check out the previous posts on this matter

http://groups.google.com/groups?
hl=en&lr=&safe=off&q=powerbuilder.ejbclient+generate+proxies

try javap from the prompt and see what that gives.
also, make sure you have the latest EBF

Ben


In article <419d3980$1@forums-2-dub>, bala.narasimhan@energy.sungard.com
says...

> PB 10 - Build 4510
> I get the following errors when trying to generate proxies for an EJB...
> Generation Errors: No binary file 'RemoteApplicationModule'
> Deployment Errors: No files returned for package/component:
> 'com.company.prod.bc4j.com.dmn.common.ejb.beanmanaged.RemoteCompaniesModule'
> . Error Code: Unknown. Proxy was not created.
>
> I did have the jar file that contains the 'RemoteApplicationModule' into the
> classpath using the Tools -> System Options -> Java tab.
>
> is there any thing else i should be doing?
>
> Thanks
>
>
>
>
>
>
>


Bala Narasimhan Posted on 2004-11-19 15:00:36.0Z
From: "Bala Narasimhan" <bala.narasimhan@energy.sungard.com>
Newsgroups: sybase.public.powerbuilder.ejbclient
References: <419d3980$1@forums-2-dub> <MPG.1c07e51c98ed7f0b989680@forums.sybase.com>
Subject: Re: EJB Proxy Generation error
Lines: 46
Organization: Sungard Energy Systems
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
NNTP-Posting-Host: 198.63.161.84
X-Original-NNTP-Posting-Host: 198.63.161.84
Message-ID: <419e0a94$1@forums-1-dub>
Date: 19 Nov 2004 07:00:36 -0800
X-Trace: forums-1-dub 1100876436 198.63.161.84 (19 Nov 2004 07:00:36 -0800)
X-Original-Trace: 19 Nov 2004 07:00:36 -0800, 198.63.161.84
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:390
Article PK: 424564

got it. Thanks.
1. I added my jars into the "EJB Stub Classpath" (comma seperated) to get it
to work.
2. I had those jar files added to the classpath in Tools -> System
Options -> Java tab. Sounds like thats not the way.

"Bede" <bede_n@osp_am_sofico.be> wrote in message
news:MPG.1c07e51c98ed7f0b989680@forums.sybase.com...
> Hi, i'm not on PB10 yet but check out the previous posts on this matter
>
> http://groups.google.com/groups?
> hl=en&lr=&safe=off&q=powerbuilder.ejbclient+generate+proxies
>
> try javap from the prompt and see what that gives.
> also, make sure you have the latest EBF
>
> Ben
>
>
> In article <419d3980$1@forums-2-dub>, bala.narasimhan@energy.sungard.com
> says...
> > PB 10 - Build 4510
> > I get the following errors when trying to generate proxies for an EJB...
> > Generation Errors: No binary file 'RemoteApplicationModule'
> > Deployment Errors: No files returned for package/component:
> >
'com.company.prod.bc4j.com.dmn.common.ejb.beanmanaged.RemoteCompaniesModule'
> > . Error Code: Unknown. Proxy was not created.
> >
> > I did have the jar file that contains the 'RemoteApplicationModule' into
the
> > classpath using the Tools -> System Options -> Java tab.
> >
> > is there any thing else i should be doing?
> >
> > Thanks
> >
> >
> >
> >
> >
> >
> >


Bede <bede_n Posted on 2004-11-22 13:10:35.0Z
From: Bede <bede_n@osp_am_sofico.be>
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: Re: EJB Proxy Generation error
Message-ID: <MPG.1c0c03ba309b0027989681@forums.sybase.com>
References: <419d3980$1@forums-2-dub> <MPG.1c07e51c98ed7f0b989680@forums.sybase.com> <419e0a94$1@forums-1-dub>
Organization: Sofico
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-15"
Content-Transfer-Encoding: 7bit
User-Agent: MicroPlanet-Gravity/2.70.2067
NNTP-Posting-Host: uu194-7-38-226.unknown.uunet.be
X-Original-NNTP-Posting-Host: uu194-7-38-226.unknown.uunet.be
Date: 22 Nov 2004 05:10:35 -0800
X-Trace: forums-1-dub 1101129035 194.7.38.226 (22 Nov 2004 05:10:35 -0800)
X-Original-Trace: 22 Nov 2004 05:10:35 -0800, uu194-7-38-226.unknown.uunet.be
Lines: 51
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:393
Article PK: 424568

glad you did.. it's a bit like plug and pray

In article <419e0a94$1@forums-1-dub>, bala.narasimhan@energy.sungard.com
says...

> got it. Thanks.
> 1. I added my jars into the "EJB Stub Classpath" (comma seperated) to get it
> to work.
> 2. I had those jar files added to the classpath in Tools -> System
> Options -> Java tab. Sounds like thats not the way.
>
>
> "Bede" <bede_n@osp_am_sofico.be> wrote in message
> news:MPG.1c07e51c98ed7f0b989680@forums.sybase.com...
> > Hi, i'm not on PB10 yet but check out the previous posts on this matter
> >
> > http://groups.google.com/groups?
> > hl=en&lr=&safe=off&q=powerbuilder.ejbclient+generate+proxies
> >
> > try javap from the prompt and see what that gives.
> > also, make sure you have the latest EBF
> >
> > Ben
> >
> >
> > In article <419d3980$1@forums-2-dub>, bala.narasimhan@energy.sungard.com
> > says...
> > > PB 10 - Build 4510
> > > I get the following errors when trying to generate proxies for an EJB...
> > > Generation Errors: No binary file 'RemoteApplicationModule'
> > > Deployment Errors: No files returned for package/component:
> > >
> 'com.company.prod.bc4j.com.dmn.common.ejb.beanmanaged.RemoteCompaniesModule'
> > > . Error Code: Unknown. Proxy was not created.
> > >
> > > I did have the jar file that contains the 'RemoteApplicationModule' into
> the
> > > classpath using the Tools -> System Options -> Java tab.
> > >
> > > is there any thing else i should be doing?
> > >
> > > Thanks
> > >
> > >
> > >
> > >
> > >
> > >
> > >
>
>
>