Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

formatting datas in DataWindow not working

3 posts in Appeon (partner product) Last posting was on 2005-05-10 10:18:21.0Z
KamMin Posted on 2004-12-06 23:40:52.0Z
Sender: 321c.41b4b4f7.846930886@sybase.com
From: KamMin
Newsgroups: sybase.public.appeon
Subject: formatting datas in DataWindow not working
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <41b4ee04.3656.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 6 Dec 2004 15:40:52 -0800
X-Trace: forums-1-dub 1102376452 10.22.241.41 (6 Dec 2004 15:40:52 -0800)
X-Original-Trace: 6 Dec 2004 15:40:52 -0800, 10.22.241.41
Lines: 6
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:614
Article PK: 12622

I have a date in the fomat 'dd/mm/yy hh:mm:ss' that comes
from an Oracle database. If I use the Format tab for my date
to be 'dd mmm, yyyy' it displays as 'hh mm' on the web. If I
create a computed field and use the String function it
displays as 'yyyy-mm-dd'.
Is this another unsupported feature?


Julie Jiang Posted on 2004-12-07 08:41:19.0Z
From: "Julie Jiang" <julie.jiang@appeon.net>
Newsgroups: sybase.public.appeon
References: <41b4ee04.3656.1681692777@sybase.com>
Subject: Re: formatting datas in DataWindow not working
Lines: 63
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_000A_01C4DC7B.AD6C71B0"
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
NNTP-Posting-Host: 61.144.207.173
X-Original-NNTP-Posting-Host: 61.144.207.173
Message-ID: <41b56caf@forums-1-dub>
Date: 7 Dec 2004 00:41:19 -0800
X-Trace: forums-1-dub 1102408879 61.144.207.173 (7 Dec 2004 00:41:19 -0800)
X-Original-Trace: 7 Dec 2004 00:41:19 -0800, 61.144.207.173
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:615
Article PK: 20828

Format that contains "mmm" is unsupported, so when you set the format to "dd mmm, yyyy", the display goes incorrect.  When you use String function, the format for the string is read from the default format specified in Appeon AEM, and the default format in AEM is 'yyyy-mm-dd'.

You can get the supported information from Appeon Help, which can be accessed by clicking the Help icon in the Appeon Developer toolbar. 

For date values, the following are the supported formats:
Separator: "/", "-", 
Formats:
mm +separator + dd + separator + yy (eg. mm/dd/yy or mm-dd-yy)
dd + separator + mm + separator + yy
yy + separator + mm + separator + dd
mm + separator + dd + separator + yyyy
dd + separator + mm + separator + yyyy
yyyy + separator + mm + separator + dd

Regards,
Julie


jake Posted on 2005-05-10 10:18:21.0Z
From: "jake" <jake.wen@appeon.net>
Newsgroups: sybase.public.appeon
References: <41b4ee04.3656.1681692777@sybase.com> <41b56caf@forums-1-dub>
Subject: Re: formatting datas in DataWindow not working
Lines: 81
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_008E_01C5558C.FCCCF4C0"
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
NNTP-Posting-Host: 210.21.221.178
X-Original-NNTP-Posting-Host: 210.21.221.178
Message-ID: <42808a6d@forums-1-dub>
Date: 10 May 2005 03:18:21 -0700
X-Trace: forums-1-dub 1115720301 210.21.221.178 (10 May 2005 03:18:21 -0700)
X-Original-Trace: 10 May 2005 03:18:21 -0700, 210.21.221.178
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:835
Article PK: 12714

all right
"Julie Jiang" <julie.jiang@appeon.net> wrote in message news:41b56caf@forums-1-dub...
Format that contains "mmm" is unsupported, so when you set the format to "dd mmm, yyyy", the display goes incorrect.  When you use String function, the format for the string is read from the default format specified in Appeon AEM, and the default format in AEM is 'yyyy-mm-dd'.

You can get the supported information from Appeon Help, which can be accessed by clicking the Help icon in the Appeon Developer toolbar. 

For date values, the following are the supported formats:
Separator: "/", "-", 
Formats:
mm +separator + dd + separator + yy (eg. mm/dd/yy or mm-dd-yy)
dd + separator + mm + separator + yy
yy + separator + mm + separator + dd
mm + separator + dd + separator + yyyy
dd + separator + mm + separator + yyyy
yyyy + separator + mm + separator + dd

Regards,
Julie