Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

ASA 9.0.2 build 2451 (help, maybe it's bug?)

4 posts in General Discussion Last posting was on 2004-12-08 15:43:43.0Z
Ernikas Posted on 2004-12-08 14:09:22.0Z
From: "Ernikas" <Ernikas@xxx.lt>
Newsgroups: ianywhere.public.general
Subject: ASA 9.0.2 build 2451 (help, maybe it's bug?)
Lines: 33
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
X-Original-NNTP-Posting-Host: c1.edrana.lt
Message-ID: <41b70b10@forums-2-dub>
X-Original-Trace: 8 Dec 2004 06:09:20 -0800, c1.edrana.lt
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 8 Dec 2004 06:09:20 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 8 Dec 2004 06:09:22 -0800
X-Trace: forums-1-dub 1102514962 10.22.108.75 (8 Dec 2004 06:09:22 -0800)
X-Original-Trace: 8 Dec 2004 06:09:22 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:3943
Article PK: 7838

Hi,

After migrating from ASA 8.02 to ASA 9.02 we get a problem with number
function.
This script illustrate our problem:
===================
begin
declare @i integer;
create table #testTo(numeris integer);
create table #testFrom(Laukas1 integer,Laukas2 integer);
select 1 into @i;
while @i<=10 loop
insert into #testFrom(Laukas1,Laukas2) values (@i,@i);
select @i+1 into @i
end loop;
insert into #testTo(numeris) select number(*) from #testFrom group by
Laukas1,Laukas2;
select * from #testTo;
end;
===================
ASA 9.02 build 2451 return wrong values. They return only zero values.
ASA 8 and ASA 9.0.1 returns correct values.

Can anybody explain this problem?
There is a bug?

Thanks

Ernikas
From Lithuania


Chris Keating (iAnywhere Solutions) Posted on 2004-12-08 14:23:15.0Z
From: "Chris Keating \(iAnywhere Solutions\)" <Spam_NoThanks_keating@iAnywhere.com>
Newsgroups: ianywhere.public.general
References: <41b70b10@forums-2-dub>
Subject: Re: ASA 9.0.2 build 2451 (help, maybe it's bug?)
Lines: 39
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Original
X-Original-NNTP-Posting-Host: keating-xp2.sybase.com
Message-ID: <41b70e4f$1@forums-2-dub>
X-Original-Trace: 8 Dec 2004 06:23:11 -0800, keating-xp2.sybase.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 8 Dec 2004 06:23:12 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 8 Dec 2004 06:23:15 -0800
X-Trace: forums-1-dub 1102515795 10.22.108.75 (8 Dec 2004 06:23:15 -0800)
X-Original-Trace: 8 Dec 2004 06:23:15 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:3944
Article PK: 7834

This is fixed in 9.0.2 EBF build 2537.

"Ernikas" <Ernikas@xxx.lt> wrote in message news:41b70b10@forums-2-dub...
> Hi,
>
> After migrating from ASA 8.02 to ASA 9.02 we get a problem with number
> function.
> This script illustrate our problem:
> ===================
> begin
> declare @i integer;
> create table #testTo(numeris integer);
> create table #testFrom(Laukas1 integer,Laukas2 integer);
> select 1 into @i;
> while @i<=10 loop
> insert into #testFrom(Laukas1,Laukas2) values (@i,@i);
> select @i+1 into @i
> end loop;
> insert into #testTo(numeris) select number(*) from #testFrom group by
> Laukas1,Laukas2;
> select * from #testTo;
> end;
> ===================
> ASA 9.02 build 2451 return wrong values. They return only zero values.
> ASA 8 and ASA 9.0.1 returns correct values.
>
> Can anybody explain this problem?
> There is a bug?
>
> Thanks
>
> Ernikas
> From Lithuania
>
>
>


Ernikas Posted on 2004-12-08 15:32:45.0Z
From: "Ernikas" <Ernikas@xxx.lt>
Newsgroups: ianywhere.public.general
References: <41b70b10@forums-2-dub> <41b70e4f$1@forums-2-dub>
Subject: Re: ASA 9.0.2 build 2451 (help, maybe it's bug?)
Lines: 47
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
X-Original-NNTP-Posting-Host: c1.edrana.lt
Message-ID: <41b71e99$1@forums-2-dub>
X-Original-Trace: 8 Dec 2004 07:32:41 -0800, c1.edrana.lt
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 8 Dec 2004 07:32:42 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 8 Dec 2004 07:32:45 -0800
X-Trace: forums-1-dub 1102519965 10.22.108.75 (8 Dec 2004 07:32:45 -0800)
X-Original-Trace: 8 Dec 2004 07:32:45 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:3945
Article PK: 7837

When it will be publishing at http://downloads.sybase.com

Ernikas

"Chris Keating (iAnywhere Solutions)" <Spam_NoThanks_keating@iAnywhere.com>

wrote in message news:41b70e4f$1@forums-2-dub...
> This is fixed in 9.0.2 EBF build 2537.
>
>
> "Ernikas" <Ernikas@xxx.lt> wrote in message news:41b70b10@forums-2-dub...
> > Hi,
> >
> > After migrating from ASA 8.02 to ASA 9.02 we get a problem with number
> > function.
> > This script illustrate our problem:
> > ===================
> > begin
> > declare @i integer;
> > create table #testTo(numeris integer);
> > create table #testFrom(Laukas1 integer,Laukas2 integer);
> > select 1 into @i;
> > while @i<=10 loop
> > insert into #testFrom(Laukas1,Laukas2) values (@i,@i);
> > select @i+1 into @i
> > end loop;
> > insert into #testTo(numeris) select number(*) from #testFrom group by
> > Laukas1,Laukas2;
> > select * from #testTo;
> > end;
> > ===================
> > ASA 9.02 build 2451 return wrong values. They return only zero values.
> > ASA 8 and ASA 9.0.1 returns correct values.
> >
> > Can anybody explain this problem?
> > There is a bug?
> >
> > Thanks
> >
> > Ernikas
> > From Lithuania
> >
> >
> >
>
>


Breck Carter [TeamSybase] Posted on 2004-12-08 15:43:43.0Z
From: "Breck Carter [TeamSybase]" <NOSPAM__bcarter@risingroad.com>
Newsgroups: ianywhere.public.general
Subject: Re: ASA 9.0.2 build 2451 (help, maybe it's bug?)
Organization: RisingRoad Professional Services
Reply-To: NOSPAM__bcarter@risingroad.com
Message-ID: <088er0tmpknqlk9te22ck09ho81g9englb@4ax.com>
References: <41b70b10@forums-2-dub>
X-Newsreader: Forte Agent 2.0/32.640
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: bcarter.sentex.ca
X-Original-Trace: 8 Dec 2004 07:43:38 -0800, bcarter.sentex.ca
Lines: 52
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 8 Dec 2004 07:43:39 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 8 Dec 2004 07:43:43 -0800
X-Trace: forums-1-dub 1102520623 10.22.108.75 (8 Dec 2004 07:43:43 -0800)
X-Original-Trace: 8 Dec 2004 07:43:43 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:3946
Article PK: 7836

See this newsgroup thread for a couple of workarounds, until the next
EBF is published:

Newsgroups: sybase.public.sqlanywhere.general
From: "John De Lello" <JohnD_NO_S...@DelWare.com>
Date: 27 Nov 2004 20:47:18 -0800
Local: Sat, Nov 27 2004 8:47 pm
Subject: Number(*) problem in 9.0.2.2451

Breck

On 8 Dec 2004 06:09:22 -0800, "Ernikas" <Ernikas@xxx.lt> wrote:

>Hi,
>
>After migrating from ASA 8.02 to ASA 9.02 we get a problem with number
>function.
>This script illustrate our problem:
>===================
>begin
>declare @i integer;
>create table #testTo(numeris integer);
>create table #testFrom(Laukas1 integer,Laukas2 integer);
>select 1 into @i;
>while @i<=10 loop
> insert into #testFrom(Laukas1,Laukas2) values (@i,@i);
> select @i+1 into @i
>end loop;
>insert into #testTo(numeris) select number(*) from #testFrom group by
>Laukas1,Laukas2;
>select * from #testTo;
>end;
>===================
>ASA 9.02 build 2451 return wrong values. They return only zero values.
>ASA 8 and ASA 9.0.1 returns correct values.
>
>Can anybody explain this problem?
>There is a bug?
>
>Thanks
>
>Ernikas
>From Lithuania
>
>

--
SQL Anywhere Studio 9 Developer's Guide
Buy the book: http://www.amazon.com/exec/obidos/ASIN/1556225067/risingroad-20
bcarter@risingroad.com
RisingRoad SQL Anywhere and MobiLink Professional Services
www.risingroad.com