Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

DW.NET 1.5 Beta - Possible bug

3 posts in DataWindow .NET Last posting was on 2004-12-14 23:37:46.0Z
Christopher Todd Posted on 2004-12-10 03:43:04.0Z
Sender: 24b9.41b91459.1804289383@sybase.com
From: Christopher TOdd
Newsgroups: sybase.public.datawindow.net
Subject: DW.NET 1.5 Beta - Possible bug
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <41b91b43.2655.1681692777@sybase.com>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 9 Dec 2004 19:42:59 -0800, 10.22.241.42
Lines: 19
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 9 Dec 2004 19:43:02 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 9 Dec 2004 19:43:04 -0800
X-Trace: forums-1-dub 1102650184 10.22.108.75 (9 Dec 2004 19:43:04 -0800)
X-Original-Trace: 9 Dec 2004 19:43:04 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.datawindow.net:959
Article PK: 125385

I can't seem to get a value other than 0 out of the rowcount
property (at any point in my code)

I am a beginner at ASP.NET (but very seasoned at PB) so I am
giving it my best shot. If this works out, I may be doing
more web development in the future. So, far I am impressed
w/ how easy it is to use!!

I have a webform that contains a DW that inserts a record at
the beginning of the page_load event. However, when I update
and commit the results, the page_load event gets kicked off
again. This causes the DW to insert another record. I wanted
to check the DW to see if it had zero records but ofcourse
it is always zero even when it is not suppose to. I tried it
out on a DW that I retrieved and had around 10 or so
records. It still said zero.

Thanks,
Chris.


dfish Posted on 2004-12-14 03:57:58.0Z
From: dfish@_no_spam_sybase.com (Dave Fish [Team Sybase])
Newsgroups: sybase.public.datawindow.net
Subject: Re: DW.NET 1.5 Beta - Possible bug
Organization: Sybase Professional Services
Reply-To: nospam_dfish@sybase.com_nospam
Message-ID: <41be5973.8463730@forums.sybase.com>
References: <41b91b43.2655.1681692777@sybase.com>
X-Newsreader: Forte Free Agent 1.21/32.243
NNTP-Posting-Host: vpn-dub-041.sybase.com
X-Original-NNTP-Posting-Host: vpn-dub-041.sybase.com
Date: 13 Dec 2004 19:57:58 -0800
X-Trace: forums-1-dub 1102996678 10.22.120.41 (13 Dec 2004 19:57:58 -0800)
X-Original-Trace: 13 Dec 2004 19:57:58 -0800, vpn-dub-041.sybase.com
Lines: 47
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.datawindow.net:1034
Article PK: 125457

Sorry for the delay in responding. You want to check in your code to
see if it is a postback or not.

In Visual Basic .NET:

If Not IsPostBack Then

'Initial Page Load

Else
'A Postback has occurred
End If

Regards,
Dave Fish
Sybase

DataWindow .NET Webcast December 16, 2004:
www.customermining.com/Sybase/NETRegPage.html

TeamSybase blogs: http://www.teamsybase.net/blogs

DataWindow.NET code examples available on CodeXchange:
http://datawindownet.codexchange.sybase.com

On 9 Dec 2004 19:43:04 -0800, Christopher TOdd wrote:

>I can't seem to get a value other than 0 out of the rowcount
>property (at any point in my code)
>
>I am a beginner at ASP.NET (but very seasoned at PB) so I am
>giving it my best shot. If this works out, I may be doing
>more web development in the future. So, far I am impressed
>w/ how easy it is to use!!
>
>I have a webform that contains a DW that inserts a record at
>the beginning of the page_load event. However, when I update
>and commit the results, the page_load event gets kicked off
>again. This causes the DW to insert another record. I wanted
>to check the DW to see if it had zero records but ofcourse
>it is always zero even when it is not suppose to. I tried it
>out on a DW that I retrieved and had around 10 or so
>records. It still said zero.
>
>Thanks,
>Chris.


Christopher Todd Posted on 2004-12-14 23:37:46.0Z
Sender: 2658.41b91b6f.1804289383@sybase.com
From: Christopher Todd
Newsgroups: sybase.public.datawindow.net
Subject: Re: DW.NET 1.5 Beta - Possible bug
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <41bf7945.66b1.1681692777@sybase.com>
References: <41be5973.8463730@forums.sybase.com>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 14 Dec 2004 15:37:41 -0800, 10.22.241.42
Lines: 53
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 14 Dec 2004 15:37:44 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 14 Dec 2004 15:37:46 -0800
X-Trace: forums-1-dub 1103067466 10.22.108.75 (14 Dec 2004 15:37:46 -0800)
X-Original-Trace: 14 Dec 2004 15:37:46 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.datawindow.net:1066
Article PK: 125492

What about the rowcount? Does it not work or am I doing it
wrong?

Thanks,
Chris.

> Sorry for the delay in responding. You want to check in
> your code to see if it is a postback or not.
>
> In Visual Basic .NET:
>
> If Not IsPostBack Then
>
> 'Initial Page Load
>
> Else
> 'A Postback has occurred
> End If
>
> Regards,
> Dave Fish
> Sybase
>
> DataWindow .NET Webcast December 16, 2004:
> www.customermining.com/Sybase/NETRegPage.html
>
> TeamSybase blogs: http://www.teamsybase.net/blogs
>
> DataWindow.NET code examples available on CodeXchange:
> http://datawindownet.codexchange.sybase.com
>
> On 9 Dec 2004 19:43:04 -0800, Christopher TOdd wrote:
>
> >I can't seem to get a value other than 0 out of the
> rowcount >property (at any point in my code)
> >
> >I am a beginner at ASP.NET (but very seasoned at PB) so I
> am >giving it my best shot. If this works out, I may be
> doing >more web development in the future. So, far I am
> impressed >w/ how easy it is to use!!
> >
> >I have a webform that contains a DW that inserts a record
> at >the beginning of the page_load event. However, when I
> update >and commit the results, the page_load event gets
> kicked off >again. This causes the DW to insert another
> record. I wanted >to check the DW to see if it had zero
> records but ofcourse >it is always zero even when it is
> not suppose to. I tried it >out on a DW that I retrieved
> and had around 10 or so >records. It still said zero.
> >
> >Thanks,
> >Chris.
>