Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

DW 1.5 - DataWindowControl disabled

9 posts in DataWindow .NET Last posting was on 2004-12-14 15:16:48.0Z
John Hnat Posted on 2004-12-13 14:52:07.0Z
Sender: 6632.41b9d6ba.1804289383@sybase.com
From: John Hnat
Newsgroups: sybase.public.datawindow.net
Subject: DW 1.5 - DataWindowControl disabled
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <41bdac97.2df9.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 13 Dec 2004 06:52:07 -0800
X-Trace: forums-1-dub 1102949527 10.22.241.41 (13 Dec 2004 06:52:07 -0800)
X-Original-Trace: 13 Dec 2004 06:52:07 -0800, 10.22.241.41
Lines: 7
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.datawindow.net:1006
Article PK: 125435

I've installed the DW 1.5 beta, and the Sybase DataWindow
1.5 control is appearing in my Toolbox. However, when I
open the Toolbox, the DataWindowControl option is disabled.
The other options (Transaction and DataStore) are enabled.

I'm hoping there is a "duh"-level answer to this issue. Any
ideas? Thanks...


dfish Posted on 2004-12-13 15:42:32.0Z
From: dfish@_no_spam_sybase.com (Dave Fish [Team Sybase])
Newsgroups: sybase.public.datawindow.net
Subject: Re: DW 1.5 - DataWindowControl disabled
Organization: Sybase Professional Services
Reply-To: nospam_dfish@sybase.com_nospam
Message-ID: <41bdb7d0.138551356@forums.sybase.com>
References: <41bdac97.2df9.1681692777@sybase.com>
X-Newsreader: Forte Free Agent 1.21/32.243
NNTP-Posting-Host: vpn-dub-080.sybase.com
X-Original-NNTP-Posting-Host: vpn-dub-080.sybase.com
Date: 13 Dec 2004 07:42:32 -0800
X-Trace: forums-1-dub 1102952552 10.22.120.80 (13 Dec 2004 07:42:32 -0800)
X-Original-Trace: 13 Dec 2004 07:42:32 -0800, vpn-dub-080.sybase.com
Lines: 26
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.datawindow.net:1009
Article PK: 125433

Are you sure you have 1.5 installed? In a webform application you
should see the WebDataWindowControl and SreamImageContainer controls
on the Sybase DataWindow 1.5 toolbox tab. The DataWindow control will
be disabled. On a winform application the WebDataWindowControl and
SreamImageContainer controls will be disabled and the DataWindow
Control will be enabled.

Regards,
Dave Fish
Sybase

TeamSybase blogs: http://www.teamsybase.net/blogs

DataWindow.NET code examples available on CodeXchange:
http://datawindownet.codexchange.sybase.com

On 13 Dec 2004 06:52:07 -0800, John Hnat wrote:

>I've installed the DW 1.5 beta, and the Sybase DataWindow
>1.5 control is appearing in my Toolbox. However, when I
>open the Toolbox, the DataWindowControl option is disabled.
>The other options (Transaction and DataStore) are enabled.
>
>I'm hoping there is a "duh"-level answer to this issue. Any
>ideas? Thanks...


John Hnat Posted on 2004-12-13 15:51:03.0Z
Sender: 6632.41b9d6ba.1804289383@sybase.com
From: John Hnat
Newsgroups: sybase.public.datawindow.net
Subject: Re: DW 1.5 - DataWindowControl disabled
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <41bdba67.2f52.1681692777@sybase.com>
References: <41bdb7d0.138551356@forums.sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 13 Dec 2004 07:51:03 -0800
X-Trace: forums-1-dub 1102953063 10.22.241.41 (13 Dec 2004 07:51:03 -0800)
X-Original-Trace: 13 Dec 2004 07:51:03 -0800, 10.22.241.41
Lines: 42
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.datawindow.net:1010
Article PK: 125436

Hi Dave,

Yes, I definitely downloaded and installed the 1.5 beta.
When I open VS and go to the Toolbox, the DW control is
called Sybase DataWindow 1.5. (I can e-mail a screen shot
if you would like.)

Some weeks ago, I did download the DW .NET 1.0 evaluation
copy. Is it possible that this is causing the problem?
Perhaps I should try un-installing and re-installing DW .NET
1.5?

> Are you sure you have 1.5 installed? In a webform
> application you should see the WebDataWindowControl and
> SreamImageContainer controls on the Sybase DataWindow 1.5
> toolbox tab. The DataWindow control will be disabled. On a
> winform application the WebDataWindowControl and
> SreamImageContainer controls will be disabled and the
> DataWindow Control will be enabled.
>
> Regards,
> Dave Fish
> Sybase
>
> TeamSybase blogs: http://www.teamsybase.net/blogs
>
> DataWindow.NET code examples available on CodeXchange:
> http://datawindownet.codexchange.sybase.com
>
> On 13 Dec 2004 06:52:07 -0800, John Hnat wrote:
>
> >I've installed the DW 1.5 beta, and the Sybase DataWindow
> >1.5 control is appearing in my Toolbox. However, when I
> >open the Toolbox, the DataWindowControl option is
> disabled. >The other options (Transaction and DataStore)
> are enabled. >
> >I'm hoping there is a "duh"-level answer to this issue.
> Any >ideas? Thanks...
>


dfish Posted on 2004-12-13 16:33:54.0Z
From: dfish@_no_spam_sybase.com (Dave Fish [Team Sybase])
Newsgroups: sybase.public.datawindow.net
Subject: Re: DW 1.5 - DataWindowControl disabled
Organization: Sybase Professional Services
Reply-To: nospam_dfish@sybase.com_nospam
Message-ID: <41bdc424.141707344@forums.sybase.com>
References: <41bdb7d0.138551356@forums.sybase.com> <41bdba67.2f52.1681692777@sybase.com>
X-Newsreader: Forte Free Agent 1.21/32.243
NNTP-Posting-Host: vpn-dub-080.sybase.com
X-Original-NNTP-Posting-Host: vpn-dub-080.sybase.com
Date: 13 Dec 2004 08:33:54 -0800
X-Trace: forums-1-dub 1102955634 10.22.120.80 (13 Dec 2004 08:33:54 -0800)
X-Original-Trace: 13 Dec 2004 08:33:54 -0800, vpn-dub-080.sybase.com
Lines: 60
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.datawindow.net:1013
Article PK: 125439

Hi John,

I would try uninstalling DataWindow .NET 1.5 (and 1.0 if it is still
on your machine). Then run the install again. It sounds like something
has gotten confused on your system.

Regards,
Dave Fish
Sybase

TeamSybase blogs: http://www.teamsybase.net/blogs

DataWindow.NET code examples available on CodeXchange:
http://datawindownet.codexchange.sybase.com

On 13 Dec 2004 07:51:03 -0800, John Hnat wrote:

>Hi Dave,
>
>Yes, I definitely downloaded and installed the 1.5 beta.
>When I open VS and go to the Toolbox, the DW control is
>called Sybase DataWindow 1.5. (I can e-mail a screen shot
>if you would like.)
>
>Some weeks ago, I did download the DW .NET 1.0 evaluation
>copy. Is it possible that this is causing the problem?
>Perhaps I should try un-installing and re-installing DW .NET
>1.5?
>
>
>
>
>> Are you sure you have 1.5 installed? In a webform
>> application you should see the WebDataWindowControl and
>> SreamImageContainer controls on the Sybase DataWindow 1.5
>> toolbox tab. The DataWindow control will be disabled. On a
>> winform application the WebDataWindowControl and
>> SreamImageContainer controls will be disabled and the
>> DataWindow Control will be enabled.
>>
>> Regards,
>> Dave Fish
>> Sybase
>>
>> TeamSybase blogs: http://www.teamsybase.net/blogs
>>
>> DataWindow.NET code examples available on CodeXchange:
>> http://datawindownet.codexchange.sybase.com
>>
>> On 13 Dec 2004 06:52:07 -0800, John Hnat wrote:
>>
>> >I've installed the DW 1.5 beta, and the Sybase DataWindow
>> >1.5 control is appearing in my Toolbox. However, when I
>> >open the Toolbox, the DataWindowControl option is
>> disabled. >The other options (Transaction and DataStore)
>> are enabled. >
>> >I'm hoping there is a "duh"-level answer to this issue.
>> Any >ideas? Thanks...
>>


John Hnat Posted on 2004-12-13 19:13:34.0Z
Sender: 329d.41bddafb.1804289383@sybase.com
From: John Hnat
Newsgroups: sybase.public.datawindow.net
Subject: Re: DW 1.5 - DataWindowControl disabled
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <41bde9de.3423.1681692777@sybase.com>
References: <41bdc424.141707344@forums.sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 13 Dec 2004 11:13:34 -0800
X-Trace: forums-1-dub 1102965214 10.22.241.41 (13 Dec 2004 11:13:34 -0800)
X-Original-Trace: 13 Dec 2004 11:13:34 -0800, 10.22.241.41
Lines: 75
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.datawindow.net:1023
Article PK: 125448

Dave,

I uninstalled DW .NET 1.5 and reinstalled it, and I am
getting the same behavior -- no WebFormDataWindowControl and
a grayed out DataWindowControl.

Any more ideas?

Has anybody else been able to successfully install DW .NET
1.5 on a machine that previously had version 1.0 installed
on it?

> Hi John,
>
> I would try uninstalling DataWindow .NET 1.5 (and 1.0 if
> it is still on your machine). Then run the install again.
> It sounds like something has gotten confused on your
> system.
>
> Regards,
> Dave Fish
> Sybase
>
> TeamSybase blogs: http://www.teamsybase.net/blogs
>
> DataWindow.NET code examples available on CodeXchange:
> http://datawindownet.codexchange.sybase.com
>
> On 13 Dec 2004 07:51:03 -0800, John Hnat wrote:
>
> >Hi Dave,
> >
> >Yes, I definitely downloaded and installed the 1.5 beta.
> >When I open VS and go to the Toolbox, the DW control is
> >called Sybase DataWindow 1.5. (I can e-mail a screen
> shot >if you would like.)
> >
> >Some weeks ago, I did download the DW .NET 1.0 evaluation
> >copy. Is it possible that this is causing the problem?
> >Perhaps I should try un-installing and re-installing DW
> NET >1.5?
> >
> >
> >
> >
> >> Are you sure you have 1.5 installed? In a webform
> >> application you should see the WebDataWindowControl and
> >> SreamImageContainer controls on the Sybase DataWindow
> 1.5 >> toolbox tab. The DataWindow control will be
> disabled. On a >> winform application the
> WebDataWindowControl and >> SreamImageContainer controls
> will be disabled and the >> DataWindow Control will be
> enabled. >>
> >> Regards,
> >> Dave Fish
> >> Sybase
> >>
> >> TeamSybase blogs: http://www.teamsybase.net/blogs
> >>
> >> DataWindow.NET code examples available on CodeXchange:
> >> http://datawindownet.codexchange.sybase.com
> >>
> >> On 13 Dec 2004 06:52:07 -0800, John Hnat wrote:
> >>
> >> >I've installed the DW 1.5 beta, and the Sybase
> DataWindow >> >1.5 control is appearing in my Toolbox.
> However, when I >> >open the Toolbox, the
> DataWindowControl option is >> disabled. >The other
> options (Transaction and DataStore) >> are enabled. >
> >> >I'm hoping there is a "duh"-level answer to this
> issue. >> Any >ideas? Thanks...
> >>
>


Jim Madderra Posted on 2004-12-14 00:44:45.0Z
Reply-To: "Jim Madderra" <powrsite_software@msn.com>
From: "Jim Madderra" <powrsite_software@msn.com>
Newsgroups: sybase.public.datawindow.net
References: <41bdc424.141707344@forums.sybase.com> <41bde9de.3423.1681692777@sybase.com>
Subject: Re: DW 1.5 - DataWindowControl disabled
Lines: 84
Organization: PowrSite Software, Inc
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: astound-66-234-222-207.ca.astound.net
X-Original-NNTP-Posting-Host: astound-66-234-222-207.ca.astound.net
Message-ID: <41be377d$1@forums-1-dub>
Date: 13 Dec 2004 16:44:45 -0800
X-Trace: forums-1-dub 1102985085 66.234.222.207 (13 Dec 2004 16:44:45 -0800)
X-Original-Trace: 13 Dec 2004 16:44:45 -0800, astound-66-234-222-207.ca.astound.net
X-Authenticated-User: pbtenbeta
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.datawindow.net:1030
Article PK: 125456

No, I had to "manually" put things back together (by adding/removing buttons
and assigning them to the proper "exe's").

Worked like a charm on a virgin system but not on one that had previous Beta
and PB10 with 1.0 on it.

<John Hnat> wrote in message news:41bde9de.3423.1681692777@sybase.com...
> Dave,
>
> I uninstalled DW .NET 1.5 and reinstalled it, and I am
> getting the same behavior -- no WebFormDataWindowControl and
> a grayed out DataWindowControl.
>
> Any more ideas?
>
> Has anybody else been able to successfully install DW .NET
> 1.5 on a machine that previously had version 1.0 installed
> on it?
>
>
>
>> Hi John,
>>
>> I would try uninstalling DataWindow .NET 1.5 (and 1.0 if
>> it is still on your machine). Then run the install again.
>> It sounds like something has gotten confused on your
>> system.
>>
>> Regards,
>> Dave Fish
>> Sybase
>>
>> TeamSybase blogs: http://www.teamsybase.net/blogs
>>
>> DataWindow.NET code examples available on CodeXchange:
>> http://datawindownet.codexchange.sybase.com
>>
>> On 13 Dec 2004 07:51:03 -0800, John Hnat wrote:
>>
>> >Hi Dave,
>> >
>> >Yes, I definitely downloaded and installed the 1.5 beta.
>> >When I open VS and go to the Toolbox, the DW control is
>> >called Sybase DataWindow 1.5. (I can e-mail a screen
>> shot >if you would like.)
>> >
>> >Some weeks ago, I did download the DW .NET 1.0 evaluation
>> >copy. Is it possible that this is causing the problem?
>> >Perhaps I should try un-installing and re-installing DW
>> NET >1.5?
>> >
>> >
>> >
>> >
>> >> Are you sure you have 1.5 installed? In a webform
>> >> application you should see the WebDataWindowControl and
>> >> SreamImageContainer controls on the Sybase DataWindow
>> 1.5 >> toolbox tab. The DataWindow control will be
>> disabled. On a >> winform application the
>> WebDataWindowControl and >> SreamImageContainer controls
>> will be disabled and the >> DataWindow Control will be
>> enabled. >>
>> >> Regards,
>> >> Dave Fish
>> >> Sybase
>> >>
>> >> TeamSybase blogs: http://www.teamsybase.net/blogs
>> >>
>> >> DataWindow.NET code examples available on CodeXchange:
>> >> http://datawindownet.codexchange.sybase.com
>> >>
>> >> On 13 Dec 2004 06:52:07 -0800, John Hnat wrote:
>> >>
>> >> >I've installed the DW 1.5 beta, and the Sybase
>> DataWindow >> >1.5 control is appearing in my Toolbox.
>> However, when I >> >open the Toolbox, the
>> DataWindowControl option is >> disabled. >The other
>> options (Transaction and DataStore) >> are enabled. >
>> >> >I'm hoping there is a "duh"-level answer to this
>> issue. >> Any >ideas? Thanks...
>> >>
>>


John Hnat Posted on 2004-12-14 12:28:30.0Z
Sender: 434e.41bedafe.1804289383@sybase.com
From: John Hnat
Newsgroups: sybase.public.datawindow.net
Subject: Re: DW 1.5 - DataWindowControl disabled
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <41bedc6e.4364.1681692777@sybase.com>
References: <41be377d$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 14 Dec 2004 04:28:30 -0800
X-Trace: forums-1-dub 1103027310 10.22.241.41 (14 Dec 2004 04:28:30 -0800)
X-Original-Trace: 14 Dec 2004 04:28:30 -0800, 10.22.241.41
Lines: 99
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.datawindow.net:1041
Article PK: 125466

Jim, could you elaborate further on what you did to get it
to work? Like your machine, mine currently has PB10
installed, and had DW .NET 1.0 at one point. I've
uninstalled DW .NET and made sure that all vestiges of
DataWindow.DLL and WebDataWindow.DLL were removed (the
uninstaller did not remove all of them), but reinstalling
after doing that still did not work.

Sybase folks: any further ideas on how to solve this
problem, especially since it seems like it will affect
anybody who had version 1.0 installed?

> No, I had to "manually" put things back together (by
> adding/removing buttons and assigning them to the proper
> "exe's").
>
> Worked like a charm on a virgin system but not on one that
> had previous Beta and PB10 with 1.0 on it.
>
> <John Hnat> wrote in message
> > news:41bde9de.3423.1681692777@sybase.com... Dave,
> >
> > I uninstalled DW .NET 1.5 and reinstalled it, and I am
> > getting the same behavior -- no WebFormDataWindowControl
> > and a grayed out DataWindowControl.
> >
> > Any more ideas?
> >
> > Has anybody else been able to successfully install DW
> > .NET 1.5 on a machine that previously had version 1.0
> > installed on it?
> >
> >
> >
> >> Hi John,
> >>
> >> I would try uninstalling DataWindow .NET 1.5 (and 1.0
> if >> it is still on your machine). Then run the install
> again. >> It sounds like something has gotten confused on
> your >> system.
> >>
> >> Regards,
> >> Dave Fish
> >> Sybase
> >>
> >> TeamSybase blogs: http://www.teamsybase.net/blogs
> >>
> >> DataWindow.NET code examples available on CodeXchange:
> >> http://datawindownet.codexchange.sybase.com
> >>
> >> On 13 Dec 2004 07:51:03 -0800, John Hnat wrote:
> >>
> >> >Hi Dave,
> >> >
> >> >Yes, I definitely downloaded and installed the 1.5
> beta. >> >When I open VS and go to the Toolbox, the DW
> control is >> >called Sybase DataWindow 1.5. (I can
> e-mail a screen >> shot >if you would like.)
> >> >
> >> >Some weeks ago, I did download the DW .NET 1.0
> evaluation >> >copy. Is it possible that this is causing
> the problem? >> >Perhaps I should try un-installing and
> re-installing DW >> NET >1.5?
> >> >
> >> >
> >> >
> >> >
> >> >> Are you sure you have 1.5 installed? In a webform
> >> >> application you should see the WebDataWindowControl
> and >> >> SreamImageContainer controls on the Sybase
> DataWindow >> 1.5 >> toolbox tab. The DataWindow control
> will be >> disabled. On a >> winform application the
> >> WebDataWindowControl and >> SreamImageContainer
> controls >> will be disabled and the >> DataWindow Control
> will be >> enabled. >>
> >> >> Regards,
> >> >> Dave Fish
> >> >> Sybase
> >> >>
> >> >> TeamSybase blogs: http://www.teamsybase.net/blogs
> >> >>
> >> >> DataWindow.NET code examples available on
> CodeXchange: >> >>
> http://datawindownet.codexchange.sybase.com >> >>
> >> >> On 13 Dec 2004 06:52:07 -0800, John Hnat wrote:
> >> >>
> >> >> >I've installed the DW 1.5 beta, and the Sybase
> >> DataWindow >> >1.5 control is appearing in my Toolbox.
> >> However, when I >> >open the Toolbox, the
> >> DataWindowControl option is >> disabled. >The other
> >> options (Transaction and DataStore) >> are enabled. >
> >> >> >I'm hoping there is a "duh"-level answer to this
> >> issue. >> Any >ideas? Thanks...
> >> >>
> >>
>
>


Jim Madderra Posted on 2004-12-14 14:19:33.0Z
Reply-To: "Jim Madderra" <powrsite_software@msn.com>
From: "Jim Madderra" <powrsite_software@msn.com>
Newsgroups: sybase.public.datawindow.net
References: <41be377d$1@forums-1-dub> <41bedc6e.4364.1681692777@sybase.com>
Subject: Re: DW 1.5 - DataWindowControl disabled
Lines: 115
Organization: PowrSite Software, Inc
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: astound-66-234-222-207.ca.astound.net
X-Original-NNTP-Posting-Host: astound-66-234-222-207.ca.astound.net
Message-ID: <41bef675@forums-1-dub>
Date: 14 Dec 2004 06:19:33 -0800
X-Trace: forums-1-dub 1103033973 66.234.222.207 (14 Dec 2004 06:19:33 -0800)
X-Original-Trace: 14 Dec 2004 06:19:33 -0800, astound-66-234-222-207.ca.astound.net
X-Authenticated-User: pbtenbeta
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.datawindow.net:1044
Article PK: 125471

Do you know Visual Studio? If not, this may not be enough...In the Toolbox,
right-click, and Choose Add/Remove buttons. Sort by vendor (Sybase), and
remove datawindowcontrol and transaction (I had "old" versions"). Add back
by pointing to datawindow .NET 1.5 directory under sybase and adding the
datawindow.dll, webdatawindow.dll, and datawindowinterop.dll's.

In my project(s), I also had to 'Add a Reference' to the datawindow and
datawindowinterop.dll's.

I believe that's it (along with installing Windows XP SP2 - which I don't
know if I actually needed or not).

<John Hnat> wrote in message news:41bedc6e.4364.1681692777@sybase.com...
> Jim, could you elaborate further on what you did to get it
> to work? Like your machine, mine currently has PB10
> installed, and had DW .NET 1.0 at one point. I've
> uninstalled DW .NET and made sure that all vestiges of
> DataWindow.DLL and WebDataWindow.DLL were removed (the
> uninstaller did not remove all of them), but reinstalling
> after doing that still did not work.
>
> Sybase folks: any further ideas on how to solve this
> problem, especially since it seems like it will affect
> anybody who had version 1.0 installed?
>
>
>
>> No, I had to "manually" put things back together (by
>> adding/removing buttons and assigning them to the proper
>> "exe's").
>>
>> Worked like a charm on a virgin system but not on one that
>> had previous Beta and PB10 with 1.0 on it.
>>
>> <John Hnat> wrote in message
>> > news:41bde9de.3423.1681692777@sybase.com... Dave,
>> >
>> > I uninstalled DW .NET 1.5 and reinstalled it, and I am
>> > getting the same behavior -- no WebFormDataWindowControl
>> > and a grayed out DataWindowControl.
>> >
>> > Any more ideas?
>> >
>> > Has anybody else been able to successfully install DW
>> > .NET 1.5 on a machine that previously had version 1.0
>> > installed on it?
>> >
>> >
>> >
>> >> Hi John,
>> >>
>> >> I would try uninstalling DataWindow .NET 1.5 (and 1.0
>> if >> it is still on your machine). Then run the install
>> again. >> It sounds like something has gotten confused on
>> your >> system.
>> >>
>> >> Regards,
>> >> Dave Fish
>> >> Sybase
>> >>
>> >> TeamSybase blogs: http://www.teamsybase.net/blogs
>> >>
>> >> DataWindow.NET code examples available on CodeXchange:
>> >> http://datawindownet.codexchange.sybase.com
>> >>
>> >> On 13 Dec 2004 07:51:03 -0800, John Hnat wrote:
>> >>
>> >> >Hi Dave,
>> >> >
>> >> >Yes, I definitely downloaded and installed the 1.5
>> beta. >> >When I open VS and go to the Toolbox, the DW
>> control is >> >called Sybase DataWindow 1.5. (I can
>> e-mail a screen >> shot >if you would like.)
>> >> >
>> >> >Some weeks ago, I did download the DW .NET 1.0
>> evaluation >> >copy. Is it possible that this is causing
>> the problem? >> >Perhaps I should try un-installing and
>> re-installing DW >> NET >1.5?
>> >> >
>> >> >
>> >> >
>> >> >
>> >> >> Are you sure you have 1.5 installed? In a webform
>> >> >> application you should see the WebDataWindowControl
>> and >> >> SreamImageContainer controls on the Sybase
>> DataWindow >> 1.5 >> toolbox tab. The DataWindow control
>> will be >> disabled. On a >> winform application the
>> >> WebDataWindowControl and >> SreamImageContainer
>> controls >> will be disabled and the >> DataWindow Control
>> will be >> enabled. >>
>> >> >> Regards,
>> >> >> Dave Fish
>> >> >> Sybase
>> >> >>
>> >> >> TeamSybase blogs: http://www.teamsybase.net/blogs
>> >> >>
>> >> >> DataWindow.NET code examples available on
>> CodeXchange: >> >>
>> http://datawindownet.codexchange.sybase.com >> >>
>> >> >> On 13 Dec 2004 06:52:07 -0800, John Hnat wrote:
>> >> >>
>> >> >> >I've installed the DW 1.5 beta, and the Sybase
>> >> DataWindow >> >1.5 control is appearing in my Toolbox.
>> >> However, when I >> >open the Toolbox, the
>> >> DataWindowControl option is >> disabled. >The other
>> >> options (Transaction and DataStore) >> are enabled. >
>> >> >> >I'm hoping there is a "duh"-level answer to this
>> >> issue. >> Any >ideas? Thanks...
>> >> >>
>> >>
>>
>>


John Hnat Posted on 2004-12-14 15:16:48.0Z
Sender: 45df.41befa0e.1804289383@sybase.com
From: John Hnat
Newsgroups: sybase.public.datawindow.net
Subject: Re: DW 1.5 - DataWindowControl disabled
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <41bf03e0.46f1.1681692777@sybase.com>
References: <41bef675@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 14 Dec 2004 07:16:48 -0800
X-Trace: forums-1-dub 1103037408 10.22.241.41 (14 Dec 2004 07:16:48 -0800)
X-Original-Trace: 14 Dec 2004 07:16:48 -0800, 10.22.241.41
Lines: 121
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.datawindow.net:1049
Article PK: 125475

Jim, it looks like that did the trick! I am now seeing the
WebDataWindowControl and StreamImageContainer in the
Toolbox, and I'm able to use them. Thanks for your help...

> Do you know Visual Studio? If not, this may not be
> enough...In the Toolbox, right-click, and Choose
> Add/Remove buttons. Sort by vendor (Sybase), and remove
> datawindowcontrol and transaction (I had "old" versions").
> Add back by pointing to datawindow .NET 1.5 directory
> under sybase and adding the datawindow.dll,
> webdatawindow.dll, and datawindowinterop.dll's.
>
> In my project(s), I also had to 'Add a Reference' to the
> datawindow and datawindowinterop.dll's.
>
> I believe that's it (along with installing Windows XP SP2
> - which I don't know if I actually needed or not).
>
>
> <John Hnat> wrote in message
> > news:41bedc6e.4364.1681692777@sybase.com... Jim, could
> > you elaborate further on what you did to get it to work?
> > Like your machine, mine currently has PB10 installed,
> > and had DW .NET 1.0 at one point. I've uninstalled DW
> > .NET and made sure that all vestiges of DataWindow.DLL
> > and WebDataWindow.DLL were removed (the uninstaller did
> > not remove all of them), but reinstalling after doing
> that still did not work. >
> > Sybase folks: any further ideas on how to solve this
> > problem, especially since it seems like it will affect
> > anybody who had version 1.0 installed?
> >
> >
> >
> >> No, I had to "manually" put things back together (by
> >> adding/removing buttons and assigning them to the
> proper >> "exe's").
> >>
> >> Worked like a charm on a virgin system but not on one
> that >> had previous Beta and PB10 with 1.0 on it.
> >>
> >> <John Hnat> wrote in message
> >> > news:41bde9de.3423.1681692777@sybase.com... Dave,
> >> >
> >> > I uninstalled DW .NET 1.5 and reinstalled it, and I
> am >> > getting the same behavior -- no
> WebFormDataWindowControl >> > and a grayed out
> DataWindowControl. >> >
> >> > Any more ideas?
> >> >
> >> > Has anybody else been able to successfully install DW
> >> > .NET 1.5 on a machine that previously had version 1.0
> >> > installed on it?
> >> >
> >> >
> >> >
> >> >> Hi John,
> >> >>
> >> >> I would try uninstalling DataWindow .NET 1.5 (and
> 1.0 >> if >> it is still on your machine). Then run the
> install >> again. >> It sounds like something has gotten
> confused on >> your >> system.
> >> >>
> >> >> Regards,
> >> >> Dave Fish
> >> >> Sybase
> >> >>
> >> >> TeamSybase blogs: http://www.teamsybase.net/blogs
> >> >>
> >> >> DataWindow.NET code examples available on
> CodeXchange: >> >>
> http://datawindownet.codexchange.sybase.com >> >>
> >> >> On 13 Dec 2004 07:51:03 -0800, John Hnat wrote:
> >> >>
> >> >> >Hi Dave,
> >> >> >
> >> >> >Yes, I definitely downloaded and installed the 1.5
> >> beta. >> >When I open VS and go to the Toolbox, the DW
> >> control is >> >called Sybase DataWindow 1.5. (I can
> >> e-mail a screen >> shot >if you would like.)
> >> >> >
> >> >> >Some weeks ago, I did download the DW .NET 1.0
> >> evaluation >> >copy. Is it possible that this is
> causing >> the problem? >> >Perhaps I should try
> un-installing and >> re-installing DW >> NET >1.5?
> >> >> >
> >> >> >
> >> >> >
> >> >> >
> >> >> >> Are you sure you have 1.5 installed? In a webform
> >> >> >> application you should see the
> WebDataWindowControl >> and >> >> SreamImageContainer
> controls on the Sybase >> DataWindow >> 1.5 >> toolbox
> tab. The DataWindow control >> will be >> disabled. On a
> >> winform application the >> >> WebDataWindowControl and
> >> SreamImageContainer >> controls >> will be disabled and
> the >> DataWindow Control >> will be >> enabled. >>
> >> >> >> Regards,
> >> >> >> Dave Fish
> >> >> >> Sybase
> >> >> >>
> >> >> >> TeamSybase blogs: http://www.teamsybase.net/blogs
> >> >> >>
> >> >> >> DataWindow.NET code examples available on
> >> CodeXchange: >> >>
> >> http://datawindownet.codexchange.sybase.com >> >>
> >> >> >> On 13 Dec 2004 06:52:07 -0800, John Hnat wrote:
> >> >> >>
> >> >> >> >I've installed the DW 1.5 beta, and the Sybase
> >> >> DataWindow >> >1.5 control is appearing in my
> Toolbox. >> >> However, when I >> >open the Toolbox, the
> >> >> DataWindowControl option is >> disabled. >The other
> >> >> options (Transaction and DataStore) >> are enabled.
> > >> >> >> >I'm hoping there is a "duh"-level answer to
> this >> >> issue. >> Any >ideas? Thanks...
> >> >> >>
> >> >>
> >>
> >>
>
>