Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

The status of MSSQL Server is NO STATE AVAILBLE

2 posts in Replication Agent Last posting was on 2005-01-06 22:18:39.0Z
Jayadev Posted on 2005-01-06 18:13:44.0Z
Sender: 10f6.41dd7f9f.1804289383@sybase.com
From: Jayadev
Newsgroups: sybase.public.rep-agent
Subject: The status of MSSQL Server is NO STATE AVAILBLE
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <41dd7fd5.10f9.1681692777@sybase.com>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 6 Jan 2005 10:13:41 -0800, 10.22.241.42
Lines: 52
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 6 Jan 2005 10:13:42 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 6 Jan 2005 10:13:44 -0800
X-Trace: forums-1-dub 1105035224 10.22.108.75 (6 Jan 2005 10:13:44 -0800)
X-Original-Trace: 6 Jan 2005 10:13:44 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.rep-agent:742
Article PK: 862380

We are doing Heterogeneous replication from MSSQL to SYBASE

MSSQL 8.0 ---------> RA 12.5 -----------> RS 12.5
-------------> SYBASE 12.5.1

MSSQL server, SYBASE server, RS server is installed in one
system, and RA in another system.

We successfully configured RA,

the output of test_connection command is as follows:

test_connection

PDS: scucceeded
RS: scucceeded

the output of resume command

REPLICATING

after doing this we have added the repagent server to RSM,
the status of this server is ACTIVE

but when I try to add MSSQL server it is showing "NO STATE
AVIALALBE"

the status of database connection is for replication agent
is showing up, and dis is showing "Always suspended".

The error which I found is RS error log

Open Client Client-Library error: Error: 84083974, Severity
5 -- 'ct_connect(): network packet layer: internal net
library error: Net-Library operation terminated due to
disconnect'.
E. 2005/01/06 22:44:54. ERROR #13045 DSI(108 MCD78.pubs) -
eue(3252)
Failed to connect to server 'MCD78' as user 'dbmaint'. See
CT-Lib and/or server error messages for more information.
I. 2005/01/06 22:44:54. The DSI thread for database
'MCD78.pubs' is shutdown.

dbmaint is my maintenance user for MSSQL server, the default
database is pubs.

we have given create table, create trigger and create
procedure permissions.


Thanks in Advance
Jayadev


Wanda Beck Posted on 2005-01-06 22:18:39.0Z
From: "Wanda Beck" <wbeck@sybase.com>
Newsgroups: sybase.public.rep-agent
References: <41dd7fd5.10f9.1681692777@sybase.com>
Subject: Re: The status of MSSQL Server is NO STATE AVAILBLE
Lines: 80
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
X-Original-NNTP-Posting-Host: wbeckw2k.sybase.com
Message-ID: <41ddb93b$1@forums-2-dub>
X-Original-Trace: 6 Jan 2005 14:18:35 -0800, wbeckw2k.sybase.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 6 Jan 2005 14:18:36 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 6 Jan 2005 14:18:39 -0800
X-Trace: forums-1-dub 1105049919 10.22.108.75 (6 Jan 2005 14:18:39 -0800)
X-Original-Trace: 6 Jan 2005 14:18:39 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.rep-agent:743
Article PK: 862383

My colleague responds:
I believe the error in the Rep Server log is because the DSI thread of the
connection cannot connect to anything (I assume the primary ds.db is
'MCD78.pubs'). Rep Server supports two types of connections: primary and
replicate, and replicate only. What LAN Rep Agent really needs is a primary
only connection, because the Rep Server can't connect back to the primary
data server (the MS SQL Server). And unless you plan on doing bi-directional
replication, you don't want the Rep Server to connect to the primary.

So the error in the Rep Server log probably does not mean anything and
should not be an issue. Is replication working?

The RSM issue is probably a configuration issue. The RSM Server will use the
LAN Rep Agent to collect meta data from the primary database (MS SQL
Server). Make sure the login used by the LAN Rep Agent is valid and has the
required permissions. The status of the MS SQL Server icon is not very
important to replication. Check to see if the status of the database
connection is correct. Check the status against the values found when you do
an 'admin who' at the Rep Server. If the status of the rep agent thread of
the connection is up then you should be ready to replicate data (as stated
above, the status of the DSI thread will be down, and the RSM will ignore
it).

Andrew

<Jayadev> wrote in message news:41dd7fd5.10f9.1681692777@sybase.com...
> We are doing Heterogeneous replication from MSSQL to SYBASE
>
> MSSQL 8.0 ---------> RA 12.5 -----------> RS 12.5
> -------------> SYBASE 12.5.1
>
> MSSQL server, SYBASE server, RS server is installed in one
> system, and RA in another system.
>
> We successfully configured RA,
>
> the output of test_connection command is as follows:
>
> test_connection
>
> PDS: scucceeded
> RS: scucceeded
>
> the output of resume command
>
> REPLICATING
>
> after doing this we have added the repagent server to RSM,
> the status of this server is ACTIVE
>
> but when I try to add MSSQL server it is showing "NO STATE
> AVIALALBE"
>
> the status of database connection is for replication agent
> is showing up, and dis is showing "Always suspended".
>
> The error which I found is RS error log
>
> Open Client Client-Library error: Error: 84083974, Severity
> 5 -- 'ct_connect(): network packet layer: internal net
> library error: Net-Library operation terminated due to
> disconnect'.
> E. 2005/01/06 22:44:54. ERROR #13045 DSI(108 MCD78.pubs) -
> eue(3252)
> Failed to connect to server 'MCD78' as user 'dbmaint'. See
> CT-Lib and/or server error messages for more information.
> I. 2005/01/06 22:44:54. The DSI thread for database
> 'MCD78.pubs' is shutdown.
>
> dbmaint is my maintenance user for MSSQL server, the default
> database is pubs.
>
> we have given create table, create trigger and create
> procedure permissions.
>
>
> Thanks in Advance
> Jayadev