Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Automation of group creation

12 posts in General Discussion Last posting was on 2005-09-16 19:56:37.0Z
abbey Posted on 2005-03-13 20:59:36.0Z
From: abbey <a_adeyeye@yahoo.co.uk>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040804 Netscape/7.2 (ax)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.mbusinessanywhere.general
Subject: Automation of group creation
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: 62.173.81.130
Message-ID: <4234a9b3@forums-2-dub>
X-Original-Trace: 13 Mar 2005 12:59:31 -0800, 62.173.81.130
Lines: 7
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 13 Mar 2005 12:59:34 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 13 Mar 2005 12:59:36 -0800
X-Trace: forums-1-dub 1110747576 10.22.108.75 (13 Mar 2005 12:59:36 -0800)
X-Original-Trace: 13 Mar 2005 12:59:36 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:292
Article PK: 17640

Hi everyone,
is there a way to automate the creation of groups (and users) without
going through the MBA web console. I know that there's a way to import
users into the system from a text file, but the documents I've read dont
mention any more.
Thanks,
Abbey


Chris Grim Posted on 2005-03-14 02:58:14.0Z
User-Agent: Microsoft-Entourage/11.1.0.040913
Subject: Re: Automation of group creation
From: Chris Grim <chrisgrim@hotmail.com>
Newsgroups: ianywhere.public.mbusinessanywhere.general
Message-ID: <BE5A3DBF.40A%chrisgrim@hotmail.com>
References: <4234a9b3@forums-2-dub>
Mime-version: 1.0
Content-type: text/plain; charset="US-ASCII"
Content-transfer-encoding: 7bit
X-Original-NNTP-Posting-Host: adsl-63-200-37-206.dsl.snfc21.pacbell.net
X-Original-Trace: 13 Mar 2005 18:58:10 -0800, adsl-63-200-37-206.dsl.snfc21.pacbell.net
Lines: 23
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 13 Mar 2005 18:58:11 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 13 Mar 2005 18:58:14 -0800
X-Trace: forums-1-dub 1110769094 10.22.108.75 (13 Mar 2005 18:58:14 -0800)
X-Original-Trace: 13 Mar 2005 18:58:14 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:295
Article PK: 8817

Abbey,

Version 5.7 includes a beta of a SOAP service that allows you to do this and
a lot more. This SOAP service will ship with documentation in our 6.0
release coming later this summer. If you look in the services control
panel, you'll see that there is a manual M-Business Server for soap. Start
that up and you can hit the port to get the WSDL, I think. I believe that
the default setting is port 8099, but that's off the top of my head.

Chris...

On 3/13/05 12:59 PM, in article 4234a9b3@forums-2-dub, "abbey"

<a_adeyeye@yahoo.co.uk> wrote:

> Hi everyone,
> is there a way to automate the creation of groups (and users) without
> going through the MBA web console. I know that there's a way to import
> users into the system from a text file, but the documents I've read dont
> mention any more.
> Thanks,
> Abbey


Enrico Pallazzo Posted on 2005-03-14 20:05:47.0Z
From: "Enrico Pallazzo" <nospam@nospam.com>
Newsgroups: ianywhere.public.mbusinessanywhere.general
References: <4234a9b3@forums-2-dub> <BE5A3DBF.40A%chrisgrim@hotmail.com>
Subject: Re: Automation of group creation
Lines: 33
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: vpn-dub-159.sybase.com
X-Original-NNTP-Posting-Host: vpn-dub-159.sybase.com
Message-ID: <4235ee9b$1@forums-1-dub>
Date: 14 Mar 2005 12:05:47 -0800
X-Trace: forums-1-dub 1110830747 10.22.120.159 (14 Mar 2005 12:05:47 -0800)
X-Original-Trace: 14 Mar 2005 12:05:47 -0800, vpn-dub-159.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:298
Article PK: 17642

The WSDL port is 8094. The SOAP API is not officially supported till the 6.0
release

"Chris Grim" <chrisgrim@hotmail.com> wrote in message
news:BE5A3DBF.40A%chrisgrim@hotmail.com...
> Abbey,
>
> Version 5.7 includes a beta of a SOAP service that allows you to do this
> and
> a lot more. This SOAP service will ship with documentation in our 6.0
> release coming later this summer. If you look in the services control
> panel, you'll see that there is a manual M-Business Server for soap.
> Start
> that up and you can hit the port to get the WSDL, I think. I believe that
> the default setting is port 8099, but that's off the top of my head.
>
> Chris...
>
> On 3/13/05 12:59 PM, in article 4234a9b3@forums-2-dub, "abbey"
> <a_adeyeye@yahoo.co.uk> wrote:
>
>> Hi everyone,
>> is there a way to automate the creation of groups (and users) without
>> going through the MBA web console. I know that there's a way to import
>> users into the system from a text file, but the documents I've read dont
>> mention any more.
>> Thanks,
>> Abbey
>
>


abbey Posted on 2005-03-17 17:32:46.0Z
From: abbey <a_adeyeye@yahoo.co.uk>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040804 Netscape/7.2 (ax)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.mbusinessanywhere.general
Subject: Re: Automation of group creation
References: <4234a9b3@forums-2-dub> <BE5A3DBF.40A%chrisgrim@hotmail.com> <4235ee9b$1@forums-1-dub>
In-Reply-To: <4235ee9b$1@forums-1-dub>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: 62.173.81.130
X-Original-NNTP-Posting-Host: 62.173.81.130
Message-ID: <4239bf3e@forums-1-dub>
Date: 17 Mar 2005 09:32:46 -0800
X-Trace: forums-1-dub 1111080766 62.173.81.130 (17 Mar 2005 09:32:46 -0800)
X-Original-Trace: 17 Mar 2005 09:32:46 -0800, 62.173.81.130
Lines: 66
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:303
Article PK: 17645

Hello again,
I'm having problems accessing the M-business soap server from my java
code (Using apache Axis). I get a ClassCastException at runtime error
(I've included a snippet of the stack trace below) whenever I use the
service stub to invoke a method, the same problem also occurs when I try
to invoke methods that return void. I've tested my axis package and
everything seems to be working ok on that front, anyway I've included my
source code, Any help would be great value.

Thanks
Abbey Adeyeye.

Source code:-
public static void main(String [] args)throws Exception
{
Avantgoapi service=new AvantgoapiLocator();
AvantgoSoap port=service.getavantgoapi();

//Group[] aG=port.groupGetAll();
port.configEnablePersonalChannels(true);
}

Stack Trace:-
Exception in thread "main" AxisFault
faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.userException
faultSubcode:
faultString: java.lang.ClassCastException
faultActor:
faultNode:
faultDetail:

{http://xml.apache.org/axis/}stackTrace:java.lang.ClassCastException
at
org.apache.axis.message.SOAPFaultBuilder.onEndChild(SOAPFaultBuilder.java:299)
at
org.apache.axis.encoding.DeserializationContext.endElement(DeserializationConte
xt.java:1090)
at
org.apache.xerces.parsers.AbstractSAXParser.endElement(Unknown Source)
at
org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanEndElement(Unknown
Source)
at
org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher
.dispatch(Unknown Source)
at
org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown
Sour
ce)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown
Source)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown
Source)
at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown
Source)
at javax.xml.parsers.SAXParser.parse(Unknown Source)
at
org.apache.axis.encoding.DeserializationContext.parse(DeserializationContext.ja
va:227)
at org.apache.axis.SOAPPart.getAsSOAPEnvelope(SOAPPart.java:696)
at org.apache.axis.Message.getSOAPEnvelope(Message.java:424)
at
org.apache.axis.handlers.soap.MustUnderstandChecker.invoke(MustUnderstandChecke


Greg Fenton Posted on 2005-03-17 18:04:29.0Z
From: Greg Fenton <greg.fenton_NOSPAM_@ianywhere.com>
Organization: iAnywhere Solutions Inc.
User-Agent: Mozilla Thunderbird 1.6.3.2f (Windows/20041206)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.mbusinessanywhere.general
Subject: Re: Automation of group creation
References: <4234a9b3@forums-2-dub> <BE5A3DBF.40A%chrisgrim@hotmail.com> <4235ee9b$1@forums-1-dub> <4239bf3e@forums-1-dub>
In-Reply-To: <4239bf3e@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: gfenton-t30.sybase.com
X-Original-NNTP-Posting-Host: gfenton-t30.sybase.com
Message-ID: <4239c6ad$1@forums-1-dub>
Date: 17 Mar 2005 10:04:29 -0800
X-Trace: forums-1-dub 1111082669 10.25.98.243 (17 Mar 2005 10:04:29 -0800)
X-Original-Trace: 17 Mar 2005 10:04:29 -0800, gfenton-t30.sybase.com
Lines: 23
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:304
Article PK: 17647


abbey wrote:
> at org.apache.axis.Message.getSOAPEnvelope(Message.java:424)
> at
> org.apache.axis.handlers.soap.MustUnderstandChecker.invoke(MustUnderstandChecke
>

Your stack trace is cut off.

Could you try capturing the data into a file and do a copy-paste from
that file into a new post?

java myProgram > myProgram.out 2>&1

[This will work in the win32 shell and most Unix-like shells]

greg.fenton
--
Greg Fenton
Consultant, Solution Services, iAnywhere Solutions
--------
Visit the iAnywhere Solutions Developer Community
Whitepapers, TechDocs, Downloads
http://www.ianywhere.com/developer/


abbey Posted on 2005-03-17 19:11:22.0Z
From: abbey <a_adeyeye@yahoo.co.uk>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040804 Netscape/7.2 (ax)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.mbusinessanywhere.general
Subject: Re: Automation of group creation
References: <4234a9b3@forums-2-dub> <BE5A3DBF.40A%chrisgrim@hotmail.com> <4235ee9b$1@forums-1-dub> <4239bf3e@forums-1-dub> <4239c6ad$1@forums-1-dub>
In-Reply-To: <4239c6ad$1@forums-1-dub>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: 62.173.81.130
X-Original-NNTP-Posting-Host: 62.173.81.130
Message-ID: <4239d65a@forums-1-dub>
Date: 17 Mar 2005 11:11:22 -0800
X-Trace: forums-1-dub 1111086682 62.173.81.130 (17 Mar 2005 11:11:22 -0800)
X-Original-Trace: 17 Mar 2005 11:11:22 -0800, 62.173.81.130
Lines: 129
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:305
Article PK: 17651


Greg Fenton wrote:
> abbey wrote:
>
>> at org.apache.axis.Message.getSOAPEnvelope(Message.java:424)
>> at
>> org.apache.axis.handlers.soap.MustUnderstandChecker.invoke(MustUnderstandChecke
>>
>
>
> Your stack trace is cut off.
>
> Could you try capturing the data into a file and do a copy-paste from
> that file into a new post?
>
> java myProgram > myProgram.out 2>&1
>
> [This will work in the win32 shell and most Unix-like shells]
>
> greg.fenton

Hi the full stack trace is:-

C:\dev>java AvantgoWebAPI.MBSoapTester
17-Mar-2005 15:11:42 org.apache.axis.utils.JavaUtils isAttachmentSupported
WARNING: Unable to find required classes (javax.activation.DataHandler
and javax.mail.inte
rnet.MimeMultipart). Attachment support is disabled.
Exception in thread "main" AxisFault
faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.userException
faultSubcode:
faultString: java.lang.ClassCastException
faultActor:
faultNode:
faultDetail:

{http://xml.apache.org/axis/}stackTrace:java.lang.ClassCastException
at
org.apache.axis.message.SOAPFaultBuilder.onEndChild(SOAPFaultBuilder.java:299)
at
org.apache.axis.encoding.DeserializationContext.endElement(DeserializationConte
xt.java:1090)
at
org.apache.xerces.parsers.AbstractSAXParser.endElement(Unknown Source)
at
org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanEndElement(Unknown
Source)
at
org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher
.dispatch(Unknown Source)
at
org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown
Sour
ce)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown
Source)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown
Source)
at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown
Source)
at javax.xml.parsers.SAXParser.parse(Unknown Source)
at
org.apache.axis.encoding.DeserializationContext.parse(DeserializationContext.ja
va:227)
at org.apache.axis.SOAPPart.getAsSOAPEnvelope(SOAPPart.java:696)
at org.apache.axis.Message.getSOAPEnvelope(Message.java:424)
at
org.apache.axis.handlers.soap.MustUnderstandChecker.invoke(MustUnderstandChecke
r.java:62)
at org.apache.axis.client.AxisClient.invoke(AxisClient.java:206)
at org.apache.axis.client.Call.invokeEngine(Call.java:2754)
at org.apache.axis.client.Call.invoke(Call.java:2737)
at org.apache.axis.client.Call.invoke(Call.java:2413)
at org.apache.axis.client.Call.invoke(Call.java:2336)
at org.apache.axis.client.Call.invoke(Call.java:1793)
at
AvantgoWebAPI.AvantgoapiBindingStub.configEnablePersonalChannels(AvantgoapiBind
ingStub.java:1892)
at AvantgoWebAPI.MBSoapTester.main(MBSoapTester.java:13)

{http://xml.apache.org/axis/}hostname:KAILAZ02

java.lang.ClassCastException
at org.apache.axis.AxisFault.makeFault(AxisFault.java:101)
at org.apache.axis.SOAPPart.getAsSOAPEnvelope(SOAPPart.java:701)
at org.apache.axis.Message.getSOAPEnvelope(Message.java:424)
at
org.apache.axis.handlers.soap.MustUnderstandChecker.invoke(MustUnderstandChecke
r.java:62)
at org.apache.axis.client.AxisClient.invoke(AxisClient.java:206)
at org.apache.axis.client.Call.invokeEngine(Call.java:2754)
at org.apache.axis.client.Call.invoke(Call.java:2737)
at org.apache.axis.client.Call.invoke(Call.java:2413)
at org.apache.axis.client.Call.invoke(Call.java:2336)
at org.apache.axis.client.Call.invoke(Call.java:1793)
at
AvantgoWebAPI.AvantgoapiBindingStub.configEnablePersonalChannels(AvantgoapiBind
ingStub.java:1892)
at AvantgoWebAPI.MBSoapTester.main(MBSoapTester.java:13)
Caused by: java.lang.ClassCastException
at
org.apache.axis.message.SOAPFaultBuilder.onEndChild(SOAPFaultBuilder.java:299)
at
org.apache.axis.encoding.DeserializationContext.endElement(DeserializationConte
xt.java:1090)
at
org.apache.xerces.parsers.AbstractSAXParser.endElement(Unknown Source)
at
org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanEndElement(Unknown
Source)
at
org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher
.dispatch(Unknown Source)
at
org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown
Sour
ce)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown
Source)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown
Source)
at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown
Source)
at javax.xml.parsers.SAXParser.parse(Unknown Source)
at
org.apache.axis.encoding.DeserializationContext.parse(DeserializationContext.ja
va:227)
at org.apache.axis.SOAPPart.getAsSOAPEnvelope(SOAPPart.java:696)


abbey Posted on 2005-03-17 21:42:56.0Z
From: abbey <a_adeyeye@yahoo.co.uk>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040804 Netscape/7.2 (ax)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.mbusinessanywhere.general
Subject: Re: Automation of group creation
References: <4234a9b3@forums-2-dub> <BE5A3DBF.40A%chrisgrim@hotmail.com> <4235ee9b$1@forums-1-dub> <4239bf3e@forums-1-dub> <4239c6ad$1@forums-1-dub> <4239d65a@forums-1-dub>
In-Reply-To: <4239d65a@forums-1-dub>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: 62.173.81.130
Message-ID: <4239f9dc$1@forums-2-dub>
X-Original-Trace: 17 Mar 2005 13:42:52 -0800, 62.173.81.130
Lines: 52
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 17 Mar 2005 13:42:53 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 17 Mar 2005 13:42:56 -0800
X-Trace: forums-1-dub 1111095776 10.22.108.75 (17 Mar 2005 13:42:56 -0800)
X-Original-Trace: 17 Mar 2005 13:42:56 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:306
Article PK: 17652

Hello again,
I used TCPMon application that comes with Axis to get the
request/response between the client and MBA soap server which I have
included below. I'm currently using Axis 1.2 and I think the
ClassCastException is being thrown when the client tries to parse the
response. Can someone tell me why?



R E Q U E S T:-

<?xml version="1.0" encoding="UTF-8"?><soapenv:Envelope
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><soapenv:Body><ns1:configEnablePersonalChannels
soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
xmlns:ns1="urn:AvantgoWebAPI"><enable
href="#id0"/></ns1:configEnablePersonalChannels><multiRef id="id0"
soapenc:root="0"
soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
xsi:type="xsd:boolean"
xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/">true</multiRef></soapenv:Body></soapenv:Envelope>



R E S P O N S E:-

HTTP/1.1 500 Internal Server Error
Server: gSOAP/2.3
Content-Type: text/xml; charset=utf-8
Content-Length: 576
Connection: close

<?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope
xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:agapi="urn:AvantgoWebAPI"><SOAP-ENV:Body
SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
id="_0"><SOAP-ENV:Fault><faultcode>SOAP-ENV:Server</faultcode><faultstring>Failed
to verify
session</faultstring><detail>Error</detail></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>

Why am I getting this error from the m-business soap service? Does it
need me to verify the soap session using some user/password? If yes,
shouldn't this be part of the wsdl, so I could send the user/password as
part of the soap service call?

Any help will be greatly appreciated.

Abbey


Enrico Pallazzo Posted on 2005-03-21 13:54:53.0Z
From: "Enrico Pallazzo" <nospam@nospam.com>
Newsgroups: ianywhere.public.mbusinessanywhere.general
References: <4234a9b3@forums-2-dub> <BE5A3DBF.40A%chrisgrim@hotmail.com> <4235ee9b$1@forums-1-dub> <4239bf3e@forums-1-dub> <4239c6ad$1@forums-1-dub> <4239d65a@forums-1-dub> <4239f9dc$1@forums-2-dub>
Subject: Re: Automation of group creation
Lines: 63
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Response
X-Original-NNTP-Posting-Host: vpn-concord-053.sybase.com
Message-ID: <423ed229@forums-2-dub>
X-Original-Trace: 21 Mar 2005 05:54:49 -0800, vpn-concord-053.sybase.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 21 Mar 2005 05:54:50 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 21 Mar 2005 05:54:53 -0800
X-Trace: forums-1-dub 1111413293 10.22.108.75 (21 Mar 2005 05:54:53 -0800)
X-Original-Trace: 21 Mar 2005 05:54:53 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:308
Article PK: 17649

You are not supplying the correct session credentials: "<faultstring>Failed
to verify session". The 5.7 soap server is a beta release and uses a
propietary authentication scheme. 6.0 will use the blowfish encryption
algorithm. For 5.7 you have to load a .dll or .so using JNI for auth,
contact support for help.

"abbey" <a_adeyeye@yahoo.co.uk> wrote in message
news:4239f9dc$1@forums-2-dub...
> Hello again,
> I used TCPMon application that comes with Axis to get the request/response
> between the client and MBA soap server which I have included below. I'm
> currently using Axis 1.2 and I think the ClassCastException is being
> thrown when the client tries to parse the response. Can someone tell me
> why?
>
>
>
> R E Q U E S T:-
>
> <?xml version="1.0" encoding="UTF-8"?><soapenv:Envelope
> xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
> xmlns:xsd="http://www.w3.org/2001/XMLSchema"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><soapenv:Body><ns1:configEnablePersonalChannels
> soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
> xmlns:ns1="urn:AvantgoWebAPI"><enable
> href="#id0"/></ns1:configEnablePersonalChannels><multiRef id="id0"
> soapenc:root="0"
> soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
> xsi:type="xsd:boolean"
> xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/">true</multiRef></soapenv:Body></soapenv:Envelope>
>
>
>
> R E S P O N S E:-
>
> HTTP/1.1 500 Internal Server Error
> Server: gSOAP/2.3
> Content-Type: text/xml; charset=utf-8
> Content-Length: 576
> Connection: close
>
> <?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope
> xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
> xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xmlns:xsd="http://www.w3.org/2001/XMLSchema"
> xmlns:agapi="urn:AvantgoWebAPI"><SOAP-ENV:Body
> SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
> id="_0"><SOAP-ENV:Fault><faultcode>SOAP-ENV:Server</faultcode><faultstring>Failed
> to verify
> session</faultstring><detail>Error</detail></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>
>
> Why am I getting this error from the m-business soap service? Does it need
> me to verify the soap session using some user/password? If yes, shouldn't
> this be part of the wsdl, so I could send the user/password as part of the
> soap service call?
>
> Any help will be greatly appreciated.
>
> Abbey


Jan Posted on 2005-04-08 14:45:30.0Z
From: "Jan" <jan@cyberprop.com>
Newsgroups: ianywhere.public.mbusinessanywhere.general
References: <4234a9b3@forums-2-dub> <BE5A3DBF.40A%chrisgrim@hotmail.com> <4235ee9b$1@forums-1-dub> <4239bf3e@forums-1-dub> <4239c6ad$1@forums-1-dub> <4239d65a@forums-1-dub> <4239f9dc$1@forums-2-dub> <423ed229@forums-2-dub>
Subject: Re: Automation of group creation
Lines: 75
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: rrba-146-114-209.telkomadsl.co.za
X-Original-NNTP-Posting-Host: rrba-146-114-209.telkomadsl.co.za
Message-ID: <4256990a@forums-1-dub>
Date: 8 Apr 2005 07:45:30 -0700
X-Trace: forums-1-dub 1112971530 165.146.114.209 (8 Apr 2005 07:45:30 -0700)
X-Original-Trace: 8 Apr 2005 07:45:30 -0700, rrba-146-114-209.telkomadsl.co.za
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:378
Article PK: 17669

Greg,

When you say "contact support for help" - who do you mean?

Can you specify the names of the files required?

Thanks!

"Enrico Pallazzo" <nospam@nospam.com> wrote in message
news:423ed229@forums-2-dub...
> You are not supplying the correct session credentials:
> "<faultstring>Failed to verify session". The 5.7 soap server is a beta
> release and uses a propietary authentication scheme. 6.0 will use the
> blowfish encryption algorithm. For 5.7 you have to load a .dll or .so
> using JNI for auth, contact support for help.
>
>
> "abbey" <a_adeyeye@yahoo.co.uk> wrote in message
> news:4239f9dc$1@forums-2-dub...
>> Hello again,
>> I used TCPMon application that comes with Axis to get the
>> request/response between the client and MBA soap server which I have
>> included below. I'm currently using Axis 1.2 and I think the
>> ClassCastException is being thrown when the client tries to parse the
>> response. Can someone tell me why?
>>
>>
>>
>> R E Q U E S T:-
>>
>> <?xml version="1.0" encoding="UTF-8"?><soapenv:Envelope
>> xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
>> xmlns:xsd="http://www.w3.org/2001/XMLSchema"
>> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><soapenv:Body><ns1:configEnablePersonalChannels
>> soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
>> xmlns:ns1="urn:AvantgoWebAPI"><enable
>> href="#id0"/></ns1:configEnablePersonalChannels><multiRef id="id0"
>> soapenc:root="0"
>> soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
>> xsi:type="xsd:boolean"
>> xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/">true</multiRef></soapenv:Body></soapenv:Envelope>
>>
>>
>>
>> R E S P O N S E:-
>>
>> HTTP/1.1 500 Internal Server Error
>> Server: gSOAP/2.3
>> Content-Type: text/xml; charset=utf-8
>> Content-Length: 576
>> Connection: close
>>
>> <?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope
>> xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
>> xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
>> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>> xmlns:xsd="http://www.w3.org/2001/XMLSchema"
>> xmlns:agapi="urn:AvantgoWebAPI"><SOAP-ENV:Body
>> SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
>> id="_0"><SOAP-ENV:Fault><faultcode>SOAP-ENV:Server</faultcode><faultstring>Failed
>> to verify
>> session</faultstring><detail>Error</detail></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>
>>
>> Why am I getting this error from the m-business soap service? Does it
>> need me to verify the soap session using some user/password? If yes,
>> shouldn't this be part of the wsdl, so I could send the user/password as
>> part of the soap service call?
>>
>> Any help will be greatly appreciated.
>>
>> Abbey
>
>


Enrico Pallazzo Posted on 2005-04-11 17:35:51.0Z
From: "Enrico Pallazzo" <enricopallazzo@myway.com>
Newsgroups: ianywhere.public.mbusinessanywhere.general
References: <4234a9b3@forums-2-dub> <BE5A3DBF.40A%chrisgrim@hotmail.com> <4235ee9b$1@forums-1-dub> <4239bf3e@forums-1-dub> <4239c6ad$1@forums-1-dub> <4239d65a@forums-1-dub> <4239f9dc$1@forums-2-dub> <423ed229@forums-2-dub> <4256990a@forums-1-dub>
Subject: Re: Automation of group creation
Lines: 83
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: vpn-dub-234.sybase.com
X-Original-NNTP-Posting-Host: vpn-dub-234.sybase.com
Message-ID: <425ab577$1@forums-1-dub>
Date: 11 Apr 2005 10:35:51 -0700
X-Trace: forums-1-dub 1113240951 10.22.120.234 (11 Apr 2005 10:35:51 -0700)
X-Original-Trace: 11 Apr 2005 10:35:51 -0700, vpn-dub-234.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:385
Article PK: 17673

By support I mean, assuming you have paid for support,
http://www.sybase.com/contactus/support

"Jan" <jan@cyberprop.com> wrote in message news:4256990a@forums-1-dub...
> Greg,
>
> When you say "contact support for help" - who do you mean?
>
> Can you specify the names of the files required?
>
> Thanks!
>
> "Enrico Pallazzo" <nospam@nospam.com> wrote in message
> news:423ed229@forums-2-dub...
>> You are not supplying the correct session credentials:
>> "<faultstring>Failed to verify session". The 5.7 soap server is a beta
>> release and uses a propietary authentication scheme. 6.0 will use the
>> blowfish encryption algorithm. For 5.7 you have to load a .dll or .so
>> using JNI for auth, contact support for help.
>>
>>
>> "abbey" <a_adeyeye@yahoo.co.uk> wrote in message
>> news:4239f9dc$1@forums-2-dub...
>>> Hello again,
>>> I used TCPMon application that comes with Axis to get the
>>> request/response between the client and MBA soap server which I have
>>> included below. I'm currently using Axis 1.2 and I think the
>>> ClassCastException is being thrown when the client tries to parse the
>>> response. Can someone tell me why?
>>>
>>>
>>>
>>> R E Q U E S T:-
>>>
>>> <?xml version="1.0" encoding="UTF-8"?><soapenv:Envelope
>>> xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
>>> xmlns:xsd="http://www.w3.org/2001/XMLSchema"
>>> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><soapenv:Body><ns1:configEnablePersonalChannels
>>> soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
>>> xmlns:ns1="urn:AvantgoWebAPI"><enable
>>> href="#id0"/></ns1:configEnablePersonalChannels><multiRef id="id0"
>>> soapenc:root="0"
>>> soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
>>> xsi:type="xsd:boolean"
>>> xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/">true</multiRef></soapenv:Body></soapenv:Envelope>
>>>
>>>
>>>
>>> R E S P O N S E:-
>>>
>>> HTTP/1.1 500 Internal Server Error
>>> Server: gSOAP/2.3
>>> Content-Type: text/xml; charset=utf-8
>>> Content-Length: 576
>>> Connection: close
>>>
>>> <?xml version="1.0" encoding="UTF-8"?><SOAP-ENV:Envelope
>>> xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
>>> xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
>>> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>>> xmlns:xsd="http://www.w3.org/2001/XMLSchema"
>>> xmlns:agapi="urn:AvantgoWebAPI"><SOAP-ENV:Body
>>> SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
>>> id="_0"><SOAP-ENV:Fault><faultcode>SOAP-ENV:Server</faultcode><faultstring>Failed
>>> to verify
>>> session</faultstring><detail>Error</detail></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>
>>>
>>> Why am I getting this error from the m-business soap service? Does it
>>> need me to verify the soap session using some user/password? If yes,
>>> shouldn't this be part of the wsdl, so I could send the user/password as
>>> part of the soap service call?
>>>
>>> Any help will be greatly appreciated.
>>>
>>> Abbey
>>
>>
>
>


Richard Hein Posted on 2005-09-15 13:43:10.0Z
From: "Richard Hein" <rhein@trialstat.com>
Newsgroups: ianywhere.public.mbusinessanywhere.general
References: <4234a9b3@forums-2-dub>
Subject: Re: Automation of group creation
Lines: 21
Organization: TrialStat
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2527
X-MIMEOLE: Produced By Microsoft MimeOLE V6.00.2900.2527
X-RFC2646: Format=Flowed; Response
NNTP-Posting-Host: 206.191.62.18
X-Original-NNTP-Posting-Host: 206.191.62.18
Message-ID: <43297a6e$1@forums-1-dub>
Date: 15 Sep 2005 06:43:10 -0700
X-Trace: forums-1-dub 1126791790 206.191.62.18 (15 Sep 2005 06:43:10 -0700)
X-Original-Trace: 15 Sep 2005 06:43:10 -0700, 206.191.62.18
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:562
Article PK: 8953

Hi all,

Was this issue ever resolved? If so, please let me know what the result
was, because I have the same problem.

Regards,

Richard Hein
rhein@N0trialSP@Mstat.com

"abbey" <a_adeyeye@yahoo.co.uk> wrote in message
news:4234a9b3@forums-2-dub...
> Hi everyone,
> is there a way to automate the creation of groups (and users) without
> going through the MBA web console. I know that there's a way to import
> users into the system from a text file, but the documents I've read dont
> mention any more.
> Thanks,
> Abbey


Christopher Grim Posted on 2005-09-16 19:56:37.0Z
User-Agent: Microsoft-Entourage/11.1.0.040913
Subject: Re: Automation of group creation
From: Christopher Grim <chrisgrim@hotmail.com>
Newsgroups: ianywhere.public.mbusinessanywhere.general
Message-ID: <BF5071B9.17FA%chrisgrim@hotmail.com>
References: <4234a9b3@forums-2-dub> <43297a6e$1@forums-1-dub>
Mime-version: 1.0
Content-type: text/plain; charset="US-ASCII"
Content-transfer-encoding: 7bit
X-Original-NNTP-Posting-Host: macgrimreaper.sybase.com
X-Original-Trace: 16 Sep 2005 12:55:58 -0700, macgrimreaper.sybase.com
Lines: 34
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 16 Sep 2005 12:55:59 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 16 Sep 2005 12:56:37 -0700
X-Trace: forums-1-dub 1126900597 10.22.108.75 (16 Sep 2005 12:56:37 -0700)
X-Original-Trace: 16 Sep 2005 12:56:37 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:564
Article PK: 8954

Richard,

This will be addressed through the SOAP api that will be part of our 6.0
launch coming a little later this year. The api was released as a beta in
version 5.7, but it is not supported until 6.0.

Chris...

On 9/15/05 6:43 AM, in article 43297a6e$1@forums-1-dub, "Richard Hein"

<rhein@trialstat.com> wrote:

> Hi all,
>
> Was this issue ever resolved? If so, please let me know what the result
> was, because I have the same problem.
>
> Regards,
>
> Richard Hein
> rhein@N0trialSP@Mstat.com
>
> "abbey" <a_adeyeye@yahoo.co.uk> wrote in message
> news:4234a9b3@forums-2-dub...
>> Hi everyone,
>> is there a way to automate the creation of groups (and users) without
>> going through the MBA web console. I know that there's a way to import
>> users into the system from a text file, but the documents I've read dont
>> mention any more.
>> Thanks,
>> Abbey
>
>