Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

is replicator able to be used for replication between ASE & ASA ?

8 posts in replicator Last posting was on 2005-04-03 08:39:14.0Z
wombarrapete Posted on 2005-03-15 03:23:42.0Z
Sender: 229b.42365472.1804289383@sybase.com
From: wombarrapete
Newsgroups: sybase.public.ase.replicator
Subject: is replicator able to be used for replication between ASE & ASA ?
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4236553a.22a5.1681692777@sybase.com>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 14 Mar 2005 19:23:38 -0800, 10.22.241.42
Lines: 10
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 14 Mar 2005 19:23:39 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 14 Mar 2005 19:23:42 -0800
X-Trace: forums-1-dub 1110857022 10.22.108.75 (14 Mar 2005 19:23:42 -0800)
X-Original-Trace: 14 Mar 2005 19:23:42 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.replicator:25
Article PK: 103302

wondering if replicator is able to be used for replication
between ASE & ASA ?

If yes -- which manual will have the info required

If no -- what is the required approach.

thanks in advance

wp


Wanda Beck Posted on 2005-03-15 17:18:27.0Z
From: "Wanda Beck" <wbeck@sybase.com>
Newsgroups: sybase.public.ase.replicator
References: <4236553a.22a5.1681692777@sybase.com>
Subject: Re: is replicator able to be used for replication between ASE & ASA ?
Lines: 21
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1478
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1478
NNTP-Posting-Host: wbeckw2k.sybase.com
X-Original-NNTP-Posting-Host: wbeckw2k.sybase.com
Message-ID: <423718e3$1@forums-1-dub>
Date: 15 Mar 2005 09:18:27 -0800
X-Trace: forums-1-dub 1110907107 10.21.35.134 (15 Mar 2005 09:18:27 -0800)
X-Original-Trace: 15 Mar 2005 09:18:27 -0800, wbeckw2k.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.replicator:26
Article PK: 103299

It's not something we've tested but it should work because Replicator uses
CIS as the interface to the replicate database. By using the CIS feature of
ASE, Replicator is insulated from needing to know database-specific
information about the replicate database.

Thanks,
wa

<wombarrapete> wrote in message news:4236553a.22a5.1681692777@sybase.com...
> wondering if replicator is able to be used for replication
> between ASE & ASA ?
>
> If yes -- which manual will have the info required
>
> If no -- what is the required approach.
>
> thanks in advance
>
> wp


wombarrapete Posted on 2005-03-16 02:29:04.0Z
Sender: 2776.42378d5b.1804289383@sybase.com
From: wombarrapete
Newsgroups: sybase.public.ase.replicator
Subject: Re: is replicator able to be used for replication between ASE & ASA ?
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <423799ea.27eb.1681692777@sybase.com>
References: <423718e3$1@forums-1-dub>
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="-=_forums-2-dub423799ea"
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 15 Mar 2005 18:28:58 -0800, 10.22.241.42
Lines: 433
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 15 Mar 2005 18:29:01 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 15 Mar 2005 18:29:04 -0800
X-Trace: forums-1-dub 1110940144 10.22.108.75 (15 Mar 2005 18:29:04 -0800)
X-Original-Trace: 15 Mar 2005 18:29:04 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.replicator:27
Article PK: 103300

Wanda - this has now progressed .. original error was due to
hosts problem on the machine ... now past that error bug
getting the following :


ASE Replicator requesting Java Virtual Machine exit with
message: ASE Replicator initialization error in component
<DDBAdmin>. Component message: Error encountered checking
environement: S0022: Invalid column name 'action'.

ASE Replicator initialization error in component <DDBAdmin>.
Component message: Error encountered checking environement:
S0022: Invalid column name 'action'.

for completeness I used the -trace switch ... I've attached
the output
in the 'trace.log' file ...

I have been unable to find any reference to a similar
problem so far but I'll keep looking ..

thanks in advance
wp

> It's not something we've tested but it should work because
> Replicator uses CIS as the interface to the replicate
> database. By using the CIS feature of ASE, Replicator is
> insulated from needing to know database-specific
> information about the replicate database.
>
> Thanks,
> wa
>
> <wombarrapete> wrote in message
> > news:4236553a.22a5.1681692777@sybase.com... wondering if
> > replicator is able to be used for replication between
> ASE & ASA ? >
> > If yes -- which manual will have the info required
> >
> > If no -- what is the required approach.
> >
> > thanks in advance
> >
> > wp
>
>


wombarrapete Posted on 2005-03-16 05:57:07.0Z
Sender: 2776.42378d5b.1804289383@sybase.com
From: wombarrapete
Newsgroups: sybase.public.ase.replicator
Subject: Re: is replicator able to be used for replication between ASE & ASA ?
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4237caaf.2bbf.1681692777@sybase.com>
References: <423799ea.27eb.1681692777@sybase.com>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 15 Mar 2005 21:57:03 -0800, 10.22.241.42
Lines: 54
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 15 Mar 2005 21:57:04 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 15 Mar 2005 21:57:07 -0800
X-Trace: forums-1-dub 1110952627 10.22.108.75 (15 Mar 2005 21:57:07 -0800)
X-Original-Trace: 15 Mar 2005 21:57:07 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.replicator:28
Article PK: 103301

Wanda - we've got it working ASE to ASE - thanks for the
reply

wp

> Wanda - this has now progressed .. original error was due
> to hosts problem on the machine ... now past that error
> bug getting the following :
>
>
> ASE Replicator requesting Java Virtual Machine exit with
> message: ASE Replicator initialization error in component
> <DDBAdmin>. Component message: Error encountered checking
> environement: S0022: Invalid column name 'action'.
>
> ASE Replicator initialization error in component
> <DDBAdmin>. Component message: Error encountered checking
> environement: S0022: Invalid column name 'action'.
>
> for completeness I used the -trace switch ... I've
> attached the output
> in the 'trace.log' file ...
>
> I have been unable to find any reference to a similar
> problem so far but I'll keep looking ..
>
> thanks in advance
> wp
>
> > It's not something we've tested but it should work
> > because Replicator uses CIS as the interface to the
> > replicate database. By using the CIS feature of ASE,
> > Replicator is insulated from needing to know
> > database-specific information about the replicate
> database. >
> > Thanks,
> > wa
> >
> > <wombarrapete> wrote in message
> > > news:4236553a.22a5.1681692777@sybase.com... wondering
> > > if replicator is able to be used for replication
> > between ASE & ASA ? >
> > > If yes -- which manual will have the info required
> > >
> > > If no -- what is the required approach.
> > >
> > > thanks in advance
> > >
> > > wp
> >
> >
>
>
> [Attachment: trace.log]


Wanda Beck Posted on 2005-03-16 23:51:48.0Z
From: "Wanda Beck" <wbeck@sybase.com>
Newsgroups: sybase.public.ase.replicator
References: <423718e3$1@forums-1-dub> <423799ea.27eb.1681692777@sybase.com>
Subject: Re: is replicator able to be used for replication between ASE & ASA ?
Lines: 55
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1478
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1478
NNTP-Posting-Host: wbeckw2k.sybase.com
X-Original-NNTP-Posting-Host: wbeckw2k.sybase.com
Message-ID: <4238c694$1@forums-1-dub>
Date: 16 Mar 2005 15:51:48 -0800
X-Trace: forums-1-dub 1111017108 10.21.35.134 (16 Mar 2005 15:51:48 -0800)
X-Original-Trace: 16 Mar 2005 15:51:48 -0800, wbeckw2k.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.replicator:30
Article PK: 103305

The Replicator fix for this is in ASE 12.5.2 ESD #2 and later.

Thanks,
wa

<wombarrapete> wrote in message news:423799ea.27eb.1681692777@sybase.com...
> Wanda - this has now progressed .. original error was due to
> hosts problem on the machine ... now past that error bug
> getting the following :
>
>
> ASE Replicator requesting Java Virtual Machine exit with
> message: ASE Replicator initialization error in component
> <DDBAdmin>. Component message: Error encountered checking
> environement: S0022: Invalid column name 'action'.
>
> ASE Replicator initialization error in component <DDBAdmin>.
> Component message: Error encountered checking environement:
> S0022: Invalid column name 'action'.
>
> for completeness I used the -trace switch ... I've attached
> the output
> in the 'trace.log' file ...
>
> I have been unable to find any reference to a similar
> problem so far but I'll keep looking ..
>
> thanks in advance
> wp
>
> > It's not something we've tested but it should work because
> > Replicator uses CIS as the interface to the replicate
> > database. By using the CIS feature of ASE, Replicator is
> > insulated from needing to know database-specific
> > information about the replicate database.
> >
> > Thanks,
> > wa
> >
> > <wombarrapete> wrote in message
> > > news:4236553a.22a5.1681692777@sybase.com... wondering if
> > > replicator is able to be used for replication between
> > ASE & ASA ? >
> > > If yes -- which manual will have the info required
> > >
> > > If no -- what is the required approach.
> > >
> > > thanks in advance
> > >
> > > wp
> >
> >
>


wombarrapete Posted on 2005-03-21 03:39:16.0Z
Sender: 2f42.4238c77b.1804289383@sybase.com
From: wombarrapete
Newsgroups: sybase.public.ase.replicator
Subject: Re: is replicator able to be used for replication between ASE & ASA ?
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <423e41e4.1064.1681692777@sybase.com>
References: <423718e3$1@forums-1-dub>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 20 Mar 2005 19:39:16 -0800
X-Trace: forums-1-dub 1111376356 10.22.241.41 (20 Mar 2005 19:39:16 -0800)
X-Original-Trace: 20 Mar 2005 19:39:16 -0800, 10.22.241.41
Lines: 41
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.replicator:32
Article PK: 103303

thanks for your responses Wanda -- perhaps you could also
help with my current problem ... I keep getting a syntax
error when issuing 'sp_addreplicateconn 'MyASA.field' (field
is the name of my asa db)... is there a way of getting
around this as it doesn't seem to like the normal syntax ...
is this something that is going to stop us investigating the
use of Replicator between ASE and ASA ?

thanks
wp

full error:
=======================
Msg 32000, Level 20, State 0:
Server 'ASE_REP', Procedure 'sp_addreplicateconn', Line 1:
Command <sp_addreplicateconn> failed - Could not add
Replicate Connection <MyASA.field> because: ASA Error -131:
Syntax error near '.' on line 1
=======================

> It's not something we've tested but it should work because
> Replicator uses CIS as the interface to the replicate
> database. By using the CIS feature of ASE, Replicator is
> insulated from needing to know database-specific
> information about the replicate database.
>
> Thanks,
> wa
>
> <wombarrapete> wrote in message
> > news:4236553a.22a5.1681692777@sybase.com... wondering if
> > replicator is able to be used for replication between
> ASE & ASA ? >
> > If yes -- which manual will have the info required
> >
> > If no -- what is the required approach.
> >
> > thanks in advance
> >
> > wp
>
>


Wanda Beck Posted on 2005-03-21 16:05:05.0Z
From: "Wanda Beck" <wbeck@sybase.com>
Newsgroups: sybase.public.ase.replicator
References: <423718e3$1@forums-1-dub> <423e41e4.1064.1681692777@sybase.com>
Subject: Re: is replicator able to be used for replication between ASE & ASA ?
Lines: 68
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1478
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1478
X-Original-NNTP-Posting-Host: wbeckw2k.sybase.com
Message-ID: <423ef0ae$1@forums-2-dub>
X-Original-Trace: 21 Mar 2005 08:05:02 -0800, wbeckw2k.sybase.com
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 21 Mar 2005 08:05:03 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 21 Mar 2005 08:05:05 -0800
X-Trace: forums-1-dub 1111421105 10.22.108.75 (21 Mar 2005 08:05:05 -0800)
X-Original-Trace: 21 Mar 2005 08:05:05 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.replicator:33
Article PK: 103304

Hi, wp,

Hmmm....It would help us to know what SQL is causing the ASA error -- it
could be Replicator that's generating or it could be CIS that's generating
it.

If you are willing to pursue this, I suggest running the Replicator debug
build and using the -debug and -trace flags on the command line. Once
Replicator is back up, turn all tracing on:

sp_tracerep all_flags, true

Then try adding your replicate connection again. In addition to the
system.log, there will be a trace.log and a debug.log. Also, in your
$SYBASE/RPL-12_5/<instance>/scripts/connections directory, there should be a
SQL script with the name of your connection MyASA_field.sql

If you send me both the trace.log and the debug.log, as well as the
connections script, MyASA_field.sql, we can try to figure out what's going
on.

Thanks,
wa

<wombarrapete> wrote in message news:423e41e4.1064.1681692777@sybase.com...
> thanks for your responses Wanda -- perhaps you could also
> help with my current problem ... I keep getting a syntax
> error when issuing 'sp_addreplicateconn 'MyASA.field' (field
> is the name of my asa db)... is there a way of getting
> around this as it doesn't seem to like the normal syntax ...
> is this something that is going to stop us investigating the
> use of Replicator between ASE and ASA ?
>
> thanks
> wp
>
> full error:
> =======================
> Msg 32000, Level 20, State 0:
> Server 'ASE_REP', Procedure 'sp_addreplicateconn', Line 1:
> Command <sp_addreplicateconn> failed - Could not add
> Replicate Connection <MyASA.field> because: ASA Error -131:
> Syntax error near '.' on line 1
> =======================
> > It's not something we've tested but it should work because
> > Replicator uses CIS as the interface to the replicate
> > database. By using the CIS feature of ASE, Replicator is
> > insulated from needing to know database-specific
> > information about the replicate database.
> >
> > Thanks,
> > wa
> >
> > <wombarrapete> wrote in message
> > > news:4236553a.22a5.1681692777@sybase.com... wondering if
> > > replicator is able to be used for replication between
> > ASE & ASA ? >
> > > If yes -- which manual will have the info required
> > >
> > > If no -- what is the required approach.
> > >
> > > thanks in advance
> > >
> > > wp
> >
> >


wombarrapete Posted on 2005-04-03 08:39:14.0Z
Sender: 2870.424fab06.1804289383@sybase.com
From: wombarrapete
Newsgroups: sybase.public.ase.replicator
Subject: Re: is replicator able to be used for replication between ASE & ASA ?
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <424fabad.2874.1681692777@sybase.com>
References: <423ef0ae$1@forums-2-dub>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 3 Apr 2005 00:39:09 -0800, 10.22.241.42
Lines: 78
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 3 Apr 2005 00:39:11 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 3 Apr 2005 00:39:14 -0800
X-Trace: forums-1-dub 1112517554 10.22.108.75 (3 Apr 2005 00:39:14 -0800)
X-Original-Trace: 3 Apr 2005 00:39:14 -0800, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.replicator:61
Article PK: 103309

Wanda - apologies for the delay as I've been flat out on
another project since your last post. I'll try to get this
info for you in the next week or so once I get some time ...

thanks
wp

> Hi, wp,
>
> Hmmm....It would help us to know what SQL is causing the
> ASA error -- it could be Replicator that's generating or
> it could be CIS that's generating it.
>
> If you are willing to pursue this, I suggest running the
> Replicator debug build and using the -debug and -trace
> flags on the command line. Once Replicator is back up,
> turn all tracing on:
>
> sp_tracerep all_flags, true
>
> Then try adding your replicate connection again. In
> addition to the system.log, there will be a trace.log and
> a debug.log. Also, in your
> $SYBASE/RPL-12_5/<instance>/scripts/connections directory,
> there should be a SQL script with the name of your
> connection MyASA_field.sql
>
> If you send me both the trace.log and the debug.log, as
> well as the connections script, MyASA_field.sql, we can
> try to figure out what's going on.
>
> Thanks,
> wa
>
> <wombarrapete> wrote in message
> > news:423e41e4.1064.1681692777@sybase.com... thanks for
> > your responses Wanda -- perhaps you could also help with
> > my current problem ... I keep getting a syntax error
> > when issuing 'sp_addreplicateconn 'MyASA.field' (field
> > is the name of my asa db)... is there a way of getting
> around this as it doesn't seem to like the normal syntax
> > ... is this something that is going to stop us
> > investigating the use of Replicator between ASE and ASA
> ? >
> > thanks
> > wp
> >
> > full error:
> > =======================
> > Msg 32000, Level 20, State 0:
> > Server 'ASE_REP', Procedure 'sp_addreplicateconn', Line
> > 1: Command <sp_addreplicateconn> failed - Could not add
> > Replicate Connection <MyASA.field> because: ASA Error
> > -131: Syntax error near '.' on line 1
> > =======================
> > > It's not something we've tested but it should work
> > > because Replicator uses CIS as the interface to the
> > > replicate database. By using the CIS feature of ASE,
> > > Replicator is insulated from needing to know
> > > database-specific information about the replicate
> > database. >
> > > Thanks,
> > > wa
> > >
> > > <wombarrapete> wrote in message
> > > > news:4236553a.22a5.1681692777@sybase.com...
> > > > wondering if replicator is able to be used for
> > > replication between ASE & ASA ? >
> > > > If yes -- which manual will have the info required
> > > >
> > > > If no -- what is the required approach.
> > > >
> > > > thanks in advance
> > > >
> > > > wp
> > >
> > >
>
>