Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

How to deploy my application

4 posts in EJB Client Last posting was on 2005-04-11 15:22:33.0Z
James Posted on 2005-04-05 16:13:13.0Z
Sender: 5791.4252adaf.1804289383@sybase.com
From: James
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: How to deploy my application
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4252b916.58c1.1681692777@sybase.com>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 5 Apr 2005 09:13:10 -0800, 10.22.241.42
Lines: 17
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 5 Apr 2005 09:13:11 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 5 Apr 2005 09:13:13 -0700
X-Trace: forums-1-dub 1112717593 10.22.108.75 (5 Apr 2005 09:13:13 -0700)
X-Original-Trace: 5 Apr 2005 09:13:13 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:516
Article PK: 424652

My PB application calls a function of a java class. It works
fine within the PB9 IDE, but when I deploy it on
other two PCs, I got some errors. I install JDK 1.4 on both
PCs in directory c:\JDK1.4 . And I put
c:\JDK1.4\jre\bin\client in system varible PATH, CLASSPATH
as well. My application is installed in directory
c:\testApp. Files pbejbclient90.dll, pbejbclient90.jar,
pbjvm90.dll and my java class file testConnection.class are
all installed in c:\testApp. When I run my application and
function CreateJavaVM("", false) is called, one PC returns
-1. And the other returns -2.

I think all my settings is correct. Could somebody give me a
detail introduce how to deloy this kind of PB application?

Thanks a lot;
James


Bede <bede_nosp Posted on 2005-04-06 08:53:27.0Z
From: Bede <bede_nosp@m_sofico.be>
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: Re: How to deploy my application
Message-ID: <MPG.1cbdc1f04fa4b0289896ea@forums.sybase.com>
References: <4252b916.58c1.1681692777@sybase.com>
Organization: Sofico
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-15"
Content-Transfer-Encoding: 7bit
User-Agent: MicroPlanet-Gravity/2.70.2067
NNTP-Posting-Host: uu194-7-38-226.unknown.uunet.be
X-Original-NNTP-Posting-Host: uu194-7-38-226.unknown.uunet.be
Date: 6 Apr 2005 01:53:27 -0700
X-Trace: forums-1-dub 1112777607 194.7.38.226 (6 Apr 2005 01:53:27 -0700)
X-Original-Trace: 6 Apr 2005 01:53:27 -0700, uu194-7-38-226.unknown.uunet.be
Lines: 26
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:518
Article PK: 424651

try installing the jre under the application's directory (where the pb
dlls are placed).. eg C:\Program Files\my_pbApp\jre

if you don't do this, you'll need to point to the jre in the registry
( HKEY_LOCAL_MACHINE\SOFTWARE\Sybase\PowerBuilder\9.0\Java\PBRTConfig )


In article <4252b916.58c1.1681692777@sybase.com>, James says...

> My PB application calls a function of a java class. It works
> fine within the PB9 IDE, but when I deploy it on
> other two PCs, I got some errors. I install JDK 1.4 on both
> PCs in directory c:\JDK1.4 . And I put
> c:\JDK1.4\jre\bin\client in system varible PATH, CLASSPATH
> as well. My application is installed in directory
> c:\testApp. Files pbejbclient90.dll, pbejbclient90.jar,
> pbjvm90.dll and my java class file testConnection.class are
> all installed in c:\testApp. When I run my application and
> function CreateJavaVM("", false) is called, one PC returns
> -1. And the other returns -2.
>
> I think all my settings is correct. Could somebody give me a
> detail introduce how to deloy this kind of PB application?
>
> Thanks a lot;
> James
>


James Posted on 2005-04-08 15:47:05.0Z
Sender: 55ad.4252da7c.1804289383@sybase.com
From: James
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: Re: How to deploy my application
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4256a779.1413.1681692777@sybase.com>
References: <MPG.1cbdc1f04fa4b0289896ea@forums.sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 8 Apr 2005 08:47:05 -0700
X-Trace: forums-1-dub 1112975225 10.22.241.41 (8 Apr 2005 08:47:05 -0700)
X-Original-Trace: 8 Apr 2005 08:47:05 -0700, 10.22.241.41
Lines: 30
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:521
Article PK: 424655

It doesn't work.

> try installing the jre under the application's directory
> (where the pb dlls are placed).. eg C:\Program
> Files\my_pbApp\jre
>
> if you don't do this, you'll need to point to the jre in
> the registry (
> HKEY_LOCAL_MACHINE\SOFTWARE\Sybase\PowerBuilder\9.0\Java\P
> BRTConfig )
>
>
> In article <4252b916.58c1.1681692777@sybase.com>, James
> > says... My PB application calls a function of a java
> > class. It works fine within the PB9 IDE, but when I
> > deploy it on other two PCs, I got some errors. I install
> > JDK 1.4 on both PCs in directory c:\JDK1.4 . And I put
> > c:\JDK1.4\jre\bin\client in system varible PATH,
> > CLASSPATH as well. My application is installed in
> > directory c:\testApp. Files pbejbclient90.dll,
> > pbejbclient90.jar, pbjvm90.dll and my java class file
> > testConnection.class are all installed in c:\testApp.
> > When I run my application and function CreateJavaVM("",
> > false) is called, one PC returns -1. And the other
> > returns -2.
> > I think all my settings is correct. Could somebody give
> > me a detail introduce how to deloy this kind of PB
> > application?
> > Thanks a lot;
> > James
> >


Bede <bede_nosp Posted on 2005-04-11 15:22:33.0Z
From: Bede <bede_nosp@m_sofico.be>
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: Re: How to deploy my application
Message-ID: <MPG.1cc4b49dcfd801189896ed@forums.sybase.com>
References: <MPG.1cbdc1f04fa4b0289896ea@forums.sybase.com> <4256a779.1413.1681692777@sybase.com>
Organization: Sofico
MIME-Version: 1.0
Content-Type: text/plain; charset="iso-8859-15"
Content-Transfer-Encoding: 7bit
User-Agent: MicroPlanet-Gravity/2.70.2067
X-Original-NNTP-Posting-Host: uu194-7-38-226.unknown.uunet.be
X-Original-Trace: 11 Apr 2005 08:22:29 -0800, uu194-7-38-226.unknown.uunet.be
Lines: 38
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 11 Apr 2005 08:22:30 -0800, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 11 Apr 2005 08:22:33 -0700
X-Trace: forums-1-dub 1113232953 10.22.108.75 (11 Apr 2005 08:22:33 -0700)
X-Original-Trace: 11 Apr 2005 08:22:33 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:522
Article PK: 424656

can you give a little more info?

Have you provided all PBDs, DLLs, jars etc.. required for ejbclient
with the executable?


In article <4256a779.1413.1681692777@sybase.com>, James says...

> It doesn't work.
> > try installing the jre under the application's directory
> > (where the pb dlls are placed).. eg C:\Program
> > Files\my_pbApp\jre
> >
> > if you don't do this, you'll need to point to the jre in
> > the registry (
> > HKEY_LOCAL_MACHINE\SOFTWARE\Sybase\PowerBuilder\9.0\Java\P
> > BRTConfig )
> >
> >
> > In article <4252b916.58c1.1681692777@sybase.com>, James
> > > says... My PB application calls a function of a java
> > > class. It works fine within the PB9 IDE, but when I
> > > deploy it on other two PCs, I got some errors. I install
> > > JDK 1.4 on both PCs in directory c:\JDK1.4 . And I put
> > > c:\JDK1.4\jre\bin\client in system varible PATH,
> > > CLASSPATH as well. My application is installed in
> > > directory c:\testApp. Files pbejbclient90.dll,
> > > pbejbclient90.jar, pbjvm90.dll and my java class file
> > > testConnection.class are all installed in c:\testApp.
> > > When I run my application and function CreateJavaVM("",
> > > false) is called, one PC returns -1. And the other
> > > returns -2.
> > > I think all my settings is correct. Could somebody give
> > > me a detail introduce how to deloy this kind of PB
> > > application?
> > > Thanks a lot;
> > > James
> > >
>