Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Custom UO editing problem

5 posts in Objects Last posting was on 2005-04-18 21:54:41.0Z
Brad Mettee Posted on 2005-04-18 16:06:21.0Z
Newsgroups: sybase.public.powerbuilder.objects
Subject: Custom UO editing problem
From: bmettee@REMOVE.pchotshots.com (Brad Mettee)
Organization: PC HotShots, Inc.
X-Newsreader: WinVN 0.99.9 (Released Version) (x86 32bit)
MIME-Version: 1.0
Content-Type: Text/Plain; charset=US-ASCII
X-Original-NNTP-Posting-Host: 65.222.202.68
Message-ID: <4263daf9$1@forums-2-dub>
X-Original-Trace: 18 Apr 2005 09:06:17 -0800, 65.222.202.68
Lines: 27
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 18 Apr 2005 09:06:18 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 18 Apr 2005 09:06:21 -0700
X-Trace: forums-1-dub 1113840381 10.22.108.75 (18 Apr 2005 09:06:21 -0700)
X-Original-Trace: 18 Apr 2005 09:06:21 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8343
Article PK: 735569

I've been working in PB10 for a few months now and found a problem in the
editor when I started, but until recently didn' t have a clue what was causing it.
It's easy to reproduce, but shouldn't exist in the first place.

Create a new custom visual object.
Try right-clicking on the object, you get a menu.
Un-Check Enabled on object properties.
Now you can't get a right click menu on the object, or anything placed on the
object.

At this point, the IDE is treating the object exactly like the runtime would, but
makes it impossible to continue editing until you make it enabled again. This
doesn't occur on window objects, they can be enabled/disabled and right-click
still works fine on any/all objects in the edit window.

This has existed from original install of 10.0 through 10.2 as far as I can tell. It
works fine in 8, don't know about 9.

Can someone else verify this please?

--
Brad Mettee
PC HotShots, Inc.
Baltimore, MD

--> Let us bring out the *Power* of your PCs <--


Roy Kiesler [TeamSybase] Posted on 2005-04-18 17:07:28.0Z
From: "Roy Kiesler [TeamSybase]" <roy.kiesler@teamsybase.com>
Reply-To: SPAM_FRE_roy.kiesler@teamsybase.com
Organization: TeamSybase
User-Agent: Mozilla Thunderbird 1.0.2 (Windows/20050317)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: Custom UO editing problem
References: <4263daf9$1@forums-2-dub>
In-Reply-To: <4263daf9$1@forums-2-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: 216.250.69.98
X-Original-NNTP-Posting-Host: 216.250.69.98
Message-ID: <4263e950$1@forums-1-dub>
Date: 18 Apr 2005 10:07:28 -0700
X-Trace: forums-1-dub 1113844048 216.250.69.98 (18 Apr 2005 10:07:28 -0700)
X-Original-Trace: 18 Apr 2005 10:07:28 -0700, 216.250.69.98
Lines: 27
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8344
Article PK: 735568

Which control are you inheriting from? I tried this with a command
button and I can't reproduce this in 10.2...

--
Roy

Brad Mettee wrote:
> I've been working in PB10 for a few months now and found a problem in the
> editor when I started, but until recently didn' t have a clue what was causing it.
> It's easy to reproduce, but shouldn't exist in the first place.
>
> Create a new custom visual object.
> Try right-clicking on the object, you get a menu.
> Un-Check Enabled on object properties.
> Now you can't get a right click menu on the object, or anything placed on the
> object.
>
> At this point, the IDE is treating the object exactly like the runtime would, but
> makes it impossible to continue editing until you make it enabled again. This
> doesn't occur on window objects, they can be enabled/disabled and right-click
> still works fine on any/all objects in the edit window.
>
> This has existed from original install of 10.0 through 10.2 as far as I can tell. It
> works fine in 8, don't know about 9.
>
> Can someone else verify this please?
>


Brad Mettee Posted on 2005-04-18 20:16:03.0Z
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: Custom UO editing problem
From: bmettee@REMOVE.pchotshots.com (Brad Mettee)
Organization: PC HotShots, Inc.
X-Newsreader: WinVN 0.99.9 (Released Version) (x86 32bit)
References: <4263daf9$1@forums-2-dub> <4263e950$1@forums-1-dub>
MIME-Version: 1.0
Content-Type: Text/Plain; charset=US-ASCII
X-Original-NNTP-Posting-Host: 65.222.202.68
Message-ID: <4264157e@forums-2-dub>
X-Original-Trace: 18 Apr 2005 13:15:58 -0800, 65.222.202.68
Lines: 44
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 18 Apr 2005 13:16:00 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 18 Apr 2005 13:16:03 -0700
X-Trace: forums-1-dub 1113855363 10.22.108.75 (18 Apr 2005 13:16:03 -0700)
X-Original-Trace: 18 Apr 2005 13:16:03 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8347
Article PK: 735572

Create a new "Custom Visual", not inherited from anything (basic custom
userobject type).

In article <4263e950$1@forums-1-dub>, roy.kiesler@teamsybase.com says...

>
>Which control are you inheriting from? I tried this with a command
>button and I can't reproduce this in 10.2...
>
>--
>Roy
>
>Brad Mettee wrote:
>> I've been working in PB10 for a few months now and found a problem in the
>> editor when I started, but until recently didn' t have a clue what was causing
> it.
>> It's easy to reproduce, but shouldn't exist in the first place.
>>
>> Create a new custom visual object.
>> Try right-clicking on the object, you get a menu.
>> Un-Check Enabled on object properties.
>> Now you can't get a right click menu on the object, or anything placed on the
>> object.
>>
>> At this point, the IDE is treating the object exactly like the runtime would,
>but
>> makes it impossible to continue editing until you make it enabled again. This
>> doesn't occur on window objects, they can be enabled/disabled and
right-click
>> still works fine on any/all objects in the edit window.
>>
>> This has existed from original install of 10.0 through 10.2 as far as I can te
>ll. It
>> works fine in 8, don't know about 9.
>>
>> Can someone else verify this please?
>>

--
Brad Mettee
PC HotShots, Inc.
Baltimore, MD

--> Let us bring out the *Power* of your PCs <--


Roy Kiesler [TeamSybase] Posted on 2005-04-18 21:54:41.0Z
From: "Roy Kiesler [TeamSybase]" <roy.kiesler@teamsybase.com>
Reply-To: SPAM_FRE_roy.kiesler@teamsybase.com
Organization: TeamSybase
User-Agent: Mozilla Thunderbird 1.0.2 (Windows/20050317)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.objects
Subject: Re: Custom UO editing problem
References: <4263daf9$1@forums-2-dub> <4263e950$1@forums-1-dub> <4264157e@forums-2-dub>
In-Reply-To: <4264157e@forums-2-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: 208.252.62.130
Message-ID: <42642c9d@forums-2-dub>
X-Original-Trace: 18 Apr 2005 14:54:37 -0800, 208.252.62.130
Lines: 55
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 18 Apr 2005 14:54:39 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 18 Apr 2005 14:54:41 -0700
X-Trace: forums-1-dub 1113861281 10.22.108.75 (18 Apr 2005 14:54:41 -0700)
X-Original-Trace: 18 Apr 2005 14:54:41 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8349
Article PK: 735571

OIC -- I create a standard visual, not a custom one.

The effect is in 10.2 as well, so you should log it as a bug.

_-
Roy

Brad Mettee wrote:
> Create a new "Custom Visual", not inherited from anything (basic custom
> userobject type).
>
> In article <4263e950$1@forums-1-dub>, roy.kiesler@teamsybase.com says...
>
>>Which control are you inheriting from? I tried this with a command
>>button and I can't reproduce this in 10.2...
>>
>>--
>>Roy
>>
>>Brad Mettee wrote:
>>
>>>I've been working in PB10 for a few months now and found a problem in the
>>>editor when I started, but until recently didn' t have a clue what was causing
>>
>>it.
>>
>>>It's easy to reproduce, but shouldn't exist in the first place.
>>>
>>>Create a new custom visual object.
>>>Try right-clicking on the object, you get a menu.
>>>Un-Check Enabled on object properties.
>>>Now you can't get a right click menu on the object, or anything placed on the
>>>object.
>>>
>>>At this point, the IDE is treating the object exactly like the runtime would,
>>
>>but
>>
>>>makes it impossible to continue editing until you make it enabled again. This
>>>doesn't occur on window objects, they can be enabled/disabled and
>
> right-click
>
>>>still works fine on any/all objects in the edit window.
>>>
>>>This has existed from original install of 10.0 through 10.2 as far as I can te
>>
>>ll. It
>>
>>>works fine in 8, don't know about 9.
>>>
>>>Can someone else verify this please?
>>>
>
>


Millard F. Brown III Posted on 2005-04-18 21:14:15.0Z
From: "Millard F. Brown III" <mf3_NOSPAM_@gatesys.com>
Newsgroups: sybase.public.powerbuilder.objects
Organization: 216.98.24.70
References: <4263daf9$1@forums-2-dub> <4263e950$1@forums-1-dub> <4264157e@forums-2-dub>
X-Newsreader: AspNNTP 1.50 (Takeshi Eto)
Subject: Re: Custom UO editing problem
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: web110.discountasp.net
X-Original-NNTP-Posting-Host: web110.discountasp.net
Message-ID: <42642327$1@forums-1-dub>
Date: 18 Apr 2005 14:14:15 -0700
X-Trace: forums-1-dub 1113858855 64.79.161.40 (18 Apr 2005 14:14:15 -0700)
X-Original-Trace: 18 Apr 2005 14:14:15 -0700, web110.discountasp.net
Lines: 64
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.objects:8348
Article PK: 735575

Brad,

I am seeing this behavior in 10.0.1. If you just check "enabled" on the
properties dialog, you can continue to edit the object. I agree that this is not
the way it ought to work, but at least there's a straightforward workaround.

Regards,
Millard[TeamSybase]

On 18 Apr 2005 13:16:03 -0700,
in sybase.public.powerbuilder.objects

Brad Mettee <bmettee@REMOVE.pchotshots.com> wrote:
>Create a new "Custom Visual", not inherited from anything (basic custom
>userobject type).
>
>In article <4263e950$1@forums-1-dub>, roy.kiesler@teamsybase.com says...
>>
>>Which control are you inheriting from? I tried this with a command
>>button and I can't reproduce this in 10.2...
>>
>>--
>>Roy
>>
>>Brad Mettee wrote:
>>> I've been working in PB10 for a few months now and found a problem in the
>>> editor when I started, but until recently didn' t have a clue what was
causing
>> it.
>>> It's easy to reproduce, but shouldn't exist in the first place.
>>>
>>> Create a new custom visual object.
>>> Try right-clicking on the object, you get a menu.
>>> Un-Check Enabled on object properties.
>>> Now you can't get a right click menu on the object, or anything placed on
the
>>> object.
>>>
>>> At this point, the IDE is treating the object exactly like the runtime
would,
>>but
>>> makes it impossible to continue editing until you make it enabled again.
This
>>> doesn't occur on window objects, they can be enabled/disabled and
>right-click
>>> still works fine on any/all objects in the edit window.
>>>
>>> This has existed from original install of 10.0 through 10.2 as far as I can
te
>>ll. It
>>> works fine in 8, don't know about 9.
>>>
>>> Can someone else verify this please?
>>>
>
>--
>Brad Mettee
>PC HotShots, Inc.
>Baltimore, MD
>
>--> Let us bring out the *Power* of your PCs <--
>

Regards,
Millard[TeamSybase]