Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

.NET connection times out

3 posts in General Discussion Last posting was on 2005-04-28 16:11:48.0Z
David Posted on 2005-04-28 13:33:48.0Z
Sender: 27d.4270e2f8.1804289383@sybase.com
From: David
Newsgroups: ianywhere.public.general
Subject: .NET connection times out
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <4270e63c.2df.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 28 Apr 2005 06:33:48 -0700
X-Trace: forums-1-dub 1114695228 10.22.241.41 (28 Apr 2005 06:33:48 -0700)
X-Original-Trace: 28 Apr 2005 06:33:48 -0700, 10.22.241.41
Lines: 13
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:4398
Article PK: 8210

Sorry to cross post, but I thought maybe my original post to
the sqlanywhere.general was to the wrong group.

I have a SQL Anywhere 9 database that I can connect to fine
via Sybase Central or ISQL. However, when I attempt to
connect using the AsaConnection object from the
IAnywhere.Data.AsaClient namespace, the open connection call
times out. The code works fine on my development box, but I
cannot get the connection to work on the production box.
Any ideas?

Thanks,
David


Chris Keating (iAnywhere Solutions) Posted on 2005-04-28 13:56:32.0Z
From: "Chris Keating \(iAnywhere Solutions\)" <Spam_NoThanks_keating@iAnywhere.com>
Newsgroups: ianywhere.public.general
References: <4270e63c.2df.1681692777@sybase.com>
Subject: Re: .NET connection times out
Lines: 19
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Original
NNTP-Posting-Host: keating-xp2.sybase.com
X-Original-NNTP-Posting-Host: keating-xp2.sybase.com
Message-ID: <4270eb90@forums-1-dub>
Date: 28 Apr 2005 06:56:32 -0700
X-Trace: forums-1-dub 1114696592 10.25.98.199 (28 Apr 2005 06:56:32 -0700)
X-Original-Trace: 28 Apr 2005 06:56:32 -0700, keating-xp2.sybase.com
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:4400
Article PK: 8212

What is your server start line and your connection string?

<David> wrote in message news:4270e63c.2df.1681692777@sybase.com...
> Sorry to cross post, but I thought maybe my original post to
> the sqlanywhere.general was to the wrong group.
>
> I have a SQL Anywhere 9 database that I can connect to fine
> via Sybase Central or ISQL. However, when I attempt to
> connect using the AsaConnection object from the
> IAnywhere.Data.AsaClient namespace, the open connection call
> times out. The code works fine on my development box, but I
> cannot get the connection to work on the production box.
> Any ideas?
>
> Thanks,
> David


David A <dealkema Posted on 2005-04-28 16:11:48.0Z
From: David A <dealkema@no_spam_here_fedex.com>
Reply-To: dealkema@no_spam_here_fedex.com
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: ianywhere.public.general
Subject: Re: .NET connection times out
References: <4270e63c.2df.1681692777@sybase.com> <4270eb90@forums-1-dub>
In-Reply-To: <4270eb90@forums-1-dub>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: 199.82.225.13
Message-ID: <42710b40$1@forums-2-dub>
X-Original-Trace: 28 Apr 2005 09:11:44 -0700, 199.82.225.13
Lines: 44
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 28 Apr 2005 09:11:45 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 28 Apr 2005 09:11:48 -0700
X-Trace: forums-1-dub 1114704708 10.22.108.75 (28 Apr 2005 09:11:48 -0700)
X-Original-Trace: 28 Apr 2005 09:11:48 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.general:4401
Article PK: 8213

Server Start Line: C:\PROGRA~1\Sybase\SQLANY~1\win32\dbsrv9.exe -x none -gd all

Connection String (C# code):
WriteToEventLog("Before make db connection", 3);
AsaConnection conn;
conn = new AsaConnection("DSN=Snapshot; uid=dba; pwd=sql");

WriteToEventLog("Before open db connection", 3);
conn.Open();
WriteToEventLog("After open db connection", 3);

When I run the code, the I see the first two logs in the application event log,
but I never get the "After open db connection" log. I've got the ianywhere
object in the GAC on the production box, but I'm guessing that there is still
some kind of configuration issue, as all the code works fine on the development
system. The dsn's match on both systems.

Thanks for your help,

David

Chris Keating (iAnywhere Solutions) wrote:
> What is your server start line and your connection string?
>
>
> <David> wrote in message news:4270e63c.2df.1681692777@sybase.com...
>
>>Sorry to cross post, but I thought maybe my original post to
>>the sqlanywhere.general was to the wrong group.
>>
>>I have a SQL Anywhere 9 database that I can connect to fine
>>via Sybase Central or ISQL. However, when I attempt to
>>connect using the AsaConnection object from the
>>IAnywhere.Data.AsaClient namespace, the open connection call
>>times out. The code works fine on my development box, but I
>>cannot get the connection to work on the production box.
>>Any ideas?
>>
>>Thanks,
>>David
>
>
>