Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

jdk 1.5 and PB9

9 posts in EJB Client Last posting was on 2007-01-03 13:00:06.0Z
Gokhan Demir Posted on 2005-05-13 22:01:29.0Z
From: Gokhan Demir <gokhan.demir@igonline.biz>
User-Agent: Mozilla Thunderbird 1.0 (Windows/20041206)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: jdk 1.5 and PB9
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: 85.105.17.113
Message-ID: <428523b4$1@forums-2-dub>
X-Original-Trace: 13 May 2005 15:01:24 -0700, 85.105.17.113
Lines: 11
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 13 May 2005 15:01:26 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 13 May 2005 15:01:29 -0700
X-Trace: forums-1-dub 1116021689 10.22.108.75 (13 May 2005 15:01:29 -0700)
X-Original-Trace: 13 May 2005 15:01:29 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:528
Article PK: 424661

Is it possible to use JDK 1.5 with Powerbuilder 9? Or Am I forced to use
Powerbuilder 10 to use JDK 1.5? Or even, is it not possible to use JDK
1.5 with Powerbuilder <any version>?

It seems my 1.4.2 generated proxies does not like the real remote
classes compiled with 1.5.0_03.

This question stands for my application in production.

Thanks in advance and Regards,
Gokhan Demir


Jim O'Neil [Sybase] Posted on 2005-05-14 00:28:53.0Z
From: "Jim O'Neil [Sybase]" <joneil_at_sybase_dot_com>
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: Re: jdk 1.5 and PB9
Message-ID: <ahha8192uio22ksi2i6lhd1jn4bamqp8nk@4ax.com>
References: <428523b4$1@forums-2-dub>
X-Newsreader: Forte Agent 2.0/32.652
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: vpn-concord-048.sybase.com
X-Original-Trace: 13 May 2005 17:28:50 -0700, vpn-concord-048.sybase.com
Lines: 18
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 13 May 2005 17:28:52 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 13 May 2005 17:28:53 -0700
X-Trace: forums-1-dub 1116030533 10.22.108.75 (13 May 2005 17:28:53 -0700)
X-Original-Trace: 13 May 2005 17:28:53 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:529
Article PK: 424662

There hasn't been any testing of 1.5, but there's no technical reason
I can think of for it not working.

On 13 May 2005 15:01:29 -0700, Gokhan Demir

<gokhan.demir@igonline.biz> wrote:

>Is it possible to use JDK 1.5 with Powerbuilder 9? Or Am I forced to use
>Powerbuilder 10 to use JDK 1.5? Or even, is it not possible to use JDK
>1.5 with Powerbuilder <any version>?
>
>It seems my 1.4.2 generated proxies does not like the real remote
>classes compiled with 1.5.0_03.
>
>This question stands for my application in production.
>
>Thanks in advance and Regards,
>Gokhan Demir


Gokhan Demir Posted on 2005-05-14 15:08:22.0Z
From: Gokhan Demir <gokhan.demir@igonline.biz>
User-Agent: Mozilla Thunderbird 1.0 (Windows/20041206)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: Re: jdk 1.5 and PB9
References: <428523b4$1@forums-2-dub> <ahha8192uio22ksi2i6lhd1jn4bamqp8nk@4ax.com>
In-Reply-To: <ahha8192uio22ksi2i6lhd1jn4bamqp8nk@4ax.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: 85.105.17.113
Message-ID: <42861464@forums-2-dub>
X-Original-Trace: 14 May 2005 08:08:20 -0700, 85.105.17.113
Lines: 50
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 14 May 2005 08:08:20 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 14 May 2005 08:08:22 -0700
X-Trace: forums-1-dub 1116083302 10.22.108.75 (14 May 2005 08:08:22 -0700)
X-Original-Trace: 14 May 2005 08:08:22 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:530
Article PK: 424663

Hi back, thanks for your answer.

I have managed to get PB9 successfully work with JDK 1.5.

However, proxy generation is a problem. PB9 can only generate proxies
with the default JDK (1.4.0) originally distributed with Powerbuilder
because of the ejb2pb90 proxy generator (or the dll version) javap
output parser. It is able to parse only JDK 1.4.0 version javap output.
But, JDK 1.4.2_08 and 1.5.0_03 are producing different (but identical)
javap outputs than the 1.4.0 version.

Therefore, I must first build my EJB application using jdk 1.4, generate
proxies, and then regenerate my EJB application using jdk 1.5, and then
deploy to the application server.

One more issue to me was the fact that original jdk folder might have
been hard coded to somewhere and each time my application was creating a
1.4.0 jdk. After changing the Powerbuilder distributed JDK folder's
name, my application was able to find jdk 1.5 successfully.

So, I have two requests:
1. It would be great if Sybase can change the javap output parser to
recognize new jdk distributions.
2. It would be great if Powerbuilder uses JAVA_HOME system environment
variable (if exists) to decide which JVM to instantiate.

Best Regards,
Gokhan Demir

Jim O'Neil [Sybase] wrote:
> There hasn't been any testing of 1.5, but there's no technical reason
> I can think of for it not working.
>
> On 13 May 2005 15:01:29 -0700, Gokhan Demir
> <gokhan.demir@igonline.biz> wrote:
>
>
>>Is it possible to use JDK 1.5 with Powerbuilder 9? Or Am I forced to use
>>Powerbuilder 10 to use JDK 1.5? Or even, is it not possible to use JDK
>>1.5 with Powerbuilder <any version>?
>>
>>It seems my 1.4.2 generated proxies does not like the real remote
>>classes compiled with 1.5.0_03.
>>
>>This question stands for my application in production.
>>
>>Thanks in advance and Regards,
>>Gokhan Demir
>
>


Roy Kiesler [TeamSybase] Posted on 2005-05-15 15:37:56.0Z
From: "Roy Kiesler [TeamSybase]" <roy.kiesler@teamsybase.com>
Reply-To: SPAM_FRE_roy.kiesler@teamsybase.com
Organization: TeamSybase
User-Agent: Mozilla Thunderbird 1.0.2 (Windows/20050317)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: Re: jdk 1.5 and PB9
References: <428523b4$1@forums-2-dub>
In-Reply-To: <428523b4$1@forums-2-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: c-24-4-166-164.hsd1.ca.comcast.net
Message-ID: <42876cce$1@forums-2-dub>
X-Original-Trace: 15 May 2005 08:37:50 -0700, c-24-4-166-164.hsd1.ca.comcast.net
Lines: 20
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 15 May 2005 08:37:53 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 15 May 2005 08:37:56 -0700
X-Trace: forums-1-dub 1116171476 10.22.108.75 (15 May 2005 08:37:56 -0700)
X-Original-Trace: 15 May 2005 08:37:56 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:531
Article PK: 424664


Gokhan Demir wrote:
> Is it possible to use JDK 1.5 with Powerbuilder 9? Or Am I forced to use
> Powerbuilder 10 to use JDK 1.5? Or even, is it not possible to use JDK
> 1.5 with Powerbuilder <any version>?
>
> It seems my 1.4.2 generated proxies does not like the real remote
> classes compiled with 1.5.0_03.
>
> This question stands for my application in production.
>
> Thanks in advance and Regards,
> Gokhan Demir

You should be, but realize this has not been tested by Sybase. Try and see.

BTW, what do you mean by "does not like"? Are you getting any errors
regarding the JRE differences?

--
Roy


Gokhan Demir Posted on 2005-05-16 06:43:14.0Z
From: Gokhan Demir <gokhan.demir@igonline.biz>
User-Agent: Mozilla Thunderbird 1.0 (Windows/20041206)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: Re: jdk 1.5 and PB9
References: <428523b4$1@forums-2-dub> <42876cce$1@forums-2-dub>
In-Reply-To: <42876cce$1@forums-2-dub>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-Original-NNTP-Posting-Host: 85.105.17.113
Message-ID: <428840fe@forums-2-dub>
X-Original-Trace: 15 May 2005 23:43:10 -0700, 85.105.17.113
Lines: 57
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 15 May 2005 23:43:11 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 15 May 2005 23:43:14 -0700
X-Trace: forums-1-dub 1116225794 10.22.108.75 (15 May 2005 23:43:14 -0700)
X-Original-Trace: 15 May 2005 23:43:14 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:532
Article PK: 424665

Hi back, thank you for your answer.

I meant a couple of errors "Error when calling a method of a JNDI ...."
by saying "does not like". But, it has later turned out to be my
mistake, such that, I was trying to access an EJB server running JVM1.4,
and my client JVM at version 1.5 <g/>.

I have been successful to make Powerbuilder 9 run correctly with jdk1.5
when both ends were using jdk1.5 and the classes were also compiled with
jdk1.5 compatibility level.

Although my first impression is that it seems ok, I will not use jdk 1.5
in my production application unless it has been officially tested and
supported by Sybase.

As in my reply to Mr O'Neil, proxy generation is a headache. Since
Powerbuilder 9 proxy generation is only able to parse jdk 1.4.0 javap
output and since this output is different in newer jdk distributions, I
have to first compile my classes using jdk1.4 (with 1.4 compatibility
level), generate proxies at Powerbuilder side, and recompile whole EJB
application using 1.5 and deploy to the ejb server running jdk 1.5.

The reason I am wishing to use the new jdk 1.5 is I would like to use
the new extensions at my EJB application side. But, the above mentioned
proxy generation logic prohibits the use of these new extensions even
though I can use the new jdk1.5. I can use it because my EJB project
compiles successfully using both 1.4 and 1.5. Propably it will require
me to upgrade to a newer Powerbuilder version to really be able to use
the new jdk extensions. Let's wait and see.

Best Regards,
Gokhan Demir.

Roy Kiesler [TeamSybase] wrote:
> Gokhan Demir wrote:
>
>> Is it possible to use JDK 1.5 with Powerbuilder 9? Or Am I forced to
>> use Powerbuilder 10 to use JDK 1.5? Or even, is it not possible to use
>> JDK 1.5 with Powerbuilder <any version>?
>>
>> It seems my 1.4.2 generated proxies does not like the real remote
>> classes compiled with 1.5.0_03.
>>
>> This question stands for my application in production.
>>
>> Thanks in advance and Regards,
>> Gokhan Demir
>
>
> You should be, but realize this has not been tested by Sybase. Try and see.
>
> BTW, what do you mean by "does not like"? Are you getting any errors
> regarding the JRE differences?
>
> --
> Roy


Sekar Posted on 2005-09-19 18:47:12.0Z
Sender: 2159.432f05de.1804289383@sybase.com
From: Sekar
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: Re: jdk 1.5 and PB9
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <432f0778.2175.1681692777@sybase.com>
References: <428840fe@forums-2-dub>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 19 Sep 2005 11:46:16 -0700, 10.22.241.42
Lines: 72
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 19 Sep 2005 11:46:17 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 19 Sep 2005 11:47:12 -0700
X-Trace: forums-1-dub 1127155632 10.22.108.75 (19 Sep 2005 11:47:12 -0700)
X-Original-Trace: 19 Sep 2005 11:47:12 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:568
Article PK: 424698

Hello,

Are you able to create JVM with JDK 1.5 inside IDE? I am not
able to create the JVM. CreateJavaVM () returns -1 when I
point to JDK 1.5. If this worked then I may be able to find
a workaround for the javap parser output.

--Thanks

> Hi back, thank you for your answer.
>
> I meant a couple of errors "Error when calling a method of
> a JNDI ...." by saying "does not like". But, it has later
> turned out to be my mistake, such that, I was trying to
> access an EJB server running JVM1.4, and my client JVM at
> version 1.5 <g/>.
>
> I have been successful to make Powerbuilder 9 run
> correctly with jdk1.5 when both ends were using jdk1.5
> and the classes were also compiled with jdk1.5
> compatibility level.
>
> Although my first impression is that it seems ok, I will
> not use jdk 1.5 in my production application unless it
> has been officially tested and supported by Sybase.
>
> As in my reply to Mr O'Neil, proxy generation is a
> headache. Since Powerbuilder 9 proxy generation is only
> able to parse jdk 1.4.0 javap output and since this
> output is different in newer jdk distributions, I have to
> first compile my classes using jdk1.4 (with 1.4
> compatibility level), generate proxies at Powerbuilder
> side, and recompile whole EJB application using 1.5 and
> deploy to the ejb server running jdk 1.5.
>
> The reason I am wishing to use the new jdk 1.5 is I would
> like to use the new extensions at my EJB application
> side. But, the above mentioned proxy generation logic
> prohibits the use of these new extensions even though I
> can use the new jdk1.5. I can use it because my EJB
> project compiles successfully using both 1.4 and 1.5.
> Propably it will require me to upgrade to a newer
> Powerbuilder version to really be able to use the new jdk
> extensions. Let's wait and see.
>
> Best Regards,
> Gokhan Demir.
>
>
> Roy Kiesler [TeamSybase] wrote:
> > Gokhan Demir wrote:
> >
> >> Is it possible to use JDK 1.5 with Powerbuilder 9? Or
> Am I forced to >> use Powerbuilder 10 to use JDK 1.5? Or
> even, is it not possible to use >> JDK 1.5 with
> Powerbuilder <any version>? >>
> >> It seems my 1.4.2 generated proxies does not like the
> real remote >> classes compiled with 1.5.0_03.
> >>
> >> This question stands for my application in production.
> >>
> >> Thanks in advance and Regards,
> >> Gokhan Demir
> >
> >
> > You should be, but realize this has not been tested by
> > Sybase. Try and see.
> > BTW, what do you mean by "does not like"? Are you
> > getting any errors regarding the JRE differences?
> >
> > --
> > Roy


Gokhan Demir Posted on 2005-09-21 12:31:40.0Z
From: Gokhan Demir <gokhan.demir@igonline.biz>
User-Agent: Mozilla Thunderbird 1.0 (Windows/20041206)
X-Accept-Language: en-us, en
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: Re: jdk 1.5 and PB9
References: <428840fe@forums-2-dub> <432f0778.2175.1681692777@sybase.com>
In-Reply-To: <432f0778.2175.1681692777@sybase.com>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: mstr195175-33153.dial-in.ttnet.net.tr
X-Original-NNTP-Posting-Host: mstr195175-33153.dial-in.ttnet.net.tr
Message-ID: <433152ac@forums-1-dub>
Date: 21 Sep 2005 05:31:40 -0700
X-Trace: forums-1-dub 1127305900 195.175.209.130 (21 Sep 2005 05:31:40 -0700)
X-Original-Trace: 21 Sep 2005 05:31:40 -0700, mstr195175-33153.dial-in.ttnet.net.tr
Lines: 92
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:569
Article PK: 424697

Hello,

Yes, I was able to do that. Please read my response to Mr O'Neil in this
thread.

I would recommend you to wait until Sybase officially supports jdk 1.5.
Otherwise, you will only be able to use jdk 1.5 with jdk 1.4 compliant
java code. Plus, it will be dangerous since Powerbuilder's EJB Client
extension is not certified on jdk 1.5.

Regards,
Gokhan Demir

Sekar wrote:
> Hello,
>
> Are you able to create JVM with JDK 1.5 inside IDE? I am not
> able to create the JVM. CreateJavaVM () returns -1 when I
> point to JDK 1.5. If this worked then I may be able to find
> a workaround for the javap parser output.
>
> --Thanks
>
>
>>Hi back, thank you for your answer.
>>
>>I meant a couple of errors "Error when calling a method of
>>a JNDI ...." by saying "does not like". But, it has later
>>turned out to be my mistake, such that, I was trying to
>>access an EJB server running JVM1.4, and my client JVM at
>>version 1.5 <g/>.
>>
>>I have been successful to make Powerbuilder 9 run
>>correctly with jdk1.5 when both ends were using jdk1.5
>>and the classes were also compiled with jdk1.5
>>compatibility level.
>>
>>Although my first impression is that it seems ok, I will
>>not use jdk 1.5 in my production application unless it
>>has been officially tested and supported by Sybase.
>>
>>As in my reply to Mr O'Neil, proxy generation is a
>>headache. Since Powerbuilder 9 proxy generation is only
>>able to parse jdk 1.4.0 javap output and since this
>>output is different in newer jdk distributions, I have to
>>first compile my classes using jdk1.4 (with 1.4
>>compatibility level), generate proxies at Powerbuilder
>>side, and recompile whole EJB application using 1.5 and
>>deploy to the ejb server running jdk 1.5.
>>
>>The reason I am wishing to use the new jdk 1.5 is I would
>>like to use the new extensions at my EJB application
>>side. But, the above mentioned proxy generation logic
>>prohibits the use of these new extensions even though I
>>can use the new jdk1.5. I can use it because my EJB
>>project compiles successfully using both 1.4 and 1.5.
>>Propably it will require me to upgrade to a newer
>>Powerbuilder version to really be able to use the new jdk
>>extensions. Let's wait and see.
>>
>>Best Regards,
>>Gokhan Demir.
>>
>>
>>Roy Kiesler [TeamSybase] wrote:
>>
>>>Gokhan Demir wrote:
>>>
>>>
>>>>Is it possible to use JDK 1.5 with Powerbuilder 9? Or
>>
>>Am I forced to >> use Powerbuilder 10 to use JDK 1.5? Or
>>even, is it not possible to use >> JDK 1.5 with
>>Powerbuilder <any version>? >>
>>
>>>>It seems my 1.4.2 generated proxies does not like the
>>
>>real remote >> classes compiled with 1.5.0_03.
>>
>>>>This question stands for my application in production.
>>>>
>>>>Thanks in advance and Regards,
>>>>Gokhan Demir
>>>
>>>
>>>You should be, but realize this has not been tested by
>>>Sybase. Try and see.
>>>BTW, what do you mean by "does not like"? Are you
>>>getting any errors regarding the JRE differences?
>>>
>>>--
>>>Roy


Timothy Madsen Posted on 2006-12-30 00:23:51.0Z
From: "Timothy Madsen" <timothy_madsen@bigfoot.com>
Newsgroups: sybase.public.powerbuilder.ejbclient
References: <428840fe@forums-2-dub> <432f0778.2175.1681692777@sybase.com> <433152ac@forums-1-dub>
Subject: Re: jdk 1.5 and PB9
Lines: 103
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.3028
X-RFC2646: Format=Flowed; Response
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.3028
NNTP-Posting-Host: c-69-248-38-201.hsd1.pa.comcast.net
X-Original-NNTP-Posting-Host: c-69-248-38-201.hsd1.pa.comcast.net
Message-ID: <4595bfa7$1@forums-1-dub>
Date: 29 Dec 2006 17:23:51 -0700
X-Trace: forums-1-dub 1167441831 69.248.38.201 (29 Dec 2006 17:23:51 -0700)
X-Original-Trace: 29 Dec 2006 17:23:51 -0700, c-69-248-38-201.hsd1.pa.comcast.net
X-Authenticated-User: pb110beta
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:705
Article PK: 424807

FYI: PB 10.5.1 (6021) Maintenance Release now supports jdk 1.5 per:
CR 431836
Description: An error occurs when attempting to deploy a project to generate
EJB proxies when using JDK 1.5. The error does not occur using JDK 1.4.

Tim.

"Gokhan Demir" <gokhan.demir@igonline.biz> wrote in message
news:433152ac@forums-1-dub...
> Hello,
>
> Yes, I was able to do that. Please read my response to Mr O'Neil in this
> thread.
>
> I would recommend you to wait until Sybase officially supports jdk 1.5.
> Otherwise, you will only be able to use jdk 1.5 with jdk 1.4 compliant
> java code. Plus, it will be dangerous since Powerbuilder's EJB Client
> extension is not certified on jdk 1.5.
>
> Regards,
> Gokhan Demir
>
> Sekar wrote:
>> Hello,
>>
>> Are you able to create JVM with JDK 1.5 inside IDE? I am not
>> able to create the JVM. CreateJavaVM () returns -1 when I
>> point to JDK 1.5. If this worked then I may be able to find
>> a workaround for the javap parser output.
>>
>> --Thanks
>>
>>
>>>Hi back, thank you for your answer.
>>>
>>>I meant a couple of errors "Error when calling a method of
>>>a JNDI ...." by saying "does not like". But, it has later
>>>turned out to be my mistake, such that, I was trying to
>>>access an EJB server running JVM1.4, and my client JVM at
>>>version 1.5 <g/>.
>>>
>>>I have been successful to make Powerbuilder 9 run
>>>correctly with jdk1.5 when both ends were using jdk1.5
>>>and the classes were also compiled with jdk1.5
>>>compatibility level.
>>>
>>>Although my first impression is that it seems ok, I will
>>>not use jdk 1.5 in my production application unless it
>>>has been officially tested and supported by Sybase.
>>>
>>>As in my reply to Mr O'Neil, proxy generation is a
>>>headache. Since Powerbuilder 9 proxy generation is only
>>>able to parse jdk 1.4.0 javap output and since this
>>>output is different in newer jdk distributions, I have to
>>>first compile my classes using jdk1.4 (with 1.4
>>>compatibility level), generate proxies at Powerbuilder
>>>side, and recompile whole EJB application using 1.5 and
>>>deploy to the ejb server running jdk 1.5.
>>>
>>>The reason I am wishing to use the new jdk 1.5 is I would
>>>like to use the new extensions at my EJB application
>>>side. But, the above mentioned proxy generation logic
>>>prohibits the use of these new extensions even though I
>>>can use the new jdk1.5. I can use it because my EJB
>>>project compiles successfully using both 1.4 and 1.5.
>>>Propably it will require me to upgrade to a newer
>>>Powerbuilder version to really be able to use the new jdk
>>>extensions. Let's wait and see.
>>>
>>>Best Regards,
>>>Gokhan Demir.
>>>
>>>
>>>Roy Kiesler [TeamSybase] wrote:
>>>
>>>>Gokhan Demir wrote:
>>>>
>>>>
>>>>>Is it possible to use JDK 1.5 with Powerbuilder 9? Or
>>>
>>>Am I forced to >> use Powerbuilder 10 to use JDK 1.5? Or
>>>even, is it not possible to use >> JDK 1.5 with
>>>Powerbuilder <any version>? >>
>>>
>>>>>It seems my 1.4.2 generated proxies does not like the
>>>
>>>real remote >> classes compiled with 1.5.0_03.
>>>
>>>>>This question stands for my application in production.
>>>>>
>>>>>Thanks in advance and Regards,
>>>>>Gokhan Demir
>>>>
>>>>
>>>>You should be, but realize this has not been tested by
>>>>Sybase. Try and see.
>>>>BTW, what do you mean by "does not like"? Are you
>>>>getting any errors regarding the JRE differences?
>>>>
>>>>--
>>>>Roy


Gokhan Demir Posted on 2007-01-03 13:00:06.0Z
From: Gokhan Demir <gokhan.demir@igonline.biz>
User-Agent: Thunderbird 1.5.0.9 (Windows/20061207)
MIME-Version: 1.0
Newsgroups: sybase.public.powerbuilder.ejbclient
Subject: Re: jdk 1.5 and PB9
References: <428840fe@forums-2-dub> <432f0778.2175.1681692777@sybase.com> <433152ac@forums-1-dub> <4595bfa7$1@forums-1-dub>
In-Reply-To: <4595bfa7$1@forums-1-dub>
Content-Type: text/plain; charset=ISO-8859-9; format=flowed
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: 85.105.196.163
X-Original-NNTP-Posting-Host: 85.105.196.163
Message-ID: <459bb6e6@forums-1-dub>
Date: 3 Jan 2007 06:00:06 -0700
X-Trace: forums-1-dub 1167832806 85.105.196.163 (3 Jan 2007 06:00:06 -0700)
X-Original-Trace: 3 Jan 2007 06:00:06 -0700, 85.105.196.163
Lines: 114
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.powerbuilder.ejbclient:709
Article PK: 424811

Hello,

Finally, it is very good news, I am very glad.

However, let me push a little. Jdk 6 was out already when the jdk 5
support was announced. When will the ejb-client be certified on jdk 6?
And which Powerbuilder version will it be? I need to have an idea to
plan migration of my existing clients.

Regards,
Gokhan Demir

Timothy Madsen wrote:
> FYI: PB 10.5.1 (6021) Maintenance Release now supports jdk 1.5 per:
> CR 431836
> Description: An error occurs when attempting to deploy a project to generate
> EJB proxies when using JDK 1.5. The error does not occur using JDK 1.4.
>
> Tim.
>
> "Gokhan Demir" <gokhan.demir@igonline.biz> wrote in message
> news:433152ac@forums-1-dub...
>> Hello,
>>
>> Yes, I was able to do that. Please read my response to Mr O'Neil in this
>> thread.
>>
>> I would recommend you to wait until Sybase officially supports jdk 1.5.
>> Otherwise, you will only be able to use jdk 1.5 with jdk 1.4 compliant
>> java code. Plus, it will be dangerous since Powerbuilder's EJB Client
>> extension is not certified on jdk 1.5.
>>
>> Regards,
>> Gokhan Demir
>>
>> Sekar wrote:
>>> Hello,
>>>
>>> Are you able to create JVM with JDK 1.5 inside IDE? I am not
>>> able to create the JVM. CreateJavaVM () returns -1 when I
>>> point to JDK 1.5. If this worked then I may be able to find
>>> a workaround for the javap parser output.
>>>
>>> --Thanks
>>>
>>>
>>>> Hi back, thank you for your answer.
>>>>
>>>> I meant a couple of errors "Error when calling a method of
>>>> a JNDI ...." by saying "does not like". But, it has later
>>>> turned out to be my mistake, such that, I was trying to
>>>> access an EJB server running JVM1.4, and my client JVM at
>>>> version 1.5 <g/>.
>>>>
>>>> I have been successful to make Powerbuilder 9 run
>>>> correctly with jdk1.5 when both ends were using jdk1.5
>>>> and the classes were also compiled with jdk1.5
>>>> compatibility level.
>>>>
>>>> Although my first impression is that it seems ok, I will
>>>> not use jdk 1.5 in my production application unless it
>>>> has been officially tested and supported by Sybase.
>>>>
>>>> As in my reply to Mr O'Neil, proxy generation is a
>>>> headache. Since Powerbuilder 9 proxy generation is only
>>>> able to parse jdk 1.4.0 javap output and since this
>>>> output is different in newer jdk distributions, I have to
>>>> first compile my classes using jdk1.4 (with 1.4
>>>> compatibility level), generate proxies at Powerbuilder
>>>> side, and recompile whole EJB application using 1.5 and
>>>> deploy to the ejb server running jdk 1.5.
>>>>
>>>> The reason I am wishing to use the new jdk 1.5 is I would
>>>> like to use the new extensions at my EJB application
>>>> side. But, the above mentioned proxy generation logic
>>>> prohibits the use of these new extensions even though I
>>>> can use the new jdk1.5. I can use it because my EJB
>>>> project compiles successfully using both 1.4 and 1.5.
>>>> Propably it will require me to upgrade to a newer
>>>> Powerbuilder version to really be able to use the new jdk
>>>> extensions. Let's wait and see.
>>>>
>>>> Best Regards,
>>>> Gokhan Demir.
>>>>
>>>>
>>>> Roy Kiesler [TeamSybase] wrote:
>>>>
>>>>> Gokhan Demir wrote:
>>>>>
>>>>>
>>>>>> Is it possible to use JDK 1.5 with Powerbuilder 9? Or
>>>> Am I forced to >> use Powerbuilder 10 to use JDK 1.5? Or
>>>> even, is it not possible to use >> JDK 1.5 with
>>>> Powerbuilder <any version>? >>
>>>>
>>>>>> It seems my 1.4.2 generated proxies does not like the
>>>> real remote >> classes compiled with 1.5.0_03.
>>>>
>>>>>> This question stands for my application in production.
>>>>>>
>>>>>> Thanks in advance and Regards,
>>>>>> Gokhan Demir
>>>>>
>>>>> You should be, but realize this has not been tested by
>>>>> Sybase. Try and see.
>>>>> BTW, what do you mean by "does not like"? Are you
>>>>> getting any errors regarding the JRE differences?
>>>>>
>>>>> --
>>>>> Roy
>
>