Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

error after aserep.sh

3 posts in replicator Last posting was on 2005-05-27 18:53:21.0Z
Leandro Rennó Posted on 2005-05-27 14:55:03.0Z
Sender: 4809.4294a31a.1804289383@sybase.com
From: Leandro Rennó
Newsgroups: sybase.public.ase.replicator
Subject: error after aserep.sh
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <429734c7.5cf4.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 27 May 2005 07:55:03 -0700
X-Trace: forums-1-dub 1117205703 10.22.241.41 (27 May 2005 07:55:03 -0700)
X-Original-Trace: 27 May 2005 07:55:03 -0700, 10.22.241.41
Lines: 6
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.replicator:82
Article PK: 103328

I executed aserep.sh and the replicator generated script of
inicialization RUN_XXXX.
Later I executed the RUN_XXXX and the replicator was in
execution, but when I tested the execution of procedure
sp_configrep in distribution database does not happen
nothing, I did not get reply.


Victoria Handros Posted on 2005-05-27 17:57:33.0Z
Message-ID: <42975F8C.F4FCC3F@sybase.com>
From: Victoria Handros <vhandros@sybase.com>
Organization: Sybase, Inc.
X-Mailer: Mozilla 4.76 [en] (Windows NT 5.0; U)
X-Accept-Language: en
MIME-Version: 1.0
Newsgroups: sybase.public.ase.replicator
Subject: Re: error after aserep.sh
References: <429734c7.5cf4.1681692777@sybase.com>
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit
NNTP-Posting-Host: vhandros2k.sybase.com
X-Original-NNTP-Posting-Host: vhandros2k.sybase.com
Date: 27 May 2005 10:57:33 -0700
X-Trace: forums-1-dub 1117216653 10.22.85.220 (27 May 2005 10:57:33 -0700)
X-Original-Trace: 27 May 2005 10:57:33 -0700, vhandros2k.sybase.com
Lines: 19
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.replicator:83
Article PK: 103329

Hi Leandro,
could you provide the command line you used to launch Replicator
initially,
and your RUN_XXX script.
Also, can you clarify on what happened when you executed sp_configrep
in the distribution database. Did you get any error messages?

Thanks,
Victoria.

Leandro, Rennó wrote:

> I executed aserep.sh and the replicator generated script of
> inicialization RUN_XXXX.
> Later I executed the RUN_XXXX and the replicator was in
> execution, but when I tested the execution of procedure
> sp_configrep in distribution database does not happen
> nothing, I did not get reply.


Leandro Rennó Posted on 2005-05-27 18:53:21.0Z
Sender: 5e2e.42976c4b.1804289383@sybase.com
From: Leandro Rennó
Newsgroups: sybase.public.ase.replicator
Subject: Re: error after aserep.sh
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <42976ca1.5e32.1681692777@sybase.com>
References: <42975F8C.F4FCC3F@sybase.com>
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="-=_forums-1-dub42976ca1"
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 27 May 2005 11:53:21 -0700
X-Trace: forums-1-dub 1117220001 10.22.241.41 (27 May 2005 11:53:21 -0700)
X-Original-Trace: 27 May 2005 11:53:21 -0700, 10.22.241.41
Lines: 64
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.ase.replicator:84
Article PK: 103330

Hi Victoria,

I executed the following command:

aserep.sh -m LINUX -a 5000 -s ASERep -r 5005 -d distribuidor
-u testerep -p testerep

Generated script $SYBASE/RPL_12-5/ASERep/RUN_ASERep and
$SYBASE/RPL_12-5/ASERep/scripts/sp_helpddb.sql

Later, I executed sp_helpddb.sql
Later, I executed the following command:

RUN_ASERep -u testerep -p testerep

No error, I listen to port 5005 ok.

Later, I executed the following command:

isql -U testerep -P testerep -S LINUX
use distribuidor (distribution database)
go
sp_configrep
go

No error, without result, ctrl+z for exit

Thanks,
Leandro

#!/bin/sh

if [ $# -eq 0 ]
then
echo "Usage: $0 -u <aserep_user> -p <password> [ options ]"
exit 1
fi

# ASE Replicator Information:
# ASE Replicator instance name: ASERep
# ASE Replicator listening port: 5005
# ASE host name: LINUX
# ASE port number: 5000
# Distribution Database name: distribuidor
# ASE Replicator log directory: /opt/sybase/RPL-12_5/ASERep/log

SYBASE=/opt/sybase
export SYBASE

/opt/sybase/RPL-12_5/bin/aserep.sh $* -s ASERep -r 5005 -m LINUX -a 5000 -d distribuidor