Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Appeon errors

4 posts in Appeon (partner product) Last posting was on 2005-07-07 04:24:02.0Z
Gafoor Posted on 2005-06-30 12:20:59.0Z
Sender: 1a11.42c3df93.1804289383@sybase.com
From: Gafoor
Newsgroups: sybase.public.appeon
Subject: Appeon errors
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <42c3e3a5.1a40.1681692777@sybase.com>
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="-=_forums-2-dub42c3e3a5"
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 30 Jun 2005 05:20:53 -0700, 10.22.241.42
Lines: 1576
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 30 Jun 2005 05:20:57 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 30 Jun 2005 05:20:59 -0700
X-Trace: forums-1-dub 1120134059 10.22.108.75 (30 Jun 2005 05:20:59 -0700)
X-Original-Trace: 30 Jun 2005 05:20:59 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:952
Article PK: 12768

Hi,

I am new to appeon... we have a powerbuilder application in
version 9 and our company is thinking to web enable it with
the help of appeon. for that they asked me to check the
capability of appeon.
so i downloaded appeon 2.8 and created a small application
with one window and dw with ODBC connection (ASA 7.x). but i
have two pblms

1. while deploying the application is showing some
incompatability and when i pressed the button 'Analysis
report', the xml file is displaying some error in (IE 6.0 on
Win-XP SP2) and it attached as analysis.jpg

2. then i tried by running the application in explorer and
it is worked fine, but when i opened a window, that contains
dw with DB connection, it shows a database error and it is
attached as app.jpg ( that means i am not able to use
database connection in the appn)

so please give me the reason for both and i want to clear it
also..this is very urgent, bcoz i have to show company a
Piolt copy of the application deployed in order to buy
Appeon.

regards
gafoor

analysis.JPG
app.JPG

Julie Jiang Posted on 2005-07-01 08:53:56.0Z
From: "Julie Jiang" <julie.jiang@appeon.net>
Newsgroups: sybase.public.appeon
References: <42c3e3a5.1a40.1681692777@sybase.com>
Subject: Re: Appeon errors
Lines: 248
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_000C_01C57E5D.39237310"
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1506
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1506
NNTP-Posting-Host: 210.21.221.178
X-Original-NNTP-Posting-Host: 210.21.221.178
Message-ID: <42c504a4@forums-1-dub>
Date: 1 Jul 2005 01:53:56 -0700
X-Trace: forums-1-dub 1120208036 210.21.221.178 (1 Jul 2005 01:53:56 -0700)
X-Original-Trace: 1 Jul 2005 01:53:56 -0700, 210.21.221.178
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:954
Article PK: 12769

Gafoor,
 
I suggest you first install the 2.8 EBF available at http://www.appeon.net/support/ebfs.
 
To fix the first error, please go to Internet Options > Security in Internet Explorer, and make sure the option "Allow active content to run in files on My Computer" is enabled.  After that, re-open the UFA report.
 
There are two possible causes for the second error: the database does not contain the table 'testdb' at all; or the configuration for the database connection is incorrect.  For the first cause, please search in your database tables and make sure the table 'testdb' does exist.  If you suspect that it is a configuration issue, please verify that you have done all the following steps correctly.  Pay special attention to step 1, 4, and 8. 
 
At the computer that has installed Appeon Server:
1) Set up a connection cache for connecting to the application database.  Make sure the connection cache can be pinged successfully.
2) Start the server.
 
At the computer that has installed Appeon Developer (you can refer to the Appeon Developer User Guide for details of the following steps):
3) Load the PB application in PowerBuilder 8 or 9 and make sure the full build of the application is successful.
4) Configure an application profile in the Appeon Developer Configuration window.  In this configuration, make sure the application DB profile is configured correctly.
5) Configure an Appeon Server profile in the Appeon Developer Configuration window, which connects to "tmk.starshoes.com.mx".  Make sure the testing connection is successful.
6) Configure an Web Server profile in the Appeon Developer Configuration window, which connects to the server that you installed "Appeon Server Web Component" to.  Make sure the testing connection is successful.
7) Configure an deployment profile in the Appeon Developer Configuration window, which connects to the configured Appeon Server profile and Web Server profile.
8) Access to Appeon AEM via the AEM button in the Appeon Developer toolbar, and set up the transaction object to connection cache mapping. 
9) Deploy your application with the Appeon Deployment Wizard.  If the application contains unsupported features, you should refer to the UFA report generated during the deployment, and remove unsupported features from the application.  For test purpose, you can start with deploy one of the Appeon demos to get familiarized. 
 
At the computer that you plan to run the application:
10) Delete all the temporary files stored in IE cache;
11) Delete the Xcelerator plug-in that has been downloaded to the client: delete the files at \WINNT\Downloaded Program Files.
12) Verify the IE security settings: for the appropriate zone in the IE Security, make sure the security is set to default; if it is Windows XP, after setting the security to default, we also need to enable the option "Download signed ActiveX controls", "Download unsigned ActiveX controls", "Initialize and script ActiveX controls not marked as safe", and "Run ActiveX controls and plug-ins".
 
Wish you success in this project!
 
Regards,
Julie
 
 
<Gafoor> wrote in message news:42c3e3a5.1a40.1681692777@sybase.com...
> Hi,
>
> I am new to appeon... we have a powerbuilder application in
> version 9 and our company is thinking to web enable it with
> the help of appeon. for that they asked me to check the
> capability of appeon.
> so i downloaded appeon 2.8 and created a small application
> with one window and dw with ODBC connection (ASA 7.x). but i
> have two pblms
>
> 1. while deploying the application is showing some
> incompatability and when i pressed the button 'Analysis
> report', the xml file is displaying some error in (IE 6.0 on
> Win-XP SP2) and it attached as analysis.jpg
>
> 2. then i tried by running the application in explorer and
> it is worked fine, but when i opened a window, that contains
> dw with DB connection, it shows a database error and it is
> attached as app.jpg ( that means i am not able to use
> database connection in the appn)
>
> so please give me the reason for both and i want to clear it
> also..this is very urgent, bcoz i have to show company a
> Piolt copy of the application deployed in order to buy
> Appeon.
>
> regards
> gafoor
>


Gafoor Posted on 2005-07-07 04:24:02.0Z
Sender: 77d5.42ccae06.1804289383@sybase.com
From: Gafoor
Newsgroups: sybase.public.appeon
Subject: Re: Appeon errors
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <42ccae5e.77d8.1681692777@sybase.com>
References: <42c504a4@forums-1-dub>
X-Original-NNTP-Posting-Host: 10.22.241.42
X-Original-Trace: 6 Jul 2005 21:23:58 -0700, 10.22.241.42
Lines: 106
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 6 Jul 2005 21:24:00 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 6 Jul 2005 21:24:02 -0700
X-Trace: forums-1-dub 1120710242 10.22.108.75 (6 Jul 2005 21:24:02 -0700)
X-Original-Trace: 6 Jul 2005 21:24:02 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:962
Article PK: 12776

Thanks Julie,

your solutions works gr8 in both cases....

Gafoor

> Gafoor,
>
> I suggest you first install the 2.8 EBF available at
> http://www.appeon.net/support/ebfs.
>
> To fix the first error, please go to Internet Options >
> Security in Internet Explorer, and make sure the option
> "Allow active content to run in files on My Computer" is
> enabled. After that, re-open the UFA report.
>
> There are two possible causes for the second error: the
> database does not contain the table 'testdb' at all; or
> the configuration for the database connection is
> incorrect. For the first cause, please search in your
> database tables and make sure the table 'testdb' does
> exist. If you suspect that it is a configuration issue,
> please verify that you have done all the following steps
> correctly. Pay special attention to step 1, 4, and 8.
>
> At the computer that has installed Appeon Server:
> 1) Set up a connection cache for connecting to the
> application database. Make sure the connection cache can
> be pinged successfully. 2) Start the server.
>
> At the computer that has installed Appeon Developer (you
> can refer to the Appeon Developer User Guide for details
> of the following steps): 3) Load the PB application in
> PowerBuilder 8 or 9 and make sure the full build of the
> application is successful. 4) Configure an application
> profile in the Appeon Developer Configuration window. In
> this configuration, make sure the application DB profile
> is configured correctly. 5) Configure an Appeon Server
> profile in the Appeon Developer Configuration window,
> which connects to "tmk.starshoes.com.mx". Make sure the
> testing connection is successful. 6) Configure an Web
> Server profile in the Appeon Developer Configuration
> window, which connects to the server that you installed
> "Appeon Server Web Component" to. Make sure the testing
> connection is successful. 7) Configure an deployment
> profile in the Appeon Developer Configuration window,
> which connects to the configured Appeon Server profile and
> Web Server profile. 8) Access to Appeon AEM via the AEM
> button in the Appeon Developer toolbar, and set up the
> transaction object to connection cache mapping. 9)
> Deploy your application with the Appeon Deployment Wizard.
> If the application contains unsupported features, you
> should refer to the UFA report generated during the
> deployment, and remove unsupported features from the
> application. For test purpose, you can start with deploy
> one of the Appeon demos to get familiarized.
>
> At the computer that you plan to run the application:
> 10) Delete all the temporary files stored in IE cache;
> 11) Delete the Xcelerator plug-in that has been downloaded
> to the client: delete the files at \WINNT\Downloaded
> Program Files. 12) Verify the IE security settings: for
> the appropriate zone in the IE Security, make sure the
> security is set to default; if it is Windows XP, after
> setting the security to default, we also need to enable
> the option "Download signed ActiveX controls", "Download
> unsigned ActiveX controls", "Initialize and script ActiveX
> controls not marked as safe", and "Run ActiveX controls
> and plug-ins".
>
> Wish you success in this project!
>
> Regards,
> Julie
>
>
> <Gafoor> wrote in message
> > news:42c3e3a5.1a40.1681692777@sybase.com... Hi,
> >
> > I am new to appeon... we have a powerbuilder application
> > in version 9 and our company is thinking to web enable
> > it with the help of appeon. for that they asked me to
> > check the capability of appeon.
> > so i downloaded appeon 2.8 and created a small
> > application with one window and dw with ODBC connection
> > (ASA 7.x). but i have two pblms
> >
> > 1. while deploying the application is showing some
> > incompatability and when i pressed the button 'Analysis
> > report', the xml file is displaying some error in (IE
> > 6.0 on Win-XP SP2) and it attached as analysis.jpg
> >
> > 2. then i tried by running the application in explorer
> > and it is worked fine, but when i opened a window, that
> > contains dw with DB connection, it shows a database
> > error and it is attached as app.jpg ( that means i am
> > not able to use database connection in the appn)
> >
> > so please give me the reason for both and i want to
> > clear it also..this is very urgent, bcoz i have to show
> > company a Piolt copy of the application deployed in
> > order to buy Appeon.
> >
> > regards
> > gafoor
> >


Dean Jones Posted on 2005-06-30 17:56:08.0Z
From: "Dean Jones" <dean_dot_jones_at_powerobjects_dot_com>
Newsgroups: sybase.public.appeon
References: <42c3e3a5.1a40.1681692777@sybase.com>
Subject: Re: Appeon errors
Lines: 46
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-RFC2646: Format=Flowed; Original
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
NNTP-Posting-Host: 216.207.144.172
X-Original-NNTP-Posting-Host: 216.207.144.172
Message-ID: <42c43238$1@forums-1-dub>
Date: 30 Jun 2005 10:56:08 -0700
X-Trace: forums-1-dub 1120154168 216.207.144.172 (30 Jun 2005 10:56:08 -0700)
X-Original-Trace: 30 Jun 2005 10:56:08 -0700, 216.207.144.172
X-Authenticated-User: TeamSybase
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:953
Article PK: 20975

It looks like you are not allowing xml to run in your browser.

Also I think the little application you setup uses a custom database. If yes
you need to map the transaction object SQLCA to a JDBC connection cache in
Appeon Enterprise Manage AEM.

--
Dean Jones [TeamSybase]
CEO
Certified PowerBuilder Developer
www.powerobjects.com
(612) 339-3355 ext 112

<Gafoor> wrote in message news:42c3e3a5.1a40.1681692777@sybase.com...
> Hi,
>
> I am new to appeon... we have a powerbuilder application in
> version 9 and our company is thinking to web enable it with
> the help of appeon. for that they asked me to check the
> capability of appeon.
> so i downloaded appeon 2.8 and created a small application
> with one window and dw with ODBC connection (ASA 7.x). but i
> have two pblms
>
> 1. while deploying the application is showing some
> incompatability and when i pressed the button 'Analysis
> report', the xml file is displaying some error in (IE 6.0 on
> Win-XP SP2) and it attached as analysis.jpg
>
> 2. then i tried by running the application in explorer and
> it is worked fine, but when i opened a window, that contains
> dw with DB connection, it shows a database error and it is
> attached as app.jpg ( that means i am not able to use
> database connection in the appn)
>
> so please give me the reason for both and i want to clear it
> also..this is very urgent, bcoz i have to show company a
> Piolt copy of the application deployed in order to buy
> Appeon.
>
> regards
> gafoor
>