Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

M-Bisiness stores pictures in cache

2 posts in General Discussion Last posting was on 2005-07-14 19:43:06.0Z
Jan Posted on 2005-07-14 14:21:23.0Z
From: "Jan" <jan@cyberprop.com>
Newsgroups: ianywhere.public.mbusinessanywhere.general
Subject: M-Bisiness stores pictures in cache
Lines: 20
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Original
X-Original-NNTP-Posting-Host: rrba-146-104-127.telkomadsl.co.za
Message-ID: <42d674de$1@forums-2-dub>
X-Original-Trace: 14 Jul 2005 07:21:18 -0700, rrba-146-104-127.telkomadsl.co.za
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 14 Jul 2005 07:21:21 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 14 Jul 2005 07:21:23 -0700
X-Trace: forums-1-dub 1121350883 10.22.108.75 (14 Jul 2005 07:21:23 -0700)
X-Original-Trace: 14 Jul 2005 07:21:23 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:465
Article PK: 8893

Hi,

I have a situation where pictures are downloaded to my device - that's OK.

Then sometimes a picture changes on the server (the actual image is
different but the name of the picture file stays the same).

On the device I can not get the new picture - I still get the old picture.

What governs this? Is it the content expiry setting in the web server that
serves the picture? Is there some setting regarding cache in the M-Business
server.

My M-Business server is version : 5.7 b47 (Windows)
My M-Business client is version : 5.7 Build 32

Thanks!
Jan


Chris Grim Posted on 2005-07-14 19:43:06.0Z
User-Agent: Microsoft-Entourage/11.1.0.040913
Subject: Re: M-Bisiness stores pictures in cache
From: Chris Grim <chrisgrim@hotmail.com>
Newsgroups: ianywhere.public.mbusinessanywhere.general
Message-ID: <BEFC0E59.1492%chrisgrim@hotmail.com>
References: <42d674de$1@forums-2-dub>
Mime-version: 1.0
Content-type: text/plain; charset="US-ASCII"
Content-transfer-encoding: 7bit
NNTP-Posting-Host: macgrimreaper.sybase.com
X-Original-NNTP-Posting-Host: macgrimreaper.sybase.com
Date: 14 Jul 2005 12:43:06 -0700
X-Trace: forums-1-dub 1121370186 10.22.46.251 (14 Jul 2005 12:43:06 -0700)
X-Original-Trace: 14 Jul 2005 12:43:06 -0700, macgrimreaper.sybase.com
Lines: 33
X-Authenticated-User: techsupp
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:466
Article PK: 8892

You can control image caching with http headers in the same way that you can
control html pages. If your images don't have an expires date, the server
assumes that they can be cached for awhile and assigns an expires date. If
you need a shorter cache or don't want them cached, you have control by
adding expires headers.

Chris...

On 7/14/05 7:21 AM, in article 42d674de$1@forums-2-dub, "Jan"

<jan@cyberprop.com> wrote:

> Hi,
>
> I have a situation where pictures are downloaded to my device - that's OK.
>
> Then sometimes a picture changes on the server (the actual image is
> different but the name of the picture file stays the same).
>
> On the device I can not get the new picture - I still get the old picture.
>
> What governs this? Is it the content expiry setting in the web server that
> serves the picture? Is there some setting regarding cache in the M-Business
> server.
>
> My M-Business server is version : 5.7 b47 (Windows)
> My M-Business client is version : 5.7 Build 32
>
> Thanks!
> Jan
>
>