Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

ini file not working with appeon

4 posts in Appeon (partner product) Last posting was on 2005-08-03 08:59:00.0Z
Gafoor Posted on 2005-08-01 10:16:03.0Z
Sender: 7bc5.42edf4cf.1804289383@sybase.com
From: Gafoor
Newsgroups: sybase.public.appeon
Subject: ini file not working with appeon
X-Mailer: WebNews to Mail Gateway v1.1t
Message-ID: <42edf663.7bd5.1681692777@sybase.com>
NNTP-Posting-Host: 10.22.241.41
X-Original-NNTP-Posting-Host: 10.22.241.41
Date: 1 Aug 2005 03:16:03 -0700
X-Trace: forums-1-dub 1122891363 10.22.241.41 (1 Aug 2005 03:16:03 -0700)
X-Original-Trace: 1 Aug 2005 03:16:03 -0700, 10.22.241.41
Lines: 25
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1005
Article PK: 20995

Hi,

in my application application and database information are
populating from the 'ini' file.

i deployed this application with appeon 3.0 Xcelerator
option and i added the ini file in the Appeon application
profile configuration window.

but when it reaches the of_init function of pfc_n_tr, it
fails. see the code below
////////////////////////////////
// Check arguments
if IsNull (as_inifile) or IsNull (as_inisection) or &
Len (Trim (as_inifile))=0 or Len (Trim (as_inisection))=0
or &
(not FileExists (as_inifile)) then return -1

//////////////////////////

it returns -1 here. why this is happening. how will i
achieve the ini functionality in my web application??.

thanks
gafoor


Julie Jiang Posted on 2005-08-02 11:11:30.0Z
From: "Julie Jiang" <julie.jiang@appeon.net>
Newsgroups: sybase.public.appeon
References: <42edf663.7bd5.1681692777@sybase.com>
Subject: Re: ini file not working with appeon
Lines: 99
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_0176_01C59795.CEAA5D80"
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
NNTP-Posting-Host: 210.21.221.178
X-Original-NNTP-Posting-Host: 210.21.221.178
Message-ID: <42ef54e2@forums-1-dub>
Date: 2 Aug 2005 04:11:30 -0700
X-Trace: forums-1-dub 1122981090 210.21.221.178 (2 Aug 2005 04:11:30 -0700)
X-Original-Trace: 2 Aug 2005 04:11:30 -0700, 210.21.221.178
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1007
Article PK: 20996

For security reason, INI files are not stored as normal files at the Web server, but stored in Appeon Server database.  Therefore, executing FileExists (as_inifile) cannot find such an INI file in the Web server and will always returns FALSE, which causes the problem you have seen.
 
Please comment out the "or & (not FileExists (as_inifile))" condition from the script.
 
Regards,
Julie
<Gafoor> wrote in message news:42edf663.7bd5.1681692777@sybase.com...
Hi,

in my application application and database information are
populating from the 'ini' file.

i deployed this application with appeon 3.0 Xcelerator
option and i added the ini file in the Appeon application
profile configuration window.

but when it reaches the of_init function of pfc_n_tr, it
fails. see the code below
////////////////////////////////
// Check arguments
if IsNull (as_inifile) or IsNull (as_inisection) or &
Len (Trim (as_inifile))=0 or Len (Trim (as_inisection))=0
or &
(not FileExists (as_inifile)) then return -1

//////////////////////////

it returns -1 here. why this is happening. how will i
achieve the ini functionality in my web application??.

thanks
gafoor