Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

dw with numeric column not working

7 posts in Appeon (partner product) Last posting was on 2005-08-11 00:59:49.0Z
Marco Meoni Posted on 2005-08-08 10:43:41.0Z
From: "Marco Meoni" <marco.meoni@cern.ch>
Newsgroups: sybase.public.appeon
Subject: dw with numeric column not working
Lines: 19
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
NNTP-Posting-Host: 159.213.37.151
X-Original-NNTP-Posting-Host: 159.213.37.151
Message-ID: <42f7375d@forums-1-dub>
Date: 8 Aug 2005 03:43:41 -0700
X-Trace: forums-1-dub 1123497821 159.213.37.151 (8 Aug 2005 03:43:41 -0700)
X-Original-Trace: 8 Aug 2005 03:43:41 -0700, 159.213.37.151
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1043
Article PK: 12821

hello,
it's pretty curious.
I've a simple dw with a numeric (number(4,2)) column called 'entrata'. The
DB is Oracle 9.2. I'm using Appeon 2.8.

- If I preview the dw within the PB9 IDE, it works fine
(http://www.marcomeoni.com/appeon0.jpg).
- But if I preview (or run) the dw in Appeon I get this weird popup
http://www.marcomeoni.com/appeon1.jpg.
- If I remove the field 'entrata' from the dw, (I've also tried to force it
to be formatted '00.00') the deploy succeed
(http://www.marcomeoni.com/appeon2.jpg).

The generated UFA report says nothing is unsupported.
Thank you in advance.

Marco


Sally Li Posted on 2005-08-09 09:56:08.0Z
From: "Sally Li" <appeon.support@appeon.net>
Newsgroups: sybase.public.appeon
References: <42f7375d@forums-1-dub>
Subject: Re: dw with numeric column not working
Lines: 109
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_040C_01C59D0B.9106F300"
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
NNTP-Posting-Host: 210.21.221.178
X-Original-NNTP-Posting-Host: 210.21.221.178
Message-ID: <42f87db8@forums-1-dub>
Date: 9 Aug 2005 02:56:08 -0700
X-Trace: forums-1-dub 1123581368 210.21.221.178 (9 Aug 2005 02:56:08 -0700)
X-Original-Trace: 9 Aug 2005 02:56:08 -0700, 210.21.221.178
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1046
Article PK: 12822

Hi Marco,
 
Appeon supports numeric (number (4,2)) columns no problem.  The error should be caused by the DataWindow previewing function, which is only intended for viewing the layout, not for testing behavior or functionality (According to the Appeon Developer User Guide).
 
Therefore, to double check whether the "entrata" column can display normally, please directly deploy the application and see the DataWindow on the Web.
 
Regards,
Sally
"Marco Meoni" <marco.meoni@cern.ch> wrote in message news:42f7375d@forums-1-dub...
hello,
it's pretty curious.
I've a simple dw with a numeric (number(4,2)) column called 'entrata'. The
DB is Oracle 9.2. I'm using Appeon 2.8.

- If I preview the dw within the PB9 IDE, it works fine
(http://www.marcomeoni.com/appeon0.jpg).
- But if I preview (or run) the dw in Appeon I get this weird popup
http://www.marcomeoni.com/appeon1.jpg.
- If I remove the field 'entrata' from the dw, (I've also tried to force it
to be formatted '00.00') the deploy succeed
(http://www.marcomeoni.com/appeon2.jpg).

The generated UFA report says nothing is unsupported.
Thank you in advance.

Marco


Marco Meoni Posted on 2005-08-09 10:26:41.0Z
From: "Marco Meoni" <marco.meoni@cern.ch>
Newsgroups: sybase.public.appeon
References: <42f7375d@forums-1-dub> <42f87db8@forums-1-dub>
Subject: Re: dw with numeric column not working
Lines: 156
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_000B_01C59CDE.B1DF6E90"
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
NNTP-Posting-Host: 159.213.37.151
X-Original-NNTP-Posting-Host: 159.213.37.151
Message-ID: <42f884e1@forums-1-dub>
Date: 9 Aug 2005 03:26:41 -0700
X-Trace: forums-1-dub 1123583201 159.213.37.151 (9 Aug 2005 03:26:41 -0700)
X-Original-Trace: 9 Aug 2005 03:26:41 -0700, 159.213.37.151
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1047
Article PK: 21012

Hello Sally, thank you for your reply.
Deploying the app on the web has actually been my first (and failed) test.
I can tell you more: if I run the app in a client-server way it works, by Appeon it doesn't.
 
Client-Server: http://www.marcomeoni.com/clientserver.jpg (the column "entrata" shows data)
With Appeon: Client-Server: http://www.marcomeoni.com/withappeon.jpg
 
cheers,
 
Marco
"Sally Li" <appeon.support@appeon.net> wrote in message news:42f87db8@forums-1-dub...
Hi Marco,
 
Appeon supports numeric (number (4,2)) columns no problem.  The error should be caused by the DataWindow previewing function, which is only intended for viewing the layout, not for testing behavior or functionality (According to the Appeon Developer User Guide).
 
Therefore, to double check whether the "entrata" column can display normally, please directly deploy the application and see the DataWindow on the Web.
 
Regards,
Sally
"Marco Meoni" <marco.meoni@cern.ch> wrote in message news:42f7375d@forums-1-dub...
hello,
it's pretty curious.
I've a simple dw with a numeric (number(4,2)) column called 'entrata'. The
DB is Oracle 9.2. I'm using Appeon 2.8.

- If I preview the dw within the PB9 IDE, it works fine
(http://www.marcomeoni.com/appeon0.jpg).
- But if I preview (or run) the dw in Appeon I get this weird popup
http://www.marcomeoni.com/appeon1.jpg.
- If I remove the field 'entrata' from the dw, (I've also tried to force it
to be formatted '00.00') the deploy succeed
(http://www.marcomeoni.com/appeon2.jpg).

The generated UFA report says nothing is unsupported.
Thank you in advance.

Marco


Marco Meoni Posted on 2005-08-09 13:49:07.0Z
From: "Marco Meoni" <marco.meoni@cern.ch>
Newsgroups: sybase.public.appeon
References: <42f7375d@forums-1-dub> <42f87db8@forums-1-dub> <42f884e1@forums-1-dub>
Subject: Re: dw with numeric column not working
Lines: 208
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_0036_01C59CFA.F8AA3AF0"
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
NNTP-Posting-Host: 159.213.37.151
X-Original-NNTP-Posting-Host: 159.213.37.151
Message-ID: <42f8b453@forums-1-dub>
Date: 9 Aug 2005 06:49:07 -0700
X-Trace: forums-1-dub 1123595347 159.213.37.151 (9 Aug 2005 06:49:07 -0700)
X-Original-Trace: 9 Aug 2005 06:49:07 -0700, 159.213.37.151
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1051
Article PK: 21016

Well, at the end I've descoverd the problem provenance and found a workaround.
Any suggestion about how to solve my problem without workaround will be appreciated.
 
Everything depends on the type of the field "entrata". It has been defined as number(5,2).
If I store just whole numbers, the datawindow works. If I type any decimal number it stores the value but fails when RETRIEVES.
 
So, the workaround has been to modify the column in FLOAT. Now the dw works always fine.
 
But... why????
"Marco Meoni" <marco.meoni@cern.ch> wrote in message news:42f884e1@forums-1-dub...
Hello Sally, thank you for your reply.
Deploying the app on the web has actually been my first (and failed) test.
I can tell you more: if I run the app in a client-server way it works, by Appeon it doesn't.
 
Client-Server: http://www.marcomeoni.com/clientserver.jpg (the column "entrata" shows data)
With Appeon: Client-Server: http://www.marcomeoni.com/withappeon.jpg
 
cheers,
 
Marco
"Sally Li" <appeon.support@appeon.net> wrote in message news:42f87db8@forums-1-dub...
Hi Marco,
 
Appeon supports numeric (number (4,2)) columns no problem.  The error should be caused by the DataWindow previewing function, which is only intended for viewing the layout, not for testing behavior or functionality (According to the Appeon Developer User Guide).
 
Therefore, to double check whether the "entrata" column can display normally, please directly deploy the application and see the DataWindow on the Web.
 
Regards,
Sally
"Marco Meoni" <marco.meoni@cern.ch> wrote in message news:42f7375d@forums-1-dub...
hello,
it's pretty curious.
I've a simple dw with a numeric (number(4,2)) column called 'entrata'. The
DB is Oracle 9.2. I'm using Appeon 2.8.

- If I preview the dw within the PB9 IDE, it works fine
(http://www.marcomeoni.com/appeon0.jpg).
- But if I preview (or run) the dw in Appeon I get this weird popup
http://www.marcomeoni.com/appeon1.jpg.
- If I remove the field 'entrata' from the dw, (I've also tried to force it
to be formatted '00.00') the deploy succeed
(http://www.marcomeoni.com/appeon2.jpg).

The generated UFA report says nothing is unsupported.
Thank you in advance.

Marco


Sally Li Posted on 2005-08-10 10:44:37.0Z
From: "Sally Li" <appeon.support@appeon.net>
Newsgroups: sybase.public.appeon
References: <42f7375d@forums-1-dub> <42f87db8@forums-1-dub> <42f884e1@forums-1-dub> <42f8b453@forums-1-dub>
Subject: Re: dw with numeric column not working
Lines: 261
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_0041_01C59DDB.67D94CA0"
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
NNTP-Posting-Host: 210.21.221.178
X-Original-NNTP-Posting-Host: 210.21.221.178
Message-ID: <42f9da95@forums-1-dub>
Date: 10 Aug 2005 03:44:37 -0700
X-Trace: forums-1-dub 1123670677 210.21.221.178 (10 Aug 2005 03:44:37 -0700)
X-Original-Trace: 10 Aug 2005 03:44:37 -0700, 210.21.221.178
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1056
Article PK: 21019

Hi Marco,
 
We used the attached test case that contains number (5,2).  It can retrieve correctly no problem.  Please see whether the attached works in your environment. 
 
If the case still does not work, the problem should be environment related.  You can either provided detailed environment information (EAServer version, Appeon deployment method, PowerBuilder version, OS version) to me or contact your technical support for more analysis.
 
If the case works at your side, please compare what is the difference between your application and our test case.
 
Regards,
Sally
"Marco Meoni" <marco.meoni@cern.ch> wrote in message news:42f8b453@forums-1-dub...
Well, at the end I've descoverd the problem provenance and found a workaround.
Any suggestion about how to solve my problem without workaround will be appreciated.
 
Everything depends on the type of the field "entrata". It has been defined as number(5,2).
If I store just whole numbers, the datawindow works. If I type any decimal number it stores the value but fails when RETRIEVES.
 
So, the workaround has been to modify the column in FLOAT. Now the dw works always fine.
 
But... why????
"Marco Meoni" <marco.meoni@cern.ch> wrote in message news:42f884e1@forums-1-dub...
Hello Sally, thank you for your reply.
Deploying the app on the web has actually been my first (and failed) test.
I can tell you more: if I run the app in a client-server way it works, by Appeon it doesn't.
 
Client-Server: http://www.marcomeoni.com/clientserver.jpg (the column "entrata" shows data)
With Appeon: Client-Server: http://www.marcomeoni.com/withappeon.jpg
 
cheers,
 
Marco
"Sally Li" <appeon.support@appeon.net> wrote in message news:42f87db8@forums-1-dub...
Hi Marco,
 
Appeon supports numeric (number (4,2)) columns no problem.  The error should be caused by the DataWindow previewing function, which is only intended for viewing the layout, not for testing behavior or functionality (According to the Appeon Developer User Guide).
 
Therefore, to double check whether the "entrata" column can display normally, please directly deploy the application and see the DataWindow on the Web.
 
Regards,
Sally
"Marco Meoni" <marco.meoni@cern.ch> wrote in message news:42f7375d@forums-1-dub...
hello,
it's pretty curious.
I've a simple dw with a numeric (number(4,2)) column called 'entrata'. The
DB is Oracle 9.2. I'm using Appeon 2.8.

- If I preview the dw within the PB9 IDE, it works fine
(http://www.marcomeoni.com/appeon0.jpg).
- But if I preview (or run) the dw in Appeon I get this weird popup
http://www.marcomeoni.com/appeon1.jpg.
- If I remove the field 'entrata' from the dw, (I've also tried to force it
to be formatted '00.00') the deploy succeed
(http://www.marcomeoni.com/appeon2.jpg).

The generated UFA report says nothing is unsupported.
Thank you in advance.

Marco


Marco Meoni Posted on 2005-08-10 11:46:33.0Z
From: "Marco Meoni" <marco.meoni@cern.ch>
Newsgroups: sybase.public.appeon
References: <42f7375d@forums-1-dub> <42f87db8@forums-1-dub> <42f884e1@forums-1-dub> <42f8b453@forums-1-dub> <42f9da95@forums-1-dub>
Subject: Re: dw with numeric column not working
Lines: 298
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_0026_01C59DB3.035D7350"
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
NNTP-Posting-Host: ppp-62-11-92-136.dialup.tiscali.it
X-Original-NNTP-Posting-Host: ppp-62-11-92-136.dialup.tiscali.it
Message-ID: <42f9e919@forums-1-dub>
Date: 10 Aug 2005 04:46:33 -0700
X-Trace: forums-1-dub 1123674393 62.11.92.136 (10 Aug 2005 04:46:33 -0700)
X-Original-Trace: 10 Aug 2005 04:46:33 -0700, ppp-62-11-92-136.dialup.tiscali.it
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1060
Article PK: 12828

Sally,
I don't see any attached test.
I use EAS 5.2 build 52025, Appeon 2.8 (although Sybase suggests Appeon 3.0 with EAS 5.2, I'm planning to upgrade...), PB 9.0.1 build 7171, deploy either Xcelerator or Pure-JavaScript, WinXP pro sp2, IE6 sp1.
cheers,
Marco
"Sally Li" <appeon.support@appeon.net> wrote in message news:42f9da95@forums-1-dub...
Hi Marco,
 
We used the attached test case that contains number (5,2).  It can retrieve correctly no problem.  Please see whether the attached works in your environment. 
 
If the case still does not work, the problem should be environment related.  You can either provided detailed environment information (EAServer version, Appeon deployment method, PowerBuilder version, OS version) to me or contact your technical support for more analysis.
 
If the case works at your side, please compare what is the difference between your application and our test case.
 
Regards,
Sally
"Marco Meoni" <marco.meoni@cern.ch> wrote in message news:42f8b453@forums-1-dub...
Well, at the end I've descoverd the problem provenance and found a workaround.
Any suggestion about how to solve my problem without workaround will be appreciated.
 
Everything depends on the type of the field "entrata". It has been defined as number(5,2).
If I store just whole numbers, the datawindow works. If I type any decimal number it stores the value but fails when RETRIEVES.
 
So, the workaround has been to modify the column in FLOAT. Now the dw works always fine.
 
But... why????
"Marco Meoni" <marco.meoni@cern.ch> wrote in message news:42f884e1@forums-1-dub...
Hello Sally, thank you for your reply.
Deploying the app on the web has actually been my first (and failed) test.
I can tell you more: if I run the app in a client-server way it works, by Appeon it doesn't.
 
Client-Server: http://www.marcomeoni.com/clientserver.jpg (the column "entrata" shows data)
With Appeon: Client-Server: http://www.marcomeoni.com/withappeon.jpg
 
cheers,
 
Marco
"Sally Li" <appeon.support@appeon.net> wrote in message news:42f87db8@forums-1-dub...
Hi Marco,
 
Appeon supports numeric (number (4,2)) columns no problem.  The error should be caused by the DataWindow previewing function, which is only intended for viewing the layout, not for testing behavior or functionality (According to the Appeon Developer User Guide).
 
Therefore, to double check whether the "entrata" column can display normally, please directly deploy the application and see the DataWindow on the Web.
 
Regards,
Sally
"Marco Meoni" <marco.meoni@cern.ch> wrote in message news:42f7375d@forums-1-dub...
hello,
it's pretty curious.
I've a simple dw with a numeric (number(4,2)) column called 'entrata'. The
DB is Oracle 9.2. I'm using Appeon 2.8.

- If I preview the dw within the PB9 IDE, it works fine
(http://www.marcomeoni.com/appeon0.jpg).
- But if I preview (or run) the dw in Appeon I get this weird popup
http://www.marcomeoni.com/appeon1.jpg.
- If I remove the field 'entrata' from the dw, (I've also tried to force it
to be formatted '00.00') the deploy succeed
(http://www.marcomeoni.com/appeon2.jpg).

The generated UFA report says nothing is unsupported.
Thank you in advance.

Marco


Sally Li Posted on 2005-08-11 00:59:49.0Z
From: "Sally Li" <appeon.support@appeon.net>
Newsgroups: sybase.public.appeon
References: <42f7375d@forums-1-dub> <42f87db8@forums-1-dub> <42f884e1@forums-1-dub> <42f8b453@forums-1-dub> <42f9da95@forums-1-dub> <42f9e919@forums-1-dub>
Subject: Re: dw with numeric column not working
Lines: 475
MIME-Version: 1.0
Content-Type: multipart/mixed; boundary="----=_NextPart_000_003A_01C59DDD.98624F00"
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1106
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
X-Original-NNTP-Posting-Host: 210.21.221.178
Message-ID: <42faa301@forums-2-dub>
X-Original-Trace: 10 Aug 2005 17:59:45 -0700, 210.21.221.178
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 10 Aug 2005 17:59:46 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 10 Aug 2005 17:59:49 -0700
X-Trace: forums-1-dub 1123721989 10.22.108.75 (10 Aug 2005 17:59:49 -0700)
X-Original-Trace: 10 Aug 2005 17:59:49 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub sybase.public.appeon:1061
Article PK: 21021

The attached is our test case.
 
Regards,
Sally
"Marco Meoni" <marco.meoni@cern.ch> wrote in message news:42f9e919@forums-1-dub...
Sally,
I don't see any attached test.
I use EAS 5.2 build 52025, Appeon 2.8 (although Sybase suggests Appeon 3.0 with EAS 5.2, I'm planning to upgrade...), PB 9.0.1 build 7171, deploy either Xcelerator or Pure-JavaScript, WinXP pro sp2, IE6 sp1.
cheers,
Marco
"Sally Li" <appeon.support@appeon.net> wrote in message news:42f9da95@forums-1-dub...
Hi Marco,
 
We used the attached test case that contains number (5,2).  It can retrieve correctly no problem.  Please see whether the attached works in your environment. 
 
If the case still does not work, the problem should be environment related.  You can either provided detailed environment information (EAServer version, Appeon deployment method, PowerBuilder version, OS version) to me or contact your technical support for more analysis.
 
If the case works at your side, please compare what is the difference between your application and our test case.
 
Regards,
Sally
"Marco Meoni" <marco.meoni@cern.ch> wrote in message news:42f8b453@forums-1-dub...
Well, at the end I've descoverd the problem provenance and found a workaround.
Any suggestion about how to solve my problem without workaround will be appreciated.
 
Everything depends on the type of the field "entrata". It has been defined as number(5,2).
If I store just whole numbers, the datawindow works. If I type any decimal number it stores the value but fails when RETRIEVES.
 
So, the workaround has been to modify the column in FLOAT. Now the dw works always fine.
 
But... why????
"Marco Meoni" <marco.meoni@cern.ch> wrote in message news:42f884e1@forums-1-dub...
Hello Sally, thank you for your reply.
Deploying the app on the web has actually been my first (and failed) test.
I can tell you more: if I run the app in a client-server way it works, by Appeon it doesn't.
 
Client-Server: http://www.marcomeoni.com/clientserver.jpg (the column "entrata" shows data)
With Appeon: Client-Server: http://www.marcomeoni.com/withappeon.jpg
 
cheers,
 
Marco
"Sally Li" <appeon.support@appeon.net> wrote in message news:42f87db8@forums-1-dub...
Hi Marco,
 
Appeon supports numeric (number (4,2)) columns no problem.  The error should be caused by the DataWindow previewing function, which is only intended for viewing the layout, not for testing behavior or functionality (According to the Appeon Developer User Guide).
 
Therefore, to double check whether the "entrata" column can display normally, please directly deploy the application and see the DataWindow on the Web.
 
Regards,
Sally
"Marco Meoni" <marco.meoni@cern.ch> wrote in message news:42f7375d@forums-1-dub...
hello,
it's pretty curious.
I've a simple dw with a numeric (number(4,2)) column called 'entrata'. The
DB is Oracle 9.2. I'm using Appeon 2.8.

- If I preview the dw within the PB9 IDE, it works fine
(http://www.marcomeoni.com/appeon0.jpg).
- But if I preview (or run) the dw in Appeon I get this weird popup
http://www.marcomeoni.com/appeon1.jpg.
- If I remove the field 'entrata' from the dw, (I've also tried to force it
to be formatted '00.00') the deploy succeed
(http://www.marcomeoni.com/appeon2.jpg).

The generated UFA report says nothing is unsupported.
Thank you in advance.

Marco