Sybase NNTP forums - End Of Life (EOL)

The NNTP forums from Sybase - forums.sybase.com - are now closed.

All new questions should be directed to the appropriate forum at the SAP Community Network (SCN).

Individual products have links to the respective forums on SCN, or you can go to SCN and search for your product in the search box (upper right corner) to find your specific developer center.

Force MBus refresh

2 posts in General Discussion Last posting was on 2005-08-16 08:34:12.0Z
Ian Posted on 2005-08-10 14:58:27.0Z
From: "Ian" <istefanison@trialstat.com>
Newsgroups: ianywhere.public.mbusinessanywhere.general
Subject: Force MBus refresh
Lines: 17
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1506
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1506
X-Original-NNTP-Posting-Host: 206.191.62.18
Message-ID: <42fa1612@forums-2-dub>
X-Original-Trace: 10 Aug 2005 07:58:26 -0700, 206.191.62.18
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 10 Aug 2005 07:58:26 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 10 Aug 2005 07:58:27 -0700
X-Trace: forums-1-dub 1123685907 10.22.108.75 (10 Aug 2005 07:58:27 -0700)
X-Original-Trace: 10 Aug 2005 07:58:27 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:520
Article PK: 8929

Hi,

I'm having a problem with mbusiness where I have a pod interacting with my
page by calling an onClick event. The onClick sets some form values.

The form values are being set correctly but do not actually display the
change until I force the screen to redraw (by dragging another window over
it or scrolling down the page then back up.)

The screen refreshes properly when I call the functions from within mbus but
with pod->onclick ... not so much.

Thanks,

Ian


Jan Posted on 2005-08-16 08:34:12.0Z
From: "Jan" <jan@cyberprop.com>
Newsgroups: ianywhere.public.mbusinessanywhere.general
References: <42fa1612@forums-2-dub>
Subject: Re: Force MBus refresh
Lines: 30
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
X-RFC2646: Format=Flowed; Original
X-Original-NNTP-Posting-Host: rrba-146-114-156.telkomadsl.co.za
Message-ID: <4301a500@forums-2-dub>
X-Original-Trace: 16 Aug 2005 01:34:08 -0700, rrba-146-114-156.telkomadsl.co.za
X-Original-NNTP-Posting-Host: forums-2-dub.sybase.com
X-Original-Trace: 16 Aug 2005 01:34:09 -0700, forums-2-dub.sybase.com
NNTP-Posting-Host: forums-master.sybase.com
X-Original-NNTP-Posting-Host: forums-master.sybase.com
Date: 16 Aug 2005 01:34:12 -0700
X-Trace: forums-1-dub 1124181252 10.22.108.75 (16 Aug 2005 01:34:12 -0700)
X-Original-Trace: 16 Aug 2005 01:34:12 -0700, forums-master.sybase.com
X-Authenticated-User: ngsysop
Path: forums-1-dub!not-for-mail
Xref: forums-1-dub ianywhere.public.mbusinessanywhere.general:527
Article PK: 17712

Hi - not sure if this will work - it worked for my problem... I have a
section on my HTML page that is hidden, a <div> that is never displayed. In
order to "refresh" the screen I'm on - I simply set the focus to an element
that is inside that hidden <div></div> section.

HTH
Jan

"Ian" <istefanison@trialstat.com> wrote in message
news:42fa1612@forums-2-dub...
> Hi,
>
> I'm having a problem with mbusiness where I have a pod interacting with my
> page by calling an onClick event. The onClick sets some form values.
>
> The form values are being set correctly but do not actually display the
> change until I force the screen to redraw (by dragging another window over
> it or scrolling down the page then back up.)
>
> The screen refreshes properly when I call the functions from within mbus
> but
> with pod->onclick ... not so much.
>
> Thanks,
>
> Ian
>
>